GnuCash Accounts don't redraw with overlay scrollbar

Bug #770304 reported by Ted Gould
46
This bug affects 7 people
Affects Status Importance Assigned to Milestone
Unity Foundations
Undecided
Unassigned
overlay-scrollbar
Undecided
Unassigned
gnucash (Ubuntu)
Undecided
Unassigned
Natty
Undecided
Unassigned
overlay-scrollbar (Ubuntu)
Medium
Unassigned
Natty
Medium
Unassigned

Bug Description

Binary package hint: overlay-scrollbar

The GNU Cash registers are entirely unusable, they don't redraw at all with the overlay scrollbar installed. Removing the package fixes it.

Ted Gould (ted)
Changed in gnucash (Ubuntu):
status: New → Invalid
Revision history for this message
Andrea Cimitan (cimi) wrote :

Ciao ted,
what do you mean with "redraw"? I am trying to figure out what's wrong, I have installed gnucash, could you guide me?

Revision history for this message
David Barth (dbarth) wrote :

@Cimi: if confirmed, you should blacklist the program first, and then try to find a fix for it.

As a workaround, one can always start a program with this environment variable:

  LIBOVERLAY_SCROLLBAR=0 <program>

to locally disable the use of the new scrollbars

Changed in unity-foundations:
assignee: nobody → Andrea Cimitan (cimi)
status: New → Triaged
Revision history for this message
Andrea Cimitan (cimi) wrote :

I've spoken yesterday with ted, I decided I'll blacklist gnucash now, then I will try to reproduce the bug in Budapest with him, as here is working fine...

Revision history for this message
Ken VanDine (ken-vandine) wrote :

update to 0.1.10 for an SRU

Changed in overlay-scrollbar (Ubuntu):
status: New → Confirmed
importance: Undecided → Medium
Revision history for this message
Martin Pitt (pitti) wrote : Please test proposed package

Accepted overlay-scrollbar into natty-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in overlay-scrollbar (Ubuntu Natty):
status: Confirmed → Fix Committed
tags: added: verification-needed
Revision history for this message
Zach Sadecki (zsadecki) wrote :

I ran into this problem after my upgrade to Natty. Launching gnucash with the LIBOVERLAY_SCROLLBAR=0 workaround worked for me. Then I enabled the proposed repo, and installed only the overlay-scrollbar package version 0.1.12-0ubuntu1. Now if I launch gnucash without the env var workaround the problem still occurs. So I do not believe that this is fixed...

Revision history for this message
Clint Byrum (clint-fewbar) wrote : Re: [Bug 770304] Re: GnuCash Accounts don't redraw with overlay scrollbar

Excerpts from Zach Sadecki's message of Sat Apr 30 15:53:45 UTC 2011:
> I ran into this problem after my upgrade to Natty. Launching gnucash
> with the LIBOVERLAY_SCROLLBAR=0 workaround worked for me. Then I
> enabled the proposed repo, and installed only the overlay-scrollbar
> package version 0.1.12-0ubuntu1. Now if I launch gnucash without the
> env var workaround the problem still occurs. So I do not believe that
> this is fixed...

Zach, did you reboot after the update? Its possible you were still using
the old configuration/library.

Revision history for this message
Andrea Cimitan (cimi) wrote :

or he's using a simlink

Revision history for this message
David Ziegler (david-ziegler) wrote :

Same report as Zach: I also ran into this after the Natty upgrade. The LIBOVERLAY_SCROLLBAR=0 workaround works for me as well. I've also installed the 0.1.12 package from proposed, and the problem remains without the environment variable.

Additional information: This is true across a reboot, and when launching /usr/bin/gnucash directly from a terminal.

Revision history for this message
Andrea Cimitan (cimi) wrote :

I have no idea... here is blacklisted. Anyone having the app blacklisted apart me?

Revision history for this message
Steven Walter (stevenrwalter) wrote :

I'm seeing the same behavior. Without LIBOVERLAY_SCROLLBAR=0, gnucash doesn't render correctly. Installing overlay-scrollbar/natty-proposed does not fix it. I did reboot after installer and it still is not fixed.

Revision history for this message
Clint Byrum (clint-fewbar) wrote :

Authors, this appears to not fix the actual issue for gnucash, marking verification-failed. Please investigate and upload a new package. Make sure to build your source package with -v0.1.9-0ubuntu1 to ensure that the full delta is included. Another option is to open a new bug report just for gnucash and let the package through if it does actually fix the other broken pieces.

tags: added: verification-failed
removed: verification-needed
Revision history for this message
Andrea Cimitan (cimi) wrote :

Could you install this and tell me what's printed on the terminal (something like "program: gnucash, g_get_prgname (): gnucash")
https://bugs.launchpad.net/ubuntu/+source/overlay-scrollbar/+bug/769277/+attachment/2084867/+files/liboverlay-scrollbar-0.1-0_0.1.9-0ubuntu1_i386.deb

Even if this is not fixing gnucash for everybody, we shouldn't block the proposed package while working on a new fix (if it's either possible)

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package overlay-scrollbar - 0.1.12-0ubuntu1

---------------
overlay-scrollbar (0.1.12-0ubuntu1) natty-proposed; urgency=low

  * New upstream release.
    - Updated blacklist:
      * -deja-dup
      * -inkscape
      * -lshw-gtk
      * +vmplayer
    - some apps show grey overlay instead orange even if the window is
      focused (LP: #771511)
    - anjuta doesn't display scrollbar after resetting the layout (LP: #771563)
  * debian/control
    - Changed maintainer to ~ubuntu-desktop

overlay-scrollbar (0.1.10-0ubuntu1) natty-proposed; urgency=low

  * New upstream release.
    - Updated blacklist:
      * vmware (LP: #770625)
      * gnucash (LP: #770304)
      * pgadmin3, codeblocks and codelite (LP: #769232)
    - liferea and cardapio requires
      GDK_POINTER_MOTION_MASK (LP: #769217) (LP: #769460)
    - liboverlay doesn't work in detached tabs (LP: #769427)
    - Scrollbar's slider appears away from the mouse (LP: #763707)
 -- Ken VanDine <email address hidden> Wed, 27 Apr 2011 10:23:24 -0400

Changed in overlay-scrollbar (Ubuntu Natty):
status: Fix Committed → Fix Released
Revision history for this message
Martin Pitt (pitti) wrote :

Reopening as the previous SRU didn't actually fix this.

Changed in overlay-scrollbar (Ubuntu Natty):
status: Fix Released → Triaged
Changed in overlay-scrollbar (Ubuntu):
status: Fix Committed → Triaged
Revision history for this message
Zach Sadecki (zsadecki) wrote :

Andrea: I'm running amd64, but I installed your overlay scrollbar package on a virtual machine and got this from the terminal when running gnucash:

program: gnucash, g_get_prgname (): gnucash

Revision history for this message
Zach Sadecki (zsadecki) wrote :

OK. This actually did fix the problem...

When I installed from proposed updates I only installed "overlay-scrollbar". When I did an update this morning the package "liboverlay-scrollbar" also got updated and now gnucash renders correctly without the env var workaround.

Revision history for this message
Steven Walter (stevenrwalter) wrote :

Seconded. I only installed overlay-scrollbar initially. Installing the new liboverlay-scrollbar fixes render for me as well.

Martin Pitt (pitti)
tags: added: verification-done
removed: verification-failed
Changed in overlay-scrollbar (Ubuntu Natty):
status: Triaged → Fix Released
Changed in overlay-scrollbar (Ubuntu):
status: Triaged → Fix Released
Revision history for this message
Andrea Cimitan (cimi) wrote :

Ok... that's why I was confused :)

Andrea Cimitan (cimi)
Changed in ayatana-scrollbar:
status: New → Confirmed
Andrea Cimitan (cimi)
Changed in unity-foundations:
assignee: Andrea Cimitan (cimi) → nobody
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers