Use title case capitalization "Lock to Launcher" & "Unlock from Launcher"

Bug #949636 reported by Jeremy Bicha on 2012-03-08
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Unity
Fix Released
Low
Unassigned
unity-2d
Low
Unassigned
unity (Ubuntu)
Low
Unassigned
unity-2d (Ubuntu)
Undecided
Unassigned

Bug Description

To match the new Ubuntu 12.04 Quicklist style, Unity's "Lock to launcher" and "Unlock from launcher" should be changed to "Lock to Launcher" and "Unlock from Launcher".

https://wiki.ubuntu.com/Unity/LauncherAPI#Static_Quicklist_entries

This general topic was discussed at http://irclogs.ubuntu.com/2012/03/06/%23ubuntu-desktop.html#t13:56

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: unity 5.4.0+bzr2054ubuntu0+654
ProcVersionSignature: Ubuntu 3.2.0-18.28-generic 3.2.9
Uname: Linux 3.2.0-18-generic x86_64
ApportVersion: 1.94-0ubuntu2
Architecture: amd64
CheckboxSubmission: 201084ed41ea7548f8becd47fa4d1e6c
CheckboxSystem: c541d13ea4f205f2fd751f76ed21105b
CompizPlugins: [core,composite,opengl,decor,mousepoll,vpswitch,regex,animation,snap,expo,move,compiztoolbox,place,grid,imgpng,gnomecompat,wall,ezoom,workarounds,resize,fade,unitymtgrabhandles,scale,session,unityshell]
CrashDB: unity
Date: Wed Mar 7 22:44:02 2012
SourcePackage: unity
UpgradeStatus: No upgrade log present (probably fresh install)

Related branches

Jeremy Bicha (jbicha) wrote :
Jeremy Bicha (jbicha) wrote :

Branch attached.

John Lea (johnlea) wrote :

Our copywriting guidelines say that only the first letter in a statement and proper nouns should be capitalised, and this is the standard used in all our websites, marketing materials, applications (U1 client, landscape, etc...), design specifications, etc... However Gnome likes to capitalise *every word*, so we have a situation where the desktop is inconsistent with everything else in the Ubuntu ecosystem. Given that it will be easier to make the desktop consistent with the Gnome standard for 12.04 rather than the other way around, I will ok this change for now, however this is something that requires further consideration and I propose we discuss it at UDS.

Didier Roche (didrocks) on 2012-03-08
Changed in unity:
status: New → Fix Committed
milestone: none → 5.6.0
Changed in unity (Ubuntu):
status: New → Fix Committed
Changed in unity:
importance: Undecided → Low
Changed in unity (Ubuntu):
importance: Undecided → Low
Adolfo Jayme (fitojb) wrote :

The new capitalization is live but not present in pot files so it can't be translated. By the way, I agree with John Lea and liked it the old way.

Adolfo Jayme (fitojb) wrote :

Disregard the last comment as the new version of Unity is still not uploaded to precise

Didier Roche (didrocks) on 2012-03-12
Changed in unity:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :
Download full text (4.1 KiB)

This bug was fixed in the package unity - 5.6.0-0ubuntu1

---------------
unity (5.6.0-0ubuntu1) precise; urgency=low

  * New upstream release.
    - compiz crashed with SIGSEGV in g_type_check_instance_cast()
      (LP: #862972)
    - compiz crashed with SIGABRT in __gnu_cxx::__verbose_terminate_handler()
      (LP: #926793)
    - compiz crashed with SIGSEGV in gdk_pixbuf_get_width() (LP: #937421)
    - Unity causes ibus to not work correctly (spaces incorrectly placed)
      (LP: #880876)
    - Dash - update Dash keyboard shortcuts so the 'CTRL + TAB' switches
      between Lenses and 'TAB' by itself moves the focus between categories
      (LP: #891648)
    - HUD - closing a window with <Alt>+<F4> opens the hud (LP: #923410)
    - unity-applications-daemon crashed with SIGSEGV in
      dee_sequence_model_free_row() (LP: #916356)
    - Launcher, Window Management - Launcher reveal should not be triggered
      when dragging a window (LP: #928805)
    - lenses are loaded on start, should be lazy loaded (LP: #929506)
    - Trash icon jumps about when trying to drag an icon onto it (LP: #932365)
    - HUD loses keypresses for the first second after opening (LP: #932906)
    - HUD doesn't give the focus back to the active application after dash/hud
      use (LP: #934061)
    - Launcher - unpinned apps show with empty pips in the launcher as if they
      exist on another workspace (LP: #937898)
    - Unity Dash should support Keywords parameter in .desktop (formerly X
      -GNOME-Keywords or X-AppInstall-Keywords) (LP: #941231)
    - Support FD.o Desktop Actions spec (LP: #942042)
    - Unity hangs when touching my touchpad/trackpad (LP: #942625)
    - [regression] Pressing alt doesn't show the menu title bar in top panel
      (LP: #943194)
    - Alt + F (or other mnemonic) doesn't work in gnome-terminal (LP: #943239)
    - [unity 5.6] Using Alt+F1 or Alt+F2 sends a ";3P" or ";3Q" to the active
      windows (LP: #943456)
    - [unity 5.6] holding alt and pressing a direction opens the alt-tab list
      in a buggy way (LP: #943902)
    - [unity-5.6] can't enter accents (^o->) in the dash since recent updates
      (LP: #944674)
    - Dash - Keyboard navigation for search filters is broken (LP: #844033)
    - Dash - If mouse highlights one icon in grid, keyboard navigation
      highlights another, so there are 2 highlighted icons (LP: #817436)
    - Alt+Tab default delay of 150ms is too long (LP: #888636)
    - Keyboard shortcut - F10 shortcut is used to show menu and this is wrong
      (LP: #878492)
    - Dash - Currently the app lens doesn't show applications that are
      available for purchase (LP: #916121)
    - Chromium is running, but not showing in launcher or alt-tab.
      (LP: #918474)
    - Dash - Different states of rating stars, and dimensions (LP: #924884)
    - alt-tab confused by a multiple instances of an application on different
      workspaces (LP: #925484)
    - Launcher - Icons are not colorized properly (LP: #930949)
    - Remove glow from Alt-tab edge and Search Field image assets
      (LP: #933578)
    - "Left Mouse Drag" and "Middle Mouse Drag" should be translatable
      (LP: #930510)
    - Launcher switcher...

Read more...

Changed in unity (Ubuntu):
status: Fix Committed → Fix Released
Gerry Boland (gerboland) on 2012-03-16
Changed in unity-2d:
milestone: none → 5.8
Gerry Boland (gerboland) on 2012-03-16
Changed in unity-2d:
milestone: 5.8 → 5.7
Jeremy Bicha (jbicha) wrote :

Oh, I didn't see that Gerry already submitted a branch for this. Well two fixes then!

Didier Roche (didrocks) on 2012-03-19
Changed in unity-2d:
milestone: 5.7 → 5.8
Gerry Boland (gerboland) on 2012-03-20
Changed in unity-2d:
status: New → Fix Committed
importance: Undecided → Low
Didier Roche (didrocks) on 2012-03-23
Changed in unity-2d:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity-2d - 5.8.0-0ubuntu1

---------------
unity-2d (5.8.0-0ubuntu1) precise-proposed; urgency=low

  * New upstream release
    - Loss of DBus connection with active Dash/Hud results in broken panel
      (LP: #953168)
    - [launcher] super key and number from _keypad_ doesn't work (LP: #750514)
    - [dash] Home lens state not reset if dash closed & reopened (LP: #948299)
    - HUD is silent to screen readers (LP: #949445)
    - Use title case capitalization "Lock to Launcher" & "Unlock from
      Launcher" (LP: #949636)
    - tiles highlight incorrect, highlight only visible at edge (LP: #953403)
    - [UIFe] Use average color of wallpaper to tint launcher/dash/panel/hud
      (LP: #960194)
  * debian/control:
    - build-dep on latest nux and unity-core
 -- Didier Roche <email address hidden> Fri, 23 Mar 2012 15:33:38 +0100

Changed in unity-2d (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers