Unity 2-d launcher doesn't hide or display properly

Bug #940590 reported by Nicholas Skaggs on 2012-02-24
118
This bug affects 23 people
Affects Status Importance Assigned to Milestone
unity-2d
High
Unassigned
unity-2d (Ubuntu)
Undecided
Unassigned

Bug Description

The Unity 2-d launcher doesn't hide or display properly after using the window switcher. Double click an application that contains more than one window, and then select your window. When the application window is switched, the launcher is stuck in the displayed state, but without the hard right edge, causing full screen windows to appear behind the launcher. See the screenshot for details

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: unity-2d 5.4.0-0ubuntu1
ProcVersionSignature: Ubuntu 3.2.0-17.26-generic 3.2.6
Uname: Linux 3.2.0-17-generic x86_64
NonfreeKernelModules: nvidia
ApportVersion: 1.93-0ubuntu2
Architecture: amd64
CheckboxSubmission: 41733012f282e0b91a263998ebc59472
CheckboxSystem: 4ed15c40009aa6f7770f606350a390a2
Date: Fri Feb 24 14:51:00 2012
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Release amd64 (20111012)
PackageArchitecture: all
SourcePackage: unity-2d
UpgradeStatus: Upgraded to precise on 2012-01-16 (39 days ago)

Related branches

Nicholas Skaggs (nskaggs) wrote :
Jani Uusitalo (uusijani) wrote :

I can confirm this is an issue, though I can't reproduce it with Nicholas' recipe. Not sure what double-clicking should do, here it works just as single-clicking does (bringing the group of windows to front in the order I left them). Thus I have no recipe to reproduce the issue, here it seems to happen seemingly at random. It is quite frequent though, happens multiple times a day and after it's triggered nothing short of killall unity-2d-shell fixes it.

I believe this started with the recentmost big Unity updates, 5.4 I think. It wasn't present in prior versions.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity-2d (Ubuntu):
status: New → Confirmed
Gerry Boland (gerboland) wrote :

Hi guys,
thanks for the report. Can you please run this command in your terminal please, and paste the output to this bug report?

gsettings get com.canonical.Unity2d.Launcher hide-mode

All it is doing is fetching the auto-hide mode setting. We can work from there.
Thanks
-Gerry

Jani Uusitalo (uusijani) wrote :

Hi Gerry. Here's output on my desktop:
jani@saegusa:~$ gsettings get com.canonical.Unity2d.Launcher hide-mode
1

Here's output on my laptop, which is also affected:
jani@lemmikki:~$ gsettings get com.canonical.Unity2d.Launcher hide-mode
2

(I've changed the setting myself using dconf-editor on my desktop but not on my laptop, IIRC.)

Amusingly, it's as if that query now triggered the issue at hand: launcher is currently stuck visible on both computers as I'm typing this. Let me try... No, unfortunately it was apparently just a coincidence: I couldn't reproduce it with the gsettings command deliberately again after killing the stuck U2D.

Jani Uusitalo (uusijani) wrote :

Just to correct myself on my previous-to-last comment: killing might not be necessary after all. I was able to make a stuck launcher start working again by switching between some windows. It definitely doesn't work with just any two windows (tried this on the other desktop still exhibiting this) but which ones matter, I can't tell yet.

Gerry Boland (gerboland) on 2012-03-07
Changed in unity-2d:
status: New → Confirmed
importance: Undecided → High
milestone: none → 5.8
Jani Uusitalo (uusijani) wrote :

I still don't have a surefire recipe for reproducing this, but it seems especially prone to occur when I have multiple Gnome terminal windows open, or one with multiple tabs in it, in addition to other apps. I have a gut feeling it's triggered 4/5 times by switching from something else into the set of Gnome terminal windows (with the mouse, via launcher).

Jan Ask (janaskhoej-gmail) wrote :

For me, this bug still occurs with a 100% updated system. It does not seem to be dependent on any windows or user actions. The 2D Unity Launcher is stuck in displayed mode, no matter what I do.

Michał Sawicz (saviq) wrote :

@Jan: stuck-on-screen is the default behavior in Ubuntu 12.04. You can change it to auto-hide via Appearance in System settings.

Are you saying that after enabling auto-hide it never hides?

Jani Uusitalo (uusijani) wrote :

From Bug #950645, here's one somewhat reliable way to trigger this: after login, have some windows open (I have Chromium, Gnome Terminal and Transmission set to start on login, don't know if this works if you start them manually), then use the workspace switcher. This causes the launcher to stick (i.e. autohide to fail).

Interestingly, if I then killall unity-2d-shell, even this recipe then fails to trigger the issue until the next login. But it seems 100% reproducible right after login.

(I'm just hoping that #950645 really is a duplicate of this one. For me the trigger's always been something else in the launcher since I almost never use the workspace switcher.)

Didier Roche (didrocks) on 2012-03-23
Changed in unity-2d:
milestone: 5.8 → 5.10.0
Jan Ask (janaskhoej-gmail) wrote :

@sarviq - Yes, even with auto-hide enabled, it still never hides. I am using a 100% updated version of 12.04.

Paweł Stołowski (stolowski) wrote :

I can reproduce this problem easily by just activating workspace switcher in new session (no need to have any windows open) and selecting a workspace. After that launcher doesn't auto-hide anymore, until I logout&login again.

James Stewart (jamesst87) wrote :

Having similar issues. For me the first time I use workspace switcher after logging on the launcher gets stuck, I can get it to hide again by just switching workspaces a few times until it disappears. However after this every time I go into workspace switcher the launcher doesn't display at all, in its place I can see whatever was on that area of the workspace I went into the switcher from, (e.g, I have my browser full screen now, if I go into workspace switcher I can see the left side of my browser where the launcher should be).

Changed in unity-2d:
status: Confirmed → Fix Committed
Shahar Or (mightyiam) wrote :

Dear Friends,

This should be fixed in precise, a freeze exception.

Thanks and Blessings,
Shahar

James Stewart (jamesst87) wrote :

Thought I'd add that I've found that pressing alt to bring up the hud makes the launcher auto-hide again.

James, thanks for sharing that alt trick. BTW - this is not (yet) fixed in precise (at least I don't see the fix yet).

Didier Roche (didrocks) on 2012-04-12
Changed in unity-2d:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity-2d - 5.10.0-0ubuntu1

---------------
unity-2d (5.10.0-0ubuntu1) precise-proposed; urgency=low

  * New upstream release:
    - unity-2d-shell crashed with SIGSEGV in
      QCoreApplication::notifyInternal() (LP: #918566)
    - Unity-2d-shell crashes on startup on 64bit machines with 20+ tiles in
      launcher (LP: #967012)
    - Unity 2-d launcher doesn't hide or display properly (LP: #940590)
    - [dash] search terms aren't applied on lens change / dash show
      (LP: #947985)
    - [5.8 pre staging] "sticky edge" option does nothing visible
      (LP: #961285)
    - [dash] Maximise, then restore - much of background not removed from
      screen (LP: #968215)
    - [hud] shows up when using ctrl+alt and pressing alt first (LP: #972318)
    - [UIFe] Dash - No message displayed when no results are returned in the
      Dash (LP: #711199)
    - Missing lens shortcuts (Super-A, Super-F) (LP: #834078)
    - [dash] Unable to scroll Filter Results (LP: #920878)
    - [launcher] stays open if you mouseOut before reveal animation completes
      (LP: #943296)
    - HUD on wrong screen on mutli monitor system (LP: #947145)
    - [a11y] Orca reports "Shell" when opening HUD, Dash or Launcher
      (LP: #948033)
    - multimonitor: Please give me a way to turn off sticky monitor edges
      (LP: #946104)
    - [dash] Esc key behavior inconsistent with Unity (LP: #966121)
    - toggling the spread from the launcher does not work (LP: #968146)
    - unity-2d-shell crashed with SIGSEGV in KeyMonitor::registerEvents()
      (LP: #965464)
    - [Dash] Focus is lost when switching with the mouse (LP: #974235)
    - Multiple items selected in HUD list (LP: #948441)
    - Hud hides launcher even if set to always show (LP: #948960)
    - [launcher] Pointer reveal barrier should be 1 way only (LP: #960175)
    - [hud] connection to HUD being created on startup (LP: #965106)
    - [dash] On 1024x786 screen, dash not fullscreen so border truncated
      (LP: #967305)
  * debian/20_ubuntu-2d-gconf-default:
    - set a default key for HUD showing on Alt, in case unity-3d isn't
      installed or run before unity-2d.
  * debian/control:
    - bump libnux-2.0-dev to latest for ABI break
 -- Didier Roche <email address hidden> Thu, 12 Apr 2012 11:02:08 +0200

Changed in unity-2d (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers