"Creating little endian" step doesn't finish

Bug #241797 reported by macada
This bug report is a duplicate of:  Bug #222700: mksquashfs hangs. Edit Remove
Affects Status Importance Assigned to Milestone
Ubuntu Customization Kit
squashfs (Ubuntu)

Bug Description

UCK: 2.0.3 in Ubuntu 8.04
When I go to console and I select the packages I want for my new ubuntu-remastering-distro, I can select whatever I want: apache, php5, openoffice, etc, but not mysql. If I select mysql-server packages and all of its dependences and the script_uck won't finish and will finish in the: "Creating little endian" step:
Updating files lists...
Packing SquashFS image...
Parallel mksquashfs: Using 1 processor
Creating little endian 3.1 filesystem on /home/macada/tmp/remaster-iso/casper/filesystem.squashfs, block size 131072.
TIOCGWINZ ioctl failed, defaulting to 80 columns
[======================================================== ] 101537/104935 96%
...... and STOPs!!!

Ive tried in diferents computers with the same results

Revision history for this message
macada (macadanet) wrote :
Revision history for this message
Krzysztof Lichota (krzysiek-launchpad-ubuntu-com) wrote : Re: [Bug 241797] Re: "Creating little endian" step doesn't finish

It has already been reported, please see the previous bug report/answer.

Revision history for this message
macada (macadanet) wrote :

Ive read almost all of bugs and, sorry but I didn't find the bug you mentioned.
If you mean this bug: https://bugs.launchpad.net/uck/+bug/194464 is not the same bug cos in my remasterized-distro was already installed mysql-server and worked. The problem of the bug 194464 is because in the host is up another mysql and there is a conflict when mysql-server brings up in the remasterized-distro (I mean inside of the chroot).
In my case I have already a remasterized-distro and working but without mysql and when I want to include it with uck I got this error.
Ive tried also to install a box from scratch with an new ubuntu 8.04 and after install uck as a unique package but I always get the same error in "creating little endian 3.1 filesystem".
I also created the my remasterized-distro with mysql-server following this manual in http://www.debuntu.org/book/export/html/216 and I got the same error in the same step: "creating little endian 3.1 filesystem ....."
Im stuck and frustrated

Revision history for this message
macada (macadanet) wrote :

Hi again,
Ive fixed the problem. mksquashfs is the problematic binary so the uck-script is not the problem. Ive tried to remasterize a distro in ubuntu 7.10 and I didn't got any error. The trouble is with the squasfs-tools package in the 8.04 release. Here is the bug commented: https://bugs.launchpad.net/ubuntu/+source/squashfs/+bug/222700
A workaround is download the debian package of the squasfs-tools: http://ftp.de.debian.org/debian/pool/main/s/squashfs/squashfs-tools_3.3-7_i386.deb. The requirements for this packages are supported in the 8.04 ubuntu.
I hope this workaround helps.

Revision history for this message
Krzysztof Lichota (krzysiek-launchpad-ubuntu-com) wrote :

Thanks for finding the solution :-)

The answer I was talking about was
https://answers.launchpad.net/uck/+question/33873, so they will be
happy to see the solution too :-)

Revision history for this message
Krzysztof Lichota (krzysiek-launchpad-ubuntu-com) wrote :

Not a bug in UCK, workaround found :-)

Changed in uck:
status: New → Invalid
Revision history for this message
Paul Sladen (sladen) wrote :

Right, so if the bug is in 'mksquashfs', lets file it there.

What's changed between the upstream Debian 3.3-7 and the Ubuntu version:

Could somebody who has the problem do:

  dpkg -l squashfs-tools

so that the version of squashfs in question is known.

Changed in squashfs:
status: New → Incomplete
Revision history for this message
bootdsc (bootdsc) wrote :

Just checked and the version is squashfs-tools 1.3.3-1ubuntu2
this is simply an out dated version and installing 3.3-7 fixed the problem

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers

Bug attachments

Remote bug watches

Bug watches keep track of this bug in other bug trackers.