mksquashfs hangs

Bug #222700 reported by Dr Paul Brewer on 2008-04-26
32
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ubuntu Customization Kit
Low
Unassigned
squashfs (Debian)
Fix Released
Unknown
squashfs (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: squashfs-tools

What I expected to happen:
mksquashfs should build a compressed filesystem

What happened instead:
mksquashfs hangs

Potential Fix, Untested:
Debian bugs reports a similar problem with mksquashfs hanging while building a compressed filesystem; there may exist a patch in CVS for squashfs on sourceforge that is not in the officially released distribution on sourceforge.

Overview:
I routinely use mksquashfs as part of a procedure to build a customized compressed filesystem.
No special parameters are input to mksquashfs, as part of this process, so this potentially affects all builders.
Whereas on ubuntu 7.10 and a single processor system, I had no problem with mksquashfs; on a multiprocessor system under ubuntu 8 it hangs.

Command that hangs:
# mksquashfs . $TMPCDCOPY/casper/filesystem.squashfs
(run as root; $TMPCDCOPY points to a valid location; process completes to 96% before hanging)

Package version:
# dpkg-query --list | grep squashfs
ii squashfs-tools 1:3.3-1ubuntu2

Arch: intel 64 bit

lsb_release -rd
Description: Ubuntu 8.04
Release: 8.04

Possible solution:
Debian bugs reports a similar problem; there may exist a patch in CVS for squashfs on sourceforge that is not in the released file on sourceforge.
I thought perhaps the ubuntu mksquashfs could suffer from the same problem and maybe does not include the code in CVS
 as mentioned with debian.

A patch is mentioned at
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=455589
cut/paste of this message follows. (However, I have not tried applying the patch he mentions)

>Message #10 received at <email address hidden> (full text, mbox):
>
>From: Stefan Lippers-Hollmann <email address hidden>
>To: <email address hidden>
>Subject: upstream CVS fixes the regression in squashfs-tools 1:3.3-1
>Date: Tue, 11 Dec 2007 02:30:54 +0100
>
>[Message part 1 (text/plain, inline)]
>
>tags 455589 + patch
>stop
>
>Looking through the recent revision history for mksquashfs.c in the
>upstream CVS, changeset 1.47 of /squashfs/squashfs-tools/mksquashfs.c:
> http://squashfs.cvs.sourceforge.net/squashfs/squashfs/squashfs-tools/mksquashfs.c?r1=1.46&r2=1.47&view=patch
>caught my eyes. Applying it to 1:3.3-1 succeeds and fixes the previously
>mentioned regression in mksquashfs:

tm-o (tm-o) wrote :

This is probably the same bug that is mentioned in squashfs mailing list. You can identify this by trying to use mksquashfs with "-no-sparse" option. This bug seems to be fixed in the latest CVS-version of suashfs-tools. This all was mentioned in squashfs mailing list:
http://sourceforge.net/mailarchive/forum.php?thread_name=oyd63wy5374.fsf%40cs.rice.edu&forum_name=squashfs-devel

I confirm this report. Mine hangs at 49% and I have tried 5 times

ii squashfs-tools 1:3.3-1ubuntu2
Running Ubuntu 8.04 i386

macada (macadanet) wrote :

A workaround is download the debian package of the squasfs-tools: http://ftp.de.debian.org/debian/pool/main/s/squashfs/squashfs-tools_3.3-7_i386.deb. The requirements for this packages are supported in the 8.04 ubuntu.
I hope this helps.

Changed in uck:
importance: Undecided → Low
status: New → Confirmed
Paul Sladen (sladen) on 2008-06-22
Changed in uck:
status: Confirmed → Invalid
Changed in squashfs:
status: New → Confirmed
Changed in squashfs:
status: Unknown → Fix Released
gutocarvalho (gutocarvalho) wrote :

I confirm this report.

The package from debian works fine.

I'm still waiting the fix in ubuntu package.

Thk's.
Guto

sanych (ssanych) wrote :

I confirm this report too.
Debian package worked.

Miguel Rodríguez (migrax) wrote :

I confirm that -no-sparse switch fixes the problem for me

Please, update update the hardy version. I always encounter this problem when I update LTSP images.

GerryG (kanab2004) wrote :

As of Ubuntu Hardy 2-6-24-24, the problem remains. the --no--sparse let it go further, but it still hung. Replaced with the debian package as noted above and all works fine.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.