Client should support multiple/custom directories for sync

Bug #385208 reported by Facundo Batista on 2009-06-09
286
This bug affects 53 people
Affects Status Importance Assigned to Milestone
Ubuntu One Client
Medium
Facundo Batista

Bug Description

I want U1 to synchronize folders that have in my disk that are not under UbuntuOne/My Files (and be able to share them)

Nicola Larosa (teknico) on 2009-06-12
Changed in ubuntuone-client:
importance: Undecided → Wishlist
status: New → Confirmed
fosk (oscarrdg) wrote :

One possible "solution" for this request is to be able to create a symlink on the Ubuntu One folder and then get the local folder sync'd:
https://bugs.edge.launchpad.net/ubuntuone-client/+bug/386019

Rigth now that is not possible with Ubuntu One, but that is how i do it with Dropbox service.

eumetaxas (eumetaxas) wrote :

Or at least let us choose where to to put the U1 folder like dropbox does

Franco (franco-soldera) wrote :

+1

I'd prefer to be able to just select the folders to sync instead of having a special 'UbuntuOne' folder. A configuration option in which one could add folders or exclude folders to sync/from sync would be nice.

Macafyc (macafyc) wrote :

I agree with #4, that would be perfect

Garyu (launchpad-dan-erik) wrote :

+1

tags: added: facundo-lucid
tags: added: chicharra-lucid-features
removed: facundo-lucid
jakslev (jakslev) wrote :

I agree - with Raphael!

David Tangye (davidtangye) wrote :

The folders and files to sync should not need to be in any special location.

One solution could be to allow symbolic links under ~/Ubuntu One or any subdirectory of it, and the target of the link would be used, not the link itself. (However symbolic links within the targets themselves would be used, not their targets.)

My rationale: nearly all my data files are in a large partition, not the / partition. This keeps the system cleaner and more robust. Access to the data files is usually via symbolic links from my $HOME directory, eg ~/Movies --> /mnt/dataPartition/$USER/Movies. This way, when I need to completely reinstall a fresh Ubuntu system (every couple of years, to clear all traces of old outdated setup), I create a new installation (in a new / partition, or overwrite the old / partition), then I just rebuild the symbolic links in the new $HOME to easily find my data files again. (eg [code]cd $HOME; for D in `cd /mnt/dataPartition/$USER && ls *` ; do ln -s /mnt/dataPartition/$USER/$D ; done[/code])

Moreover, and as a workaround, at least the "~/Ubuntu One" object should be able to be placed anywhere, and a symbolic link created in $HOME to point to it. So, as per above, I am currently trying [code]cd $HOME; rm "Ubuntu One"; ln -s "/mnt/dataPartition/$USER/Ubuntu One"[/code]

David Tangye (davidtangye) wrote :

Having written all the above I now see that this bug probably should be marked as a duplicate to the Bug at https://bugs.edge.launchpad.net/ubuntuone-client/+bug/406930 "Add symlink handling", which has many other duplicates, some of which have approx 100 people registered as "affected"

pablomme (pablomme) wrote :

@David: symlinking was mentioned in comment #1 above, along with a link to one of the duplicates of the bug you mention.

This bug is not a duplicate of that bug. This bug is about a different (full-blown) solution to the inability to choose a folder to sync in Ubuntu One. Actually it's possible to implement both solutions simultaneously.

David Tangye (davidtangye) wrote :

@pablomme: If synchronisation were set up via symlinks, this should solve the issue of Ubuntu One not being able to process directories, as a symlink can target either a file, directory, or another symlink (or a hard link for that matter). So you are prbably right: its perhaps not strictly a duplicate, but its closely related in that fixing one, fixes the other (this bug).

Facundo Batista (facundo) wrote :

We'll provide User Defined Folders, which will provide this capability in the home directory of the user. It's not clear that providing this functionality outside that dir would be needed, we think that this is a good first step, and with it we could take better decisions about how to (if) continue.

summary: - I want to get into U1 any folder of my disk
+ I want to get into U1 any folder of my home
Changed in ubuntuone-client:
assignee: nobody → Facundo Batista (facundo)
tags: added: u1-lucid
Roman Yepishev (rye) on 2010-02-11
summary: - I want to get into U1 any folder of my home
+ Client should support multiple/custom directories for sync
pablomme (pablomme) wrote :

@Roman: possibly you want "UbuntuOne" to appear somewhere in the summary?

carles (carles) on 2010-02-11
Changed in ubuntuone-client:
status: Confirmed → Incomplete
Roman Yepishev (rye) wrote :

@pablomme: I guess since the bug is filed against ubuntuone-client it is not that useful to have ubuntuone in the title.

@carles: Why was the status changed? There is an active development of User-Defined Folders (UDF for short) in UbuntuOne.

Changed in ubuntuone-client:
importance: Wishlist → Medium
status: Incomplete → Confirmed
tags: added: chicharra
Changed in ubuntuone-client:
status: Confirmed → Fix Committed
dansteck (dansteck) wrote :

(copied from duplicate bug)

Perhaps add support for simply being able to add different folders to the ubuntuone sync list. Say I want my Pictures folder to sync, I could right click on it and say "Share with UbuntuOne." This way the user can keep their files organized on their computer but also have support for syncing with other computers. When the sync occurs it would be nice to have the files automatically go to their respective folders on the other computer(s).

Changed in ubuntuone-client:
status: Fix Committed → Fix Released
Benjamin Geer (benjamin-geer) wrote :

Facundo, restricting UDFs to the home directory won't solve this problem for me. I keep all important documents on an external hard drive, not in my home directory. If Ubuntu One can't sync those documents, it's completely useless for me.

Facundo Batista (facundo) wrote :

Benjamin:

The "inside home" support was the first step for a more broad support (not restricting to home had too many open variables at the time: for example, what should be done if you want to synchronize "/dev"?).

We preferred to give support inside HOME, that start a too big discussion that might finished in this feature not being in Lucid.

As I said, there're plans to support directories *outside* home... the best you can do for that is to open a new bug for it. It would be awesome if you specify your use case (external hard drive, for example), where you mount it, which directories you'll want to support, what do you expect to happen when you unplug the disk and plug it again and data in it changed, etc.

Thank you very much for your time!

Alan Lue (alan-lue) wrote :

I have a suggestion: how about if Ubuntu One's design included support for syncing of configuration data, such as ~/.emacs, ~/.vimrc and ~/.bash* files?

Access to directories with sensitive information such as ~/.ssh and ~/.gnupg has to be excluded, but otherwise syncing configuration would be a great benefit to those who use multiple machines.

Facundo Batista (facundo) wrote :

Alan, what a lot of people do is to use symlinks in the following way:

- In Ubuntu One, they create a directory to put all these dot-something config dirs:

      mkdir "Ubuntu One/dot-configs"

- Then they move the real config files into there

      mv .vimrc "Ubuntu One/dot-configs/"

  (sometimes they rename it without the initial dot, so as they're not hidden anymore)

- Then they do a symlink of that:

      ln -s "Ubuntu One/dot-configs/.vimrc" .

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers