Booting to live session fails with: at-spi-bus-launcher: unable to create file '/run/user/999/dconf/user': Permission denied.

Bug #1767067 reported by kyt on 2018-04-26
72
This bug affects 8 people
Affects Status Importance Assigned to Milestone
Ubuntu Kylin
Undecided
Unassigned
ubiquity (Ubuntu)
Critical
Unassigned
Bionic
Critical
Unassigned

Bug Description

Test Case:
1. Boot an iso to ubiquity-dm (try or install Ubuntu)
2. Press "Try Ubuntu"

Actual result
50% of the boots boot to gdm, the journal contains "Permission denied" errors

Expected result
The system boots to the live session

Flavours affects:
Ubuntu, Kylin, Budgie, MATE

Related branches

kyt (952456204-6) wrote :
kyt (952456204-6) wrote :
Jean-Baptiste Lallement (jibel) wrote :

confirmed by 3 tests on 3 flavours (Kylin, Budgie and Ubuntu)

affects: ubuntu → ubiquity (Ubuntu)
Changed in ubiquity (Ubuntu):
importance: Undecided → Critical
Jean-Baptiste Lallement (jibel) wrote :

From the log

Apr 26 15:39:45 ubuntu dbus-daemon[1582]: [session uid=999 pid=1582] Activating via systemd: service name='org.a11y.Bus' unit='at-spi-dbus-bus.service' requested by ':1.60' (uid=999 pid=4068 comm="/usr/lib/ibus/ibus-x11 --kill-daemon " label="unconfined")
Apr 26 15:39:45 ubuntu systemd[1567]: Starting Accessibility services bus...
Apr 26 15:39:45 ubuntu at-spi-bus-laun[4081]: unable to create file '/run/user/999/dconf/user': Permission denied. dconf will not work properly.
Apr 26 15:39:45 ubuntu at-spi-bus-laun[4081]: message repeated 4 times: [ unable to create file '/run/user/999/dconf/user': Permission denied. dconf will not work properly.]
Apr 26 15:39:45 ubuntu dbus-daemon[1582]: [session uid=999 pid=1582] Successfully activated service 'org.a11y.Bus'
Apr 26 15:39:45 ubuntu systemd[1567]: Started Accessibility services bus.

Jean-Baptiste Lallement (jibel) wrote :

journal in english with a failed boot.

summary: - [Live]Wrong Permission in live mode.
+ Booting to live session fails with: at-spi-bus-launcher: unable to
+ create file '/run/user/999/dconf/user': Permission denied.
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubiquity (Ubuntu):
status: New → Confirmed
description: updated
Jean-Baptiste Lallement (jibel) wrote :
  • dm Edit (253.4 KiB, text/plain)
Jean-Baptiste Lallement (jibel) wrote :
description: updated
Cristiano (cristianov) on 2018-04-26
Changed in ubiquity (Ubuntu Bionic):
status: Confirmed → Fix Released
Changed in ubuntukylin:
status: New → Confirmed
tags: added: ubiquity-18.04.12
tags: added: bionic
Cristiano (cristianov) wrote :

is the fix been released?

Adam Conrad (adconrad) wrote :

There is no fix for this yet, please don't randomly change the status.

Changed in ubiquity (Ubuntu Bionic):
status: Fix Released → Confirmed
Will Cooke (willcooke) wrote :

Testing strategy for any potentially fixed images:

1. Screen Reader in ubiquity-dm
2. Live Session works in both BIOS and UEFI modes
3. Screen Reader in Live session in both BIOS & UEFI modes
4. Smoke test: boot -> install -> reboot

Ramandeep (coolweather) wrote :

I think there must be some date set for a Fake Final release so that we get Real Final release on time.

information type: Public → Public Security
information type: Public Security → Public
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubiquity - 18.04.14

---------------
ubiquity (18.04.14) bionic; urgency=medium

  * Revert the previous upload. It didn't actually *fix* all cases, just
    papered over them. If the race was lost, the screen reader still didn't
    work in ubiquity-dm mode.
  * Move the Gio.Settings code into the constructor of the wizard. This runs
    with dropped privileges (uid = 0, euid = 999) whereas run() runs as root
    (uid = 0, euid = 0). When run as 0 / 0, dconf creates its
    XDG_RUNTIME_DIR/dconf/user database as root. We need to ensure that it
    runs in a context with dropped privileges. (LP: #1767067)

 -- Iain Lane <email address hidden> Thu, 26 Apr 2018 15:46:32 +0100

Changed in ubiquity (Ubuntu Bionic):
status: Confirmed → Fix Released
experimancer (experimancer) wrote :

What's the new ETA for 18.04 final release (which was delayd because of this bug)?

Jeremy Bicha (jbicha) wrote :

experimancer, please don't ask for an ETA. It will be released when it's ready. When it's released, there will be an announcement on the ubuntu-announce email list so feel free to subscribe there.

https://lists.ubuntu.com/mailman/listinfo/ubuntu-announce

Will Cooke (willcooke) wrote :

Test cases from comment 11 passed on the machine that was previously broken.

Andreas Hasenack (ahasenack) wrote :

I checked "2. Live Session works in both BIOS and UEFI modes" with image sha256 a55353d837cbf7bc006cf49eeff05ae5044e757498e30643a9199b9a25bc9a34

In Legacy mode, don't press any key during boot until you reach the GUI, where the option of trying the live env or running the installer will be presented. In the previous image, trying the live env shoved me to a login screen, whereas in this new image it worked as expected.

In UEFI mode, I had to add "maybe-ubiquity" to the kernel command line in grub to get the same choice presented to me, and then clicking "try" worked just fine without shoving me to a login screen.

I ran the following tests on Ubuntu Desktop in legacy mode:
- boot to ubiquity-dm -> live session -> install
- boot to ubiquity-dm -> install
- from syslinux -> live session -> install
- from syslinux -> install
- I tried with and without orca activated in ubiquity-dm
- I did a series of boots to ubiquity-dm -> live session

All the tests ran successfully.

Alireza (alirezaabdalmaleky) wrote :

When you release this?

Changed in ubiquity (Ubuntu Bionic):
assignee: nobody → Lucifer Conrad Reeves (luciferreeves)
assignee: Lucifer Conrad Reeves (luciferreeves) → nobody
Tyler Hicks (tyhicks) wrote :

I ran the following tests on Ubuntu Desktop in UEFI mode:
- boot to uniquity-dm -> live session
- from syslinux -> live session
- I tried with and without orca activated in ubiquity-dm
- I tried with and without orca activated in the live session

I was unable to test in legacy mode or perform an actual install.

All the tests ran successfully.

experimancer (experimancer) wrote :

jbicha, don't reply with such an arrogant attitude on relevant questions about this bug - it is only interesting to most Ubuntu community members because of being a show stopper for 18.04 final release.

FYI, I (and most of the community) have been following and tracking: https://lists.ubuntu.com/archives/ubuntu-announce/2018-April/thread.html for a long time, but you (Ubuntu) don't announce anything there; nothing about this bug, nothing about the final relase being suddenly delayd, so fix the bug, talk with your community and release the 18.04 or tell us why it has been delayd and for how long, thanks.

On Thu, Apr 26, 2018 at 09:41:52PM -0000, experimancer wrote:
> jbicha, don't reply with such an arrogant attitude on relevant questions
> about this bug - it is only interesting to most Ubuntu community members
> because of being a show stopper for 18.04 final release.

> FYI, I (and most of the community) have been following and tracking:
> https://lists.ubuntu.com/archives/ubuntu-announce/2018-April/thread.html
> for a long time, but you (Ubuntu) don't announce anything there; nothing
> about this bug, nothing about the final relase being suddenly delayd, so
> fix the bug, talk with your community and release the 18.04 or tell us
> why it has been delayd and for how long, thanks.

It is a waste of time to ask for updated timelines on this bug. The people
who are in a position to give you an updated estimate are busy working on
making the release actually happen.

It is true that this bug means the release has been delayed relative to when
the Release Team intended to release it. However, that does not make the
release "late". It is a bug that Launchpad reports milestone expectations
relative to 00:00 UTC. The actual committment is that it releases on
2018-04-26 (no timezone or time specified). You may find it useful to
adjust your expectations accordingly.

Adrian Nöthlich (promasu) wrote :

To set things clear... I'm not a dev for Ubuntu. I'm a normal user, who develops in his free time.
I'm waiting for a release too, but it does not make any sense from a companys' or developers' perspective to publish a buggy, new version. This is just a normal bug and as long there are other bugs, Bionic will not be released...
I'm almost sure that there are more bugs in the last RC published, which are going to be fixed before release.
And who knows. Maybe there is an other RC for a day or two to confirm that these bugs are all fixed.

The devs have better things to do in these hours than sending a mail to a mailinglist.
Just keep caln, be patient and stand by.

Achim Behrens (k1l) wrote :

@21:
https://lists.ubuntu.com/archives/ubuntu-announce/2018-April/000231.html
while you were demanding to be informed about every step developers and volunteers do at the release, they did their job and made the release happen.
If you are really that interessted in the release process, i bet the teams would not reject volunteers to help them. But if you are just impatient, well, that makes you look not that good now.

Jeremy Bicha (jbicha) wrote :

@experimancer, I am sorry that you thought my response was arrogant.

The nature of the release process is that it's not possible to provide an exact hour and minute for release. The release was announced months ago that it would happen on April 26. In an extraordinary event, it's possible for a release to slip as late as the next day. While this was an annoying bug, it is sadly not unusual for late issues to be discovered while getting ready to prepare the release. That is why we test release candidate images -- so that we can find important issues in time to fix them and still get the release out sometime on the promised day. Most of these late bugs never get any attention at all in social media or news sites.

Since the release did happen on April 26 (at least in some timezones), there was no need to put out an announcement about it being late because it wasn't yet late really.

Ubuntu simply has way too many users for Ubuntu volunteers like me to be able to provide all of you individualized attention and explanations as to why we don't have a more precise ETA. In any case, this is completely off-topic since this webpage is about a bug that has now been fixed.

Jerry Kao (jerry.kao) wrote :

I can not reproduced this issue with image "ubuntu-18.04-desktop-amd64" just downloaded at 10:00am UTC+8.
md5sum 129292a182136a35e1f89c586dbac2e2

Jeremy Bicha (jbicha) on 2018-04-27
Changed in ubuntukylin:
status: Confirmed → Fix Released
kyt (952456204-6) on 2018-04-28
Changed in ubuntukylin:
milestone: none → bionic-final
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers