Some dash searches don't return application results, but retrying or toggling the 'applications' filter works

Bug #1295908 reported by Juan Manuel on 2014-03-22
130
This bug affects 21 people
Affects Status Importance Assigned to Milestone
Unity
Triaged
High
Unassigned
unity (Ubuntu)
High
Unassigned
Xenial
High
Unassigned

Bug Description

Steps to reproduce:
 1. Open Dash
 2. Type a name of an application installed on your system, like "calculator"
 3. press escape

What happens: Application scope stops giving results

What should happen: Application scope should still give results

How to fix it once it happens:
A)type something and either hit escape or delete what you have typed.
B)Check "application" in filters in the Dash (it gets unchecked)

From the comments, it seems this might have something to do with people having online searches disabled.

ProblemType: Bug
DistroRelease: Ubuntu 13.10
Package: unity 7.1.2+13.10.20131014.1-0ubuntu1
ProcVersionSignature: Ubuntu 3.11.0-18.32-generic 3.11.10.4
Uname: Linux 3.11.0-18-generic x86_64
ApportVersion: 2.12.5-0ubuntu2.2
Architecture: amd64
CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
Date: Fri Mar 21 19:12:19 2014
InstallationDate: Installed on 2013-10-05 (167 days ago)
InstallationMedia: Ubuntu 13.04 "Raring Ringtail" - Release amd64 (20130424)
MarkForUpload: True
SourcePackage: unity
UpgradeStatus: Upgraded to saucy on 2013-12-10 (101 days ago)

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity (Ubuntu):
status: New → Confirmed
vanadium (ftack) wrote :

I don't agree that this bug report is a duplicate of bug #1308037. The other bug reports no applications appearing in the applications scope. This bug report reports applications not anymore appearing in the home lens. The Applications lens still keeps working, though (but not, as I understand, in bug #1308037).

As a matter of fact, it is due to "Applications" being disabled in "Filter results" in the home dash at some time during the session, without apparent reason. Checking "Applications" back on again makes applications reappear in the home lens.

It is not possible to say what triggers this, and thus impossible to provide steps to "reproduce" this issue.

vanadium (ftack) wrote :

Switchin on "Filter results" reveals that searches for user files may disable the Category "Applications". The following time the dash is summoned, it will not find applications when typing in a new search term. Pressing "Escape" before entering the new search term will enable the Application scope, and again cause the Dash to find applications.

This is a bug, because the scope of the home lens should not change by itself. Again, this bug is NOT a duplicate of bug #1308037.

vanadium (ftack) wrote :

I should have added that this is a bug that exists for some time. It was reported for 13.10, I am currently running an updated 14.04.

Changed in unity:
status: New → Confirmed
TomasHnyk (sup) wrote :

Possible duplicate is also bug # 1239031 , but I am not sure.

description: updated
description: updated
Iain Lane (laney) wrote :

Forgive me that I'm re-explaining the bug, but I just want it to be clear. When I see this (I agree it is certainly not #1308037 - when that happens [haven't seen it for a long time though], *no* searches ever give a result until Unity is restarted - this is about some searches not working & retrying being okay), it's like this.

  - Open dash, search for something.
  - Usually it works but sometimes I get "Sorry, there is nothing that matches your search." wrongly.
  - When that happens, I can open "Filter results" and select "Applications" to see the results.
  - It's easy to reproduce - just hit ctrl-backspace and type the same search term a few times. Soon it'll not work.

I can only get this to happen on one of my two machines. Perhaps the interesting difference is that the one which reproduces it has been installed for a long time and the other one is quite new.

tags: added: rls-w-incoming
TomasHnyk (sup) wrote :

Hm, I cannot reproduce it now on 15.10 even though it used to happen always. (I always do a clean isntall but my ~ directory is about ten yours old).

Seth Johnson (sethj) wrote :

Thank you for taking the time to report this bug. We have tried to recreate this on the latest release of Ubuntu and cannot reproduce it. This bug is being marked as Invalid. If you believe the problem to still exist in the latest version of Ubuntu please comment on why that is the case and change the bug status to NEW.

Changed in unity (Ubuntu):
status: Confirmed → Invalid
Changed in unity:
status: Confirmed → Invalid
Colin Law (colin-law) wrote :

I am still seeing it intermittently on 15.10. See uploaded screenshot

Changed in unity:
status: Invalid → Confirmed
Changed in unity (Ubuntu):
status: Invalid → Confirmed
Andrea Azzarone (azzar1) wrote :

Hey Colin,

I'm working right now to improve the reliability of dash and scopes. I marked this bug as a duplicated of the #1229370.

Colin Law (colin-law) wrote :

I don't see how this is a dup of #1229370 as that one refers to a solid failure of the home scope, whereas I am seeing an intermittent one. In fact that one looks like a simple problem to do with whether the scope is correctly installed.

Andrea Azzarone (azzar1) wrote :

Sorry you are right.

Changed in unity:
assignee: nobody → Andrea Azzarone (azzar1)
Changed in unity (Ubuntu):
assignee: nobody → Andrea Azzarone (azzar1)
Changed in unity:
milestone: none → 7.3.3
importance: Undecided → High
Changed in unity (Ubuntu):
importance: Undecided → High
Changed in unity:
status: Confirmed → Triaged
Changed in unity (Ubuntu):
status: Confirmed → Triaged
Colin Law (colin-law) wrote :

OK, keep up the good work :)

Iain Lane (laney) on 2015-10-14
summary: - Sometimes applications stop showing up in the Dash
+ Some dash searches don't return application results, but re-trying or
+ toggling the 'applications' filter works
summary: - Some dash searches don't return application results, but re-trying or
+ Some dash searches don't return application results, but retrying or
toggling the 'applications' filter works
Changed in unity:
milestone: 7.3.3 → 7.4.0
tags: added: rls-x-incoming
removed: rls-w-incoming
Will Cooke (willcooke) on 2015-11-16
tags: removed: rls-x-incoming
tags: added: unity-backlog

Bug #1526980 can be related.

Any news? This bug has been there since 2011.

tags: added: xenial

Feel free to reassign yourselves to the bug just before starting working on it. Otherwise it's blocked for other contributors.

Changed in unity:
assignee: Andrea Azzarone (azzar1) → nobody
Changed in unity (Ubuntu):
assignee: Andrea Azzarone (azzar1) → nobody
Changed in unity (Ubuntu Xenial):
assignee: Andrea Azzarone (azzar1) → nobody
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers