[SRU] "When power is critically low" setting does nothing

Bug #1599264 reported by Will Cooke on 2016-07-05
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
One Hundred Papercuts
Medium
Unassigned
ubuntu-docs (Ubuntu)
Medium
Chris Perry
Xenial
Undecided
Unassigned
Yakkety
Undecided
Unassigned
unity-control-center (Ubuntu)
Medium
Will Cooke
Xenial
Medium
Will Cooke
Yakkety
Medium
Will Cooke

Bug Description

[Impact]

In unity-control-center (u-c-c) there is an option for taking an action when "Power is critically low". The choices are "Hibernate" or "Power off". Often Hibernate is a disabled option because of problems with hibernate on various systems.

However - what to do in the event of a critically low power situation is now handled by Upowerd automatically and so making a choice in u-c-c does nothing at all.

As such, leaving that option accessible to users will lead to confusion.

This patch removes the option from the UI.

[Test Case]

On an unpatched machine with a battery (i.e. laptop) open the power panel in u-c-c (Power/Settings menu in the top right corner -> System Settings -> Power. Note that the 2nd option down is "When power is critically low".

Once this update is applied and u-c-c is closed and reopened, this option is no longer present.

[Regression Potential]
There are some deletions from the ui file and some corresponding code deletions from the associated c file (cc-power-panel.c).

It is possible that extra code has been removed that could cause a crash or affect other options in the power panel.

However, the changes are fairly small and easy to review. Nothing looks out of place. Also testing has not shown any problems.

[Other Info]

Verbal (IRC) +1 from design via mpt.
+1 from docs team via mailing list.

Related branches

Will Cooke (willcooke) wrote :

Patch out the "When power is critically low" section of the power ui.

The attachment "powerui.patch" seems to be a patch. If it isn't, please remove the "patch" flag from the attachment, remove the "patch" tag, and if you are a member of the ~ubuntu-reviewers, unsubscribe the team.

[This is an automated message performed by a Launchpad user owned by ~brian-murray, for any issues please contact him.]

tags: added: patch
Will Cooke (willcooke) wrote :

Removing patch and adding branch.

tags: removed: patch
Will Cooke (willcooke) wrote :

For doc team: this is what the power panel looks like after the changes. You will note the "When power is critically low" section is now removed.

Will Cooke (willcooke) wrote :

For doc team: this is what the power panel looks like after the changes. You will note the "When power is critically low" section is now removed.

Changed in unity-control-center (Ubuntu):
status: New → Confirmed
Will Cooke (willcooke) on 2016-07-06
Changed in unity-control-center (Ubuntu):
importance: Undecided → High
assignee: nobody → Will Cooke (willcooke)
milestone: none → ubuntu-16.04.1
Gunnar Hjalmarsson (gunnarhj) wrote :

Thanks for the docs hint, Will. Suppose it affects this page:

https://help.ubuntu.com/stable/ubuntu-help/power-lowpower.html

Changed in ubuntu-docs (Ubuntu):
importance: Undecided → Medium
status: New → Confirmed
Changed in ubuntu-docs (Ubuntu Xenial):
status: New → Won't Fix
Doug Smythies (dsmythies) wrote :

@Gunnar: It is not clear to me why we wouldn't fix this in Xenial. I think we should.

Will Cooke (willcooke) on 2016-07-06
Changed in unity-control-center (Ubuntu Yakkety):
milestone: ubuntu-16.04.1 → ubuntu-16.10
Changed in unity-control-center (Ubuntu Xenial):
milestone: none → ubuntu-16.04.1
assignee: nobody → Will Cooke (willcooke)
importance: Undecided → High
status: New → Confirmed
Gunnar Hjalmarsson (gunnarhj) wrote :

On 2016-07-06 19:56, Doug Smythies wrote:
> @Gunnar: It is not clear to me why we wouldn't fix this in Xenial. I
> think we should.

I explained my view on the ubuntu-doc mailing list:

https://lists.ubuntu.com/archives/ubuntu-doc/2016-July/020106.html

So in short:

* To the extent an UI freeze exception is needed for SRU:ing the actual
  u-c-c change: Ok from a docs POV.

* The change would still not justify the work with SRU:ing the
  corresponding spot in the desktop guide.

Jeremy Bicha (jbicha) wrote :

Gunnar, at least it's a text deletion instead of addition or change for ubuntu-docs which means it shouldn't affect translations. I can understand SRU's being a fair amount of work, but an SRU for this seems do-able to me.

Gunnar Hjalmarsson (gunnarhj) wrote :

@Jeremy: Would a deletion of that para be sufficient? Possibly. But in any case, for all languages except en_US ubuntu-docs is made available on the desktop via the language packs, so an SRU of ubuntu-docs *always* involves a full translation update.

Do-able? Indeed. Worth it? Not IMO.

The official held criteria for setting if a bug fix should go into a stable release update is simply this: if the fix cannot break other software or the risk of doing so is less than leaving it as it is, then it goes to an update.

Changed in ubuntu-docs (Ubuntu Xenial):
importance: Undecided → Medium
status: Won't Fix → Triaged
Changed in ubuntu-docs (Ubuntu Yakkety):
status: Confirmed → Triaged
Changed in unity-control-center (Ubuntu Xenial):
status: Confirmed → Triaged
Changed in unity-control-center (Ubuntu Yakkety):
status: Confirmed → Triaged

Since this bug is just a minor usability issue, its priority should be "medium". "High" if for bugs that represent major disruptions.

Changed in unity-control-center (Ubuntu Xenial):
importance: High → Medium
Changed in unity-control-center (Ubuntu Yakkety):
importance: High → Medium
Changed in hundredpapercuts:
status: New → Triaged
importance: Undecided → Medium
Will Cooke (willcooke) on 2016-07-07
summary: - "When power is critically low" setting does nothing
+ [SRU] "When power is critically low" setting does nothing
Will Cooke (willcooke) wrote :

Update description to be SRU compliant.

description: updated
description: updated
Gunnar Hjalmarsson (gunnarhj) wrote :

On 2016-07-07 00:27, Alberto Salvia Novella wrote:
> The official held criteria for setting if a bug fix should go into a
> stable release update ...

There are no general criteria for determining when a bug fix *should* be backported. The purpose of the SRU criteria is to make clear under which circumstances backporting *may* take place. Obviously they don't override 'cost-benefit' considerations.

Changed in ubuntu-docs (Ubuntu Xenial):
importance: Medium → Undecided
status: Triaged → Won't Fix
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity-control-center - 15.04.0+16.10.20161003.1-0ubuntu1

---------------
unity-control-center (15.04.0+16.10.20161003.1-0ubuntu1) yakkety; urgency=medium

  [ Robert Ancell ]
  * Don't check if we're running under Unity - we only support Unity
    (LP: #1554878, #1629668)
  * Ubuntu only supports usernames with lowercase letters. (LP:
    #1600638)

  [ Sebastien Bacher ]
  * Revert the change from r12750 to include only graphical sessions.
    (LP: #1380364)

  [ <email address hidden> ]
  * Removed "when battery is critical" functionality from the power
    panel as this is now handled by Upower and these settings now do
    nothing. Fixes LP: #1599264 (LP: #1599264)

 -- <email address hidden> (<email address hidden>) Mon, 03 Oct 2016 11:19:09 +0000

Changed in unity-control-center (Ubuntu Yakkety):
status: Triaged → Fix Released
no longer affects: unity-control-center (Ubuntu Z-series)
Changed in ubuntu-docs (Ubuntu Yakkety):
importance: Medium → Undecided
status: Triaged → Won't Fix
Chris Perry (clissold345) wrote :

I think it should be straightforward for me to update the desktop help (17.04). However, I need to check (in simple terms) what ubuntu now does when the power gets low. When the battery gets to 10% ubuntu will (attempt to) suspend? Is that correct? If the computer has problems suspending ubuntu will not know that and will still (attempt to) suspend? Is that correct? I'm asking because I'm planning to state what happens in the desktop help. Here's the link for the current version of the affected page:

https://help.ubuntu.com/stable/ubuntu-help/power-lowpower.html

Gunnar Hjalmarsson (gunnarhj) wrote :

@Chris: The main thing with respect to this bug report is to remove the middle para, which is no longer applicable. Then, if you also want to confirm that the rest of the page is accurate, it's fine.

Chris Perry (clissold345) wrote :

Hi Gunnar, I take your point that I'm going beyond fixing this bug - but that (ideally) is what a good tech writer does.

I think here's the answer to my question (link below). The default setting is "suspend" - yes I've checked 16.04 and that is correct. However, there's a bug so that when the setting is "suspend" Ubuntu shuts down when power is critically low. So can I fix this bug and also state that ubuntu by default shuts down when power is critically low? I believe that unless the user fiddles with the gnome settings, which aren't documented in the desktop help, there's no possibility of suspend, so can I remove the info about suspend on this page. In that case it will be a very short page!

http://askubuntu.com/questions/667668/notebook-does-not-power-off-when-battery-is-critically-low

Gunnar Hjalmarsson (gunnarhj) wrote :

@Chris: Hmm.. I'm now inclined to think that we should drop the whole page, since the point with it is to describe a control which no longer exists. The suspend state is mentioned at other places in the desktop guide, and maybe we should just add somewhere that the computer suspends automatically when the power is critically low.

If you agree, can you please submit a MP along those lines? Then we can continue talking there.

( It was not my intention to criticize you for thinking beyond the scope of this bug. Actually I don't think you do, and even if you had, it would have been a good thing. ;) )

Changed in ubuntu-docs (Ubuntu):
assignee: nobody → Chris Perry (clissold345)
importance: Undecided → Medium
status: Triaged → Fix Committed
no longer affects: ubuntu-docs (Ubuntu Z-series)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-docs - 17.04.1

---------------
ubuntu-docs (17.04.1) zesty; urgency=medium

  * scripts/validate.sh:
    - Modified so it can be called via a symlink from 'ubuntu-help/C'
      or 'html'.
  * power-hibernate.page:
    - Changed command due to upstart->systemd transition.
  * Bump version to 17.04 / zesty.
  * html/ubuntu.xsl:
    - Make unordered lists bulleted and not numbered (LP: #1649554).
  * keyboard-layouts.page:
    - Note about how to show rarely used xkb layout variants.
  * Updated ubuntu-help.pot.
  * debian/compat, debian/control:
    - Bump to debhelper version 9

  [ Chris Perry ]
  * tips-specialchars.page:
    - Section "Compose key" updated (LP: #1624778).
  * addremove-ppa.page:
    - Revise PPA description (LP: #1628706).
  * keyboard-layouts.page:
    - Move text of marginal note.
  * mouse-middleclick.page, mouse-touchpad-click.page:
    - Revise description of middle-click from touchpad (LP: #1617718).
  * power-lowpower.page:
    - Update since related control in "System Settings -> Power" has
      been removed (LP: #1599264, LP: #1641786).
  * accounts-add.page, net-firewall-on-off.page:
    - Minor clarifications.
  * net-wireless-*.page, net-problem.page:
    - GUI conformity modifications (LP: #1637126)
    - New shared section (LP: #977251)
  * addremove-install.page, addremove-remove.page:
    - Clearer description of Ubuntu Software's focus on applications
      (LP: #1637861).
    - Mentioning of snaps (LP: #1658785).
  * printing-setup.page:
    - Section about network printer added (LP: #1630272).
  * mouse-mousekeys.page:
    - Improved description of mouse keys (LP: #964727).
  * disk-*.page:
    - GUI conformity modifications (LP: #1651360).
  * List type explicitly stated on multiple pages.
  * addremove-creator.page:
    - New page describing Startup Disk Creator (LP: #1569532).
  * security-settings.page:
    - New page describing the Security & Privacy panel in System
      Settings (LP: #1200381).

  [ Doug Smythies ]
  * scripts/validate.sh:
    - Changed to --strict validation.
  * ubuntu-help/C/legal.xml:
    - Specify https to avoid a "permanently moved" redirection.

 -- Gunnar Hjalmarsson <email address hidden> Mon, 20 Feb 2017 15:11:00 +0100

Changed in ubuntu-docs (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers