Error formatting disk using disk utility

Bug #1059872 reported by Jeremiah Njoroge on 2012-10-01
This bug affects 177 people
Affects Status Importance Assigned to Milestone
util-linux (Debian)
Fix Released
util-linux (Ubuntu)

Bug Description


Formatting a SD card using the disk utility fails with an error message

"Error formatting disk - Error synchronizing after initial wipe: Timed out waiting for object (udisks-error-quark, 0)"

The underlying problem is that the "wipefs" tool from util-linux does not work any more.

You can work around this bug in gnome-disk-utility using these steps:

* After selecting the SD card, instead of clicking the gear icon to format,
  click the partition in the "Volumes" section.

* Delete the partition ("minus" icon)

* Create a new partition

[Test Case]

$ sudo modprobe scsi_debug dev_size_mb=200
# this creates a new /dev/sdX, usually /dev/sdb; check dmesg!

# now create a partition table
$ cat <<EOF | sudo sfdisk /dev/sdb
# partition table of /dev/sdb
unit: sectors

/dev/sdb1 : start= 32, size= 409568, Id=83
/dev/sdb2 : start= 0, size= 0, Id= 0
/dev/sdb3 : start= 0, size= 0, Id= 0
/dev/sdb4 : start= 0, size= 0, Id= 0

# now create an ext4 file system:
$ sudo mkfs.ext4 /dev/sdb1

# check contents:
$ sudo blkid -p /dev/sdb /dev/sdb1
/dev/sdb: PTTYPE="dos"
/dev/sdb1: UUID="4bd1c542-a61f-43c4-a7e5-cc50e66e6b5a" VERSION="1.0" TYPE="ext4" USAGE="filesystem" PART_ENTRY_SCHEME="dos" PART_ENTRY_TYPE="0x83" PART_ENTRY_NUMBER="1" PART_ENTRY_OFFSET="32" PART_ENTRY_SIZE="409568" PART_ENTRY_DISK="8:16"

# wipe:
$ sudo wipefs -a /dev/sdb

# now check contents again
$ sudo blkid -p /dev/sdb /dev/sdb1

# in the broken case, you will still see a "dos" partition table and the ext4 partition; in the working case, /dev/sdb won't show anything and /dev/sdb1 does not exist any more

ProblemType: Bug
DistroRelease: Ubuntu 12.10
Package: udisks 1.0.4-6
ProcVersionSignature: Ubuntu 3.5.0-15.23-generic 3.5.4
Uname: Linux 3.5.0-15-generic x86_64
ApportVersion: 2.6.1-0ubuntu1
Architecture: amd64
CustomUdevRuleFiles: 51-android.rules 51-android.rules~
Date: Mon Oct 1 15:07:46 2012
InstallationMedia: Ubuntu 12.10 "Quantal Quetzal" - Alpha amd64 (20120720.1)
MachineType: FOXCONN NT-A2400&NT-A3500
 PATH=(custom, no user)
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.5.0-15-generic root=UUID=fcc445e4-9662-47cc-855d-ca17ad1c2a87 ro quiet splash vt.handoff=7
SourcePackage: udisks
UpgradeStatus: No upgrade log present (probably fresh install) 03/29/2011
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: 4.6.4
dmi.board.asset.tag: To be filled by O.E.M. NT-A2400&NT-A3500
dmi.board.vendor: FOXCONN
dmi.board.version: FAB 1.0
dmi.chassis.asset.tag: To Be Filled By O.E.M.
dmi.chassis.type: 4
dmi.chassis.vendor: FOXCONN
dmi.chassis.version: To Be Filled By O.E.M.
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvr4.6.4:bd03/29/2011:svnFOXCONN:pnNT-A2400&NT-A3500:pvrFAB1.0:rvnFOXCONN:rnNT-A2400&NT-A3500:rvrFAB1.0:cvnFOXCONN:ct4:cvrToBeFilledByO.E.M.: NT-A2400&NT-A3500
dmi.product.version: FAB 1.0
dmi.sys.vendor: FOXCONN

Related branches

Jeremiah Njoroge (jnjoroge) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in udisks (Ubuntu):
status: New → Confirmed
komputes (komputes) wrote :

This affects USB disks as well as SD cards.

summary: - Error formatting disk(SD card) using disk utility
+ Error formatting disk using disk utility
Kangarooo Jānis (kangarooo) wrote :

Theres no update for Udisks or gnome-disks yet still error exists in 12.10
Gparted works. Why?

Kangarooo Jānis (kangarooo) wrote :

Why buggy version left pbulic?

2green (zendhetmij) wrote :

Ubuntu 12.04 and 12.10 can not format a usb stick or drive without using the terminal.

In day to day use this function is used a lot by users to clean the drive before adding new data like pictures etc.

I'll use the terminal for this, but some people will return to windows for this.

Dmitry Pankratov (dremon) wrote :

Still exists in 13.04.

2green (zendhetmij) wrote :

Still exists in 13.04 (As mentioned by Dmitry), same problem also occurs with the 'startup disk creator'.... Related?

I'll check if this bug is registered for the startup disk creator, which should be a high priority given the situation that we want more users for ubuntu.

swiety (swie99) wrote :

It's strange for me, but when i delete partition and add new then i can successfully format it

cameleon (el-cameleon-1) wrote :

it is incredible that we cannot do something as simple as formatting a usb-pen with default tools in 2013 with Ubuntu.

I love open source softwares, but sometimes I feel tired...

Ari Passopolis (apasserby) wrote :

This bug is an excresence on open source. Someone should have the good sense to fix it for once and all.

calltheninja (calltheninja) wrote :

Wow. It's bugs like this that scare people away from free operating systems. The default disk utility can't format disks? SERIOUSLY???

Judson W (judderwocky) wrote :

I completely agree with the latter comments. I love open source, but I had this problem on a computer while i was trying to convince somebody to use Ubuntu.

Now how do you think that conversation went?

Frankly, when this stuff happens and its such a pain, I find myself second guessing why I use it all.

I had to use the startup disk creator to format a drive.

How pathetic is that.

And you know what, this bug has been around for months.

Still here in Raring 13.10. Uffff....
Workaround: install GParted and be happy. It's a bit more criptic (and powerful --- the unix way). Simple remember to unmount the device before formatting-

rachel (rachel-g41) wrote :

First, as someone very new to Linux I'm glad to see this isn't just my problem.

However, the Gparted solution doesn't work for me - Gparted can't see the disk in question (although it shows in Disks).

I'd be grateful for any other solutions.

the same problem on
ubuntu 13.10 32/bit
Error synchronizing after initial wipe: Timed out waiting for object (udisks-error-quark, 0)

Getting the same problem on Ubuntu 13.04 64-bit. I intend to completely format a disk (Overwrite data with zeroes) so using gparted isn't an alternative in my case.

Jan D (jandeyk-gmail) wrote :

This is hurting my pride using Ubuntu...
Please fix this!
Fresh install Ubuntu 13.10 64-bit.

Fabián Rodríguez (magicfab) wrote :

I've reported this in Debian (unstable):

Changed in udisks (Debian):
status: Unknown → New
Artiom Neganov (aneganov) wrote :

Ебаный стыд. Извините.

A comment upstream says this is related to - has anyone checked if upgrading util-linux fixes the issue?

Thanks Alberto --- I hope that a more recent util-linux could be pushed for Trusty --- it will be a no-end of problems like this one otherwise...

Phillip Susi (psusi) wrote :

The comment in the debian bug is nonsense; the linked bug report says nothing about it fixing a bug in udisks. It also is fixed in Ubuntu.

I tested it again on 13.04 --- it seems fixed. I didn't notice because the status of this bug has not changed. Can anyone test it on 13.10 and then mark it as fixed?

I'm using Ubuntu 13.10 on my laptop and still having this issue, this is how I ended up here :(

Antonio Miras (amarostegui) wrote :

The same problem in my Dell desktop computer. Ubuntu 13.10 x64

Phillip Susi (psusi) wrote :

Ok, I found the correct debian bug that corresponds to this, and merged the other one with it. It looks like this will indeed be fixed by upgrading util-linux, but it is too late for that to happen in 14.04.

Changed in udisks (Debian):
status: New → Unknown

Hmmm... I checked it again in 13.10 with `gnome-disk` and I had no problem in formatting an USB key with it. Which are the systems where it fails? Or it is another application?

Changed in udisks (Debian):
status: Unknown → Confirmed
Antonio Miras (amarostegui) wrote :

Romano, in my computer, the bug happens when using "gnome-disks" to format a USB drive

tags: added: trusty

It renders essential functionality of the package (or a dependent one) broken.

Changed in udisks (Ubuntu):
status: Confirmed → Triaged
importance: Undecided → High
Changed in udisks (Debian):
status: Confirmed → Fix Released
Heiko L (hl1) wrote :

This bug exists for 1+1/2 years and finally made it into the LTS version 14.04 (Trusty).
I'm wondering why this bug was allowed to break such basic and essential functionality like formatting a USB stick in an Ubuntu LTS version.
If it couldn't get fixed, the tool should have been replaced by GParted.
(Yes, GParted may be a little more complex to use, but what is the use of a tool that does not work?)
(doesn't work on any of 3 Ubuntu 14.04 computers)

Changed in udisks (Debian):
status: Fix Released → Confirmed
Changed in udisks (Ubuntu):
status: Triaged → In Progress
assignee: nobody → Dimitri John Ledkov (xnox)
Dimitri John Ledkov (xnox) wrote :

udisks1 is obsolete, the fix is needed in udisks2 instead.

Changed in udisks2 (Ubuntu):
status: New → In Progress
importance: Undecided → High
assignee: nobody → Dimitri John Ledkov (xnox)
Changed in udisks (Ubuntu):
status: In Progress → Won't Fix
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package udisks2 - 2.1.3-2git1ubuntu1

udisks2 (2.1.3-2git1ubuntu1) utopic; urgency=medium

  * Add a patch, to allow passing an option over dbus Format call to
    ignore errors from synchronization after the initial wipe. (LP:
 -- Dimitri John Ledkov <email address hidden> Tue, 22 Jul 2014 18:33:22 +0100

Changed in udisks2 (Ubuntu):
status: In Progress → Fix Released
Phillip Susi (psusi) wrote :

That's not the right thing to do Dimitri. The problem is not with the synchronization, but the fact that wipefs is not actually removing the partition table. It is wipefs that needs patched, not udisks.

Martin Pitt (pitti) wrote :

Eek, yes. At some point we *need* to get off our hilariously ancient util-linux and upload a current version. Dimitri, I'm not going to keep this patch, it's never going to go upstream or in other distros, and is just a sad workaround for our broken wipefs.

affects: udisks2 (Ubuntu) → util-linux (Ubuntu)
Changed in util-linux (Ubuntu):
status: Fix Released → Triaged
affects: udisks (Debian) → util-linux (Debian)
no longer affects: udisks (Ubuntu)
Dimitri John Ledkov (xnox) wrote :

Adjust the device to format as appropriate with both util-linux 2.20 and 2.24 the synchronization after initial wipe fails, unless i use the silence option as demonstrated.
I'll try to figure out how to run a similar thing as an autopkgtest, such that formating works when util-linux is upgraded and this fix is reverted.

Changed in udisks2 (Ubuntu):
assignee: nobody → Dimitri John Ledkov (xnox)
Changed in util-linux (Ubuntu):
assignee: Dimitri John Ledkov (xnox) → nobody
Changed in udisks2 (Ubuntu):
status: New → Triaged
Dimitri John Ledkov (xnox) wrote :

Whilst the bug maybe elsewhere, udisks2 will need an action to revert the patch i uploaded, thus keeping the task againt udisks2 assigned to myself.

Changed in util-linux (Debian):
status: Confirmed → New
Phillip Susi (psusi) wrote :

Dimitri, are you going to revert that patch? I was going to revert it locally to verify that installing the new util-linux 2.24 from debian experimental fixed it, but it seems that the bzr branch is significantly out of date for some reason...

On 27 July 2014 03:16, Phillip Susi <email address hidden> wrote:
> Dimitri, are you going to revert that patch? I was going to revert it
> locally to verify that installing the new util-linux 2.24 from debian
> experimental fixed it, but it seems that the bzr branch is significantly
> out of date for some reason...

I've tested locally both 2.24 and 2.25 from pkg-util-linux and the
sample python script to format a drive using UDisks2 API still fails
with a timeout syncing after initial wipe.
I see no reason to revert that patch, given that UDisks still fails to
format drives, by default. And all that patch does is introduces an
extra option to be less safe.
I also have preliminary scripts to make this into an autopackagetest
using loop mounts.

At the moment though, udisks2 API users are a bit broken e.g. "Disks"
gui utility most importantly.

If there is an urgent desire to revert this harmless by-default patch,
I can stop using UDisks2 api in usb-creator altogether and instead use
something like pyparted or just manual set of low-level commands
(wipefs, mkfs, parted...)



Phillip Susi (psusi) wrote :

I was going to say that adding an option would break the ABI wouldn't it? And it sounds like you are saying that it did, and so the disk utility now is completely broken. If so, then yes, this certainly does need reverted; we can't be changing the ABI.

Dimitri John Ledkov (xnox) wrote :

On 28 July 2014 14:35, Phillip Susi <email address hidden> wrote:
> I was going to say that adding an option would break the ABI wouldn't
> it? And it sounds like you are saying that it did, and so the disk
> utility now is completely broken. If so, then yes, this certainly does
> need reverted; we can't be changing the ABI.

No ABI is broken, nor changed. Please read & understand the patch I
uploaded, before making false statements. If you have questions, ask
and I'll explain more what it does.

disk utility can't format drives in Ubuntu. The patch I added to
UDisks2 has no effect on disks utility in either way, since simply the
default (broken) behavior is used there.



Phillip Susi (psusi) wrote :

I see now.. through the magic of dbus variants you can add optional arguments without breaking abi.

Running util-linux 2.24.2-1, this timeout problem has been solved for me. It correctly removes the existing partition table on a test disk, creates a new one, and does not give the timeout error.

Still though, got any idea why the bzr branch for udisks2 is broken?

Changed in util-linux (Debian):
status: New → Fix Released
Changed in udisks2 (Ubuntu Trusty):
milestone: none → ubuntu-14.04.2
Changed in util-linux (Ubuntu Trusty):
milestone: none → ubuntu-14.04.2
status: New → Triaged
importance: Undecided → High
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in udisks2 (Ubuntu Trusty):
status: New → Confirmed
Martin Pitt (pitti) wrote :

Now that this hack didn't even help: Now usb-creator silently fails to format the device, instead of showing the error message about it.

Martin Pitt (pitti) wrote :

I also confirm that the current wipefs fails to remove the signatures of a device, and that wipefs from recent util-linux (I tried 2.25 from Debian experimental) fixes this.

Changed in udisks2 (Ubuntu):
assignee: Dimitri John Ledkov (xnox) → nobody
status: Triaged → Invalid
Changed in udisks2 (Ubuntu Trusty):
status: Confirmed → Invalid
Martin Pitt (pitti) on 2014-08-18
description: updated
Martin Pitt (pitti) on 2014-08-19
Changed in util-linux (Ubuntu):
status: Triaged → Fix Committed
Launchpad Janitor (janitor) wrote :
Download full text (14.2 KiB)

This bug was fixed in the package util-linux - 2.25-8ubuntu1

util-linux (2.25-8ubuntu1) utopic; urgency=medium

  * Merge with Debian experimental.
    - This is now a non-ancient version. (LP: #1012081)
    - No longer uses /etc/ by default, but a file in /run/.
      (LP: #1244595)
    - mkswap wipes fs signatures (LP: #1047666)
    - Fix "reatime" manpage typo (LP: #1047666)
    - wipefs properly cleans up fs signatures (LP: #1059872)
    Remaining Ubuntu changes:
    - Regularly trim SSDs automatically (core-1311-ssd-trimming):
      + Add debian/fstrim-all: Script to detect which mounted partitions
        need/support trimming, and call fstrim(8) on all of them.
        Install into /usr/sbin/.
      + Add debian/fstrim-all.8: Manpage for the above.
      + Add debian/fstrim-all.cron: Trivial shell script to call fstrim-all,
        so that admins can easily adjust/disable it. Installed as
    - Upstart support:
      + Add hwclock{-save}.upstart, and install them in debian/rules.
      + Drop initscripts dependency.
      + Drop debian/hwclock.rules and hwclock.default.
    - Add mountall-options.patch, see patch header.
    - uuid-runtime.postinst: Due to the way the uuidd account is created, it
      will get a uid/gid allocation for userns use. This isn't needed and is a
      waste of uid/gid so always clear uuidd from subuid/subgid.
  * Drop /lib/init/fstab parsing fallback in mount. Patch does not apply at
    all any more, is specific to mountall (and thus should not be relied
    upon), and not very useful; all init systems, schroot, debootstrap etc.
    mount /sys, /proc/ and friends by themselves already.

util-linux (2.25-8) experimental; urgency=medium

  * Only install linux32/64 manpages on linux-any
  * Fix uuid-runtime.postinst to skip rmdir when not needed (Closes: #757432)
  * fdisk-udeb: use dh-exec to skip sfdisk install on sparc

util-linux (2.25-7) experimental; urgency=medium

  * Mangle installed files on sparc (sfdisk)
  * Fix sparc install mangling
  * Use --disable-mountpoint instead of rm
  * Use dh-exec (>= 0.13)
  * Install mips,ppc,s390 setarch symlinks and manpages

util-linux (2.25-6) experimental; urgency=medium

  The "Jonno was here" release.

  [ Jon Severinsson ]
  * Drop changelog file from the ancient mount source package.

  [ Andreas Henriksson ]
  * util-linux: Drop all (obsolete) Replaces/Conflicts

  [ Jon Severinsson ]
  * Add Replaces/Breaks bash-completion (<< 1:2.1-3).
  * Multiple cleanups in debian/control.
  * Minor cleanup of debian/rules.
  * Use filter, not findstring, for arch matching
  * Simplify linux-only install file handling
  * Use debian/*-udeb.install files for udeb packages.
  * Fix util-linux lintian override.

  [ Andreas Henriksson ]
  * Minor uuid-runtime.postinst cleanup
  * Add d/p/cfdisk-reenable-cursor-when-quitting.patch (Closes: #755991)

util-linux (2.25-5) experimental; urgency=medium

  The "big maintainer-script cleanup" release

  * Drop debian/uuid-runtime.prerm (and related lintian override)
    - dh_installinit will automatically start and stop services as needed.
  * Drop debian/libuuid1.postin...

Changed in util-linux (Ubuntu):
status: Fix Committed → Fix Released
Changed in gnome-disk-utility:
importance: Unknown → Medium
status: Unknown → Confirmed
Martin Pitt (pitti) on 2014-08-20
Changed in gnome-disk-utility:
importance: Medium → Undecided
status: Confirmed → New
status: New → Invalid
no longer affects: gnome-disk-utility
Yu Ning (yuningdodo) wrote :

Hi, I have proposed a patch which backport util-linux 2.25-8ubuntu1 from utopic to trusty:

The patch works for myself, however I am not sure if there will be any side effect since it's really a lot of changes.

JFYI, to build it dh-exec 0.13 is required, you will have to download the utopic deb [1] and install it on trusty manually.


Alex (alecsandru-g) on 2014-10-05
description: updated

Tried to format an USB drive this morning with full update stable 14.04.1 Ubuntu Gnome release, using Disk utility; still no way, timeout wiping.

Three years after, I have still to use gparted to do it (which works ok, but you can't say it is exactly user-friendly).

Mupfelzitze (pb-g) wrote :

Fresh Ubuntu 14.04.1 LTS. Disk utility fails in formatting empty partition on usb-disk:

Error formatting partition
Error synchronizing after initial wipe: Timed out waiting for object (udisks-error-quark, 0)

jimav (james-avera) wrote :

Same story using the version in Ubuntu 14.10 (the package says it is version 0.2.62 but usb-creator-gtk --version says it is 0.2.23):

Attempting to erase a USB which has no valid partition table gets "Timed out waiting for object".

jimav (james-avera) wrote :


If gparted is used to create an msdos partition table, but NO partitions, then 'Erase Disk' in usb-creator-gtk fails with the timeout error.

If gparted is used to create an (empty) FAT32 partition, then 'Erase Disk' in usb-creator-gtk seems to succeed, but the "Make Startup Disk" button remains grayed out so you can't do anything with it.

I ran usb-creator-gtk -i file.iso because the interactive iso picker does not work.

Timo Jyrinki (timo-jyrinki) wrote :

The latest usb-creator in 14.04 LTS should work better (, workarounding at least part of the util-linux problem which probably will not see a complete backport of the new feature needed in 14.04 LTS.

Timo Jyrinki (timo-jyrinki) wrote :

To be noted that from my previous tests I managed to erase a USB stick with any condition with the (no partition table, partition table but no partitions, with partitions) although with an occasional need for retry.

It might be that a bug in 14.10 bug could be a different bug with similar symptoms.

Changed in util-linux (Ubuntu Trusty):
status: Triaged → Won't Fix
Amr Ibrahim (amribrahim1987) wrote :

Does that mean that disk-utility will still not be able to erase disks in Trusty?

Timo Jyrinki (timo-jyrinki) wrote :

Hmm, right, this was of course related to that utility instead of usb creator which had similar problems. So, I'm not sure if the proposed branch is suitable but at least it could be still considered as the disk-utility is still affected.

Changed in util-linux (Ubuntu Trusty):
status: Won't Fix → Triaged
Elias Aarnio (elias-aarnio) wrote :

This bug also causes that it is impossible to format a SATA drive inserted into a docking bay.

Benjamin Xiao (ben-r-xiao) wrote :

Still getting this issue on 15.04

org.freedesktop.DBus.Python.GLib.Error: Traceback (most recent call last):
  File "/usr/lib/python3/dist-packages/dbus/", line 707, in _message_cb
    retval = candidate_method(self, *args, **keywords)
  File "/usr/share/usb-creator/usb-creator-helper", line 273, in Format
    block.call_format_sync('vfat', GLib.Variant('a{sv}', {'label': GLib.Variant('s', '')}), None)
GLib.Error: udisks-error-quark: GDBus.Error:org.freedesktop.UDisks2.Error.Failed: Error synchronizing after initial wipe: Timed out waiting for object (0)

Amr Ibrahim (amribrahim1987) wrote :

Any news on this bug for trusty?

Amr Ibrahim (amribrahim1987) wrote :


Changed in util-linux (Debian):
status: Fix Released → New
Changed in util-linux (Debian):
status: New → Incomplete
Changed in util-linux (Debian):
status: Incomplete → Fix Released
Changed in udisks2 (Ubuntu Trusty):
milestone: ubuntu-14.04.2 → none
Changed in util-linux (Ubuntu Trusty):
milestone: ubuntu-14.04.2 → trusty-updates
no longer affects: udisks2 (Ubuntu Trusty)
description: updated
description: updated
Minosone (menno-pleijster) wrote :

I'm still experiencing this error on a fully updated Ubuntu , I'm trying to format a regular disk, but it won't let me via the gear menu. I can still format it by clicking on the + icon instead.

Min Jia (oliverjia) wrote :

I still experience this bug on a fully updated Ubuntu 14.04.4 when I tried to format a HDD installed via a hard drive caddy at the CD Rom position.
This is really getting ridiculous. This bug made me hesitate to recommend Ubuntu to my colleagues.
Please, FIX this bug.

Phillip Susi (psusi) wrote :

If it bothers you that much, run 15.10 or 16.04.

Erick Brunzell (lbsolost) wrote :

@ Phillip Susi, if that's an indication that this bug won't be fixed in Trusty then please change the status from Triaged to Won't fix.

"If it bothers you that much, run 15.10 or 16.04."

I tried both, Phillip, but the bug is still present. I couldn't conceive of such a basic malfunction affecting the previous LTS, so I switched back to 14.04, only to be shocked and horrified to discover that the bug has been around this long.

Imagine, a fundamental function broken for years is still tolerated in the NEXT LTS release. I don't know how to describe that level of lethargy.

(This makes at least two default apps in the current release of Ubuntu that manifest total failure to function, since Transmission just deletes torrents as soon as the downloads complete, probably due to some complex permissions clusterfrell casual users shouldn't be expected to understand or rectify.)

Anyone, I'll be trying out upgrading util-linux from Ivan's ppa to see if that works.

Yep, as reported by others, upgrading to util-linux 2.25.2-4 in Ivan's ppa fixed the issue in 14.04.4 splendidly. Therefore, since as of 3 days ago 16.04 was giving me the same trouble, and Launchpad is showing util-linux 2.26.2 as default in 16.04, there must be a regression reintroducing this terrible bug in the newer util-linux, or there was something else wrong with the daily build of 4/16 that caused a similar symptomatic manifestation. As for 15.10, I'm seeing util-linux 2.25.2-4 as default, yet I encountered the same problem, and, in fact, had to fix my USB drive on my ancient Windows laptop before I could use it to downgrade to 14.04.4. Who but God knows why.

Phillip Susi (psusi) wrote :

I can not reproduce this using the steps listed in the bug description on 15.10, can you?

no longer affects: udisks2 (Ubuntu)
Ara Pulido (ara) on 2016-05-17
Changed in oem-priority:
status: New → Incomplete
Ara Pulido (ara) on 2016-05-18
no longer affects: oem-priority

This bug has been in existence for years. I just loaded up a new install of Ubuntu 16.04 and ran into this. I also cannot use my DVD drive because every time I put a disc in I get an error that the disk is already mounted. I used dconf-editor and disabled the automount features and rebooted. No good.

I'm beginning to believe that Ubuntu is a total crap system. Bugs hang around for years and never get fixed. You install the OS on a new computer and basic features don't EFFING WORK. It really is ridiculous. After 13 years of using Linux every day you'd think I would have learned by now. It sucks on the desktop.

@claytondillard, please calm down.
You should be aware that the times in which you choose Linux for stability or robustness are long gone (if ever they existed). Now you choose it for freedom, for helping, for fixing things community-wise, or otherwise you are misguided.
Windows 10 never hung on my wife's PC in the last year. My Linux has to be hard reset twice a week....
So if this bug it's a pet peeve for you, try to fix it or pay someone to fix it (I did that for a Libreoffice problem, and it worked!). You can get angry only on things you paid for... ;-)

Gábor Lipták (gliptak) wrote :

I just ran into on 16.10

NoBugs! (luke32j) wrote :

How is this broken after at least two years? Or is it meant to scare beginner users that may have chosen the wrong setting, choosing "format" drive, this is considered to be really a command-line-only task?

Foo Bar (foobar123456789) wrote :

Just remove this shitty package from Ubuntu/Debian/... and provide GPARTED by default! That works!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions

Remote bug watches

Bug watches keep track of this bug in other bug trackers.