mod_ident no longer included in apache

Bug #1333388 reported by Alex Bligh on 2014-06-23
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
apache2 (Debian)
Fix Released
Unknown
apache2 (Ubuntu)
Undecided
Unassigned
Trusty
Medium
Unassigned

Bug Description

Precise included mod_ident in apache2.2. Trusty does not include mod_ident in apache2.4. There appears to be no other package containing mod_ident.so. Therefore an upgrade between Precise (LTS) and Trusty (LTS) will unfixably break anything using mod_ident.

This affects me sufficiently that I will happily build and contribute a mod_ident package for apache 2.4 (assuming I can pull it out the source), but I am reliably informed fixing this merely requires adding '--enable-ident' to debian/rules (not yet verified). This would seem the obvious fix.

Alex Bligh (ubuntu-alex-org) wrote :

The attached patch appear to result in it building, and being able to be inserted as a module.

root@trustytest:/home/ubuntu/apache2/apache2-2.4.7# for i in ../*.deb ; do echo $i ; dpkg -c $i | fgrep ident ; done
../apache2_2.4.7-1ubuntu4_amd64.deb
-rw-r--r-- root/root 62 2014-06-23 20:00 ./etc/apache2/mods-available/ident.load
../apache2.2-bin_2.4.7-1ubuntu4_amd64.deb
../apache2-bin_2.4.7-1ubuntu4_amd64.deb
-rw-r--r-- root/root 10248 2014-06-23 20:04 ./usr/lib/apache2/modules/mod_ident.so
../apache2-data_2.4.7-1ubuntu4_all.deb
../apache2-dbg_2.4.7-1ubuntu4_amd64.deb
-rw-r--r-- root/root 28316 2014-06-23 20:04 ./usr/lib/debug/usr/lib/apache2/modules/mod_ident.so
../apache2-dev_2.4.7-1ubuntu4_amd64.deb
../apache2-doc_2.4.7-1ubuntu4_all.deb
-rw-r--r-- root/root 10502 2014-06-23 20:03 ./usr/share/doc/apache2-doc/manual/ja/mod/mod_ident.html
-rw-r--r-- root/root 9993 2014-06-23 20:03 ./usr/share/doc/apache2-doc/manual/fr/mod/mod_ident.html
-rw-r--r-- root/root 9550 2014-06-23 20:03 ./usr/share/doc/apache2-doc/manual/en/mod/mod_ident.html
-rw-r--r-- root/root 9068 2014-06-23 20:03 ./usr/share/doc/apache2-doc/manual/ko/mod/mod_ident.html
lrwxrwxrwx root/root 0 2014-06-23 20:04 ./usr/share/doc/apache2-doc/manual/zh-cn/mod/mod_ident.html -> ../../en/mod/mod_ident.html
lrwxrwxrwx root/root 0 2014-06-23 20:04 ./usr/share/doc/apache2-doc/manual/da/mod/mod_ident.html -> ../../en/mod/mod_ident.html
lrwxrwxrwx root/root 0 2014-06-23 20:04 ./usr/share/doc/apache2-doc/manual/de/mod/mod_ident.html -> ../../en/mod/mod_ident.html
lrwxrwxrwx root/root 0 2014-06-23 20:04 ./usr/share/doc/apache2-doc/manual/pt-br/mod/mod_ident.html -> ../../en/mod/mod_ident.html
lrwxrwxrwx root/root 0 2014-06-23 20:04 ./usr/share/doc/apache2-doc/manual/tr/mod/mod_ident.html -> ../../en/mod/mod_ident.html
lrwxrwxrwx root/root 0 2014-06-23 20:04 ./usr/share/doc/apache2-doc/manual/es/mod/mod_ident.html -> ../../en/mod/mod_ident.html
../apache2-mpm-event_2.4.7-1ubuntu4_amd64.deb
../apache2-mpm-itk_2.4.7-1ubuntu4_amd64.deb
../apache2-mpm-prefork_2.4.7-1ubuntu4_amd64.deb
../apache2-mpm-worker_2.4.7-1ubuntu4_amd64.deb
../apache2-suexec_2.4.7-1ubuntu4_amd64.deb
../apache2-suexec-custom_2.4.7-1ubuntu4_amd64.deb
../apache2-suexec-pristine_2.4.7-1ubuntu4_amd64.deb
../apache2-utils_2.4.7-1ubuntu4_amd64.deb
../libapache2-mod-macro_2.4.7-1ubuntu4_amd64.deb
../libapache2-mod-proxy-html_2.4.7-1ubuntu4_amd64.deb

root@trustytest:/home/ubuntu/apache2/apache2-2.4.7# a2enmod ident
Enabling module ident.
To activate the new configuration, you need to run:
  service apache2 restart
root@trustytest:/home/ubuntu/apache2/apache2-2.4.7# service apache2 restart
 * Restarting web server apache2 AH00558: apache2: Could not reliably determine the server's fully qualified domain name, using 127.0.1.1. Set the 'ServerName' directive globally to suppress this message

The attachment "Patch to add mod_ident" seems to be a patch. If it isn't, please remove the "patch" flag from the attachment, remove the "patch" tag, and if you are a member of the ~ubuntu-reviewers, unsubscribe the team.

[This is an automated message performed by a Launchpad user owned by ~brian-murray, for any issues please contact him.]

tags: added: patch
Alex Bligh (ubuntu-alex-org) wrote :

If you prefer this as a separate module, this would appear to compile and load as a module:
  https://github.com/abligh/libapache-mod-ident

Direction on which you would prefer would be useful and I will get testing.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in apache2 (Ubuntu):
status: New → Confirmed
Alex Bligh (ubuntu-alex-org) wrote :

Arguably the real fix to this is to configure apache with --reallyall (compile everything), then perhaps put the more esoteric modules in a secondary package (libapache2-mod-extra or something).

Alex Bligh (ubuntu-alex-org) wrote :

This gets worse.

You can't even use your own mod_ident, because whenever apache2 is upgraded, it runs this:

    OBSOLETE_CONFFILES="...
    /etc/apache2/mods-available/ident.load
    ..."

    ...
    if [ -n "$2" ] || obsolete_conffile_exists ; then
           prepare_rm_conffile
           prepare_mv_conffile
    fi

which goes and removes its .load file.

What is the justification for mandatory removal of functional configuration files shipped with the upstream package, just because someone decided they shouldn't be used by default? It's almost as if someone has made it deliberately near impossible to use these modules.

Robie Basak (racb) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better.

I think I spoke to you on IRC about this a while ago? We follow Debian's configure options by default. It would be useful to understand what Debian's position on this is. Is Debian also missing this configuration option in 2.4, and if so have we asked them to re-add it?

tags: added: needs-upstream-report
tags: removed: needs-upstream-report
Robie Basak (racb) wrote :

Sorry, I missed your comment. I'll link the Debian bug.

Robie Basak (racb) wrote :

Debian reports that this was fixed in 2.4.10-1. As Utopic is on 2.4.10-1ubuntu1, I presume this is fixed in Utopic, so marking this as Fix Released.

I'm not sure if this qualifies for an SRU to Trusty (details at https://wiki.ubuntu.com/StableReleaseUpdates), but I'll add a Trusty task so you can track that.

Changed in apache2 (Ubuntu):
status: Confirmed → Fix Released
Changed in apache2 (Ubuntu Trusty):
status: New → Confirmed
importance: Undecided → Medium
Alex Bligh (ubuntu-alex-org) wrote :

Yes, we did talk on IRC :-)

As far as I can tell, utopic 2.4.10-1ubuntu1 does not build modident (still). I suspect what might have been fixed in the debian bug my report got merged into (https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=711925) is the constant removal of any module called modident wherever you load it from. However, this doesn't address the problem that modident is missing in the first place.

Robie Basak (racb) wrote :

OK, reopening.

Changed in apache2 (Ubuntu):
status: Fix Released → New
Robie Basak (racb) wrote :

So do we need a bug in Debian to re-enable mod ident?

Alex Bligh (ubuntu-alex-org) wrote :

Yep, though I think that was what https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=752922 asked for.

Robie Basak (racb) wrote :

It might be worth asking in that bug, or filing a new one, and clarifying the two issues.

Changed in apache2 (Debian):
status: Unknown → Fix Released
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in apache2 (Ubuntu):
status: New → Confirmed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package apache2 - 2.4.10-8ubuntu2

---------------
apache2 (2.4.10-8ubuntu2) vivid; urgency=medium

  * Allow "triggers-awaited" and "triggers-pending" states in addition to
    "installed" when determining whether to defer actions or process
    deferred actions (LP: #1393832).
 -- Colin Watson <email address hidden> Wed, 26 Nov 2014 11:31:44 +0000

Changed in apache2 (Ubuntu):
status: Confirmed → Fix Released
Daniel Granville (dgranville) wrote :

Where can I get that package with the missing mod_ident(apache2 - 2.4.10-8ubuntu2)? When I attempt to install it:

# apt-get install apache2=2.4.10-8ubuntu2
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Version '2.4.10-8ubuntu2' for 'apache2' was not found

After installing the 2.4.10 apache2 packages that are available for Trusty:
  apache2=2.4.10-1ubuntu1.1~ubuntu14.04.2
  apache2-bin=2.4.10-1ubuntu1.1~ubuntu14.04.2
  apache2-data=2.4.10-1ubuntu1.1~ubuntu14.04.2

They too do not include mod_ident.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.