Comment 7 for bug 1333388

Alex Bligh (ubuntu-alex-org) wrote :

This gets worse.

You can't even use your own mod_ident, because whenever apache2 is upgraded, it runs this:

    OBSOLETE_CONFFILES="...
    /etc/apache2/mods-available/ident.load
    ..."

    ...
    if [ -n "$2" ] || obsolete_conffile_exists ; then
           prepare_rm_conffile
           prepare_mv_conffile
    fi

which goes and removes its .load file.

What is the justification for mandatory removal of functional configuration files shipped with the upstream package, just because someone decided they shouldn't be used by default? It's almost as if someone has made it deliberately near impossible to use these modules.