X blink with Vostro 360 and Ubuntu Oneiric and Precise

Bug #918769 reported by Jerome Tournier on 2012-01-19
36
This bug affects 5 people
Affects Status Importance Assigned to Milestone
xf86-video-intel
Fix Released
Medium
linux (Ubuntu)
High
Unassigned
Precise
High
Unassigned

Bug Description

I can't actually manage to have X working correctly with my Vostro 360.
The X session start but the screen blink every ~10s (and stay back most
of the time).

I found a lot of people having similar problem, but no solution can be
applied to my case.

X logs for Ubuntu 11.10 (i386 but same issue for amd64):

00:02.0 VGA compatible controller: Intel Corporation 2nd Generation Core
Processor Family Integrated Graphics Controller (rev 09)
I will attach a kernel and Xorg dump.

The only way for me to have correct resolution (1920x1080) was in using
the Live CDROM of elementary OS (based on Ubuntu Maverick 10.10) which
use:
- linux-headers-2.6.35-28-generic 2.6.35-28.49
- xserver-xorg-video-intel 2:2.12.0-1ubuntu5.2

.. but once the system installed, the black screen problem come back. I
can't actually undestand the difference between the live OS and the
installed one (after the installation, the kernel is slightly different;
but after installing exactly the same than the one used in the live CD,
the problem persist).

I also tried other Ubuntu release, even the latest Ubuntu 12.04 precise
(alpha version): same issue.

Booting with nomodeset helps also, but lead to a low resolution.

Any idea on what could explain that eveything is working correctly with
the livecd, and nothing once the system installed ?

More generaly, how can i help to have a working solution ?

Packages installed:
-------------------
ii libdrm-intel1 2.4.30-1ubuntu1
ii xserver-xorg-video-intel 2:2.15.901-1ubuntu4

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: xserver-xorg-video-intel 2:2.15.901-1ubuntu4
ProcVersionSignature: Ubuntu 3.2.0-9.16-generic-pae 3.2.1
Uname: Linux 3.2.0-9-generic-pae i686
ApportVersion: 1.91-0ubuntu1
Architecture: i386
CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
Date: Thu Jan 19 17:07:41 2012
DistUpgraded: Fresh install
DistroCodename: precise
DistroVariant: ubuntu
ExtraDebuggingInterest: Yes, whatever it takes to get this fixed in Ubuntu
GraphicsCard:
 Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller [8086:0102] (rev 09) (prog-if 00 [VGA controller])
   Subsystem: Dell Device [1028:0512]
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Alpha i386 (20120112)
MachineType: Dell Inc. Vostro 360
ProcEnviron:
 PATH=(custom, no user)
 LANG=fr_FR.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.2.0-9-generic-pae root=UUID=4f9a709d-de4a-4cc6-a27b-0c6e05a2cde2 ro quiet splash vt.handoff=7
SourcePackage: xserver-xorg-video-intel
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 12/22/2011
dmi.bios.vendor: Dell Inc.
dmi.bios.version: A06
dmi.board.name: 07K1DC
dmi.board.vendor: Dell Inc.
dmi.board.version: A00
dmi.chassis.type: 13
dmi.chassis.vendor: Dell Inc.
dmi.chassis.version: PRAndrews_2H03P_A01.SDR
dmi.modalias: dmi:bvnDellInc.:bvrA06:bd12/22/2011:svnDellInc.:pnVostro360:pvr00:rvnDellInc.:rn07K1DC:rvrA00:cvnDellInc.:ct13:cvrPRAndrews_2H03P_A01.SDR:
dmi.product.name: Vostro 360
dmi.product.version: 00
dmi.sys.vendor: Dell Inc.
version.compiz: compiz 1:0.9.6+bzr20110929-0ubuntu8
version.libdrm2: libdrm2 2.4.30-1ubuntu1
version.libgl1-mesa-dri: libgl1-mesa-dri 7.11-0ubuntu4
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 7.11-0ubuntu4
version.xserver-xorg-core: xserver-xorg-core 2:1.10.4-1ubuntu6
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.6.0-1ubuntu13
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.99~git20110811.g93fc084-0ubuntu1
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.15.901-1ubuntu4
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20111201+b5534a1-1

Jerome Tournier (jtournier-8) wrote :
Bryce Harrington (bryce) wrote :

Hmm, familiar sounding bug, but not really anything in the logs to say what's going on in this case.

[ 16.600] (II) intel(0): Output eDP1 connected
[ 16.600] (II) intel(0): Output VGA1 disconnected
[ 16.600] (II) intel(0): Output HDMI1 disconnected
[ 16.600] (II) intel(0): Output DP1 disconnected
[ 16.600] (II) intel(0): Output HDMI2 disconnected
[ 16.600] (II) intel(0): Output HDMI3 disconnected
[ 16.600] (II) intel(0): Output DP2 disconnected

Could be another eDP problem; I see your system has its panel connected like that. There's been a lot of work on that recently due to various bugs. The 3.2 kernel supposedly had quite a few fixes for eDP, but evidently not enough.

Presumably if you disable the laptop display and use an external display on VGA or HDMI it should work. That might be worth testing as a workaround if you have a spare monitor.

These types of bugs are typically issues in the kernel drm kms code, so given you see different kernels are used in live cd vs. installation, that would be a reasonably thing to look at. In fact, let's have you test an upstream kernel snapshot, just in case this issue is already solved:

  http://kernel.ubuntu.com/~kernel-ppa/mainline/drm-next/

Also test this one, in case the fix is still in testing:

  http://kernel.ubuntu.com/~kernel-ppa/mainline/drm-intel-next/

If neither of those kernels solves the problem, let me know and we can notify Intel and go from there.

Changed in xserver-xorg-video-intel (Ubuntu):
importance: Undecided → High
status: New → Incomplete
status: Incomplete → New
Bryce Harrington (bryce) wrote :

Oh, also before you test those kernels, please enable drm debug messages:

Run `sudo xdiagnose`, it's the first checkbox. Tick that, apply, wait for grub to rebuild, then reboot the machine. Reproduce the issue, and collect `sudo dmesg.txt` which will have the detailed eDP debug messages.

Changed in xserver-xorg-video-intel (Ubuntu):
status: New → Incomplete
Bryce Harrington (bryce) wrote :

Actually, instead of those two kernels, try testing this one, which is much newer:

  http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.3-rc1-precise/

Changed in xserver-xorg-video-intel (Ubuntu):
status: Incomplete → New
status: New → Incomplete
Jerome Tournier (jtournier-8) wrote :

None of the mentioned kernel solve the problem, even the latest 3.3.0-030300rc1_3.3.0-030300rc1.

I've enable graphic debug with xdiagnose. Dmesg output is in attachment.

Bryce Harrington (bryce) on 2012-01-25
Changed in xserver-xorg-video-intel (Ubuntu):
status: Incomplete → Confirmed
Jerome Tournier (jtournier-8) wrote :

Hi,

Is there any thing i can do to help solving this problem ?
Thx.

Download full text (4.1 KiB)

Forwarding this bug from Ubuntu reporter Jerome Tournier:
http://bugs.launchpad.net/ubuntu/+source/xserver-xorg-video-intel/+bug/918769

[Problem]
X session starts up fine but the screen blinks every ~10sec. Also displays black screen.

Booting with nomodeset makes issue stop.

Also tested mainline kernel 3.3.0-030300rc1_3.3.0-030300rc1 and (I think) drm-next and drm-intel-next.

[Original Description]
I can't actually manage to have X working correctly with my Vostro 360.
The X session start but the screen blink every ~10s (and stay back most
of the time).

I found a lot of people having similar problem, but no solution can be
applied to my case.

X logs for Ubuntu 11.10 (i386 but same issue for amd64):

00:02.0 VGA compatible controller: Intel Corporation 2nd Generation Core
Processor Family Integrated Graphics Controller (rev 09)
I will attach a kernel and Xorg dump.

The only way for me to have correct resolution (1920x1080) was in using
the Live CDROM of elementary OS (based on Ubuntu Maverick 10.10) which
use:
- linux-headers-2.6.35-28-generic 2.6.35-28.49
- xserver-xorg-video-intel 2:2.12.0-1ubuntu5.2

.. but once the system installed, the black screen problem come back. I
can't actually undestand the difference between the live OS and the
installed one (after the installation, the kernel is slightly different;
but after installing exactly the same than the one used in the live CD,
the problem persist).

I also tried other Ubuntu release, even the latest Ubuntu 12.04 precise
(alpha version): same issue.

Booting with nomodeset helps also, but lead to a low resolution.

Any idea on what could explain that eveything is working correctly with
the livecd, and nothing once the system installed ?

More generaly, how can i help to have a working solution ?

Packages installed:
-------------------
ii libdrm-intel1 2.4.30-1ubuntu1
ii xserver-xorg-video-intel 2:2.15.901-1ubuntu4

DistroRelease: Ubuntu 12.04
Package: xserver-xorg-video-intel 2:2.15.901-1ubuntu4
ProcVersionSignature: Ubuntu 3.2.0-9.16-generic-pae 3.2.1
Uname: Linux 3.2.0-9-generic-pae i686
ApportVersion: 1.91-0ubuntu1
Architecture: i386
CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
Date: Thu Jan 19 17:07:41 2012
DistUpgraded: Fresh install
DistroCodename: precise
DistroVariant: ubuntu
ExtraDebuggingInterest: Yes, whatever it takes to get this fixed in Ubuntu
GraphicsCard:
 Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller [8086:0102] (rev 09) (prog-if 00 [VGA controller])
   Subsystem: Dell Device [1028:0512]
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Alpha i386 (20120112)
MachineType: Dell Inc. Vostro 360
ProcEnviron:
 PATH=(custom, no user)
 LANG=fr_FR.UTF-8ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.2.0-9-generic-pae root=UUID=4f9a709d-de4a-4cc6-a27b-0c6e05a2cde2 ro quiet splash vt.handoff=7
SourcePackage: xserver-xorg-video-intel
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 12/22/2011
dmi.bios.vendor: Dell Inc.
dmi.bios.version: A06
dmi.board.name: 07K1DC
dmi.board.vendor: Dell Inc.
dmi.board.v...

Read more...

Created attachment 57884
BootDmesg.txt

Created attachment 57885
CurrentDmesg.txt

Created attachment 57886
Lspci.txt

Created attachment 57887
XorgLog.txt

Created attachment 57888
dmesg.txt

This is a dmesg (I believe it's against the mainline kernel mentioned above) has drm debug flipped on.

Here I notice eDP being turned on and off repeatedly; could this be involved in the blinking behavior the user reports?

Jesse /loves/ eDP ...

Bryce Harrington (bryce) wrote :

Hi Jerome,

Thanks for the log. I notice that it looks like it's trying to turn eDP-1 on and off repeatedly; I wonder if that might be involved with or the cause of your blinking.

There have been a long litany of issues with DisplayPort on Ironlake this past year or so, it wouldn't surprise me if this issue boiled down to that. However, that's just a guess.

I think the next step should be to forward this upstream, as I suspect it's another DP bug in the kernel driver code.

Bryce Harrington (bryce) wrote :

Jerome Tournier - I've forwarded this bug upstream to https://bugs.freedesktop.org/show_bug.cgi?id=46856 - please subscribe yourself to this bug, in case they need further information or wish you to test something. Thanks ahead of time!

Changed in xserver-xorg-video-intel (Ubuntu):
status: Confirmed → Triaged
tags: added: blocks-hwcert blocks-hwcert-enablement
Bryce Harrington (bryce) wrote :

Hi Jerome,

Upstream seems quiet. It may be possible to work around this though. Try switching off some of the extraneous outputs and see if that eliminates the blinking. So, try an xorg.conf like this:

Section "Device"
        Identifier "Configured Video Device"
EndSection

Section "Monitor"
        Identifier "Configured Monitor"
        Identifier "HDMI1"
        Option "Ignore" "True"
EndSection

Section "Monitor"
        Identifier "Configured Monitor"
        Identifier "HDMI2"
        Option "Ignore" "True"
EndSection

Section "Monitor"
        Identifier "Configured Monitor"
        Identifier "HDMI3"
        Option "Ignore" "True"
EndSection

Section "Monitor"
        Identifier "Configured Monitor"
        Identifier "DP1"
        Option "Ignore" "True"
EndSection

Section "Monitor"
        Identifier "Configured Monitor"
        Identifier "DP2"
        Option "Ignore" "True"
EndSection

Section "Monitor"
        Identifier "Configured Monitor"
        Identifier "eDP1"
        Option "Ignore" "True"
EndSection

Section "Screen"
        Identifier "Default Screen"
        Monitor "Configured Monitor"
        Device "Configured Video Device"
EndSection

Pardon any typos, this is written off the top of my head.

Assuming that works and eliminates the blinking, the next step is to isolate the minimum output(s) that need disabled. One by one comment out the Monitor sections and restart X. If X works without blinking, leave the section commented out. If it blinks, then re-enable it by uncommenting the section, and move on to the next output. Let us know what you find.

Changed in xserver-xorg-video-intel (Ubuntu):
status: Triaged → Incomplete
Robert Hooker (sarvatt) on 2012-03-19
affects: xserver-xorg-video-intel (Ubuntu) → linux (Ubuntu)
Bryce Harrington (bryce) wrote :

Actually, in checking with a HWE engineer, the issue may be that eDP is what's being used to drive the laptop display for this particular hardware SKU, rather than LVDS as normal. So, likely, twiddling xorg.conf isn't going to get us to a usable situation.

So, I think we just need to get this tested against a newer kernel. Can you re-test using a 3.3 kernel? Snag it here:

  http://kernel.ubuntu.com/~kernel-ppa/mainline/

tags: added: rls-mgr-p-tracking
Changed in xserver-xorg-video-intel:
importance: Unknown → Medium
status: Unknown → Confirmed
Greg Vallande (gvallande) wrote :

Hi All,

   I'm retesting this bug on a Vostro (All-In-One) 201105-8054 - I tested with kernel: linux-image-3.3.2-030302-generic_3.3.2-030302.201204131335_i386 and the X Blink issue still is there.

[steps]

I connected an external display (which appeared very slow) so that I could navigate and install kernel 3.3.2 - I rebooted - disconnected the display and I'm left with a blank screen producing the "Blink" that was mentioned in the bug above.

Wonder if this is another dupe of the eDP bpp bug... does drm-intel-next still have this issue? Daniel pushed a good fix in recently...

Bryce Harrington (bryce) wrote :

Upstream thinks this potentially might be a dupe of an eDP issue they recently fixed.

Debs of their upstream kernel tree are available here:

  http://kernel.ubuntu.com/~kernel-ppa/mainline/drm-intel-experimental/

Please install the kernel debs and report back here with your findings.

Changed in linux (Ubuntu):
status: Incomplete → New
status: New → Incomplete

Just posted an update to #42278 that might be related as well.

Changed in xserver-xorg-video-intel:
status: Confirmed → Incomplete

commit 23bb2df76c6af94c40483cb80ee3559a2d10a596
Author: Jesse Barnes <email address hidden>
Date: Thu Jun 14 15:28:33 2012 -0400

    drm/i915: cache the EDID for eDP panels

Changed in xserver-xorg-video-intel:
status: Incomplete → Fix Released

A patch referencing this bug report has been merged in Linux v3.5-rc4:

commit d6f24d0fa6cdf3431a2fe3330a74bc6c5871f496
Author: Jesse Barnes <email address hidden>
Date: Thu Jun 14 15:28:33 2012 -0400

    drm/i915: cache the EDID for eDP panels

Bryce Harrington (bryce) wrote :

Patch to fix this is included in Linux v3.5-rc4.

Changed in linux (Ubuntu):
status: Incomplete → Triaged
Changed in linux (Ubuntu Precise):
status: New → Triaged
importance: Undecided → High
tags: added: kernel-handoff-graphics
Joseph Salisbury (jsalisbury) wrote :

@Jerome Tournier

Can you test the latest mainline kernel[0] and report back if this bug is fixed?

Thanks in advance!

[0] http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.5-rc5-quantal/

tags: added: kernel-da-key

Tested on Fedora's kernel-3.5.0-0.rc5.git3.1.fc18 the bug still remains, it behaves like older kernels (3.4) with "drm_kms_helper poll=0" in grub. If Vostro 360 is powered on, then everything is ok, but on reboot the screen is dark in KDE. Still the reboot seems to be an issue.

Jerome Tournier (jtournier-8) wrote :

The v3.5-rc5-quantal does not solve the problem.
But this one solve it: https://bugs.freedesktop.org/attachment.cgi?id=62301

Jerome Tournier (jtournier-8) wrote :

And with this one: https://bugs.freedesktop.org/attachment.cgi?id=62598
"This one fixes the flicker that occurs at detect time. With both patches (the HDMID one and this one) the Vostro is behaving like it should"

This bug was filed against a series that is no longer supported and so is being marked as Won't Fix. If this issue still exists in a supported series, please file a new bug.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: Triaged → Won't Fix
Po-Hsu Lin (cypressyew) on 2013-05-29
tags: added: 201105-8054
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.