Ubuntu

New "push mouse offscreen" feature really difficult to get

Reported by Didier Roche on 2012-01-30
270
This bug affects 56 people
Affects Status Importance Assigned to Milestone
Unity
Critical
Jason Smith
Unity Distro Priority
Critical
Unassigned
gnome-control-center (Ubuntu)
Critical
Didier Roche
Precise
Critical
Didier Roche
unity (Ubuntu)
Critical
Unassigned
Precise
Critical
Unassigned

Bug Description

In unity 5.2 RC1:
- revealing the launcher by putting mouse on the edge and pushing seems very hard (the distance to push it long). This is even worse on trackpad.

Related issue:
on multimonitor setup, going from one monitor to the edge suffer from the same issue (you have to push the mouse a lot, more than it felt naturally needed). Especially when you drag a window using the trackpad.
Also, when you put your mouse on the central point slowly to go to monitor 2, you get stuck even if you believe that the mouse is already on the monitor 2 (because there is one pixel left on monitor 1 and the whole cursor is drawn on monitor 2)

This is on a dell Latitute XT2, with default mouse velocity option.

Changed in unity:
status: New → Confirmed
importance: Undecided → High
Didier Roche (didrocks) on 2012-01-30
tags: added: 5.2
tags: added: 5.2-rc1
removed: 5.2
Sebastien Bacher (seb128) wrote :

Confirmed, it's quite hard to use with a trackpad, easier with a mouse if you know that you need to overdo the action, still not obvious though, it could use some tweaking

Didier Roche (didrocks) on 2012-01-30
description: updated
Didier Roche (didrocks) wrote :
Download full text (4.9 KiB)

my values with the dell xt2 to make it feel more natural with both my trackpad and my mouse:
- reveal pressure: 50
- edge stop overcome pressure: 30
- pressure decay rate: 60
- edge stop velocity: 50

hw info:
trackpad:
[ 7.696] (II) config/udev: Adding input device N-Trig Pen (/dev/input/event7)
[ 7.696] (**) N-Trig Pen: Applying InputClass "evdev tablet catchall"
[ 7.696] (**) N-Trig Pen: Applying InputClass "Wacom N-Trig class"
[ 7.696] (II) LoadModule: "wacom"
[ 7.696] (II) Loading /usr/lib/xorg/modules/input/wacom_drv.so
[ 7.698] (II) Module wacom: vendor="X.Org Foundation"
[ 7.698] compiled for 1.11.3, module version = 0.12.0
[ 7.698] Module class: X.Org XInput Driver
[ 7.698] ABI class: X.Org XInput driver, version 16.0
[ 7.698] (II) Using input driver 'wacom' for 'N-Trig Pen'
[ 7.698] (II) Loading /usr/lib/xorg/modules/input/wacom_drv.so
[ 7.698] (**) N-Trig Pen: always reports core events
[ 7.698] (**) Option "Device" "/dev/input/event7"
[ 7.698] (II) N-Trig Pen: type not specified, assuming 'stylus'.
[ 7.698] (II) N-Trig Pen: other types will be automatically added.
[ 7.698] (**) Option "Button2" "3"
[ 7.698] (--) N-Trig Pen stylus: using pressure threshold of 27 for button 1
[ 7.698] (--) N-Trig Pen stylus: Wacom USB TabletPC tablet maxX=9600 maxY=7200 maxZ=256 resX=36772 resY=44173 tilt=disabled
[ 7.698] (II) N-Trig Pen stylus: hotplugging dependent devices.
[ 7.698] (EE) N-Trig Pen stylus: Invalid type 'cursor' for this device.
[ 7.698] (EE) N-Trig Pen stylus: Invalid type 'touch' for this device.
[ 7.698] (II) N-Trig Pen stylus: hotplugging completed.
[ 7.714] (**) Option "config_info" "udev:/sys/devices/pci0000:00/0000:00:1d.1/usb7/7-2/7-2:1.1/input/input7/event7"
[ 7.714] (II) XINPUT: Adding extended input device "N-Trig Pen stylus" (type: STYLUS, id 10)
[ 7.714] (**) N-Trig Pen stylus: (accel) keeping acceleration scheme 1
[ 7.714] (**) N-Trig Pen stylus: (accel) acceleration profile 0
[ 7.714] (**) N-Trig Pen stylus: (accel) acceleration factor: 2.000
[ 7.714] (**) N-Trig Pen stylus: (accel) acceleration threshold: 4
[ 7.715] (II) config/udev: Adding input device N-Trig Pen (/dev/input/mouse1)

my mouse:
[ 63.766] (II) config/udev: Adding input device Microsoft Microsoft 3-Button Mouse with IntelliEye(TM) (/dev/input/mouse4)
[ 63.766] (II) No input driver specified, ignoring this device.
[ 63.766] (II) This device may have been added with another device file.
[ 63.766] (II) config/udev: Adding input device Microsoft Microsoft 3-Button Mouse with IntelliEye(TM) (/dev/input/event13)
[ 63.766] (**) Microsoft Microsoft 3-Button Mouse with IntelliEye(TM): Applying InputClass "evdev pointer catchall"
[ 63.766] (II) Using input driver 'evdev' for 'Microsoft Microsoft 3-Button Mouse with IntelliEye(TM)'
[ 63.766] (II) Loading /usr/lib/xorg/modules/input/evdev_drv.so
[ 63.766] (**) Microsoft Microsoft 3-Button Mouse with IntelliEye(TM): always reports core events
[ 63.766] (**) evdev: Microsoft Microsoft 3-Button Mouse with IntelliEye(TM): Device: "/dev/input/event13"
[ 63.766] (...

Read more...

Didier Roche (didrocks) wrote :

ok, to have a little bit more pleasing experience, I had to push:
-reveal pressure to 55
- stop overcome pressue to 40

Didier Roche (didrocks) on 2012-02-01
Changed in unity (Ubuntu):
status: New → Confirmed
Giovanni Mellini (merlos) wrote :

Same problem for me

giovanni@whale:~$ apt-cache policy unity
unity:
  Installato: 5.2.0~+bzr1884ubuntu0+626
  Candidato: 5.2.0~+bzr1884ubuntu0+626
  Tabella versione:
 *** 5.2.0~+bzr1884ubuntu0+626 0
        500 http://ppa.launchpad.net/unity-team/ppa/ubuntu/ precise/main i386 Packages
        100 /var/lib/dpkg/status
     5.0.0-0ubuntu3 0
        500 http://en.archive.ubuntu.com/ubuntu/ precise/main i386 Packages
giovanni@whale:~$

It's really difficult to reveal the launcher using the trackpad of my laptop. I think this is a big regression in term of usability

Giovanni Mellini (merlos) wrote :

To complete the information I'm on a F3J Asus laptop with the default velocy mouse.

Giovanni Mellini (merlos) wrote :

@Didier how I can try the settings you posted?

Omer Akram (om26er) on 2012-02-01
Changed in unity (Ubuntu):
importance: Undecided → High
psypher (psypher246) wrote :

HI all,

I got the same issues. Too much pressure to unhide launcher and mouse gets stuck between multiple screens. At first i though this was a bug but now I understand how this works. So I dropped my "Launcher Reveal Pressure" to 10 and the "Edge Stop Velocity" to 30. So what I understand this does is bring the launcher up easily and does not so easily grab my cursor when moving between screens and slower speeds. Yet still being able to bring up the launcher on the 2nd screen.

I suggest these should be default settings or something around there.

Didier Roche (didrocks) wrote :

@psypher246: it's not possible to put those settings as the default, as it clearly impacts other well behaving trackpad. The workaround we found for now is to add the option to gnome-control-center until a better solution happen.

Changed in gnome-control-center (Ubuntu):
status: New → Triaged
importance: Undecided → High
assignee: nobody → Didier Roche (didrocks)
psypher (psypher246) wrote :

If I move my mouse from left primary screen to right secondary screen, please could the edge stop velocity be 0 when going in that direction. only when moving from right to left on the secondary screen should the mouse get stuck and then require more pressure to open the launcher. There is no need to try and lock my mouse when moving from left to right. It gets very tiring trying to jiggle the mouse loose all the time.

Didier Roche (didrocks) wrote :

This was the first behavior, but after some user testing, we saw that people, when wanted to just use the scrollbar on the left monitor, went to far away and then was frustrated as you have the launcher reveal blocking you on the right screen to come back. So the current solution with the "stop" pressure is a better solution as a conclusion.

The good news is that you have option to tweak that to your will :)

psypher (psypher246) wrote :

OK fair point, thanks

Having a setting that needs to be tweaked in order for the launcher to work is not a solution to this bug. Ubuntu should work without configuration, especially for something as essential as revealing the launcher.

Omer Akram (om26er) wrote :

For a few people there happens a case where the launcher won't reveal at all and they have to adjust a few settings in CCSM to fix that so I have changed the importance for this bug to Critical as it would affect a large number of people.

Changed in unity:
status: Confirmed → Triaged
Changed in unity (Ubuntu Precise):
status: Confirmed → Triaged
Changed in unity:
importance: High → Critical
Changed in unity (Ubuntu Precise):
importance: High → Critical
Changed in gnome-control-center (Ubuntu Precise):
importance: High → Critical
tags: added: precise qa-manual-testing rls-mgr-p-tracking
Didier Roche (didrocks) wrote :

Assigning and pinging Jason for the unity side, as we spent quite some time looking at the issue.

I'll anyway handle the gnome-control-center part

Changed in unity:
assignee: nobody → Jason Smith (jassmith)
Jason Smith (jassmith) wrote :

Rick,

The drivers are the primary reason this isn't working for some people. Some touchpads are scaling inputs incorrectly, resulting in very low velocity pressures. This should not prevent it from working for these people, but it does make revealing take a bit more effort than intended. I have not seen a completely unworkable setup yet. The slider merely helps people who have misbehaving hardware deal with the faulty drivers.

Ideally, the correct thing to do would be to ensure that all touchpads react the same way on all machines.

I discovered today that the speed at which I point with the trackpad is a critical factor. If I do it slowly, it causes the launcher to appear more easily.

Also, I am using a Dell Mini 10v, with a bog standard, trackpad. I don't think it's right to chalk this up to a "driver" issue.

Note that if I put the cursor to the far right of the screen, and do a "quick" swipe with the track pad, it moves the cursor all the way to the left of the screen. It then takes severaly quick swipes to reveal the launcher, but only one slow swipe.

Didier Roche (didrocks) wrote :

I'm subscribing RAOF to the bug as from the tests we clearly saw that not every trackpad are giving the same velocity.

Didier Roche (didrocks) wrote :

after some discussion, it seems that are two cases:
- cases like dell mini 10v (and your asus altec), where a quick swipe travels all the screen, but the launcher doesn't reveal (maybe not based on monitor width?)
- cases like the xt2 where you can try whatever you want: you can travel 50% of the screen at most

Pako (elektrobank01) wrote :

So what will RAOF do, make different drivers for every single computer on the planet? You waste your time with childish experiments. The only fix for this is to scale or shrink the window when launcher appears. I have to repeat this over and over again. This is the only reasonable fix for now from this guy. -> https://bugs.launchpad.net/ayatana-design/+bug/765819/comments/51

Didier Roche (didrocks) on 2012-02-06
Changed in gnome-control-center (Ubuntu Precise):
status: Triaged → Fix Committed
Changed in unity-distro-priority:
status: New → Fix Committed
Jason Smith (jassmith) wrote :

The idea is that you are sustaining a push over a period of time. The important factor is the time. If you open CCSM and adjust the responsiveness slider you will have a shorter required sustained push. We dont have to expose this slider if we can decide on a value for it. Currently it defaults to 1.0f.

The reason your quick swipes dont work is that they dont sustain the pressure for very long. You are applying very high pressure for a very short period of time. So the system sees this as very similar to accidentally cruising into the side when quickly going for the back button. The idea is to show intention. Maybe we currently require too much intention.

The problem is people are trying to push faster, when the correct motion is a slow sustained push. The slider (even if we dont expose it) basically allows you to tweak for sustained push vs higher allowed pressures. The more "responsive" the launcher is, the more prone to false positives it becomes. I have chosen a very conservative value for now, perhaps we should increase the value to 2.0f.

Chris Halse Rogers (raof) wrote :

Another thing I'm trying to do is to get more information into the hands of Unity - it's not clear if we can get enough information to have the perfect behaviour for all hardware by default, but there's still data to try.

Geoff Teale (tealeg) wrote :

Just confirming the same behaviour on a thinkpad E525. It is true that the behaviour feels somewhat different on the built in trackpad than on my Filco USB trackpad, but I think perhaps that this is perhaps cognitively clumsy too.

ike (ikeahloe) wrote :

mine will not reveal at all, even if i keep pushing left a country's length. somply put, if the windows are over it, it won't reveal anymore after 5.2 update.

@ike ... did you try pushing to the left slowly?

Nicola Jelmorini (jelmorini) wrote :

I have the same problem as @ike.

I think that for the average user it's difficult to know what "slowly" or "quickly" or "pressure" is correct. When you use a mouse or touchpad pointer, it's anyway a virtual object on the screen, and we don't have the "physical" feeling for "pressure" or whatever else. This behavior has to be the seamless as possible.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-control-center - 1:3.2.2-2ubuntu6

---------------
gnome-control-center (1:3.2.2-2ubuntu6) precise; urgency=low

  [ Aurélien Gâteau ]
  * debian/patches/58_ubuntu_icon_views_redesign.patch
    - Implement the new category headers (LP: #921061)

  [ Didier Roche ]
  * debian/patches/04_new_appearance_settings.patch, respect new
    design requests:
    - High Contrast misspelled as "HighContrast" etc (LP: #878790)
    - The scope of "Restore defaults" button in Appearance>Behavior is
      not clear enough (LP: #924253)
    - Add a new launcher reveal slider (LP: #923749)
    - The Background section in Appearance panel should have an option
      to display the dotted grid (LP: #922544)
    - Restore Defaults buttons in appearance should be replaced with in
      context hints (LP: #922543)
    - Rename tabs to look and User Interface to Background (LP: #918580)

  [ Christopher James Halse Rogers ]
  * debian/patches/59_install_gcm_components_on_demand.patch:
    - Install gnome-color-manager tools on-demand. Fixes the "calibrate"
      and "View profile" buttons without requiring us to install 33MB of
      Arygll on the CDs. (LP: #868803)
 -- Didier Roche <email address hidden> Tue, 07 Feb 2012 18:13:21 +0100

Changed in gnome-control-center (Ubuntu Precise):
status: Fix Committed → Fix Released
Mossroy (mossroy) wrote :

It's a bit better with the reveal sensitivity set to high.

Anyway, if the "push mouse offscreen" feature might be a good idea on trackpads, I still don't find it ergonomical with a mouse.
At first use, people (including me) don't seem to have the reflex to push on the left, and think the launcher does not reveal, or does not work.

Another problem is that this push on the left physically moves the mouse on the left, while the cursor does not move.
After a few pushes, the mouse has moved a few centimeters on the left. So you need to lift it and reposition it on the right (else it finally hits the keyboard, if you are right-handed)

psypher (psypher246) wrote :

I agree with Mossroy 100%. My first impressions too. After using it for a while I kinda get it. But I have to say transitioning between multiple desktops is really annoying, a movement from left to right just keeps getting stuck in the middle. despite understanding the requirement to be able to position the mouse on a scroll bar or to unhide the other monitors launcher. Need to find some other solution or fairer settings.

What was exactly fixed int the committed fix above?

Didier Roche (didrocks) wrote :

@psypher246: Unity Distro Priority is a target that enables us to track on report (like http://people.canonical.com/~platform/design/upstream.html) generated from it. The "fix committed" here means "distro acked it's an issue and made upstream aware of it".

psypher (psypher246) wrote :

Oh ok, cool, well I see there is now a reveal sensitivity slider in the appearance app (formerly user settings, formerly appearance, glad they went back to appearance) I think is a much better way of tweaking this for different input devices.

Pako (elektrobank01) wrote :

Here is the key for launcher handling. First you have to push mouse about 1.023,7cm. while using force betwen 0.327 and 0.524Nm of torque.

David Barth (dbarth) on 2012-02-10
Changed in unity:
milestone: none → 5.6.0
Changed in unity (Ubuntu Precise):
milestone: none → ubuntu-12.04-beta-1

I've tested this feature with a mouse and 2 trackpads, in single screen and multi-monitor situations. This feature is easiest to use when set to "High" sensitivity. I think it would make sense to make "High" the default, and allow users who are getting too many false positives to back that off if necessary.

Works best means:
1. It's easiest to reveal the launcher, and I think more discoverable (won't have as many people thinking the launcher is broken).
2. It's fastest to reveal the launcher. With the default setting, it is a long process to make the launcher reveal.

Tim Penhey (thumper) on 2012-02-20
tags: added: distro-priority
psypher (psypher246) wrote :

Would like to add that a few updates came through and set the "edge stop velocity" by default to 65. This makes transitioning between multiple monitors, smoothly, near impossible and extremely annoying. I have set it back down to 20 which improves the response a lot.

I have also set my "reveal sensitivity" to High and seems ok for mouse. But still not sensitive enough for my touchpad. So I would say the sliders needs to be adjusted as so: The line it locks at should be in the middle. That line it should be the default but the same sensitivity as "High" is currently. The proposed "High" should be even more sensitive than the current one. Then we have a high range to play with.

Alistair Buxton (a-j-buxton) wrote :

Is this bug about the default sensitivity, or about the launcher not revealing at all no matter how hard you push? Seems like these are two different problems. (the former being opinion, the latter being a serious bug.)

I have the sensitivity set very high so that the launcher reveals very easily. I also have a dual monitor set up. In 5.2 the launcher revealed very easily for me. Since updating to 5.4 the launcher is extremely difficult to reveal.

This isn't a sensitivity issue. It seems that something fails when the pointer first comes into contact with the screen edge. If that happens then the launcher won't reveal no matter how hard I push. I have to move the pointer away from the edge before pushing again. The next time, it might reveal very easily, or it might fail again.

This only happens on the first monitor. The second monitor behaves exactly as it did in 5.2.

Seems like comment 24 has this problem too, as well as most of the duplicates of this bug.

psypher (psypher246) wrote :

I have been having these issues today as well after update. Couldn't open primary launcher no matter what i did. Adjusted my edge stop velocity to default again and then back to 30 after a while. Problem stopped.

Just seems like the whole feature needs work, not sure if we can lump all the issues under one bug or should there multiple bugs? I'll be happy to log if I must

Alistair Buxton (a-j-buxton) wrote :

I tried resetting everything to defaults and it is still almost impossible to reveal the launcher on my primary screen. When the launcher does reveal it seems to be following the settings, and the launcher on second monitor always follows the settings. In 5.2 both launchers followed the settings correctly.

Didier Roche (didrocks) on 2012-02-20
Changed in unity-distro-priority:
importance: Undecided → Critical
Alistair Buxton (a-j-buxton) wrote :

Been looking at this some more and it seems that when the sensitivity is low I can unhide the launcher by VERY gently stroking the pointer against the left edge. The harder I hit the left edge the less likely it seems to be for it to reveal. Possible reversed </> or some kind of overflow? The second launcher on monitor two continues to work perfectly.

I have also noticed that if I push *really* hard against the edge the mouse pointer starts bouncing around all over the screen.

Filippos Kolyvas (fkol-k4) wrote :

After falsely subscribing to bug 871986, i see that now i'm in the right place.
After reading the comments on thiw bug, i confirm that it easier for the launcher to reveal after the adjustments proposed.
I still however have to "hit hard" the left part of the screen to reveal the launcher, something that i don't consider a right setting, because of two reasons:
1. It is not an obvious decision to start "hitting the left side of the screen". An obvious thing to do is to leave the cursor there for a little longer, something that sadly does not work.
2. It reminds me of the "you just need a bigger hammer" logic, of which i am no t a fan.
I also want to point out that this cannot be solved when using 12.04 in virtualbox guest installation, as pressuring left with the mouse just a) exits the mouse off the guest OS onto the host OS if the host OS is on "never hide launcher" setting, or b) reveals the Host OS launcher if the host OS is on "autohide" or "avoid window" launcher setting.

Jason Smith (jassmith) on 2012-02-21
description: updated
John Lea (johnlea) on 2012-02-21
description: updated
Changed in unity:
assignee: Jason Smith (jassmith) → Chris Halse Rogers (raof)
John Lea (johnlea) on 2012-02-21
description: updated
tags: added: udp
Alistair Buxton (a-j-buxton) wrote :

Thanks for updating the description with the nvidia workaround. It solved the problem for me.

Ubuntu-QC-1 (aobreyss) wrote :

FYI, on Precise amd64, I use a Logitech wireless touchpad instead of a mouse. For me it's a total no go, I just can't get Unity to unhide, whatever I do, whatever the settings, always have to use the Super key which is really annoying.

Chris Halse Rogers (raof) wrote :

Is there a separate bug for the nvidia issue? This bug is starting to lose focus - the nvidia issue is separate from the initial problem that the X server is not sending the most useful data to Unity.

I can fix the nvidia issue - that's a simple bug in the X server - but it's still not entirely clear what the most useful data to base these thresholding decisions on *is*.

psypher (psypher246) wrote :

As Filippos I too miss the old feature of just leaving the mouse there for a seconds and revealing the launcher. I don't understand the need for applying pressure, excessively moving the mouse. Is it possible to add that back as an option in the Appearance tab

Didier Roche (didrocks) wrote :

removing the "nvidia part" of this bug which is not related to first discussion and is now fixed into the distro.

description: updated
Changed in unity:
assignee: Chris Halse Rogers (raof) → Jason Smith (jassmith)
Didier Roche (didrocks) wrote :

(note that most of people commenting here were using intel)

Martin Pitt (pitti) on 2012-03-02
Changed in unity (Ubuntu):
milestone: ubuntu-12.04-beta-1 → ubuntu-12.04-beta-2
psypher (psypher246) wrote :

I have been running the past week or so with the launcher unhidden permanently. Since updating today and trying to set the launcher to autohide I too now an unable to unhide it at all.

Didier Roche (didrocks) on 2012-03-12
Changed in unity:
milestone: 5.6.0 → 5.8.0
Didier Roche (didrocks) wrote :

the values are now eased in the distro.

Changed in unity-distro-priority:
status: Fix Committed → Fix Released
Changed in unity:
status: Triaged → Fix Released
Changed in unity (Ubuntu Precise):
status: Triaged → Fix Released
P Cantwall (p-cantwell) wrote :

It is 2012-04-28 and this bug still exists. I have a geforce 9800 gtk+ but using the old "ubuntu approved" drivers supplied as "recommended." There will be a slight black shadow on the left when I want it to appear, but it doesn't open and the black "glow" collapses. It takes repeated attempts of bouncing the cursor to make it appear after it is stuck. I'm using Beta2 and I haven't been offered the final release in System Update yet.

P Cantwall (p-cantwell) wrote :

I reread the comments and adjusted my mouse. Adding about 1/10 on the slider for Acceleration (I usually want no acceleration) makes the Launcher show more reliably. I'm sorry I didn't think of this sooner after reading the notes and adding my report.

Chris (fabricator4) wrote :

@P Cantwall

Just do a dist-upgrade, or better still download and install the new release.

This is supposedly "fixed", and it seems a little better since sometime in beta2, however the reveal sensitivity still does not go far enough to fixing the problem. I can't see much difference between the default configuration and maximum reveal sensitivity. Maximum sensitivity really should allow the Launcher to appear as soon as the mouse hits the LHS.

I don't *want* to have to increase my mouse acceleration. I do a lot of fine work in photo editing and I like my mouse acceleration the way it is.

Chris

Winston (winston-nolan) wrote :

After my last update I am not suffering from this bug. IT used to work fine. I could use Unity and could be productive. Now, I hate unity and the launcher. When is a fix due? Ubuntu, you need to pay more attention to usability and your users

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related blueprints