Ubuntu

Unknown keyword in configuration file: gfxboot

Reported by Ara Pulido on 2010-09-23
510
This bug affects 133 people
Affects Status Importance Assigned to Milestone
usb-creator
New
Undecided
Unassigned
usb-creator (Fedora)
Unknown
Unknown
usb-creator (Ubuntu)
High
Unassigned
Lucid
Critical
Unassigned
Maverick
Medium
Unassigned
Natty
Medium
Unassigned
Oneiric
High
Unassigned
Precise
High
Unassigned

Bug Description

Binary package hint: usb-creator

Using Maverick, I have created an image of UNE 10.04.1

When trying to boot a dell mini9 with it, it does not boot:

Unknown keyword in configuration file: gfxboot

vesamenu.cr32: Not a COM32 image

ProblemType: Bug
DistroRelease: Ubuntu 10.10
Package: usb-creator-gtk 0.2.24
ProcVersionSignature: Ubuntu 2.6.35-22.33-generic 2.6.35.4
Uname: Linux 2.6.35-22-generic x86_64
NonfreeKernelModules: nvidia
Architecture: amd64
Date: Thu Sep 23 09:42:07 2010
InstallationMedia: Ubuntu 10.04 LTS "Lucid Lynx" - Release amd64 (20100429)
PackageArchitecture: all
ProcEnviron:
 LANG=en_GB.utf8
 SHELL=/bin/bash
SourcePackage: usb-creator

Ara Pulido (apulido) wrote :
Evan Dandrea (ev) wrote :

The best we can do here is to change the UI to warn the user that creating 10.04 USB disks from 10.10 will not work:
https://wiki.ubuntu.com/MaverickMeerkat/TechnicalOverview#Known issues

Changed in usb-creator (Ubuntu):
importance: Undecided → Critical
status: New → Confirmed
Liam Dunn (ldunn) wrote :

Would something as simple as adding "WARNING: This program is currently unable to create USB disks for Ubuntu 10.04" to the label at the top of the usb-creator window be sufficient?

Liam Dunn (ldunn) wrote :

Well, I've proposed a merge to that effect.

Colin Watson (cjwatson) wrote :

I suspect we actually just need to copy gfxboot.c32 to the disk in this situation.

Changed in usb-creator (Ubuntu Maverick):
milestone: none → maverick-updates
status: New → Triaged
importance: Undecided → Critical
Changed in usb-creator (Ubuntu Natty):
status: Confirmed → Triaged
Kate Stewart (kate.stewart) wrote :

One possible workaround is to type 'live' at the boot prompt.

I saw this for a liveCD for i386, and amd64.

Unknown keyword in configuration file: gfxboot
vesamenu.c32: not a COM32R image
boot:_

last 2 lines repeat if you do nothing, some sort of loop. However it does respond to the keyboard, and typing 'live' got it to continue booting.

vitja (vitja-makarov) wrote :

It seems to me that this bug occures because of new version of SYSLINUX in Maverick. 10.04 have 3.63 and Maverick have 4.01

Possible solution is to distribute older version of SYSLINUX with usb-creator and use it instead of newer one for old releases.

Just downloaded and installed 10.04.1 onto a usb stick. Typing 'live' (both with and without quotation marks) gives the result:

boot: live
Could not find kernel image live

As with 'live', gives the same output.

Bazon (bazonbloch) wrote :

For those who might help it:
In a duplicate of this bug description is a workaround:
after the boot: prompt, just enter help and hit return. afterwards it boots normally:
https://bugs.launchpad.net/ubuntu/+source/syslinux/+bug/617779/comments/7

Luca Ferroni (liuck) wrote :

This bug happened to me in creating a Maverick USB boot disk with Lynx usb-creator-gtk.

Even in this case typing "help" at prompt act as a workaround for the issue.

Mark Bellis (markbellis) wrote :

"help" fix worked for installing 10.04.1

Paul (paulsantman) wrote :

Created a USB boot disk for Linux Mint 10 RC (based on Ubuntu 10.10). In my case, typing "help" at the boot screen didn't work, but typing "live" did the trick.

thank you very much guys! It really worked this way!!!

 Vangelis Konstantoulakis

________________________________
From: Paul <email address hidden>
To: <email address hidden>
Sent: Sat, October 30, 2010 12:37:45 PM
Subject: [Bug 645818] Re: 10.04.1 image created in Maverick does not boot in my
Dell Mini9

Created a USB boot disk for Linux Mint 10 RC (based on Ubuntu 10.10). In
my case, typing "help" at the boot screen didn't work, but typing "live"
did the trick.

--
10.04.1 image created in Maverick does not boot in my Dell Mini9
https://bugs.launchpad.net/bugs/645818
You received this bug notification because you are a direct subscriber
of the bug.

Status in “usb-creator” package in Ubuntu: Triaged
Status in “usb-creator” source package in Maverick: Triaged
Status in “usb-creator” source package in Natty: Triaged

Bug description:
Binary package hint: usb-creator

Using Maverick, I have created an image of UNE 10.04.1

When trying to boot a dell mini9 with it, it does not boot:

Unknown keyword in configuration file: gfxboot

vesamenu.cr32: Not a COM32 image

ProblemType: Bug
DistroRelease: Ubuntu 10.10
Package: usb-creator-gtk 0.2.24
ProcVersionSignature: Ubuntu 2.6.35-22.33-generic 2.6.35.4
Uname: Linux 2.6.35-22-generic x86_64
NonfreeKernelModules: nvidia
Architecture: amd64
Date: Thu Sep 23 09:42:07 2010
InstallationMedia: Ubuntu 10.04 LTS "Lucid Lynx" - Release amd64 (20100429)
PackageArchitecture: all
ProcEnviron:
LANG=en_GB.utf8
SHELL=/bin/bash
SourcePackage: usb-creator

To unsubscribe from this bug, go to:
https://bugs.launchpad.net/ubuntu/+source/usb-creator/+bug/645818/+subscribe

I managed to get ubuntu 10.04 back on my computer. The aid was to create the usb boot stick from a ubuntu 10.04 computer instead of my companion ubuntu 10.10 computer.

Quote from:
https://wiki.ubuntu.com/MaverickMeerkat/ReleaseNotes#Common%20Desktop%20Applications

"It is not possible to create Ubuntu 10.04 USB disks from the Startup Disk Creator in Ubuntu 10.10 due to a backwards incompatibility in the syslinux program."

Changed in usb-creator (Ubuntu Natty):
assignee: nobody → Canonical Foundations Team (canonical-foundations)
Changed in usb-creator (Ubuntu Maverick):
assignee: nobody → Canonical Foundations Team (canonical-foundations)
Changed in usb-creator (Ubuntu Natty):
milestone: none → natty-alpha-1
Colin Watson (cjwatson) on 2010-12-03
Changed in usb-creator (Ubuntu Natty):
milestone: natty-alpha-1 → natty-alpha-2
scottuss (scottuss) wrote :

This bug affects me, and can confirm that typing "help" and pressing Return does allow booting from the USB. I created an Ubuntu 10.04.1 LTS bootable stick from Ubuntu 10.10.

> This bug affects me, and can confirm that typing "help" and pressing Return does allow booting from the USB. I created an Ubuntu 10.04.1 LTS bootable stick from Ubuntu 10.10.

Confirmed. This is a great work-around. Using Kubuntu 10.04 to create a 10.10 UNR thumb drive.

I have a hard time accepting the "it will not work" responses or the "please read the release notes" responses, especially considering the "help" work-around (to date, one of the easiest work-arounds I've had to do).

The bug is marked as critical, so I won't be to critical. :)

Thanks for the help.

-Tres

Colin Watson (cjwatson) on 2011-01-21
Changed in usb-creator (Ubuntu Natty):
milestone: natty-alpha-2 → ubuntu-11.04-beta
Colin Watson (cjwatson) on 2011-02-11
Changed in usb-creator (Ubuntu Maverick):
assignee: Canonical Foundations Team (canonical-foundations) → Evan Dandrea (ev)
Changed in usb-creator (Ubuntu Natty):
assignee: Canonical Foundations Team (canonical-foundations) → Evan Dandrea (ev)
tags: added: iso-testing
Changed in usb-creator (Ubuntu Lucid):
importance: Undecided → Critical
milestone: none → ubuntu-10.04.2
Kate Stewart (kate.stewart) wrote :

Adding lucid to the tracking (although this problem is not in lucid's code), since this impacting the testing of lucid 10.04.2 right now as well. Will mark it as invalid later- but want to use it for tracking 10.04.2 issues.

Per jibel's request:

I created a 10.04.2 bootable USB with usb-creator-gtk on Lucid. I was able to boot to a live session with this USB image.
System that booted is an Acer Aspire One Model ZA3.

summary: - 10.04.1 image created in Maverick does not boot in my Dell Mini9
+ Unknown keyword in configuration file: gfxboot
tags: added: lucid
removed: ubuntu-une
tags: removed: lucid
Fabio Marconi (fabiomarconi) wrote :

Hello
I cannot reproduce this issue in any of Natty's images that i've tested, only with 10.04.2 images.
usb-creator 0.2.28 is working well with Natty's images, but i've got gfxboot bug only with Lucid's images.
Fabio

Fabio Marconi (fabiomarconi) wrote :

Tested just now in natty 20110215 amd64 with natty 20110215 amd64 Desktop image

Fabio Marconi (fabiomarconi) wrote :

tested just now lucid 20110211.1 amd64 desktop usb created in natty 20110215 and i've got again gfxboot bug

Kate Stewart (kate.stewart) wrote :

Have documented this issue in 10.04.2 release notes, so marking lucid as invalid now since this was just a place holder.

Changed in usb-creator (Ubuntu Lucid):
milestone: ubuntu-10.04.2 → ubuntu-10.04.3
status: New → Invalid
milestone: ubuntu-10.04.3 → ubuntu-10.04.2

Lo siento mucho, pero NO entiendo NADA el Ingles, no sé que es lo que me pones en esta carta
Salu2

> Date: Fri, 18 Feb 2011 03:47:33 +0000
> From: <email address hidden>
> To: <email address hidden>
> Subject: [Bug 645818] [NEW] Unknown keyword in configuration file: gfxboot
>
> You have been subscribed to a public bug:
>
> Binary package hint: usb-creator
>
>
> Using Maverick, I have created an image of UNE 10.04.1
>
> When trying to boot a dell mini9 with it, it does not boot:
>
> Unknown keyword in configuration file: gfxboot
>
> vesamenu.cr32: Not a COM32 image
>
> ProblemType: Bug
> DistroRelease: Ubuntu 10.10
> Package: usb-creator-gtk 0.2.24
> ProcVersionSignature: Ubuntu 2.6.35-22.33-generic 2.6.35.4
> Uname: Linux 2.6.35-22-generic x86_64
> NonfreeKernelModules: nvidia
> Architecture: amd64
> Date: Thu Sep 23 09:42:07 2010
> InstallationMedia: Ubuntu 10.04 LTS "Lucid Lynx" - Release amd64 (20100429)
> PackageArchitecture: all
> ProcEnviron:
> LANG=en_GB.utf8
> SHELL=/bin/bash
> SourcePackage: usb-creator
>
> ** Affects: usb-creator (Ubuntu)
> Importance: Critical
> Assignee: Evan Dandrea (ev)
> Status: Triaged
>
> ** Affects: usb-creator (Ubuntu Lucid)
> Importance: Critical
> Status: Invalid
>
> ** Affects: usb-creator (Ubuntu Maverick)
> Importance: Critical
> Assignee: Evan Dandrea (ev)
> Status: Triaged
>
> ** Affects: usb-creator (Ubuntu Natty)
> Importance: Critical
> Assignee: Evan Dandrea (ev)
> Status: Triaged
>
>
> ** Tags: amd64 apport-bug iso-testing maverick
> --
> Unknown keyword in configuration file: gfxboot
> https://bugs.launchpad.net/bugs/645818
> You received this bug notification because you are subscribed to Ubuntu ubuntu-10.04.2.

Alberto Jovito (thedemon007) wrote :

Orticio ese email lo recibes por que te has supcrito a la bug y cada vez que hay un mensaje o modifican algo en esta bug te envian un correo

> Date: Wed, 23 Feb 2011 09:48:10 +0000
> From: <email address hidden>
> To: <email address hidden>
> Subject: [Bug 645818] Re: Unknown keyword in configuration file: gfxboot
>
> Orticio ese email lo recibes por que te has supcrito a la bug y cada vez
> que hay un mensaje o modifican algo en esta bug te envian un correo

Estuve manipulando con los archivos de Ubuntu y NO SE que es lo que hice para suscribirme a esta bug teniendo en cuenta que no conozco el idioma inglés y da la casualidad que todo lo que veo me sale en éste idioma, que para mí es como si fuera el chino.Te voy a pedir un favor muy grande y es que me puedas orientar la manera de que me pueda borrar de éste bug, porque no doy con la forma de poder hacerlo.
Te doy las gracias anticipadas y te considero un buen amigo mío por haberme escrito este correo.
GRACIAS nuevamente

>
> --
> You received this bug notification because you are subscribed to Ubuntu
> ubuntu-10.04.2.
> https://bugs.launchpad.net/bugs/645818
>
> Title:
> Unknown keyword in configuration file: gfxboot
>
> Status in “usb-creator” package in Ubuntu:
> Triaged
> Status in “usb-creator” source package in Lucid:
> Invalid
> Status in “usb-creator” source package in Maverick:
> Triaged
> Status in “usb-creator” source package in Natty:
> Triaged
>
> Bug description:
> Binary package hint: usb-creator
>
>
> Using Maverick, I have created an image of UNE 10.04.1
>
> When trying to boot a dell mini9 with it, it does not boot:
>
> Unknown keyword in configuration file: gfxboot
>
> vesamenu.cr32: Not a COM32 image
>
> ProblemType: Bug
> DistroRelease: Ubuntu 10.10
> Package: usb-creator-gtk 0.2.24
> ProcVersionSignature: Ubuntu 2.6.35-22.33-generic 2.6.35.4
> Uname: Linux 2.6.35-22-generic x86_64
> NonfreeKernelModules: nvidia
> Architecture: amd64
> Date: Thu Sep 23 09:42:07 2010
> InstallationMedia: Ubuntu 10.04 LTS "Lucid Lynx" - Release amd64 (20100429)
> PackageArchitecture: all
> ProcEnviron:
> LANG=en_GB.utf8
> SHELL=/bin/bash
> SourcePackage: usb-creator

Alberto Jovito (thedemon007) wrote :

Bueno Orticio yo no te he escrito el correo ese te lo mandan automáticamente cuando alguien comenta la bug que esta acá https://bugs.launchpad.net/ubuntu/+source/usb-creator/+bug/645818 para borrarte de la bug visita aca: https://bugs.launchpad.net/ubuntu/+source/usb-creator/+bug/645818 luego le das donde dice Unsubscribe

Orticio Jlgtgutisu (jlgutisu3) wrote :

Alberto Jovio, no sabes la alegría que me distes al poderme orientar sobre la manera de poderme dar de baja de los Bugs, ya que estaba recibiendo un montón de archivos que no tenía la menor idea de lo que me querían decir. He hecho numerosas combinaciones para poderme dar de baja, pero nunca lo conseguía.
Alberto Jovio, yo soy un novato en Ubuntu, pero tengo muchísimo interés en aprender y poderlo trabajar, pero no lo he conseguido hacer, por mi falta de conocer el idioma inglés.
Repito, te considero un buen amigo y te quedo muy agradecido

> Date: Fri, 25 Feb 2011 10:07:10 +0000
> From: <email address hidden>
> To: <email address hidden>
> Subject: [Bug 645818] Re: Unknown keyword in configuration file: gfxboot
>
> Bueno Orticio yo no te he escrito el correo ese te lo mandan
> automáticamente cuando alguien comenta la bug que esta acá
> https://bugs.launchpad.net/ubuntu/+source/usb-creator/+bug/645818 para
> borrarte de la bug visita aca: https://bugs.launchpad.net/ubuntu/+source
> /usb-creator/+bug/645818 luego le das donde dice Unsubscribe
>
> --
> You received this bug notification because you are subscribed to Ubuntu
> ubuntu-10.04.2.
> https://bugs.launchpad.net/bugs/645818
>
> Title:
> Unknown keyword in configuration file: gfxboot
>
> Status in “usb-creator” package in Ubuntu:
> Triaged
> Status in “usb-creator” source package in Lucid:
> Invalid
> Status in “usb-creator” source package in Maverick:
> Triaged
> Status in “usb-creator” source package in Natty:
> Triaged
>
> Bug description:
> Binary package hint: usb-creator
>
>
> Using Maverick, I have created an image of UNE 10.04.1
>
> When trying to boot a dell mini9 with it, it does not boot:
>
> Unknown keyword in configuration file: gfxboot
>
> vesamenu.cr32: Not a COM32 image
>
> ProblemType: Bug
> DistroRelease: Ubuntu 10.10
> Package: usb-creator-gtk 0.2.24
> ProcVersionSignature: Ubuntu 2.6.35-22.33-generic 2.6.35.4
> Uname: Linux 2.6.35-22-generic x86_64
> NonfreeKernelModules: nvidia
> Architecture: amd64
> Date: Thu Sep 23 09:42:07 2010
> InstallationMedia: Ubuntu 10.04 LTS "Lucid Lynx" - Release amd64 (20100429)
> PackageArchitecture: all
> ProcEnviron:
> LANG=en_GB.utf8
> SHELL=/bin/bash
> SourcePackage: usb-creator

Mikele (mikilion) wrote :

The problem is incompatibility between Syslinux of Ubuntu Maverick and vesamenu.c32 of Ubuntu Lucid as reported here:

https://bugzilla.redhat.com/show_bug.cgi?id=662557

Try replacing the file vesamenu.c32 on the USB disk drive with that one "/usr/lib/syslinux/vesamenu.c32" of Ubuntu Maverick system or use UNetbootin than works fine.

Robbie Williamson (robbiew) wrote :

I'm confused with all the tested comments. Which releases are we now currently seeing this issue? I'm also lowering the severity since we have a workaround...as far as I can tell.

Changed in usb-creator (Ubuntu Maverick):
importance: Critical → Medium
Changed in usb-creator (Ubuntu Natty):
importance: Critical → Medium
Colin Watson (cjwatson) on 2011-04-02
Changed in usb-creator (Ubuntu Natty):
milestone: ubuntu-11.04-beta-1 → ubuntu-11.04-beta-2
Jeremy Foshee (jeremyfoshee) wrote :

Robbie,
    I've experienced this with Natty Beta 1. I can confirm that the replacement of vesamenu.c32 recommended by Mikele gets me past the error and I can install. What a pain! :-)

~JFo

Jeremy Foshee (jeremyfoshee) wrote :

strike that previous. There is a separate error in my natty image. I am pulling a current daily and will update on if I still see the issue.

~JFo

Jeremy Foshee (jeremyfoshee) wrote :

The current daily image of Natty does not display this behavior.

~JFo

Colin Watson (cjwatson) on 2011-04-15
Changed in usb-creator (Ubuntu Natty):
milestone: ubuntu-11.04-beta-2 → ubuntu-11.04
elvis (elvisa) wrote :

Not sure if it's related or not:

I install Ubuntu via PXE/netboot. vesamenu.c32 provided with Lucid 10.04LTS (144392 bytes) works fine for PXE booting.

When attempting to use the netboot files provided by Natty 11.04 beta-2 (156716 bytes), it crashes both my virtual machine (Virtualbox 4, running native Intel PXE as well as gPXE 1.0.1) as well as my physical machine (attempted with both the native Realtek PXE ROM as well as gPXE 1.0.1 via USB).

Replacing Natty's vesamenu.c32 with Lucid's version fixes the problem, and allows me to install via PXE/netboot.

Pete Graner (pgraner) on 2011-04-25
Changed in usb-creator (Ubuntu Natty):
milestone: ubuntu-11.04 → natty-updates
Changed in usb-creator (Ubuntu Oneiric):
status: New → Triaged
importance: Undecided → Medium
assignee: nobody → Evan Dandrea (ev)
milestone: none → ubuntu-11.10
bernhard (bernhardredl) wrote :

both daily iso and beta2 64bit desktop iso hang, while trying to boot from usb stick.
the splash is displayed and after about 10min there is massive text displayed to stdout (so fast that i can't read anything)

previous released worked with this hardware

Matt Jones (mjones41) wrote :

Comment #28 from Mikele worked for me.

Replacing the file vesamenu.c32 on the USB disk drive with that one "/usr/lib/syslinux/vesamenu.c32" of Ubuntu Maverick system works fine, and is a permanent fix.

This is the same when using Mint 10 and Mint 11.

Tory (tory-andrew-law) wrote :

This just happened to me. I created a 10.04.2 Server boot drive from 11.04 Desktop.

Zeka (zekaspb) wrote :

=( Me too

Brett Alton (brett-alton) wrote :

I can confirm that trying to create a usb start disk using a 64-bit 10.04.2 lucid server image and a 64-bit 11.04 natty desktop, the boot fails with the following message: "vesamenu.c32 is not an COM32R image"

SEWilco (scot-wilcoxon) wrote :

Shouldn't this be treated as a failure of an LTS version? Ubuntu users who have followed the upgrade recommendations are now unable to create 10.04.2 LTS disks. An existing LTS server is not affected, but LTS can no longer be used for new machines.

A workaround is to remove the LTS classification.

Alessandro Losavio (alo21) wrote :

I found the same bug on Xubuntu 11.10 alpha 2 amd64. I tried to create a LiveCD on USB using the program default for Ubuntu and UNEbootin.

Alessandro Losavio (alo21) wrote :

I found the same bug on Mythbuntu 11.10 alpha 2 amd64.

Using ubuntu natty to create a live usb of the 10.04 2 LTS 32bit ISO gives this problem.

Copying the file "/usr/lib/syslinux/vesamenu.c32" from natty into the syslinux folder on the USB brings up the vesa boot menu instead of the error (and beeps a couple of times from the PC speaker - i dont know if this is normal or not). If i dont select an option the system boots normally.

no config files need alteration. (someone else suggested this fix in another thread)

Daniel Cai (dcai656) wrote :

using my dell 710m to install UNR 9.10 doesnt work you cant click anything execpt shut down

Carla Sella (carla-sella) wrote :

Today I tested Lucid image 20110720.1 (http://cdimage.ubuntu.com/lucid/daily-live/20110720.1/lucid-desktop-amd64.iso) and I still have the same problem as previous test.
On boot I get this message:
vesamenu.cr32: Not a COM32 image
and my PC doesn't boot.

mtu (mtu) wrote :

I can confirm the bug and the workaround:
I'm on 10.10 and I used usb-creator-gtk to create an image of Linux Mint 10 (also based on 10.10). I got the same error.
Then I replaced the 'syslinux/vesamenu.c32' file on the stick with the one found in /usr/lib/syslinux/vesamenu.c32 and it worked.

mayleen (der-feindliche-spunk) wrote :

We had the same case:

10.10 (actually Linux Mint 10) and creating a 11.04 bootable USB.

The above mentioned workaround solved this problem too.

Link to original case (german): http://www.linuxmintusers.de/index.php?topic=4263.0

Very annoying issue. I just tried to generate a bootable pen drive for hours until I found this bug. At least I would have expected usb-creator to raise a message stating that the pendrive won't boot. It should be possible for usb-creator to find out which ISO the user wants to put on the pendrive, no? Ideally though, it would just work^tm, i.e. by shipping the appropriate vesamenu.c32 itself. Hence, can we reassign to usb-creator?

Changed in usb-creator (Ubuntu Oneiric):
importance: Medium → High
tags: added: rls-mgr-o-tracking
Changed in usb-creator (Ubuntu Oneiric):
milestone: ubuntu-11.10 → oneiric-updates
tags: added: rls-mgr-p-tracking
removed: rls-mgr-o-tracking
Mads Vering Krarup (m-vering) wrote :

#10 and #11: "help" fix worked for installing 10.04.3 as well

Steve Langasek (vorlon) on 2011-10-26
tags: added: rls-p-tracking
Steve Langasek (vorlon) on 2011-11-16
Changed in usb-creator (Ubuntu Precise):
milestone: none → ubuntu-12.04
Changed in usb-creator (Ubuntu Lucid):
status: Invalid → Confirmed
Fabio Marconi (fabiomarconi) wrote :

Testing 10.04.04, afflicted, all the others images not, i dubt that is a bug in usb-creator
---
Ubuntu Bug Squad volunteer triager
http://wiki.ubuntu.com/BugSquad

Fabio Marconi (fabiomarconi) wrote :

Meaning: images/releases, sorry
---
Ubuntu Bug Squad volunteer triager
http://wiki.ubuntu.com/BugSquad

Fabio Marconi (fabiomarconi) wrote :

Substituting vesamenu.c32 file in isolinux, with the ione present in precise, the session boot, not in a god way, but boot.
---
Ubuntu Bug Squad volunteer triager
http://wiki.ubuntu.com/BugSquad

Fabio Marconi (fabiomarconi) wrote :

boot meaning that start and stay looped on plymouth

Paolo Rotolo (paolorotolo) wrote :

I can confirm this issue on the daily build of Ubuntu Lucid 10.04.4

Jeff Lane (bladernr) wrote :

And on the release version of 10.04.4... USB stick was made with usbcreator on an Oneiric machine :(

Jeff Lane (bladernr) wrote :

I should add that the "help" workaround does still work for this...

For anyone who hasn't read the previous comments, you "should' be able to get 10.04.4 to boot by waiting for the boot: prompt (the screen that tells you about the COM32 error). At the boot prompt type 'help' to open the help screen and hit enter. once the help screen opens, hit Enter on more time to boot the installer.

Some have also suggested that typing 'live' will work as well. That only applies to the Desktop images, AFAIK, for Alternate and Server installers, you'll have to use the 'help' workaround instead.

Evan Dandrea (ev) wrote :

The solution is to build syslinux 3.63 as syslinux-legacy in precise. However, I'm running into difficulty trying to build this version on precise using precise's nasm. It's failing with "cannot mix real and virtual attributes in nobits section"

Terrence Bruff (tbruff13) wrote :

This bug affected me in Kubuntu 10.04.4 in both 32 bit and 64 bit using both unetbootin and Startup Disk creator. With Unetbootin there was just a hanging and with Startup disk creator there was the same error. I believe it is caused by version incompatibilities somewhere

Colin Watson (cjwatson) wrote :

@ev: That syslinux build failure was fixed by:

  http://git.kernel.org/?p=boot/syslinux/syslinux.git;a=commitdiff;h=4ba801edb01acae7281fe09f6225c38390033817

However, it's not easy to backport that in conjunction with the gfxboot patch. When I tried, I got further but ended up with:

ld -m elf_i386 -T syslinux.ld -M -o isolinux.elf isolinux.o > isolinux.map
isolinux.o:isolinux.asm:1070:(.text+0x6a0): relocation truncated to fit: R_386_16 against `.bss1'
isolinux.o:isolinux.asm:1073:(.text+0x6a6): relocation truncated to fit: R_386_16 against `.bss1'
isolinux.o:ui.inc:643:(.text+0xa7c): relocation truncated to fit: R_386_16 against `.bss1'
isolinux.o:comboot.inc:559:(.text+0x11ed): relocation truncated to fit: R_386_16 against `.bss1'
isolinux.o:comboot.inc:755:(.text+0x12c0): relocation truncated to fit: R_386_16 against `.bss1'
isolinux.o:comboot.inc:756:(.text+0x12c4): relocation truncated to fit: R_386_16 against `.bss1'
isolinux.o:com32.inc:76:(.text+0x13ff): relocation truncated to fit: R_386_16 against `.bss1'
isolinux.o:com32.inc:77:(.text+0x1403): relocation truncated to fit: R_386_16 against `.bss1'
isolinux.o:com32.inc:209:(.text+0x14eb): relocation truncated to fit: R_386_16 against `.bss1'
isolinux.o:com32.inc:247:(.text+0x1511): relocation truncated to fit: R_386_16 against `.bss1'
isolinux.o:com32.inc:252:(.text+0x1517): additional relocation overflows omitted from the output
make[1]: *** [isolinux.elf] Error 1

I think it might be easier to attempt to fix the issue with nasm directly, rather than trying to make this Frankenstein backport work.

Colin Watson (cjwatson) wrote :

This started failing with natty's nasm. In maverick, it builds fine.

      nasm | 2.08.01-1 | maverick | source, amd64, armel, i386, powerpc
      nasm | 2.09.04-1 | natty | source, amd64, armel, i386, powerpc

Colin Watson (cjwatson) wrote :

More specifically, 2.08.02-1 (from Debian) succeeds after correcting the bogus .size in memdisk/memset.S (s/memcpy/memset/g) but 2.09-1 (also from Debian) fails. 2.09 was a fairly substantial release, though:

  http://www.nasm.us/doc/nasmdocc.html#section-C.1.12

Colin Watson (cjwatson) wrote :

@ev: Here's a patch which fixes the build on precise for me, as minimal as I can get it. Please do test this though - all I've done is test that it builds, not that it works!

tags: added: patch
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package usb-creator - 0.2.38

---------------
usb-creator (0.2.38) precise; urgency=low

  [ Colin Watson ]
  * Fix production of Ubuntu <= 10.04 images on Ubuntu >= 10.10 using
    syslinux-legacy (LP: #645818).

  [ Evan Dandrea ]
  * When comparing against 10.04, treat its point releases the same as
    the initial release.
  * Drop code to insert 'ui' in front of 'gfxboot bootlogo' in 10.04.
    The ui command was added after 10.04.
 -- Evan Dandrea <email address hidden> Mon, 16 Apr 2012 11:29:30 +0100

Changed in usb-creator (Ubuntu Precise):
status: Triaged → Fix Released
Julian Taylor (jtaylor) wrote :

I just created an lucid 10.04.4 32 bit image with 0.2.38 and still got this error

Changed in usb-creator (Ubuntu Precise):
status: Fix Released → New
Julian Taylor (jtaylor) wrote :

the checksum of my 10.04.4 iso is correct and a natty 32 bit iso just created with the same usb-creator version works.

Evan Dandrea (ev) wrote :

Hi Julian,

Thanks for bringing this to my attention. I'll have a look.

Evan Dandrea (ev) wrote :

This is indeed still broken.

Changed in usb-creator (Ubuntu Precise):
status: New → Confirmed
Changed in usb-creator (Ubuntu):
milestone: ubuntu-12.04 → precise-updates
Changed in usb-creator (Ubuntu Precise):
milestone: ubuntu-12.04 → precise-updates
Nicolas Delvaux (malizor) wrote :

I had the very same problem today with the latest Quantal Daily-Live. Its unable to boot.
I used usb-creator on Precise. The strange thing is that it used to work with former daily lives...

Mathieu MD (mathieu.md) wrote :

On Kubuntu 12.10 it still affect me.

However, the solution shown here worked for me:
http://askubuntu.com/questions/141311/unknown-keyword-in-configuration-file-boot-error-when-booting-off-a-live-usb
"
The problem is that usb-creator depends on syslinux-legacy 3.63, and uses it to write boot up informations into USB, while the parameters "ui" can only be accepted by syslinux 4.05, which was installed on ubuntu 12.04.

A simple solution to solve everything is:

sudo mv /usr/bin/syslinux-legacy /usr/bin/syslinux-legacy.bak
sudo ln -s /usr/bin/syslinux /usr/bin/syslinux-legacy

And you can actually use syslinux 4.05 to write boot information into USB.
"

dino99 (9d9) wrote :
Changed in usb-creator (Ubuntu Maverick):
status: Triaged → Invalid
Changed in usb-creator (Ubuntu Natty):
status: Triaged → Invalid
Changed in usb-creator (Ubuntu Oneiric):
status: Triaged → Invalid
tags: added: lucid precise
removed: maverick
Evan Dandrea (ev) on 2013-05-30
Changed in usb-creator (Ubuntu):
assignee: Evan Dandrea (ev) → nobody
Changed in usb-creator (Ubuntu Natty):
assignee: Evan Dandrea (ev) → nobody
Changed in usb-creator (Ubuntu Precise):
assignee: Evan Dandrea (ev) → nobody
Changed in usb-creator (Ubuntu Maverick):
assignee: Evan Dandrea (ev) → nobody
Changed in usb-creator (Ubuntu Oneiric):
assignee: Evan Dandrea (ev) → nobody
Dimitri John Ledkov (xnox) wrote :

This doesn't affect quantal and up does it? (As in using usb-creator _from_ quantal and up to create boot images _of_ quantal and up?)

usb-creator should be SRUed to Precise with fixes, such that users can prepare usb-sticks of the next release.

Changed in usb-creator (Ubuntu):
status: Confirmed → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions

Remote bug watches

Bug watches keep track of this bug in other bug trackers.