Ubuntu

[i965] X freezes starting on April 3rd

Reported by Jithin Emmanuel on 2009-04-11
740
This bug affects 78 people
Affects Status Importance Assigned to Milestone
xf86-video-intel
Fix Released
Critical
compiz (Ubuntu)
Undecided
Michael Vogt
Jaunty
Undecided
Martin Pitt
Karmic
Undecided
Michael Vogt
xserver-xorg-video-intel (Ubuntu)
Critical
Arlete
Jaunty
Critical
Arlete
Karmic
Critical
Arlete

Bug Description

[Problem]
Starting around 4/3, when mesa was upgraded from 7.3 to 7.4, several i965 users started noticing X freeze after several hours of use, triggered by application usage especially noticeable with (but not unique to) compiz enabled.

[Impact]
The freeze bug affects a subset of i965 based systems, most particularly those using compiz. Exact numbers cannot be determined, but may be as high as 25-50% based on rough estimates.

The problem is severe: An unpredictable lockup of the system that requires a power cycle to recover from. For some users it comes on within minutes, while for others it comes after a few hours of use.

[How Addressed in Development Version]
For now, the patch being proposed for Jaunty has been uploaded to Karmic.

Longer term, we plan to move from EXA to UXA once the latter is stable enough. It has been found that while UXA exhibits other kinds of freezes, we've not yet been able to reproduce this particular freeze there.

[Patch for Jaunty]
A low-risk workaround that has proven effective at eliminating freezes, or at least greatly reducing their frequency, is to increase the Virtual framebuffer size. Some users do this locally as a matter of course to gain dual-head support, so this setting has received extremely widespread testing already.

The patch for Jaunty causes the Virtual size to be set to 2048x2048 if it is not otherwise specified. Users can still override this with their own settings, larger or smaller, as desired.

A side effect of this patch is that it also mitigates bug 158415 to a degree, which will make projector usage somewhat easier for this hardware because it will enable X to recognize higher resolutions available from the external monitor than were available on initial boot.

[Test Case]
The best method found to reproduce the bug is:
  a. Enable compiz
  b. Set your desktop to a 6x1 workspace layout
  c. Run http://launchpadlibrarian.net/25683477/repro.sh
  d. System will freeze anywhere from 1-20 min typically
  e. Power-button shutdown is required to reset the system

[Regression Potential]
In general, Virtual has been widely and extensively tested, so we do not expect this patch to trigger regressions.

The patch is coded to only take effect on i965 systems, so the scope of any regression that might conceivably be triggered will be limited to just that hardware.

[Suspects]
Omitting obviously trivial, unrelated changes, here are what changed in several suspect packages in the timeframe in question:

* intel driver:
  4/01: 118_drop_legacy3d.patch: Removed Legacy3D
  4/03: 114_fix_xv_with_non_gem.patch: Dropped since it caused regression
  4/06: 119_drm_bo_unreference_needs_null.patch: Fixes various nullptr derefs
  4/08: 120_fix_vt_switch.patch: Fix nullptr deref in video playback

* xserver:
  4/08: 177_animated_cursor_change_master.patch: fixes animated cursors
  4/06: 174_set_bg_pixmap_of_cow_to_none.patch: Sets bg pixmap of
         composite overlay window to None
  3/30: 172_cwgetbackingpicture_nullptr_check.patch: fix race condition
         when minimzing/maximizing firefox with flash video playing.

* mesa:
  4/03: 7.4 released
    * Added MESA_GLX_FORCE_DIRECT env var for Xlib/software driver
    * GLSL version 1.20 is returnd by the GL_SHADING_LANGUAGE_VERSION query
    * glGetActiveUniform() returned wrong size for some array types
    * Fixed some error checking in glUniform()
    * Fixed a potential glTexImage('proxy target') segfault
    * Fixed bad reference counting for 1D/2D texture arrays
    * Fixed VBO + glPush/PopClientAttrib() bug #19835
   * Assorted i965 driver bug fixes
    * Fixed a Windows compilation failure in s_triangle.c
    * Fixed a GLSL array indexing bug
    * Fixes for building on Haiku

* linux:
  4/04: 2.6.28-11.41: Revert MCHBAR patch
  4/02: 2.6.28-11.40: Add MCHBAR patch

* libdrm:
  4/04: 02_libdrm_nouveau_update.patch: Only affects nouveau code
  3/29: libdrm-nouveau1.symbols: Probably innocuous

[Workarounds]
Various people have found one or more of the following have helped to reduce the frequency or eliminate the freezes:

  * Turn off compiz
  * AccelMethod UXA
  * Set NoAccel true
  * Set Virtual to something high
  * MigrationHeuristic greedy
  * Revert to 2.4 -intel driver

[Current Theory]
A 3D memory buffer accumulates data until something gets in there incorrectly and leads to a freeze. This can happen either slowly over a long period of light use, or fairly soon if using the system heavily. It is not simply a matter of filling the memory up, so the trigger often seems to be random, but usually follows some sort of graphics transition (such as the 3D effect from alt-tab, or closing a firefox window).

It is fairly certain that there are multiple freeze bugs present in X.org with the -intel driver. This causes significant confusion when people having different bugs think they might have the same one, and find the symptoms and workarounds don't match. It is also suspected that the same root bug may have multiple different ways of triggering it.

Increasing the Virtual settings seems to either eliminate or greatly reduce the frequency of these freezes. Presumably this allocates larger memory buffers so the chances of something hitting a wrong thing are greatly lessened. However, none of this is well understood.

[Original Report]
I am using kubuntu jaunty beta. My system is freezing randomly. I have the latest updates.
After freezing the mouse pointer still works. And sometimes the power off button works. On powering off , when the stage for kubuntu logo comes its showing a distorted image.

This happens with or without desktop effects. These freezes are very randomly, but mostly when I run some new applications.
I am using intel graphics.

[lspci]
00:00.0 Host bridge [0600]: Intel Corporation Mobile PM965/GM965/GL960 Memory Controller Hub [8086:2a00] (rev 0c)
     Subsystem: Hewlett-Packard Company Device [103c:30be]
00:02.0 VGA compatible controller [0300]: Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller [8086:2a02] (rev 0c)
     Subsystem: Hewlett-Packard Company Device [103c:30be]

Jithin Emmanuel (jithin1987) wrote :
Jithin Emmanuel (jithin1987) wrote :
Jithin Emmanuel (jithin1987) wrote :

Sorry the first attachment is lscpci , typo

Bryce Harrington (bryce) on 2009-04-11
summary: - X freezes in kubunty jaunty (mouse pointer works)
+ X freezes with or without desktop effects
summary: - X freezes with or without desktop effects
+ [i965] X freezes with or without desktop effects

What you have described is a generic freeze. It could be caused by any number of things, and you need to take some additional steps to provide a complete report. "randomly" is not specific enough to be able to analyze the problem.

When did you upgrade to Jaunty? When did you first notice the freezes occurring?

How frequently do the freezes occur? How many per day would you say you experience?

List the applications you typically have open at the time of the freeze.

Describe example activities you were performing for a few of the recent freezes. You mentioned it occurs when you run new applications, which applications were these? In what way were they "new"?

For more tips on troubleshooting freeze bugs, please refer to these links:

  https://wiki.ubuntu.com/X/Troubleshooting/Freeze
  https://wiki.ubuntu.com/X/Bugs/IntelDriver

Jithin Emmanuel (jithin1987) wrote :

I did not have the freezes on jaunty alpha6. I remember it started occurring on last friday april 3rd . I am sure because it was that day kde 4.2.2 updates hit the jaunty repos. Prior to that date, when I was using kde 4.2.1 I didn't have any freezes.
The application I have running are firefox, kmail , kopete, eclipse, konsole.

Some times freeze occurs after I start kmail , but not always. Mostly when freezing I will be using konsole or kmail or firefox.
New in the sense after I start some new applications. Though I never noticed this occurring on idle state. Some times freeze occurs after login, but only after applications start and I get desktop.

Jithin Emmanuel (jithin1987) wrote :

And I am using a laptop hp compaq 6910p

Matthew Woerly (nattgew) wrote :

I'm having random freezes too, with Gnome and Compiz. They seemed to just start recently, maybe around April 3rd like you said.
I thought it was related to Gnome-Do at first, because it always froze when trying to bring up Gnome-Do. I removed that and still had the problem. So then I thought it was the UXA acceleration, but I changed back to EXA and still had it freeze. Now the freezes seem random, I'll see if I can find some kind of trend in when they occur.

00:02.0 VGA compatible controller [0300]: Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller [8086:2a02] (rev 0c)

On Sat, Apr 11, 2009 at 08:44:00AM -0000, Jithin Emmanuel wrote:
> I did not have the freezes on jaunty alpha6. I remember it started occurring on last friday april 3rd . I am sure because it was that day kde 4.2.2 updates hit the jaunty repos. Prior to that date, when I was using kde 4.2.1 I didn't have any freezes.
> The application I have running are firefox, kmail , kopete, eclipse, konsole.
>
> Some times freeze occurs after I start kmail , but not always. Mostly when freezing I will be using konsole or kmail or firefox.
> New in the sense after I start some new applications. Though I never noticed this occurring on idle state. Some times freeze occurs after login, but only after applications start and I get desktop.
>

Thanks for narrowing it to date 4/3, that's probably a very good clue.
Please attach your /var/log/dpkg.log so I can see what versions of
things you had installed that date.

Bryce

in fact i was about to point as probably guilty the xorg updates for that day. In fact i remember i've updated late at night and the other day i had about 5 freezes during the day.

However i didn't see anything deeply related with a freeze in the changelog.

I'm waiting for another freeze, so i can downgrade to a previous version and check again.

the thing is that this bug is hard to reproduce...

Andres Mujica (andres.mujica) wrote :

Would it be possible to the affected users to downgrade the mesa packages to version 7.3?

libglu1-mesa_7.3-1ubuntu4_i386.deb
libgl1-mesa-dri_7.3-1ubuntu4_i386.deb
libgl1-mesa-glx_7.3-1ubuntu4_i386.deb
mesa-utils_7.3-1ubuntu4_i386.deb

these ones are probably at /var/cache/apt/archives on your machines, if not go to packages.ubuntu.com and download those versions.

Thanks

tags: added: metabug regression-potential
Jithin Emmanuel (jithin1987) wrote :
Bryce Harrington (bryce) wrote :

2009-04-03 23:32:25 upgrade libgl1-mesa-dri 7.3-1ubuntu4 7.4-0ubuntu1
2009-04-03 23:32:25 status half-configured libgl1-mesa-dri 7.3-1ubuntu4
2009-04-03 23:32:25 status unpacked libgl1-mesa-dri 7.3-1ubuntu4
2009-04-03 23:32:25 status half-installed libgl1-mesa-dri 7.3-1ubuntu4
2009-04-03 23:32:26 status half-installed libgl1-mesa-dri 7.3-1ubuntu4
2009-04-03 23:32:27 status unpacked libgl1-mesa-dri 7.4-0ubuntu1
2009-04-03 23:32:27 status unpacked libgl1-mesa-dri 7.4-0ubuntu1
2009-04-03 23:32:27 upgrade libgl1-mesa-glx 7.3-1ubuntu4 7.4-0ubuntu1
2009-04-03 23:32:27 status half-configured libgl1-mesa-glx 7.3-1ubuntu4
2009-04-03 23:32:27 status unpacked libgl1-mesa-glx 7.3-1ubuntu4
2009-04-03 23:32:27 status half-installed libgl1-mesa-glx 7.3-1ubuntu4
2009-04-03 23:32:27 status half-installed libgl1-mesa-glx 7.3-1ubuntu4
2009-04-03 23:32:27 status unpacked libgl1-mesa-glx 7.4-0ubuntu1
2009-04-03 23:32:27 status unpacked libgl1-mesa-glx 7.4-0ubuntu1

Bingo.

On my i965 system, after reproducing the freezes yesterday, I downgraded to mesa 7.3 (and nothing else), left it running overnight, and have seen no freezes since.

To confirm, please downgrade these packages; you may still have them in your /var/cache/apt/archives/, else you can get them off packages.ubuntu.com.

If my theory is correct, you'll have no further freezes after installing these packages.

Changed in xserver-xorg-video-intel (Ubuntu):
assignee: nobody → Bryce Harrington (bryceharrington)
importance: Undecided → Critical
milestone: none → ubuntu-9.04
status: New → Triaged
Bryce Harrington (bryce) on 2009-04-12
summary: - [i965] X freezes with or without desktop effects
+ [i965] X freezes starting on April 3rd
Andres Mujica (andres.mujica) wrote :

For those without the packages at /var/cache/apt/archives

https://edge.launchpad.net/ubuntu/jaunty/i386/mesa-utils/7.3-1ubuntu4
https://edge.launchpad.net/ubuntu/jaunty/i386/libgl1-mesa-dri/7.3-1ubuntu4
https://edge.launchpad.net/ubuntu/jaunty/i386/libgl1-mesa-glx/7.3-1ubuntu4
https://edge.launchpad.net/ubuntu/jaunty/i386/libglu1-mesa/7.3-1ubuntu4

download, install with sudo dpkg -i filename and restart your session. Don't apply new updates until it's confirmed or discard that the problem is with mesa.

thanks

Andres Mujica (andres.mujica) wrote :

i've downgraded, waiting for the freeze to happen (about 24 hours ago i had 2 freezes, just a few hours i had another one, so at least tomorrow night will report back)

however check this comment

https://bugs.edge.launchpad.net/ubuntu/+bug/358033/comments/15

unless is not related... :(

wirechief (wirechief) wrote :

I need the packages listed by Andres Mujica however i need the amd64 versions, can they be gotten ? I tried to find
them at the link listed without success.

wirechief (wirechief) wrote :

I hope that those who find they need to reboot because of the freeze have at least tried RSEIUB , if used correctly
it can prevent filesystem damage here is a link to how its used.. http://techpatterns.com/forums/about911.html
I have noticed that `intel_reg_dumper`, which is available as part of the xserver-xorg-video-intel-dbg package
reveals the register that is being changed when the freeze occurs, running it before and after the crash and using
sudo intel_reg_dumper > reg_good.txt before the crash and sudo intel_reg_dumper > reg_bad.txt after the crash
from a ssh session to the sick machine and then doing sudo diff reg_good.txt reg_reg_bad.txt will show the register
that is changing .
 diff reg_good.txt reg_bad.txt
140c140
< (II): MI_MODE: 0x00000200
---
> (II): MI_MODE: 0x00000000
and then
wirechief@wirechief-laptop:~$ cat reg_bad.txt |grep MI_MODE
(II): MI_MODE: 0x00000000
wirechief@wirechief-laptop:~$ cat reg_good.txt |grep MI_MODE
(II): MI_MODE: 0x00000200
I am reading in other bug reports this is the common indication that the freeze issue has occurred.

Andres Mujica (andres.mujica) wrote :

change i386 for amd64 in the path.

wirechief (wirechief) wrote :

Sun Apr 12 12:28pm
my mesa downgraded .
sudo dpkg -l |grep mesa
ii libgl1-mesa-dri 7.3-1ubuntu4 A free implementation of the OpenGL API -- D
ii libgl1-mesa-glx 7.3-1ubuntu4 A free implementation of the OpenGL API -- G
ii libglu1-mesa 7.3-1ubuntu4 The OpenGL utility library (GLU)
ii mesa-utils 7.3-1ubuntu4 Miscellaneous Mesa GL utilities

I will have to research how to put these on hold so they are not updated on my next du
i got this when i tried.
sudo echo mesa-utils hold |dpkg --set-selections
dpkg: operation requires read/write access to dpkg status area

Bryce Harrington (bryce) on 2009-04-12
description: updated
description: updated
Andres Mujica (andres.mujica) wrote :

wirechief you've missed a sudo before dpkg

crashsystems (crashsystems) wrote :

As Bryce Harrington suggested, I downgraded my mesa packages to the previous version. I did this almost 24 hours ago, and 15 minutes ago I had another freeze. So I think ether the bug was introduced in an earlier version, or is in another package entirely.

Steve Langasek (vorlon) wrote :

crashsystems,

to confirm: you restarted X after downgrading the mesa packages?

Yes, X was restarted. Since I took my laptop several places, it got rebooted
several times.

VangelistX (vangelistx) wrote :

Maybe newly released Mesa 7.5 will solve the problem?

http://www.phoronix.com/scan.php?page=news_item&px=NzE4OQ

What about including Mesa 7.5 in Jaunty?

Jithin Emmanuel (jithin1987) wrote :

After I downgraded to mesa 7.3 I am not facing any freezes so far. But the thing is, I am on vacation and is not under thesame conditions I got the bug, ie I am not using my laptop frequently and nor running applications I used to run and I am not using wifi. Anyway I will report back if I notice any freezes, I have been using with out any dektop effects, now I will enable them and use.

Jithin Emmanuel (jithin1987) wrote :

OK. I got my freeze after I enabled desktop effects with mesa 7.3. It seems like I asked for it the moment I switched desktop effects ON in my kubuntu. :( So mesa 7.3 is not the solution it seems.

It's definitely related to desktop effects, I am totally lockup-free without them, but will reliably freeze the instant I turn them on (alt-shift-f12).

However, I am also plagued by bug 342923 which makes performance pretty awful and with screen corruption. I wonder if these two bugs are related somehow.

I was running KDE4.2 from the PPA packages on intrepid before jaunty, and there were no problems at all. The intel Xorg driver has my finger pointing at it.

Jithin Emmanuel (jithin1987) wrote :

Same story here. I wish I was using intrepid with kde from PPA.

wirechief (wirechief) wrote :

Yes i have rebooted a number of times now and a no lockup as of yet.
I made a seperate bug on the pinning.. 359392

On Sun, Apr 12, 2009 at 9:55 PM, Andres Mujica
<email address hidden> wrote:
> wirechief you've missed a sudo before dpkg
>
> --
> [i965] X freezes starting on April 3rd
> https://bugs.launchpad.net/bugs/359392
> You received this bug notification because you are a direct subscriber
> of the bug.
>

--
Reach out and share life, care for others,

wirechief (wirechief) wrote :

I am not using Desktop effects. I disabled compiz. perhaps after
another 24hr i will give
them a try although for me I wasn't using them unless they are enabled
by default.
I did notice a drop in my screen performance but not significantly.

On Mon, Apr 13, 2009 at 8:35 AM, Jithin Emmanuel <email address hidden> wrote:
> Same story here. I wish I was using intrepid with kde from PPA.
>
> --
> [i965] X freezes starting on April 3rd
> https://bugs.launchpad.net/bugs/359392
> You received this bug notification because you are a direct subscriber
> of the bug.
>

--
Reach out and share life, care for others,

Is bug 359231 related to this bug, even if I have a different GPU (nvidia in my case)?

https://bugs.launchpad.net/bugs/359231

It's worth mentioning that I made the change mentioned in bug 342923:

        Option "AccelMethod" "EXA"
        Option "MigrationHeuristic" "greedy"

And I no longer get any freezes, even with effects turned on, and the desktop is a lot quicker now.

(I have a GMA965)

Matt Zimmerman (mdz) wrote :

Bug 358574 may be a duplicate of this one, please evaluate.

wirechief (wirechief) wrote :
Jithin Emmanuel (jithin1987) wrote :

Today I am back to work and the moment I started my laptop in my office. I had 2 freezes in a row on login and after that it went away, one with desktop effects and one with out desktop effects. I guess mesa 7.3 has nothing to do with the freezes. Shall I updates back to mesa 7.4

The 3rd time before I logged in I ssh'ed to my box and has Xorg.0.log tail'ed

Jithin Emmanuel (jithin1987) wrote :

Ok It froze again gor the 3rd time but this time it closed the ssh connection I had and I was not able to connect again until I restarted.

Can any one confirm on
        Option "AccelMethod" "EXA"
        Option "MigrationHeuristic" "greedy"
change?

Christophe Olinger (olingerc) wrote :

Hey guys,

Just wanted to say that I'm experiencing the same problem on my hp2510p tablet PC which also got an intel graphics card. Am using kubuntu jaunty fully updated with kde 4.2.2 and the freezes started around the date mentioned here although I can't remember the exact date. The only applications I had freezes in were dolphin and firefox but those are the only ones I used. Desktop effects are enabled. I'll be on holiday for some days now so I can unfortunately not participate :-(

Good luck guys.

Alex57185 (alexandre-demasi) wrote :

I had the same problem on my Dell XPS M1330 with the intel cart. I updated this packages :

ibglu1-mesa
libgl1-mesa
libgl1-mesa-glx
mesa-utils

I use the debian packages in Sid (version 7.4-2 ) , and I updated the intel driver in the Sid repository.

I don't have any freeze after that (and I use the Desktop effect)

Zack Evans (zevans23) wrote :

@Jithin Emmanuel: I have multiple freeze bugs I think, including the one that appeared after the update to kernel 11.41. I have other freeze bugs that go back some time and therefore aren't related to recent updates.

Anyway - I can confirm that
        Option "AccelMethod" "EXA"
        Option "MigrationHeuristic" "greedy"
is rock-stable for me, so I'm now running that in day and experimenting with tracking my bugs down in the evening.

Note that my lockups are not specific to UXA, and happen with EXA if I omit the MigrationHeuristic option.

Mobile 945GME Express.

Jithin Emmanuel (jithin1987) wrote :

I upgraded back to mesa 7.4 and also added
        Option "AccelMethod" "EXA"
        Option "MigrationHeuristic" "greedy"
So far I am not having any freezes, but now my opera has a blank icon in system tray. Which will be taken over by the icon in its left if some new system tray icon is going to come on its right.
Have you faced this problem Zack Evans.

Jithin Emmanuel (jithin1987) wrote :

On more diggint it seems that
        Optio.n "AccelMethod" "EXA"
        Option "MigrationHeuristic" "greedy"
affects system tray icon on non kde applications in kubuntu. Do not know how its affects gnomes system tray.
Can any one using this option on a gnome desktop comment on this?

Martin Pitt (pitti) on 2009-04-17
Changed in xserver-xorg-video-intel (Ubuntu Jaunty):
milestone: ubuntu-9.04 → jaunty-updates
Bryce Harrington (bryce) on 2009-04-21
description: updated
Bryce Harrington (bryce) on 2009-04-25
Changed in xserver-xorg-video-intel (Ubuntu Karmic):
milestone: jaunty-updates → karmic-alpha-1
Changed in xserver-xorg-video-intel:
status: Unknown → Confirmed
Bryce Harrington (bryce) on 2009-04-28
description: updated
Steve Beattie (sbeattie) on 2009-04-28
tags: added: jaunty regression-release
removed: regression-potential
Bryce Harrington (bryce) on 2009-04-29
description: updated
Changed in xserver-xorg-video-intel (Ubuntu Karmic):
status: Triaged → Fix Released
Bryce Harrington (bryce) on 2009-04-30
description: updated
Martin Pitt (pitti) on 2009-04-30
Changed in compiz (Ubuntu Jaunty):
assignee: nobody → Martin Pitt (pitti)
status: New → In Progress
Changed in compiz (Ubuntu Karmic):
assignee: nobody → Martin Pitt (pitti)
status: New → In Progress
Steve Langasek (vorlon) on 2009-05-01
Changed in xserver-xorg-video-intel (Ubuntu Jaunty):
status: Triaged → Fix Committed
tags: added: verification-needed
Steve Langasek (vorlon) on 2009-05-01
Changed in compiz (Ubuntu Jaunty):
status: In Progress → Fix Committed
Steve Beattie (sbeattie) on 2009-05-01
tags: added: hw-specific
Martin Pitt (pitti) on 2009-05-11
Changed in compiz (Ubuntu Karmic):
assignee: Martin Pitt (pitti) → Michael Vogt (mvo)
Bryce Harrington (bryce) on 2009-05-13
Changed in xserver-xorg-video-intel (Ubuntu Karmic):
assignee: Bryce Harrington (bryceharrington) → nobody
Changed in xserver-xorg-video-intel (Ubuntu Jaunty):
assignee: Bryce Harrington (bryceharrington) → nobody
reini (rrumberger) on 2009-05-26
Changed in xserver-xorg-video-intel (Ubuntu Jaunty):
status: Fix Committed → Confirmed
Martin Pitt (pitti) on 2009-06-07
Changed in xserver-xorg-video-intel (Ubuntu Jaunty):
status: Confirmed → Fix Committed
561 comments hidden view all 641 comments

On Thu, 2009-06-11 at 07:05 +0000, Jithin Emmanuel wrote:
> On Thursday 11 Jun 2009 4:43:06 am zwaldowski wrote:
> > Well, hot damn! Let me get that installed right now...
> >
> > Jithin, before you do anything drastic, I just found out the hard way
> > that Fedora IS NOT FIXED. And they don't even have Magic SysRq's
> > enabled! Good thing I wasn't in the middle of installing it...
> kernel 2.6.30 + packages from xorg-edgers is working for me. So far no freeze
> and everything is pretty stable. Suspend and hibernation is also working,
> though desktop effects are getting disabled after that.

Not here, almost always hang on resume from suspend and still random
(but rare) lockups with mouse still active.

Jithin Emmanuel (jithin1987) wrote :

I think the situation is improving and hope that by the time intel 2.8
driver is released everything is fixed. Except for these minor issues
I am almost happy with the current situation.

On Sun, Jun 14, 2009 at 5:38 PM, Soeren Sonnenburg<email address hidden> wrote:
> On Thu, 2009-06-11 at 07:05 +0000, Jithin Emmanuel wrote:
>> On Thursday 11 Jun 2009 4:43:06 am zwaldowski wrote:
>> > Well, hot damn!  Let me get that installed right now...
>> >
>> > Jithin, before you do anything drastic, I just found out the hard way
>> > that Fedora IS NOT FIXED.  And they don't even have Magic SysRq's
>> > enabled!  Good thing I wasn't in the middle of installing it...
>> kernel 2.6.30 + packages from xorg-edgers is working for me. So far no freeze
>> and everything is pretty stable. Suspend and hibernation is also working,
>> though desktop effects are getting disabled after that.
>
> Not here, almost always hang on resume from suspend and still random
> (but rare) lockups with mouse still active.
>
> --
> [i965] X freezes starting on April 3rd
> https://bugs.launchpad.net/bugs/359392
> You received this bug notification because you are a direct subscriber
> of the bug.
>

--
Thanks
Jithin Emmanuel

W. C. Fields - "If I had to live my life over, I'd live over a
saloon." - http://www.brainyquote.com/quotes/authors/w/w_c_fields.html

If you're no longer experiencing freezes, and you're using xorg-edgers stuff, please let us know /specifically/ which version of xserver-xorg-video-intel you're running.

> If you're no longer experiencing freezes, and you're using xorg-edgers
> stuff, please let us know /specifically/ which version of
> xserver-xorg-
> video-intel you're running.

Not sure if I need to reply directly to this thread about this, but here
goes: I am using xserver-xorg-video-intel 2.7.99.901
+git20090611.6d062e9e-0ubuntu0sarvatt~jaunty

You may have noticed that this is not the latest version. The reason is
simple: I just pinned/locked my packages to prevent upgrading, fearing
that things would break (I did not have a single problem with this
driver and the version before, been using that for a few weeks or so
since I switched to jaunty).

Thus, since I'm not running the latest one, I somewhat doubt my
testimonial will be relevant, but here goes, in the hope it is useful. I
am using a Dellbuntu Inspiron 530n, which has this 3100 gpu:

00:02.0 VGA compatible controller: Intel Corporation 82G33/G31 Express
Integrated Graphics Controller (rev 02), Dell Device 020d

Yes, I asked specifically because there is a(nother) regression in the latest stuff from xorg-edgers, so I was going to try everything from today and downgrade working backwards[1] until I found something that worked. But I'll give 2.7.99.901
+git20090611.6d062e9e-0ubuntu0sarvatt~jaunty a try first.

[1] http://ubuntuforums.org/showthread.php?p=7457024#post7457024

Lanoxx (lanoxx) wrote :

I have been running with a kernel from the kernel-ppa 2.6.30
http://kernel.ubuntu.com/~kernel-ppa/mainline/v2.6.30/
and the intel driver 2.7.1 from X updates
https://launchpad.net/~ubuntu-x-swat/+archive/x-updates
and compiz reenabled for three days now without a freeze.
I am on amd64.

Best Regards
Lanoxx

Jithin Emmanuel (jithin1987) wrote :

On Monday 15 Jun 2009 2:17:54 am Mike.lifeguard wrote:
> If you're no longer experiencing freezes, and you're using xorg-edgers
> stuff, please let us know /specifically/ which version of xserver-xorg-
> video-intel you're running.
I am using
xserver-xorg-video-intel
2:2.7.99.901+git20090611.6d062e9e-0ubuntu0sarvatt~jaunty

libdrm2 - 2.4.11+git20090519.f355ad89-0ubuntu0sarvatt~jaunty

xserver-xorg-core
2:1.6.1.901+git20090523+server-1.6-branch.5cd5a012-0ubuntu0sarvatt2

and kernel 2..6.30
--
Thanks
Jithin Emmanuel

Oded Arbel (oded-geek) wrote :
Download full text (3.4 KiB)

I have a regression in Karmic: after living with the "green" drivers for a couple of week and everything was fine, I upgraded to Karmic on Thursday and ever since I had multiple freezes. I don't know if this is related to this bug, but I'll assume that it is unless someone tell me otherwise:

I got only one freeze while working, and it looks exactly the same as this problem: the screen freezes but the mouse still responds and I can ssh into the machine. But most of the freezes where while the laptop was on power with the lid closed, which means the screen is actually off and when I open it several hours later nothing responds - the computer is still on but the screen is disabled and nothing I do brings it back. I haven't yet tried to ssh into the laptop when its like that as usually I need to do something right away and I have to power cycle it.

Anyway, going through syslog I found this which might be related:
Jun 20 15:17:57 sepiroth kernel: [ 9960.560081] INFO: task events/1:10 blocked for more than 120 seconds.
Jun 20 15:17:57 sepiroth kernel: [ 9960.560088] "echo 0 > /proc/sys/kernel/hung_task_timeout_secs" disables this message.
Jun 20 15:17:57 sepiroth kernel: [ 9960.560095] events/1 D 0000000100213a35 0 10 2
Jun 20 15:17:57 sepiroth kernel: [ 9960.560108] ffff88007d3c9db0 0000000000000046 0000000000000000 0000000000013000
Jun 20 15:17:57 sepiroth kernel: [ 9960.560119] ffff88007d3c03a8 0000000000013000 0000000000013000 0000000000013000
Jun 20 15:17:57 sepiroth kernel: [ 9960.560128] 0000000000013000 0000000000013000 ffff88007d3c03a8 0000000000013000
Jun 20 15:17:57 sepiroth kernel: [ 9960.560138] Call Trace:
Jun 20 15:17:57 sepiroth kernel: [ 9960.560157] [<ffffffff806d9467>] __mutex_lock_slowpath+0xd7/0x160
Jun 20 15:17:57 sepiroth kernel: [ 9960.560170] [<ffffffff802436b1>] ? finish_task_switch+0x51/0x110
Jun 20 15:17:57 sepiroth kernel: [ 9960.560179] [<ffffffff806d9186>] mutex_lock+0x26/0x50
Jun 20 15:17:57 sepiroth kernel: [ 9960.560215] [<ffffffffa0132ec8>] i915_gem_retire_work_handler+0x38/0x90 [i915]
Jun 20 15:17:57 sepiroth kernel: [ 9960.560238] [<ffffffffa0132e90>] ? i915_gem_retire_work_handler+0x0/0x90 [i915]
Jun 20 15:17:57 sepiroth kernel: [ 9960.560248] [<ffffffff802643d5>] run_workqueue+0x95/0x170
Jun 20 15:17:57 sepiroth kernel: [ 9960.560256] [<ffffffff80264554>] worker_thread+0xa4/0x120
Jun 20 15:17:57 sepiroth kernel: [ 9960.560266] [<ffffffff80268e90>] ? autoremove_wake_function+0x0/0x40
Jun 20 15:17:57 sepiroth kernel: [ 9960.560274] [<ffffffff802644b0>] ? worker_thread+0x0/0x120
Jun 20 15:17:57 sepiroth kernel: [ 9960.560282] [<ffffffff80268a35>] kthread+0x55/0xa0
Jun 20 15:17:57 sepiroth kernel: [ 9960.560290] [<ffffffff802130ca>] child_rip+0xa/0x20
Jun 20 15:17:57 sepiroth kernel: [ 9960.560299] [<ffffffff802689e0>] ? kthread+0x0/0xa0
Jun 20 15:17:57 sepiroth kernel: [ 9960.560306] [<ffffffff802130c0>] ? child_rip+0x0/0x20

There are several copies of these over a period of about 20 minutes, each almost exactly 2 minutes after another (as can probably be deduced from the error message) before it falls silent again - I can't tell for sure whether its related to the freeze, exce...

Read more...

Jorge G (geojorg) wrote :

I can confirm the same issue of Obed Arbel, when I close the lid i get the freezes, I don't get the freeze by doing hard work on the laptop or using compiz, I am using the lastest intel driver available. I will try to ssh to the machine next time to get some information.

Jithin Emmanuel (jithin1987) wrote :

I have the same issue when X freezes on laptop lid close. Problem is X is in
a infinite loop. I raised a bug upstream

https://bugs.freedesktop.org/show_bug.cgi?id=22383

On Sun, Jun 21, 2009 at 12:09 AM, Jorge G <email address hidden> wrote:

> I can confirm the same issue of Obed Arbel, when I close the lid i get
> the freezes, I don't get the freeze by doing hard work on the laptop or
> using compiz, I am using the lastest intel driver available. I will try
> to ssh to the machine next time to get some information.
>
> --
> [i965] X freezes starting on April 3rd
> https://bugs.launchpad.net/bugs/359392
> You received this bug notification because you are a direct subscriber
> of the bug.
>

--
Thanks
Jithin Emmanuel

Fran Lebowitz<http://www.brainyquote.com/quotes/authors/f/fran_lebowitz.html>
- "Life is something to do when you can't get to sleep."

Oded Arbel (oded-geek) wrote :

I got the same freeze again (with laptop screen closed) but without the syslog messages, so its probably not related.

My problem is not an immediate lockup like it seems that Jithin Emmanuel reported (though I haven't looked at the Xorg log yet) - if I just close the lid and leave it for a few minutes and open it again then its usually still ok. For me the freeze happens when I have the screen closed for a long time - several hours.

Jithin Emmanuel (jithin1987) wrote :

Oded For me the lock up in instantaneously. So we might be having different
issues. I am using packages from xorg-edgers PPA.
And for me also there is no messages in syslog its only in Xorg log

On Sun, Jun 21, 2009 at 12:24 PM, Oded Arbel <email address hidden> wrote:

> I got the same freeze again (with laptop screen closed) but without the
> syslog messages, so its probably not related.
>
> My problem is not an immediate lockup like it seems that Jithin Emmanuel
> reported (though I haven't looked at the Xorg log yet) - if I just close
> the lid and leave it for a few minutes and open it again then its
> usually still ok. For me the freeze happens when I have the screen
> closed for a long time - several hours.
>
> --
> [i965] X freezes starting on April 3rd
> https://bugs.launchpad.net/bugs/359392
> You received this bug notification because you are a direct subscriber
> of the bug.
>

--
Thanks
Jithin Emmanuel

Henny Youngman<http://www.brainyquote.com/quotes/authors/h/henny_youngman.html>
- "I told the doctor I broke my leg in two places. He told me to quit
going
to those places."

Lanoxx (lanoxx) wrote :

I just wanted to give an update about my configuration sofar:

Uptime:
 18:58:44 up 8 days, 17:09, 5 users, load average: 0.45, 0.59, 0.71

With Kernel 2.6.30 from the kernel-ppa/mainline and intel driver 2.7.1
from x-update I have been running stable and without any issues. I have
reactived normal compiz compositing by removing compiz from the
blacklisting and activating it in the apperance menu. Also
suspend/resume works well, even a little quicker than before and with
less errors on resume.

Regards
Lanoxx

Botond Szász (boteeka) wrote :

I also experience this problem not only when the lid is closed but after the screen goes blank when my laptop is idle for about half an hour. It also happened once when the screensaver was active and moved the mouse to bring the screen alive, and it stopped responding, the screen went black and I had to powercycle to get control again.

I'm using the 2.6.30 kernel from kernel-ppa/mainline and intel driver 2.7.99.901 on Jaunty.

My freezes also occur when the laptop is idle for a long time, though I don't close the lid or suspend the computer: Screensaver -> screen off (but never suspend/hibernate)...

So it certainly looks to me as though these freezes are different.

Bernhard (b.a.koenig) wrote :

For people having a freeze after recovery from screensaver, please refer to bug 328760.

Martin Pitt (pitti) wrote :

Is there anyone who could give some feedback about a Jaunty standard
configuration/kernel with the jaunty-proposed -intel driver? We need
to get some verification to get this into jaunty-updates.

I would kindly ask people to stop reporting problems with 2.6.30/UXA
here. The bug trail is long enough as it is, and problems with
2.6.30/UXA belong in separate bug reports. Thank you!

reini (rrumberger) wrote :

Am Montag 22 Juni 2009 schrieb Martin Pitt:
> Is there anyone who could give some feedback about a Jaunty
> standard configuration/kernel with the jaunty-proposed -intel
> driver?

Sure can. No freezes since I installed it, and I installed it as soon
as it hit the proposed repos +- a couple of hours.

Mario (diraimondo) wrote :

reini wrote:
> Am Montag 22 Juni 2009 schrieb Martin Pitt:
>> Is there anyone who could give some feedback about a Jaunty
>> standard configuration/kernel with the jaunty-proposed -intel
>> driver?
>
> Sure can. No freezes since I installed it, and I installed it as soon
> as it hit the proposed repos +- a couple of hours.

With driver in ubuntu-proposed I have had no more freeze (the kind with
the only the mouse pointer working) but I had other kind of freeze. I've
upgraded the kernel to 2.6.30 and I don't have freezes since one week.

My solution: kernel 2.6.30 + intel drivers in jaunty-proposed.

Mario

Martin Pitt (pitti) on 2009-06-22
tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xserver-xorg-video-intel - 2:2.6.3-0ubuntu9.3

---------------
xserver-xorg-video-intel (2:2.6.3-0ubuntu9.3) jaunty-proposed; urgency=low

  * Add patch 121_reserve-unused-memory-at-end-of-aperture.patch. This
    reserves a block of unused memory between the exa offscreen buffer and
    end of aperture, to prevent freeze with EXA on GM965 cards
    (LP: #359392).

 -- Bryce Harrington <email address hidden> Sun, 07 Jun 2009 11:34:02 -0700

Changed in xserver-xorg-video-intel (Ubuntu Jaunty):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package compiz - 1:0.8.2-0ubuntu8.1

---------------
compiz (1:0.8.2-0ubuntu8.1) jaunty-proposed; urgency=low

  * debian/patches/028_compiz_manager_blacklist: Revert change from
    1:0.8.2-0ubuntu8 to un-blacklist GM965 (8086:2a02) again. We now have a
    better workaround in the -intel driver. (LP: #359392)

 -- Martin Pitt <email address hidden> Thu, 30 Apr 2009 08:14:27 +0200

Changed in compiz (Ubuntu Jaunty):
status: Fix Committed → Fix Released
Martin Pitt (pitti) wrote :

965 is not blacklisted in karmic's compiz any more:

compiz (1:0.8.2-0ubuntu12) karmic; urgency=low
 [...]
  [ Michael Vogt ]
  * debian/patches/028_compiz_manager_blacklist:
    - remove GM965 from the blacklist again, the karmic intel
      driver should work fine with it
  [...]

Changed in compiz (Ubuntu Karmic):
status: In Progress → Fix Released
Martin Pitt (pitti) wrote :

karmic's compiz does not blacklist 965 any more either.

Thomas Foss (tafoxx) wrote :
Download full text (7.0 KiB)

What about Jaunty's Compiz?

On Mon, Jun 22, 2009 at 12:21 PM, Martin Pitt <email address hidden>wrote:

> karmic's compiz does not blacklist 965 any more either.
>
> --
> [i965] X freezes starting on April 3rd
> https://bugs.launchpad.net/bugs/359392
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in X.org xf86-video-intel: Confirmed
> Status in “compiz” source package in Ubuntu: Fix Released
> Status in “xserver-xorg-video-intel” source package in Ubuntu: Fix Released
> Status in compiz in Ubuntu Jaunty: Fix Released
> Status in xserver-xorg-video-intel in Ubuntu Jaunty: Fix Released
> Status in compiz in Ubuntu Karmic: Fix Released
> Status in xserver-xorg-video-intel in Ubuntu Karmic: Fix Released
>
> Bug description:
> [Problem]
> Starting around 4/3, when mesa was upgraded from 7.3 to 7.4, several i965
> users started noticing X freeze after several hours of use, triggered by
> application usage especially noticeable with (but not unique to) compiz
> enabled.
>
> [Impact]
> The freeze bug affects a subset of i965 based systems, most particularly
> those using compiz. Exact numbers cannot be determined, but may be as high
> as 25-50% based on rough estimates.
>
> The problem is severe: An unpredictable lockup of the system that requires
> a power cycle to recover from. For some users it comes on within minutes,
> while for others it comes after a few hours of use.
>
> [How Addressed in Development Version]
> For now, the patch being proposed for Jaunty has been uploaded to Karmic.
>
> Longer term, we plan to move from EXA to UXA once the latter is stable
> enough. It has been found that while UXA exhibits other kinds of freezes,
> we've not yet been able to reproduce this particular freeze there.
>
> [Patch for Jaunty]
> A low-risk workaround that has proven effective at eliminating freezes, or
> at least greatly reducing their frequency, is to increase the Virtual
> framebuffer size. Some users do this locally as a matter of course to gain
> dual-head support, so this setting has received extremely widespread testing
> already.
>
> The patch for Jaunty causes the Virtual size to be set to 2048x2048 if it
> is not otherwise specified. Users can still override this with their own
> settings, larger or smaller, as desired.
>
> A side effect of this patch is that it also mitigates bug 158415 to a
> degree, which will make projector usage somewhat easier for this hardware
> because it will enable X to recognize higher resolutions available from the
> external monitor than were available on initial boot.
>
> [Test Case]
> The best method found to reproduce the bug is:
> a. Enable compiz
> b. Set your desktop to a 6x1 workspace layout
> c. Run http://launchpadlibrarian.net/25683477/repro.sh
> d. System will freeze anywhere from 1-20 min typically
> e. Power-button shutdown is required to reset the system
>
> [Regression Potential]
> In general, Virtual has been widely and extensively tested, so we do not
> expect this patch to trigger regressions.
>
> The patch is coded to only take effect on i965 systems, so the scope of any
> regression that might conceivably be triggered wi...

Read more...

reini (rrumberger) wrote :

a) seems to be fixed, too
b) please snip - your posts are seriously hard to read with >>20
   lines

Am Montag 22 Juni 2009 schrieb Thomas Foss:
> What about Jaunty's Compiz?

Am Montag 22 Juni 2009 schrieb Launchpad Bug Tracker:
> This bug was fixed in the package compiz - 1:0.8.2-0ubuntu8.1
>
> ---------------
> compiz (1:0.8.2-0ubuntu8.1) jaunty-proposed; urgency=low
>
> * debian/patches/028_compiz_manager_blacklist: Revert change
> from 1:0.8.2-0ubuntu8 to un-blacklist GM965 (8086:2a02) again. We
> now have a better workaround in the -intel driver. (LP: #359392)
>
> -- Martin Pitt <email address hidden> Thu, 30 Apr 2009
> 08:14:27 +0200

Oded Arbel (oded-geek) wrote :

I opened bug #390633 for intel freeze in Karmic when doing "blank screen".

Thanks for all the help, I think this issue is resolved for Jaunty and I hope it doesn't come back for Karmic.

nwadams (nwnadams) wrote :

i'm using kernel 2.6.28-13-generic (so jaunty stock including updates (recommended, important))
I am also using the xserver-xorg-video-intel from the jaunty proposed repo.

I've been fine over the last 24 hours under normal usage with compiz enabled and using mostly internet, videos, some wine. No freezes, lockups, crashes, nothing.

I'm 100% sure this is unrelated but sometimes when i resume from suspend it crashes x and i have to re-log in.

Is there anything i can run with my kernel that normally causes the freezes that i can do to confirm it being fixed?

> What about Jaunty's Compiz?

It's not blacklisted anymore either. I've been running a stock Jaunty
system (with nothing from proposed) and I finally got my compiz back when I
installed a bunch of updates this morning.

Changed in xserver-xorg-video-intel:
status: Confirmed → Fix Released
jippie (jph4dotcom) wrote :

Probably still early, I know, but after 34hrs I am still in a stable kde
desktop with a load of effects enabled :o) Before it took maybe 15 to 30
minutes to hang.
I only installed the released fixes, deleted the my manually edited
xorg.conf and rebooted ... No tests with prereleased kernels, test
patches other drivers ...

Hope this helps. Thanks guys!!

JP

Bug Watch Updater wrote:
> ** Changed in: xserver-xorg-video-intel
> Status: Confirmed => Fix Released
>
>

filsd (filsdd) wrote :

Hi,
First thanks for all the effort to hunt this bug. =)

Not sure if this is related to this bug, but someone using Jaunty with these updates could test the program Blender 3d (Version 2.49a) and see if these artifacts still occurs?:

http://www.trollwerks.org/BrokenBlender.png
http://i42.tinypic.com/bgww8x.jpg

They occur in the Jaunty live cd without these updates.

You can download the blender on its official site. =)

Okay, where do I go next with this bug (not here on Launchpad; this issue)? Despite it being marked "Fix Released" in both Jaunty and Karmic, I still get the freeze with stock and Xorg-Edgers drivers (on Jaunty) and on today's Daily Live CD.

Martin Pitt (pitti) wrote :

zwaldowski [2009-07-15 0:43 -0000]:
> Okay, where do I go next with this bug (not here on Launchpad; this
> issue)? Despite it being marked "Fix Released" in both Jaunty and
> Karmic, I still get the freeze with stock and Xorg-Edgers drivers (on
> Jaunty) and on today's Daily Live CD.

If you get it with xorg-edgers and karmic daily CDs, it's a different
issue. Can you please do the steps on
https://wiki.ubuntu.com/X/Troubleshooting/Freeze and report a new bug?

Piscium (piscium) wrote :

This bug is marked as fixed, however with Ubuntu Karmic Alpha 5, the 3 times I logged in, the screen froze, the first and second times about 2 minutes after login, and the third time about ten minutes after login. When this happens I have to power off the PC.

I was doing different things when the screen froze, so I do not think it was the particular action that caused the freeze. I don't know if the freeze is related to this bug. As someone wrote in the bug description, there could be different bugs that manifest in the same way (freezing).

Here is my lspci output:
00:02.0 VGA compatible controller: Intel Corporation 82865G Integrated Graphics Controller (rev 02)

With respect to Ubuntu 9.04 that I currently use, things are far from perfect. Watching video streaming is difficult as the image freezes often, scrolling on Firefox is slow, and most annoying of all is that once or twice a day the gnome-panel takes up 50% of CPU time, so the panel freezes. I can often unfreeze it by killing the gnome-panel process. Note however that the gnome panel freezing is less serious than the screen freezing that I experience with Karmic Alpha 5.

António

EddieArt (arteleb1) wrote :

This bug has been around for a very long time now--it seems over a year and a half (not just from April because I have seen related posts dating to 2008). Why is it so hard to remedy? Is it even known if this is something wrong with the latests Ubuntu releases, latest kernels, drivers, or just s.th. wrong with the intel graphics card itself?

Geir Ove Myhr (gomyhr) wrote :

> This bug has been around for a very long time now--it seems over a year
> and a half (not just from April because I have seen related posts dating
> to 2008).

There are lots of different bugs that lead to the same problem -
namely that the system freezes. This particular bug report is for the
freezes that started occuring on April 3rd on many systems. This
problem has been found (the driver was reading ahead too far into
unallocated memory) and fixed. There are other bugs that can cause
this (and new bugs may be introduced), but it is not the same bug.

> Why is it so hard to remedy?

Because each bug has a different fix. They're working on a workaround
upstream that will automatically restart the GPU when it hangs, but
since that a significant chunk of new code it takes time to implement.

If you're system is experiencing freezes, file it as new bug report
with `ubuntu-bug -p xserver-xorg-video-intel`, and also provide the
information described at
https://wiki.ubuntu.com/X/Troubleshooting/Freeze (Batchbuffer stuff,
etc.)

EddieArt (arteleb1) wrote :
Download full text (8.4 KiB)

Hi Geir,

Thanks a lot for your response, even if it doesn't fix the problem.
I really appreciate your trying to help although I have a different
distribution. This goes to show how great a community you all have at
Ubuntu--which is more to than I can say right now about Mint.

By the way, do these various intel graphics cards problems effect all
Debian-based distributions or does it start only at Ubuntu?

Keep up the good work.
Peace,

Eddie

<email address hidden>

On Wed, Oct 7, 2009 at 5:08 AM, Geir Ove Myhr <email address hidden> wrote:

> > This bug has been around for a very long time now--it seems over a year
> > and a half (not just from April because I have seen related posts dating
> > to 2008).
>
> There are lots of different bugs that lead to the same problem -
> namely that the system freezes. This particular bug report is for the
> freezes that started occuring on April 3rd on many systems. This
> problem has been found (the driver was reading ahead too far into
> unallocated memory) and fixed. There are other bugs that can cause
> this (and new bugs may be introduced), but it is not the same bug.
>
> > Why is it so hard to remedy?
>
> Because each bug has a different fix. They're working on a workaround
> upstream that will automatically restart the GPU when it hangs, but
> since that a significant chunk of new code it takes time to implement.
>
> If you're system is experiencing freezes, file it as new bug report
> with `ubuntu-bug -p xserver-xorg-video-intel`, and also provide the
> information described at
> https://wiki.ubuntu.com/X/Troubleshooting/Freeze (Batchbuffer stuff,
> etc.)
>
> --
> [i965] X freezes starting on April 3rd
> https://bugs.launchpad.net/bugs/359392
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in X.org xf86-video-intel: Fix Released
> Status in “compiz” package in Ubuntu: Fix Released
> Status in “xserver-xorg-video-intel” package in Ubuntu: Fix Released
> Status in compiz in Ubuntu Jaunty: Fix Released
> Status in xserver-xorg-video-intel in Ubuntu Jaunty: Fix Released
> Status in compiz in Ubuntu Karmic: Fix Released
> Status in xserver-xorg-video-intel in Ubuntu Karmic: Fix Released
>
> Bug description:
> [Problem]
> Starting around 4/3, when mesa was upgraded from 7.3 to 7.4, several i965
> users started noticing X freeze after several hours of use, triggered by
> application usage especially noticeable with (but not unique to) compiz
> enabled.
>
> [Impact]
> The freeze bug affects a subset of i965 based systems, most particularly
> those using compiz. Exact numbers cannot be determined, but may be as high
> as 25-50% based on rough estimates.
>
> The problem is severe: An unpredictable lockup of the system that requires
> a power cycle to recover from. For some users it comes on within minutes,
> while for others it comes after a few hours of use.
>
> [How Addressed in Development Version]
> For now, the patch being proposed for Jaunty has been uploaded to Karmic.
>
> Longer term, we plan to move from EXA to UXA once the latter is stable
> enough. It has been found that while UXA exhibits other kinds of freezes,
> we've not yet been able to repr...

Read more...

Arlete (arletepg2009) on 2010-01-11
Changed in xserver-xorg-video-intel (Ubuntu):
assignee: nobody → Arlete (arletepg2009)
Changed in xserver-xorg-video-intel (Ubuntu Jaunty):
assignee: nobody → Arlete (arletepg2009)
Changed in xserver-xorg-video-intel (Ubuntu Karmic):
assignee: nobody → Arlete (arletepg2009)

Is launchpad supposed to send me 23 emails as it just did? Might be nice to not make people CCed on the bug annoyed like this :(

Dave Conniff (chronniff) wrote :

I just got the same thing

EddieArt (arteleb1) wrote :
Download full text (7.1 KiB)

same here
i wonder what happened

On Tue, Feb 9, 2010 at 5:07 PM, Dave Conniff <email address hidden> wrote:

> I just got the same thing
>
> --
> [i965] X freezes starting on April 3rd
> https://bugs.launchpad.net/bugs/359392
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in X.org xf86-video-intel: Fix Released
> Status in “compiz” package in Ubuntu: Fix Released
> Status in “xserver-xorg-video-intel” package in Ubuntu: Fix Released
> Status in “compiz” source package in Jaunty: Fix Released
> Status in “xserver-xorg-video-intel” source package in Jaunty: Fix Released
> Status in “compiz” source package in Karmic: Fix Released
> Status in “xserver-xorg-video-intel” source package in Karmic: Fix Released
>
> Bug description:
> [Problem]
> Starting around 4/3, when mesa was upgraded from 7.3 to 7.4, several i965
> users started noticing X freeze after several hours of use, triggered by
> application usage especially noticeable with (but not unique to) compiz
> enabled.
>
> [Impact]
> The freeze bug affects a subset of i965 based systems, most particularly
> those using compiz. Exact numbers cannot be determined, but may be as high
> as 25-50% based on rough estimates.
>
> The problem is severe: An unpredictable lockup of the system that requires
> a power cycle to recover from. For some users it comes on within minutes,
> while for others it comes after a few hours of use.
>
> [How Addressed in Development Version]
> For now, the patch being proposed for Jaunty has been uploaded to Karmic.
>
> Longer term, we plan to move from EXA to UXA once the latter is stable
> enough. It has been found that while UXA exhibits other kinds of freezes,
> we've not yet been able to reproduce this particular freeze there.
>
> [Patch for Jaunty]
> A low-risk workaround that has proven effective at eliminating freezes, or
> at least greatly reducing their frequency, is to increase the Virtual
> framebuffer size. Some users do this locally as a matter of course to gain
> dual-head support, so this setting has received extremely widespread testing
> already.
>
> The patch for Jaunty causes the Virtual size to be set to 2048x2048 if it
> is not otherwise specified. Users can still override this with their own
> settings, larger or smaller, as desired.
>
> A side effect of this patch is that it also mitigates bug 158415 to a
> degree, which will make projector usage somewhat easier for this hardware
> because it will enable X to recognize higher resolutions available from the
> external monitor than were available on initial boot.
>
> [Test Case]
> The best method found to reproduce the bug is:
> a. Enable compiz
> b. Set your desktop to a 6x1 workspace layout
> c. Run http://launchpadlibrarian.net/25683477/repro.sh
> d. System will freeze anywhere from 1-20 min typically
> e. Power-button shutdown is required to reset the system
>
> [Regression Potential]
> In general, Virtual has been widely and extensively tested, so we do not
> expect this patch to trigger regressions.
>
> The patch is coded to only take effect on i965 systems, so the scope of any
> regression that might conceivably be triggered...

Read more...

Steve Langasek (vorlon) wrote :

It would be nice indeed, but some users have gotten the idea that it's appropriate to run apport-collect against bugs unsolicited, and everyone cc:ed on the bug receives notifications of the new attachments. I'm afraid there's not much that can be done about this problem in the short term.

Changed in xserver-xorg-video-intel:
importance: Unknown → Critical
Changed in xserver-xorg-video-intel:
importance: Critical → Unknown
Changed in xserver-xorg-video-intel:
importance: Unknown → Critical
Displaying first 40 and last 40 comments. View all 641 comments or add a comment.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments

Remote bug watches

Bug watches keep track of this bug in other bug trackers.