Ubuntu

Kernel panic during boot in VirtualBox with kernel 2.6.26.*-generic

Reported by Jon Packard on 2008-07-06
230
Affects Status Importance Assigned to Milestone
Linux
Invalid
Undecided
Unassigned
Virtualbox
Fix Released
Unknown
Mandriva
Fix Released
Critical
linux (Ubuntu)
High
Colin King
Intrepid
High
Colin King

Bug Description

Kernel 2.6.26.* / 2.6.27.* (intrepid) panics during boot in Virtualbox.

The problem occours with VT-x/AMD-V disabled. Enabling the VT-x/AMD-V (on a host that supports this) and the problem doesn't show up.

Expected result: System boots correctly.

Actual result: System fails to boot with kernel panic errors.

Errors on screen (see attached for screen shot):
Code: Bad EIP value.
Kernel panic - not syncing: Attempted to kill the idle task!

Jon Packard (jonpackard) wrote :
Michael Lok (munhoe-lok) wrote :

I'm having the same problem as well. Hardy as host (Kubuntu, 2.6.24-19-generic) and Intrepid Alpha1 on VirtualBox 1.62. In addition to getting the "Attempted to kill the idle task!" message, I'm also getting: "Kernel panic - not syncing: Fatal exception in interrupt". Kernel panic occurs when booting with 2.6.26-3. 2.6.26-2 works once in a while.

hatchetman82 (hatchetman82) wrote :

same here.
attempting to install kubuntu 8.10 alpha 1 from *.iso image in virtualbox 1.6.2. host is windows xp sp2

Jon Packard (jonpackard) on 2008-07-08
Changed in linux:
status: New → Confirmed
hatchetman82 (hatchetman82) wrote :

here's what i think is the virtualbox bug : http://www.virtualbox.org/ticket/918
at least it matches the error i got from virtualBox

Kjell Braden (afflux) wrote :

This issue is still showing up on todays (20080709 ubuntu-alternate-i386 images (and maybe others).

Changed in linux:
importance: Undecided → High
Trip McKay (trip-mckay) wrote :

Hi,

I had this issue, too. But after trying some options in the virtual machine do the following to get a much higher successful boot rate (at least it works for me):

Go into the Settings of the VM, choose the Advanced Tab in General and check "Enable VT-X/AMD-V". I am virtualizing with Windows Vista Home Premium SP1 as Host and an AMD Athlon 64 X2 Dual Core Processor 4800+ 2.50 GHz Brisbane. After unchecking the option I will get the "bad EIP" error codes again.

Hope this helps nailing down the problem.

Trip McKay (trip-mckay) wrote :

Update: I tryed to boot up the machine today as of this bug report after disabling and reenabling the VT-X/AMD-V option. Now the VM does not find the Hard disk and is stuck at

Begin: waiting for root file system...

and drops to a BusyBox shell. It says first "ALERT! /dev/disk/by-uuid/<placeholder> does not exist. Dropping to a shell!". Fill <placeholder> with the uuid of the hd. Updates are of as yesterday, and it did work yesterday before applying updates just fine.

MikeBee (michaelbeeson) wrote :

This also happens with Intrepid Ibex Alpha 2 on mac host virtualbox 1.6.2. Tried messing about with the options, but to no avail...

Jacopo Moronato (jmoronat) wrote :

Similar problem here: VirtualBox on Windows Vista Home Premium host.

With kernel 2.6.26-2 i have "BUG: Unable to handle kernel <1>"
With kernel 2.6.26-3 i have "kernel panic - not syncing: fatal exception in interrupt"

ANDREA (andrea54) wrote :

i've experienced the very same problem. in fact virtualbox often closes with the virtual machine "booting" and leaves log files in my home folder. the most recent one contains this information (if it's of any help) :

Log created: 2008-07-14T15:46:37.801203000Z
Executable: /usr/lib/virtualbox/VirtualBox
Arg[0]: /usr/lib/virtualbox/VirtualBox
Arg[1]: -comment
Arg[2]: Development
Arg[3]: -startvm
Arg[4]: 8584ee88-3448-4011-bb9a-616db97c989f
internal REM fatal error: rc=VERR_INTERNAL_ERROR cpu_outb

!!Assertion Failed!!
Expression: <NULL>
Location : /build/buildd/virtualbox-ose-1.5.6-dfsg/src/recompiler/VBoxRecompiler.c(4679) remAbort
internal REM fatal error: rc=VERR_INTERNAL_ERROR cpu_outb

whenever the virtual machine does not get closed, this error appears:
Code 3c 62 20 00 6f 64 65 3a 20 00 3d 3d 3d 3d 3d 3d 3d 3d 3d 3d 3d 3d 3d 3d 3d 3d 0a 00 31 61 2f 30 78 32 30 0a 00 30 20 74 61 73 <6B> 3d 63 30 34 33 63 33 34 30 20 74 61 73 6b 2e 74 69 3d 63 30
EIP: {<c04ee7eb>] printk_buf.24875+0x2b/0x400 SS:ESP 0068:c046f780
Kernel panic - not syncing: Fatal exception in interrupt

host: hardy 8.04 , kubuntu, using virtualbox. if i can be of any further assistance please let me know.

ANDREA

btw: i get 0 success rate with the options previously mentioned, i have not even once been able to correctly boot using 2.6.26 ...

Kjell Braden (afflux) wrote :

The virtualbox bug is not about 2.6.26 but the 2.6.23 kernel (the few comments at the end are from hatchetman82, he seems to have missed this).

Kjell Braden (afflux) wrote :

closing the upstream task for now, as there is no upstream bug (yet).

Changed in linux:
status: New → Invalid
Chris (chris-pm) wrote :

I can confirm the above.

Trying to boot the Kubuntu Alpha2 iso (intrepid-alternate-i386.iso) gives the same EIP errors.
Trying to run the 'Check CD for defects' also results in EIP errors.

Host system is Hardy, 2.6.24-19-generic

Thomas N (konstigt) wrote :

I can also boot 2.6.26-2 but not -3. However, booting -2 there is some problem with X so it doesn't start.

VirtualBox 1.6.2 on Hardy host.

Cleber Santz (clebersantz) wrote :

If help, i believe the same problem is occurring too with Fedora 10 (Kernel 2.6.26-0)

Alessio Treglia (quadrispro) wrote :

I can confirm the bug, I tried to boot an intrepid alpha2 (alternate i386) iso with VirtualBox and I received the same result.

IceWil (icewil) wrote :

Same problem here (host : Ubuntu 8.04 64-bit).

Adam Niedling (krychek) wrote :

I don't think that any more confirmation is needed.

ANDREA (andrea54) wrote :

... in case anybody cares even with .4 it's still failing here ...

Chris (chris-pm) wrote :

Thanks Andrea. I'm keeping an eye on this as I want to try out/help with Intrepid. But unfortunately I don't have a spare partition to use so vm is my only option at the moment.

Brian Curtis (bcurtiswx) wrote :

Just adding to the long list of confirmations. Virtualbox VM Ubuntu 8.10 07-17-08 updates. I use the old kernel to get it to work (2.6.24), for the time being.

peter76 (pf-moll) wrote :

This is weird, as I don't have problems ( and never had ) at all running Intrepid in VB under Hardy; both have all the latest updates as of today. What info should I point out here to solve why it's working for me and not others?

TAC one (tacone) wrote :

In response to Peter76: today's nightly build doesn't work for me as much as the previous ones.
On a side note the error message changed to: "Bug: Unable to handle kernel"

Jon Packard (jonpackard) wrote :

peter76: Thanks very much for your input on this. I would be interested to know if you have either VT-x or AMD-V enabled (Virtual machine settings > General > Advanced). If so, try disabling it and see if you are still able to boot the latest Intrepid kernel. Also, which version of Virtualbox or Virtualbox-OSE (Open Source Edition) are you using? Thanks!

I'm also able to boot without any problem. I'm using VirtualBox 1.6.2
(not OSE), with x86 Hardy alpha 2, kernel version 2.6.26-4. I do have
"VT-x/AMD-V" enabled, and I believe I also was able to boot alpha 1
with this option as well.

I'm not home this weekend, so I won't be able to test with VT-x/AMD-V
off. If nobody else has responded by late Sunday, I can give it a
try.

On Sat, Jul 19, 2008 at 3:02 PM, Jon Packard <email address hidden> wrote:
> peter76: Thanks very much for your input on this. I would be interested
> to know if you have either VT-x or AMD-V enabled (Virtual machine
> settings > General > Advanced). If so, try disabling it and see if you
> are still able to boot the latest Intrepid kernel. Also, which version
> of Virtualbox or Virtualbox-OSE (Open Source Edition) are you using?
> Thanks!
>
> --
> Kernel panic during boot after upgrading to kernel 2.6.26.3-generic
> https://bugs.launchpad.net/bugs/246067
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in The Linux Kernel: Invalid
> Status in "linux" source package in Ubuntu: Confirmed
>
> Bug description:
> Running Intrepid Alpha1 in a Virtualbox 1.6.2 guest. Host is Hardy.
>
> linux-image-2.6.26-3-generic:
> Installed: 2.6.26-3.9
> Candidate: 2.6.26-3.9
> Version table:
> *** 2.6.26-3.9 0
> 500 http://us.archive.ubuntu.com intrepid/main Packages
> 100 /var/lib/dpkg/status
>
> Expected result: System boots correctly.
>
> Actual result: System fails to boot with kernel panic errors.
>
> Errors on screen (see attached for screen shot):
> Code: Bad EIP value.
> Kernel panic - not syncing: Attempted to kill the idle task!
>
> I can boot to linux-image-2.6.26-2-generic without any problems after the upgrade.
>

I am not able to boot. Playing with "VT-x/AMD-V" doesn't change it.

peter76 (pf-moll) wrote :

@ Jon Packard: yes, I have Vt-x enabled; and when I disable it I get a kernel panic as well, which ends the same as ANDREA's. I'm running VB 1.6.2 under Hardy. My processor is a C2D T5600. Attached is a dmesg from Intrepid. What looks weird to me is:

weird, boot CPU (#0) not listedby the BIOS.

If I can do anything else, let me know,

Peter

Bobby (lostinquestions) wrote :

This problem also exists, for me, in Alpha 3.

Saivann Carignan (oxmosys) wrote :

In my case, under VirtualBox, intrepid always boot with VT-x enabled, and it always get a kernel panic whitout VT-x enabled.

Careful : When the VT-x box have a grey check, it is still not enabled. You must make sure that VirtualBox is really configured to use VT-x.

Saivann Carignan (oxmosys) wrote :

Bug reported on VirtualBox bug tracking system :
http://www.virtualbox.org/ticket/1875

Ubuntu also crashes when VT-x is enabled.

CPU: Intel Core2Duo T7300

lylepratt (lylepratt) wrote :

At first I was experiencing the same error. Then i decided to try it with amd-v enabled. Turns out my bios didn't support it, so I flashed it with a new version, turned on amd-v and have successfully installed ubuntu 8.10 in virtual box.

Ross Peoples (deejross) wrote :

I had VT-x disabled and got [0.491424] BUG: unable to handle kernel <1> which repeats itself all the way down the screen. I turned VT-x on and was able to boot. KEEP IN MIND, that when you check the Enable VT-x/AMD-V checkbox once, that does NOT enable it!!! That just puts it into a grayed state. Clicking it a second time enables it.

TAC one (tacone) wrote :

Thank you Ross, but (really) enabling VT seems not to work for me and guess a number of people. It just changes the error message.

Steve Langasek (vorlon) on 2008-07-28
Changed in linux:
milestone: none → ubuntu-8.10
Christoph Korn (c-korn) wrote :

I forgot to enable VT-x in the BIOS.

Now intrepid boots.

Phil (philheaton) wrote :

Works fine for me.

Host system Hardy 8.04.1 amd64 with Virtualbox 1.6.2.

Host Specs:

Samsung X22 Notebook
Intel Core 2 Duo T7500 2.2Ghz
2GiB RAM

Virtualising Intrepid Alpha 3 32bit guest. Have enabled VT-x/AMD-V and PAE/NX and given the VM 1Gib RAM, 128MB Video RAM, SATA Controller, ALSA Audio Driver and USB/USB 2.0 Controller via Virtualbox.

Boots into the Live CD Environment and runs without problems. Installer works as it should, NAT connectivity works fine through Intel 4695 WiFi on host machine as does sound. Complete install of VM took approx 20 mins.

I found that after installation, the VM needed to be completely turned off not restarted as this would cause problems with X.

Once booted into the new VM, VirtualBox Guest Additions refused to install the Xorg modules (see VBAdditionsXorg screenshot).

Hope this is of some use.

Cheers, Phil.

As everyone said before, this problem is relative to the VT-x / AMD-V setting.

This setting is relative to hardware virtualization support either by your CPU and, as lylepratt wrote, your motherboard. You can find more information about Intel Virtualization Technology (Intel VT) and AMD Virtualization (AMD-V) supported CPUs on the Hardware support section of this Wikipedia x86 virtualization page (http://en.wikipedia.org/wiki/AMD-V).

Activating this option on an hardware which don't support it (CPU and/or motherboard) will not change anything and you will not be able to boot any of these three first alpha.

As found on the Ubuntu KVM Wiki page (https://help.ubuntu.com/community/KVM): To see if your processor supports one of these, you can run the following command. If nothing is printed, it means that your CPU doesn't support hardware virtualisation. Otherwise, it does - but you still need to make sure that virtualisation is enabled in the BIOS.

egrep '(vmx|svm)' /proc/cpuinfo

For information, I'm running Hardy 8.04.1 AMD64 and VirtualBox 1.6.2 on an AMD Athlon 64 X2 3800+ (no AMD-V support).

Thomas N (konstigt) wrote :

I have enabled virtualization in my BIOS (Toshiba T61) and also enabled VT-x in VirtualBox. I still cannot boot (using daily alternate 070729).

model name : Intel(R) Core(TM)2 Duo CPU T7250 @ 2.00GHz
flags : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe nx lm constant_tsc arch_perfmon pebs bts pni monitor ds_cpl vmx est tm2 ssse3 cx16 xtpr lahf_lm ida

Craig73 (funrun73) wrote :

@Alexandre Kraft - My CPU doesn't support VT-x/AMD-V and I have turned the VT-x/AMD-V option off and I still can't boot the newer kernel. How does this fit into your theory that this is indeed the problem?

Jon Packard (jonpackard) on 2008-08-07
Changed in linux:
status: Confirmed → Fix Released
Changed in linux:
status: Fix Released → Confirmed
Changed in virtualbox:
status: Unknown → New
Changed in linux:
assignee: nobody → ubuntu-kernel-team
Colin King (colin-king) on 2008-08-21
Changed in linux:
assignee: ubuntu-kernel-team → colin-king
Colin King (colin-king) on 2008-08-29
Changed in linux:
milestone: ubuntu-8.10 → intrepid-alpha-6
status: Confirmed → Fix Committed
71 comments hidden view all 151 comments
Scott Wegner (swegner) wrote :

Sun released VirtualBox 2.0 today, which is a major version update. Amongst other things, the changelog cites "VMM: VT-x fixes". Has anybody upgraded and given it a try?

Cleber Santz (clebersantz) wrote :

For me too, the error still persists

TAC one (tacone) wrote :

On Thu, Sep 4, 2008 at 8:15 PM, Cleber Santz <email address hidden> wrote:
> For me too, the error still persists

The error persists for me too.

Christoph Korn (c-korn) wrote :

This bug is milestoned for intrepid-alpha-6.

pitit.atchoum (pitit-atchoum) wrote :

it works with Virtualbox 2.0 :)

TAC one (tacone) wrote :

On Sat, Sep 6, 2008 at 7:34 PM, pitit.atchoum <email address hidden> wrote:
> it works with Virtualbox 2.0 :)

Not for me. Virtualbox 2.0 + Intrepid Alpha 5 + virtualization
disabled in the bios == same bug as before.

Trip McKay (trip-mckay) wrote :

confirmed

did 3 flawless boots: it works with Virtualbox 2.0 if VT-X/AMD-V is enabled (only)

Christoph Korn (c-korn) wrote :

It does not.

Christoph Korn (c-korn) wrote :

It also worked with VT-X enabled in prior versions of virtualbox.

This is no progress.

Trip McKay (trip-mckay) wrote :

more info:

tested with kernels 2.6.27-2, 2.6.27-1 and with 2.6.26-5 and always booted with VT-X/AMD-V enabled

Vadim Peretokin (vperetokin) wrote :

It worked when I enabled the extension, but not without it. Ubuntu 8.04
works fine with that disabled fyi.

description: updated
Snavely (tompv11) wrote :

To all:
Ubuntu 8.04 host
Alpha's 1-5 have the same kernel panic problem using VMware Player 2.0.5

Jacopo Moronato (jmoronat) wrote :

Same kernel panic after upgrade to Alpha 5 & VirtualBox 2.0 .

Trying to upgrade from Ubuntu Hardy to Intrepid Ibex (on VirtualBox OSE 1.6.2 and Debian Sid/linux 2.6.26), here.
Initially I got the same kernel panic error, but "noreplace-paravirt" boot option did the trick.
Now I can boot with or w/ any ACPI enabled in the Advanced settings of VirtualBox.

Cyphase (cyphase) wrote :

I was able to get Alpha 5 working in Virtualbox 2.0. I used the alternate installer instead of the desktop CD. Of course, I used the noreplace-paravirt kernel option. After installing, I tried booting with noreplace-paravirt. It booted, but X wouldn't respond to my keyboard or mouse. I went to a virtual terminal and tried to add the c-korn ppa ( https://launchpad.net/~c-korn/+archive ), but when I ran apt-get update, it couldn't resolve any domain names. The network interface wasn't working. I manually downloaded the patched kernel from http://ppa.launchpad.net/c-korn/ubuntu/pool/main/l/linux/ and put it on an iso, then mounted it in Virtualbox. After installing it via dpkg, I restarted the VM. It booted without a problem. After that I used Synaptic to force the versions of all the kernel packages to the c-korn repository. This seems like it should work for everyone.

"noreplace-paravirt" is the mot du jour. I tried the latest Alpha 5 desktop CD (i386) in install mode with that option, and at least it booted so far. It seems very very very sluggish (compared to previous Ubuntu-versions-in-virtualbox) and is I might abort the install as I'm short on time, but it seems to work.

Saivann Carignan (oxmosys) wrote :

Last comment on upstream VirtualBox bug says that this was virtualbox problem, and that this issue is fixed with upcoming 2.0.2 release. http://www.virtualbox.org/ticket/1875

Christoph Korn (c-korn) wrote :

If the bug is a VirtualBox bug is the kernel patch being reverted?

Launchpad Janitor (janitor) wrote :
Download full text (20.6 KiB)

This bug was fixed in the package linux - 2.6.27-3.4

---------------
linux (2.6.27-3.4) intrepid; urgency=low

  [ Colin Ian King ]

  * SAUCE: fix kernel oops in VirtualBox during paravirt patching
    - LP: #246067
  * SAUCE: qc-usb: Enable Logitech QuickCam Messenger
    - LP: #209901
  * SAUCE: appleir: Enable driver for new MacBook Pro
    - LP: #157919

  [ Tim Gardner ]

  * Enabled CONFIG_DEBUG_RODATA=y

  [ Upstream Kernel Changes ]

  * Revert "ALSA: hda - Added model selection for iMac 24""
  * Revert "x86: fix HPET regression in 2.6.26 versus 2.6.25, check hpet
    against BAR, v3"
  * Revert "[ARM] use the new byteorder headers"
  * Revert "mac80211: Use IWEVASSOCREQIE instead of IWEVCUSTOM"
  * Revert "crypto: camellia - Use kernel-provided bitops, unaligned access
    helpers"
  * svcrdma: Fix race between svc_rdma_recvfrom thread and the dto_tasklet
  * sched, cpuset: rework sched domains and CPU hotplug handling (v4)
  * ACPI: Fix now signed module parameter.
  * ACPI: Change package length error to warning
  * ACPI: Fix now signed module parameter.
  * ACPI: Fix typo in "Disable MWAIT via DMI on broken Compal board"
  * acpi: add checking for NULL early param
  * UBIFS: fix zero-length truncations
  * Input: bcm5974 - add maintainer entry
  * sh64: re-add the __strnlen_user() prototype
  * sh: fix ptrace_64.c:user_disable_single_step()
  * PNPACPI: ignore the producer/consumer bit for extended IRQ descriptors
  * UBIFS: always read hashed-key nodes under TNC mutex
  * UBIFS: allow for racing between GC and TNC
  * [CIFS] Fix plaintext authentication
  * sparc32: Implement smp_call_function_single().
  * sh: crash kernel resource fix
  * sh: fix kexec entry point for crash kernels
  * sh: fix platform_resource_setup_memory() section mismatch
  * sh: update Migo-R defconfig
  * sh: update AP325RXA defconfig
  * sh: fix semtimedop syscall
  * cifs: fix O_APPEND on directio mounts
  * [CIFS] update cifs change log
  * [CIFS] Turn off Unicode during session establishment for plaintext
    authentication
  * ACPI: thinkpad-acpi: wan radio control is not experimental
  * sparc: Fix resource flags for PCI children in OF device tree.
  * remove blk_register_filter and blk_unregister_filter in gendisk
  * ALSA: oxygen: fix distorted output on AK4396-based cards
  * ipv6: When we droped a packet, we should return NET_RX_DROP instead of
    0
  * pkt_sched: Fix locking of qdisc_root with qdisc_root_sleeping_lock()
  * net: Unbreak userspace usage of linux/mroute.h
  * Don't trigger softlockup detector on network fs blocked tasks
  * Resource handling: add 'insert_resource_expand_to_fit()' function
  * sparc64: setup_valid_addr_bitmap_from_pavail() should be __init
  * UBIFS: do not update min_idx_lebs in stafs
  * UBIFS: push empty flash hack down
  * UBIFS: remove incorrect index space check
  * UBIFS: improve statfs reporting
  * UBIFS: fix assertion
  * UBIFS: add forgotten gc_idx_lebs component
  * UBIFS: introduce LEB overhead
  * UBIFS: improve statfs reporting even more
  * UBIFS: fill f_fsid
  * drm/radeon: downgrade debug message from info to debug.
  * Remove invalidate_partition call from do_md_stop.
  * Fix problem with wai...

Changed in linux:
status: Fix Committed → Fix Released
Trip McKay (trip-mckay) wrote :

Booted up-to-date Intrepid with 2.6.27-3.4 successfull 3 times without any problems to desktop with Virtualbox 2.0.0 and VT-X/AMD-V disabled. The third time it fell back to text-output doing a fsck check but continued without any problems.
I do have to say that with VT-X/AMD-V (which my CPU supports) enabled it feels somehow faster...

TAC one (tacone) wrote :

On Fri, Sep 12, 2008 at 9:28 AM, Trip McKay <email address hidden> wrote:
> Booted up-to-date Intrepid with 2.6.27-3.4 successfull 3 times without any problems to desktop with Virtualbox 2.0.0 and VT-X/AMD-V disabled. The third time it fell back to text-output doing a fsck check but continued without any problems.
> I do have to say that with VT-X/AMD-V (which my CPU supports) enabled it feels somehow faster...

This night I booted with an alpha5 livecd using noreplace-paravirt,
chrooted my existing (virtual) alpha5 Hd installation, and installed
the 2.6.27-3 image. After rebooting it worked but, as the livecd
itself, feels very sluggish. For every thing I do I have to wait for
the screen to redraw (and it does *slowly*).

I am using Virtualbox 2.0 (1.6 had the same problem, though).

I'm asking again what Christoph Korn asked. If the bug is caused by VirtualBox, and it will be fixed in 2.0.2, then why is the kernel patch necessary? It does help with VBox <= 2.0.0, but only makes things slower with VBox 2.0.2 (currently under development).
So is the custom kernel patch going to be reverted or not?

Oliver Gerlich (ogerlich) wrote :

Does the patch really make things slower with newer VBox version?

Anyway, it is nice to be able to run Intrepid at normal speed also in a non-bleeding-edge Vbox installation, so I'd appreciate if the patch is kept.

Christoph Korn (c-korn) wrote :

VirtualBox 2.0.2 fixes the bug.

It also runs with the unpatched kernel.

For me also, VB2.0.2 + alpha5 boots straight away. Although VB2.0.2 and alpha3 dropped to textmode once and panicked a second time.

TAC one (tacone) wrote :

On Sat, Sep 13, 2008 at 1:58 AM, Tristan Wibberley
<email address hidden> wrote:
> For me also, VB2.0.2 + alpha5 boots straight away. Although VB2.0.2 and
> alpha3 dropped to textmode once and panicked a second time.
>
> --
> Kernel panic during boot in VirtualBox with kernel 2.6.26.*-generic
> https://bugs.launchpad.net/bugs/246067
> You received this bug notification because you are a direct subscriber
> of the bug.

About the slow screen refresh, I installed Vbox 2.02, then downgraded
to 2.6 kernel and everything seems back to normal. 2.7 is still
sluggish.

Changed in virtualbox:
status: New → Fix Released
Saivann Carignan (oxmosys) wrote :

Colin King : This bug is now fixed in virtualbox, should you consider reverting the kernel to his initial state?

Same problem, kernel panic.

Config:
HOST:
Ubuntu Hardy 8.04.1 amd84 updated.
Intel Core 2 Duo Q6600
8GB RAM

GUEST:
Ubuntu Intrepid Alpha 4 ISO i386 Desktop CD
1GB RAM
8GB Virtual Disk

Best regards.

Christoph Korn (c-korn) wrote :

Which VirtualBox version do you use?

Virtualbox OSE 1.5.6 (Hardy)

Christoph Korn (c-korn) wrote :

The bug is fixed in 2.0.2.

http://www.virtualbox.org/wiki/Downloads

I have virtualbox 2.0.2.
Intrepid is starting correctly with kernel 2.6.27.2 but I have again kernel panic with latest kernel 2.6.27.3

Christoph Korn (c-korn) wrote :

I cannot confirm that.

Is it exactly the same panic as before?

Saivann Carignan (oxmosys) wrote :

I also can't reproduce any kernel panic with 2.0.2, VT-x enabled or not with latest kernel.

I had kernel panics (not the same as initially) with kernel 2.6.26-3 yesterday, but now it's booting fine...

Christoph Korn (c-korn) wrote :

I reverted the virtualbox patch from latest intrepid kernel.

https://launchpad.net/~c-korn/+archive

For those who experience speed problems with the patched kernel.

Aspa (b-karthiksankar) wrote :

I too got the same error

Elolisos (elisnycander) on 2010-02-10
Changed in linux (Ubuntu):
status: Fix Released → New
Michael Rooney (mrooney) wrote :

Did you mean to change the status? It is not good to change them without explanation.

Changed in linux (Ubuntu):
status: New → Fix Released
Changed in mandriva:
importance: Unknown → Critical
Displaying first 40 and last 40 comments. View all 151 comments or add a comment.