[FFe] dh_python2 transition of zope packages

Bug #831411 reported by Gediminas Paulauskas on 2011-08-22
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
python-tz (Ubuntu)
Undecided
Barry Warsaw
restrictedpython (Ubuntu)
Undecided
Unassigned
zope.app.zopeappgenerations (Ubuntu)
Undecided
Unassigned
zope.copypastemove (Ubuntu)
Undecided
Unassigned
zope.i18n (Ubuntu)
Undecided
Unassigned
zope.i18nmessageid (Ubuntu)
Undecided
Unassigned
zope.location (Ubuntu)
Undecided
Unassigned
zope.proxy (Ubuntu)
Undecided
Unassigned
zope.ptresource (Ubuntu)
Undecided
Unassigned
zope.sendmail (Ubuntu)
Undecided
Barry Warsaw
zope.sqlalchemy (Ubuntu)
Undecided
Unassigned
zope.tales (Ubuntu)
Undecided
Unassigned
zope.testbrowser (Ubuntu)
Undecided
Unassigned

Bug Description

Most of the Zope packages in Ubuntu have transitioned to use dh_python2 instead of python-central (https://wiki.ubuntu.com/BarryWarsaw/PythonHelpers). A few were not converted in time for Feature Freeze, so now we need an exception grant and review.

Gediminas Paulauskas (menesis) wrote :

All packages have been uploaded to SchoolTool PPA <https://launchpad.net/~schooltool-owners/+archive/ppa/>.

Build logs for all of them:

https://launchpad.net/~schooltool-owners/+archive/ppa/+build/2738879/+files/buildlog_ubuntu-oneiric-i386.python-tz_2010b-1ubuntu1_BUILDING.txt.gz

https://launchpad.net/~schooltool-owners/+archive/ppa/+build/2738610/+files/buildlog_ubuntu-oneiric-i386.zope.app.zopeappgenerations_3.5.1-0ubuntu2_BUILDING.txt.gz

https://launchpad.net/~schooltool-owners/+archive/ppa/+build/2738628/+files/buildlog_ubuntu-oneiric-i386.zope.copypastemove_3.7.0-0ubuntu2_BUILDING.txt.gz

https://launchpad.net/~schooltool-owners/+archive/ppa/+build/2738614/+files/buildlog_ubuntu-oneiric-i386.zope.i18n_3.7.4-0ubuntu2_BUILDING.txt.gz

https://launchpad.net/~schooltool-owners/+archive/ppa/+build/2738612/+files/buildlog_ubuntu-oneiric-i386.zope.i18nmessageid_3.5.3-0ubuntu3_BUILDING.txt.gz

https://launchpad.net/~schooltool-owners/+archive/ppa/+build/2738634/+files/buildlog_ubuntu-oneiric-i386.zope.location_3.9.1-0ubuntu1_BUILDING.txt.gz

https://launchpad.net/~schooltool-owners/+archive/ppa/+build/2738609/+files/buildlog_ubuntu-oneiric-i386.zope.proxy_3.6.1-0ubuntu3_BUILDING.txt.gz

https://launchpad.net/~schooltool-owners/+archive/ppa/+build/2741479/+files/buildlog_ubuntu-oneiric-i386.zope.ptresource_3.9.0-0ubuntu4_BUILDING.txt.gz

https://launchpad.net/~schooltool-owners/+archive/ppa/+build/2738645/+files/buildlog_ubuntu-oneiric-i386.zope.sendmail_3.6.0-1ubuntu1_BUILDING.txt.gz

https://launchpad.net/~schooltool-owners/+archive/ppa/+build/2738820/+files/buildlog_ubuntu-oneiric-i386.zope.sqlalchemy_0.6.1-0ubuntu1_BUILDING.txt.gz

https://launchpad.net/~schooltool-owners/+archive/ppa/+build/2739328/+files/buildlog_ubuntu-oneiric-i386.zope.tales_3.5.1-0ubuntu2_BUILDING.txt.gz

https://launchpad.net/~schooltool-owners/+archive/ppa/+build/2739483/+files/buildlog_ubuntu-oneiric-i386.zope.testbrowser_3.8.2-0ubuntu2_BUILDING.txt.gz

Stefano Rivera (stefanor) wrote :

FFe granted for python-pytz, and I'll mark the rest of them confirmed as I go

Changed in python-tz (Ubuntu):
status: New → Confirmed
Changed in zope.app.zopeappgenerations (Ubuntu):
status: New → Confirmed
Changed in zope.copypastemove (Ubuntu):
status: New → Confirmed
Changed in zope.i18n (Ubuntu):
status: New → Confirmed
Stefano Rivera (stefanor) wrote :

zope.location includes a new upstream release. I assume this is necessary?

Changed in zope.i18nmessageid (Ubuntu):
status: New → Confirmed
Changed in zope.location (Ubuntu):
status: New → Incomplete
Stefano Rivera (stefanor) wrote :

I notice some of them remove pydeb some don't. Any particular reason?

Changed in zope.proxy (Ubuntu):
status: New → Confirmed
Changed in zope.ptresource (Ubuntu):
status: New → Confirmed
Stefano Rivera (stefanor) wrote :

Any particuar reason to drop zope.sendmail's test suite?

Changed in zope.sendmail (Ubuntu):
status: New → Incomplete
Changed in zope.sqlalchemy (Ubuntu):
status: New → Confirmed
Changed in zope.tales (Ubuntu):
status: New → Confirmed
Changed in zope.testbrowser (Ubuntu):
status: New → Confirmed
Changed in restrictedpython (Ubuntu):
status: New → Confirmed
Gediminas Paulauskas (menesis) wrote :

A new version of zope.location was not necessary. New version now includes LICENSE.txt, so I could drop the in-place patch.

It also tightens dependencies a little, but that does not matter much for Debian packages.

Changed in zope.location (Ubuntu):
status: Incomplete → New
Gediminas Paulauskas (menesis) wrote :

zope.sendmail update does not drop the test suite. It replaces the script with an include of test_helper script from zope.testing, like all other Zope packages do.

In reality, there is no automated testing of Debian Zope packages. The files in debian/tests are for autopkgtest, and I update them, but there is no buildbot that does run those tests.

Changed in zope.sendmail (Ubuntu):
status: Incomplete → New
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package zope.app.zopeappgenerations - 3.5.1-0ubuntu2

---------------
zope.app.zopeappgenerations (3.5.1-0ubuntu2) oneiric; urgency=low

  * Switch to dh_python2 (LP: #831411).
 -- Gediminas Paulauskas <email address hidden> Mon, 22 Aug 2011 18:44:07 +0300

Changed in zope.app.zopeappgenerations (Ubuntu):
status: Confirmed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package restrictedpython - 3.6.0-0ubuntu2

---------------
restrictedpython (3.6.0-0ubuntu2) oneiric; urgency=low

  * Use dh_python2 instead of deprecated python-central (LP: #831411).
 -- Gediminas Paulauskas <email address hidden> Wed, 24 Aug 2011 19:09:29 +0300

Changed in restrictedpython (Ubuntu):
status: Confirmed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package zope.copypastemove - 3.7.0-0ubuntu2

---------------
zope.copypastemove (3.7.0-0ubuntu2) oneiric; urgency=low

  * Use dh_python2 instead of deprecated python-central (LP: #831411).
 -- Gediminas Paulauskas <email address hidden> Mon, 22 Aug 2011 18:52:56 +0300

Changed in zope.copypastemove (Ubuntu):
status: Confirmed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package zope.i18n - 3.7.4-0ubuntu2

---------------
zope.i18n (3.7.4-0ubuntu2) oneiric; urgency=low

  * Use dh_python2 instead of python-central (LP: #831411, Closes: #617169).
  * debian/control:
    + Add Vcs-Browser and Homepage fields.
    + Bump Standards-Version to 3.9.2. No changes needed.
 -- Gediminas Paulauskas <email address hidden> Mon, 22 Aug 2011 18:55:05 +0300

Changed in zope.i18n (Ubuntu):
status: Confirmed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package zope.i18nmessageid - 3.5.3-0ubuntu3

---------------
zope.i18nmessageid (3.5.3-0ubuntu3) oneiric; urgency=low

  * Switch to dh_python2 (LP: #831411, Closes: #617170):
    - debian/control: remove python-central and python-van.pydeb from
      Build-Depends.
    - debian/rules: replace pydeb and python-central with python2.
  * debian/control:
    - Add Homepage and Vcs-Browser fields.
    - Bump Standards-Version to 3.9.2, no changes needed.
  * debian/copyright: Update to latest dep5 spec.
 -- Gediminas Paulauskas <email address hidden> Thu, 19 May 2011 18:11:34 +0300

Changed in zope.i18nmessageid (Ubuntu):
status: Confirmed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package zope.proxy - 3.6.1-0ubuntu3

---------------
zope.proxy (3.6.1-0ubuntu3) oneiric; urgency=low

  * Switch to dh_python2 (LP: #831411, Closes: #617173):
    - debian/control: remove python-central and python-van.pydeb from
      Build-Depends.
    - debian/rules: replace pydeb and python-central with python2.
  * debian/control:
    - Add Homepage and Vcs-Browser fields.
    - Bump Standards-Version to 3.9.2, no changes needed.
  * debian/copyright: Update to latest dep5 spec.
 -- Gediminas Paulauskas <email address hidden> Mon, 22 Aug 2011 20:35:09 +0300

Changed in zope.proxy (Ubuntu):
status: Confirmed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package zope.ptresource - 3.9.0-0ubuntu4

---------------
zope.ptresource (3.9.0-0ubuntu4) oneiric; urgency=low

  * Use dh_python2 instead of deprecated python-central (LP: #831411).
 -- Gediminas Paulauskas <email address hidden> Tue, 23 Aug 2011 14:36:19 +0300

Changed in zope.ptresource (Ubuntu):
status: Confirmed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package zope.tales - 3.5.1-0ubuntu2

---------------
zope.tales (3.5.1-0ubuntu2) oneiric; urgency=low

  * Use dh_python2 instead of deprecated python-central (LP: #831411).
 -- Gediminas Paulauskas <email address hidden> Tue, 23 Aug 2011 18:41:00 +0300

Changed in zope.tales (Ubuntu):
status: Confirmed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package zope.testbrowser - 3.8.2-0ubuntu2

---------------
zope.testbrowser (3.8.2-0ubuntu2) oneiric; urgency=low

  * Use dh_python2 instead of deprecated python-central (LP: #831411).
 -- Gediminas Paulauskas <email address hidden> Tue, 23 Aug 2011 19:25:36 +0300

Changed in zope.testbrowser (Ubuntu):
status: Confirmed → Fix Released
Gediminas Paulauskas (menesis) wrote :

pydeb generates more specific dependencies, with version requirements, and also handles setuptools extras (allows to move extra dependencies to suggests/recommends or a metapackage). Where the upstream package has very few dependencies, version requirements are satisfied in old Debian/Ubuntu releases, or there are no extras/only test extra with zope.testing, dh_python2 is enough, so I removed the build-depends on van.pydeb.

The hope is to add the missing features from dh_pydeb to dh_python2 and retire the former.

Scott Kitterman (kitterman) wrote :

Please also consider how such features would relate to python3 and file bugs against python-defaults and python3-defaults in Debian (patches welcome).

Changed in zope.sendmail (Ubuntu):
status: New → Confirmed
Changed in zope.location (Ubuntu):
status: New → Confirmed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package zope.location - 3.9.1-0ubuntu1

---------------
zope.location (3.9.1-0ubuntu1) oneiric; urgency=low

  * New upstream release.
    - Now includes LICENSE.txt.
  * Use dh_python2 instead of deprecated python-central (Closes: #617172).
    (LP: #831411).
  * debian/copyright: convert to dep5 format.
 -- Gediminas Paulauskas <email address hidden> Mon, 22 Aug 2011 20:20:11 +0300

Changed in zope.location (Ubuntu):
status: Confirmed → Fix Released
Barry Warsaw (barry) on 2011-09-01
Changed in python-tz (Ubuntu):
assignee: nobody → Barry Warsaw (barry)
milestone: none → ubuntu-11.10-beta-1
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package python-tz - 2010b-1ubuntu1

---------------
python-tz (2010b-1ubuntu1) oneiric; urgency=low

  * debian/patches/tzdata: remove import of pkg_resources (Closes: #599047)
  * Switch to dh_python2 (LP: #831411, Closes: #617041).
  * Switch to source format 3.0 (quilt)
  * debian/control: build-depend on python-all (not -dev).
 -- Gediminas Paulauskas <email address hidden> Tue, 23 Aug 2011 18:14:25 +0300

Changed in python-tz (Ubuntu):
status: Confirmed → Fix Released
Barry Warsaw (barry) on 2011-09-01
Changed in python-tz (Ubuntu):
milestone: ubuntu-11.10-beta-1 → ubuntu-11.10-beta-2
Barry Warsaw (barry) on 2011-09-01
Changed in zope.sendmail (Ubuntu):
assignee: nobody → Barry Warsaw (barry)
milestone: none → ubuntu-11.10-beta-2
status: Confirmed → Fix Released
Barry Warsaw (barry) wrote :

Stefano, Gediminas. I notice that the merge proposal for zope.sqlalchemy also updates the package to the latest upstream version. Does the FFe approval also cover that? I'm willing to upload it if so.

Stefano Rivera (stefanor) wrote :

Barry: Thanks, I should have clarified that.

Gediminas: I assumed a new zope.sqlalchemy was required to support sqlalchemy 0.6 (zope.sqlalchemy 0.6 claims to be the first version to do so, in the changelog). Correct? Have you checked that the single reverse-dependency isn't broken?

Gediminas Paulauskas (menesis) wrote :

Stefano: yes, the newer zope.sqlalchemy is to support the sqlalchemy 0.6 that is in ubuntu since maverick. Maybe the old version works as well, but the changes are minor, mostly bugfixes and more tests. If anything, it's the old version that is broken.

The old version had other problems, e.g. a long list of conflicts with old SQLAlchemy versions, no license. I did not want to make two uploads, first for transition, with patches, and the other new version, removing those patches, so made one.

Barry: FFe covers the dh_python2 transition. zope.sqlalchemy is in universe, so feature freeze does not apply to it. Please upload.

What makes you think feature freeze doesn't apply to Universe?

Scott Kitterman (kitterman) wrote :

It does sound like we should go ahead with the new version for zope.sqlalchemy. FFe approved for that too.

Barry Warsaw (barry) wrote :

On Sep 05, 2011, at 03:32 PM, Scott Kitterman wrote:

>It does sound like we should go ahead with the new version for
>zope.sqlalchemy. FFe approved for that too.

Sounds good; I'll upload that.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package zope.sqlalchemy - 0.6.1-0ubuntu1

---------------
zope.sqlalchemy (0.6.1-0ubuntu1) oneiric; urgency=low

  * New upstream release.
    - SQLAlchemy 0.6.x support
  * Use dh_python2 instead of deprecated python-central (Closes: #617178).
    (LP: #831411)
  * debian/control:
    - build-depend on python-all (not -dev).
  * debian/copyright: update, convert to dep5 format.
 -- Gediminas Paulauskas <email address hidden> Tue, 23 Aug 2011 16:39:24 +0300

Changed in zope.sqlalchemy (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.