Conflicts has not been updated for ~b4 (firefox cannot start after xulrunner upgrade)

Bug #201938 reported by Luca Carrogu on 2008-03-13
32
Affects Status Importance Assigned to Milestone
firefox (Ubuntu)
Undecided
Mozilla Bugs
xulrunner-1.9 (Ubuntu)
Medium
Mozilla Bugs

Bug Description

My system:
Ubuntu Hardy up to date
2.6.24-12-generic

After xulrunner upgrade to version 1.9~b4+nobinonly-0ubuntu1 firefox 3.0~b3+nobinonly-0ubuntu4 doesn't start anymore.
Launching it from terminal it reports

motoplux@laptop-motoplux:~$ firefox
Could not find compatible GRE between version 1.9b3 and 1.9b3.

enguerran (enguerrangillet) wrote :

I can confirm this on an Ubuntu Hardy up to date with 2.6.24-12-generic

Marty (marty-supine) wrote :

Confirming this bug. Up to date Hardy on amd64.

Luca Carrogu (motoplux) on 2008-03-13
Changed in firefox:
status: New → Confirmed

confirm on hardy alpha 6

carletto@voyager:~$ firefox
Could not find compatible GRE between version 1.9b3 and 1.9b3.

Gert Kulyk (gkulyk) wrote :

Please be a bit more patient - the new firefox is already uploaded, build on major archs is completed, so the package should be on archive.ubuntu.com within the next 1-2 hours (other mirrors may need more time). But ok, maybe a conflict between incompatible versions should be introduced, to prevent this kind of situations.

Luca Carrogu (motoplux) wrote :

Thanks Gert.
Should I change the status in fix commited (or released)?

Samuel Abels (knipknap) wrote :

Confirming that the new package works.

Daniel T Chen (crimsun) wrote :

Binaries built on all supported arches.

Changed in firefox:
status: Confirmed → Invalid
Luca Carrogu (motoplux) wrote :

Updated and working again
Thanks to all

Changed in firefox:
status: Invalid → Fix Released
Gert Kulyk (gkulyk) wrote :

This is not easy to decide. While I'm willing to accept such a behavior in a development release, I'm not sure if something like this would not occur the next time xulrunner and firefox will get an update (e.g. when pulling in beta5), which will most likely occur when hardy will be in beta state.

I do not know enough about the xulrunner and firefox internals to decide, if xulrunner beta5 will prevent firefox beta4 from starting. If so, firefox beta4 should get a conflicts against xulrunner-1.9 >= 1.9~b5+nobinonly-0ubuntu1, or however the next version will be named, to prevent update of xulrunner unless firefox is uploaded.

Gert Kulyk (gkulyk) wrote :

Ok, maybe I'm not the fastest writer when using english :-).

Fred (eldmannen+launchpad) wrote :

This is now solved.

The update is in the repository.
Just update. :)

Daniel T Chen (crimsun) wrote :

Per discussion in #ubuntu-devel.

Changed in firefox:
importance: Undecided → Medium
status: Fix Released → Triaged
Chris Cheney (ccheney) wrote :

18:27 < cjwatson> firefox-3.0 depends: xulrunner-1.9 (>= 1.9~b4~)
18:27 < cjwatson> ah, but
18:27 < calc> but xulrunner doesn't conflict with old firefox
18:27 < cjwatson> xulrunner-1.9 Breaks: firefox-3.0 (<< 3.0~b3)
18:27 < cjwatson> that should be b4

Daniel T Chen (crimsun) wrote :

19:27 cjwatson > firefox-3.0 depends: xulrunner-1.9 (>= 1.9~b4~)
19:27 cjwatson > ah, but
19:27 calc > but xulrunner doesn't conflict with old firefox
19:27 cjwatson > xulrunner-1.9 Breaks: firefox-3.0 (<< 3.0~b3)
19:27 cjwatson > that should be b4

Alexander Sack (asac) wrote :

fixed on branch for the next upload. We should remember to do that on every release until we reach RC/final.

Changed in xulrunner-1.9:
status: Triaged → Fix Committed
jeremy-list (quick-dudley) wrote :

This bug is back in xulrunner-1.9 (1.9~b5+nobinonly-0ubuntu3) and firefox 3.0~b5+nobinonly-0ubuntu2. Looks like someone's been 'updating' the hardy repositories without even a quick check to see the programs launch.

Changed in xulrunner-1.9:
status: Fix Committed → New
linas (linasvepstas) wrote :

Yep. I get

  "Could not find compatible GRE between version 1.9b5 and 1.9b5."

and have been getting that for 3-4 days now, despite daily updates.

John Vivirito (gnomefreak) wrote :

This is a bug in xulrunner not so much firefox

Changed in firefox:
assignee: nobody → mozilla-bugs
status: New → Invalid
Changed in xulrunner-1.9:
assignee: nobody → mozilla-bugs
status: New → Incomplete
linas (linasvepstas) wrote :

bug was marked "incomplete", but its not clear what additional info is desired; changing status to "new".

Changed in xulrunner-1.9:
status: Incomplete → New
linas (linasvepstas) wrote :

... and this bug is a recurring theme .. see previous reports ... bug 191608, 191873

linas (linasvepstas) wrote :

I currently have:

 dpkg -l | grep -E ' (firefox-3.0|xulrunner-1.9|libnss3|libnspr4)'
ii firefox-3.0 3.0~b5+nobinonly-0ubuntu2 safe and easy web browser from Mozilla
ii firefox-3.0-gnome-support 3.0~b5+nobinonly-0ubuntu2 Support for Gnome in Mozilla Firefox
ii libnspr4-0d 4.7.1~beta2-0ubuntu1 NetScape Portable Runtime Library
ii libnss3-0d 3.12.0~beta3-0ubuntu1 Transition package for Network Security Serv
ii libnss3-1d 3.12.0~beta3-0ubuntu1 Network Security Service libraries
ii xulrunner-1.9 1.9~b5+nobinonly-0ubuntu3 XUL + XPCOM application runner
ii xulrunner-1.9-gnome-support 1.9~b5+nobinonly-0ubuntu3 Support for Gnome in xulrunner-1.9 applicati

linas (linasvepstas) wrote :

The ubuntu repos were updated today, but the problem remains.
after update, I have the following:

dpkg -l | grep -E ' (firefox-3.0|xulrunner-1.9|libnss3|libnspr4)'
ii firefox-3.0 3.0~b5+nobinonly-0ubuntu3 safe and easy web browser from Mozilla
ii libnspr4-0d 4.7.1~beta2-0ubuntu1 NetScape Portable Runtime Library
ii libnss3-0d 3.12.0~beta3-0ubuntu1 Transition package for Network Security Service
ii libnss3-1d 3.12.0~beta3-0ubuntu1 Network Security Service libraries
ii xulrunner-1.9 1.9~b5+nobinonly-0ubuntu3 XUL + XPCOM application runner

John Vivirito (gnomefreak) wrote :

Please do not change the bug status without reading https://wiki.ubuntu.com/MozillaTeam/Bugs/Procedures.
It was marked as incomplete because we are unable to confirm this issue at this time and as we go through our bugs we may ask for more info but for this moment incomplete lets us know its not confirmed and no upstream bug has been reported. We need to beable to confirm this bug on our systems before we can fix it.
Most likely this issue with this bug is one package not being updated in order but we are currently working on this bug.

Changed in xulrunner-1.9:
status: New → Incomplete
John Vivirito (gnomefreak) wrote :

Linas, This sounds like your using a repo that doesnt get updated as fast as the rest or you need to fix the errors on your side as the fix was released and pushed into archives as stated above. try using aptitude to fix dpkg,s current state if you are seeing this issue still.
Marking as fix released .

Changed in xulrunner-1.9:
status: Incomplete → Fix Released
linas (linasvepstas) wrote :

OK,
"Incomplete" usually means "there is not enough information, and so no one is working on the bug." Since no one asked for additional information, I guess I don't understand how the bug can be marked "incomplete". Whatever.

My repos, per /etc/apt/sources.list, are:

deb http://us.archive.ubuntu.com/ubuntu/ hardy main restricted
deb-src http://us.archive.ubuntu.com/ubuntu/ hardy main restricted
deb http://us.archive.ubuntu.com/ubuntu/ hardy-updates main restricted universe
deb-src http://us.archive.ubuntu.com/ubuntu/ hardy-updates main restricted
deb http://us.archive.ubuntu.com/ubuntu/ hardy universe
deb-src http://us.archive.ubuntu.com/ubuntu/ hardy universe
deb http://us.archive.ubuntu.com/ubuntu/ hardy multiverse
deb-src http://us.archive.ubuntu.com/ubuntu/ hardy multiverse
deb http://security.ubuntu.com/ubuntu hardy-security main restricted
deb-src http://security.ubuntu.com/ubuntu hardy-security main restricted
deb http://security.ubuntu.com/ubuntu hardy-security universe
deb-src http://security.ubuntu.com/ubuntu hardy-security universe
deb http://security.ubuntu.com/ubuntu hardy-security multiverse
deb-src http://security.ubuntu.com/ubuntu hardy-security multiverse

Is this not the master repo? Is there some other Hardy repo that we should be using?

You state that I should "fix the errors on my side", but you do not state what these errors are. I'll fix them, but don't know where the errors might be.

You state that I should use aptitude to fix dpkg's current state, but I don't know what you mean by this. A cycle of apt-get update; apt-get upgrade shows that my system is up-to-date, and aptitude shows I have no missing packages, and no obsolete packages. What is it exactly that I am expected to do?

Please not that I am not the only person reporting this problem; this appears to be a recurring theme, and so far, there does not actually appear to be any fix for this...?

Changed in xulrunner-1.9:
status: Fix Released → New

If this is not a mozilla bug, but a repository-state bug, then perhaps the bug should be removed from the mozilla bug queue, and assigned to the packaging/repository team instead.

linas (linasvepstas) wrote :

I found a fix for this. It was some sort of packaging problem, left over from earlier versions.

The directory /etc/gre.d (gecko rendering engine) contained a config file that specified
earlier (and inappropriate) xulrunner versions. I discovered this while performing a
dpkg -P xulrunner xulrunner-1.9 firefox firefox-3.0 (-P is purge-remove, which removes
the config files as well as the binaries/libraries). dpkg reported an error, complaining that
/etc/gre.d was not empty. Upon removing this directory, and reinstalling firefox-3, the
troublesome error message went away, and firefox started working.

I had to manually remove /etc/gre.d/1.9b4.system.conf -- it was this file that caused
all the problems for me.

Alexander Sack (asac) wrote :

the b5 package had this issue for the last time. but now things should be properly prepared for the next upgrade round.

Changed in xulrunner-1.9:
status: New → Fix Released
Peter (peterroots) wrote :

Kubuntu 8.04
firefox 3.0.13
xulrunner 1.9.0.13

can't run firefox - at CLI I get 'could not find compatible GRE between version 1.9.0.1 and 1.9.0.*.'

This bug may have been fixed but seems to be back again!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers