Inconsistency in xfce4-mime-settings

Bug #1802582 reported by melolontha on 2018-11-09
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
xubuntu-default-settings (Ubuntu)
Undecided
Unassigned

Bug Description

This bug report pertains to Xubuntu 16.04.3 LTS. My current kernel is 4.4.0-116-generic x86_64.

Mime types can not be changed consistently. My attached bug report shows the details with screenshots for which I did not find out how to post them here. So look at the attachment, please.

There is no attachment.

affects: xorg-server (Ubuntu) → xfce4-settings (Ubuntu)
Changed in xfce4-settings (Ubuntu):
status: New → Incomplete
Adalbert Hanßen (melolontha) wrote :

Sorry, I thought it was attached. Hope it works this time.

How did you install the newer LibreOffice version? I assume via snap, or?

I tried to reproduce it in 18.04, but I did not encounter the problem.

Adalbert Hanßen (melolontha) wrote :
Download full text (12.5 KiB)

How I installed LO6.1?
I downloaded LibreOffice_6.1.2_Linux_x86-64_deb.tar.gz and unpacked it to my directory
/home/v/Downloads/LibreOffice_6.1.2.1_Linux_x86-64_deb

Then I did this lkogged in with the administrator credentials:

administrator@administrator-W530:~$ cd /home/administrator/Downloads/LibreOffice_6.1.2.1_Linux_x86-64_deb/DEBS/
administrator@administrator-W530:~/Downloads/LibreOffice_6.1.2.1_Linux_x86-64_deb/DEBS$ sudo dpkg -i *.deb
[sudo] Passwort für administrator:
Vormals nicht ausgewähltes Paket libobasis6.1-base wird gewählt.
(Lese Datenbank ... 256284 Dateien und Verzeichnisse sind derzeit installiert.)
Vorbereitung zum Entpacken von libobasis6.1-base_6.1.2.1-1_amd64.deb ...
Entpacken von libobasis6.1-base (6.1.2.1-1) ...
Vormals nicht ausgewähltes Paket libobasis6.1-calc wird gewählt.
Vorbereitung zum Entpacken von libobasis6.1-calc_6.1.2.1-1_amd64.deb ...
Entpacken von libobasis6.1-calc (6.1.2.1-1) ...
Vormals nicht ausgewähltes Paket libobasis6.1-core wird gewählt.
Vorbereitung zum Entpacken von libobasis6.1-core_6.1.2.1-1_amd64.deb ...
Entpacken von libobasis6.1-core (6.1.2.1-1) ...
Vormals nicht ausgewähltes Paket libobasis6.1-draw wird gewählt.
Vorbereitung zum Entpacken von libobasis6.1-draw_6.1.2.1-1_amd64.deb ...
Entpacken von libobasis6.1-draw (6.1.2.1-1) ...
Vormals nicht ausgewähltes Paket libobasis6.1-en-us wird gewählt.
Vorbereitung zum Entpacken von libobasis6.1-en-us_6.1.2.1-1_amd64.deb ...
Entpacken von libobasis6.1-en-us (6.1.2.1-1) ...
Vormals nicht ausgewähltes Paket libobasis6.1-extension-beanshell-script-provider wird gewählt.
Vorbereitung zum Entpacken von libobasis6.1-extension-beanshell-script-provider_6.1.2.1-1_amd64.deb ...
Entpacken von libobasis6.1-extension-beanshell-script-provider (6.1.2.1-1) ...
Vormals nicht ausgewähltes Paket libobasis6.1-extension-javascript-script-provider wird gewählt.
Vorbereitung zum Entpacken von libobasis6.1-extension-javascript-script-provider_6.1.2.1-1_amd64.deb ...
Entpacken von libobasis6.1-extension-javascript-script-provider (6.1.2.1-1) ...
Vormals nicht ausgewähltes Paket libobasis6.1-extension-mediawiki-publisher wird gewählt.
Vorbereitung zum Entpacken von libobasis6.1-extension-mediawiki-publisher_6.1.2.1-1_amd64.deb ...
Entpacken von libobasis6.1-extension-mediawiki-publisher (6.1.2.1-1) ...
Vormals nicht ausgewähltes Paket libobasis6.1-extension-nlpsolver wird gewählt.
Vorbereitung zum Entpacken von libobasis6.1-extension-nlpsolver_6.1.2.1-1_amd64.deb ...
Entpacken von libobasis6.1-extension-nlpsolver (6.1.2.1-1) ...
Vormals nicht ausgewähltes Paket libobasis6.1-extension-pdf-import wird gewählt.
Vorbereitung zum Entpacken von libobasis6.1-extension-pdf-import_6.1.2.1-1_amd64.deb ...
Entpacken von libobasis6.1-extension-pdf-import (6.1.2.1-1) ...
Vormals nicht ausgewähltes Paket libobasis6.1-extension-report-builder wird gewählt.
Vorbereitung zum Entpacken von libobasis6.1-extension-report-builder_6.1.2.1-1_amd64.deb ...
Entpacken von libobasis6.1-extension-report-builder (6.1.2.1-1) ...
Vormals nicht ausgewähltes Paket libobasis6.1-firebird wird gewählt.
Vorbereitung zum Entpacken von libobasis6.1-firebird_6.1.2.1-1_amd64.deb ...
Entpacken von libobasis...

I tried this method too, and it works fine in 18.04 also. It is possible that the bug is not easily reproducible or specific to the version in 16.04.

Adalbert Hanßen (melolontha) wrote :

"specific to the version in 16.04": That may be possible.

Fortunately I happened to find the workaround how to change a MIME setting despite xfce4-mime-settings refuses to alter some of the settings by first associating the file browser to a file type and then my specific version of LO. So the next one who gets trapped hopefully finds this discussion and even more hopefully, he/she finds my workaround (which is a bit hard to find since my whole report is in the attachment because I could not include screenshots into my initial posting).

It looks like the settings are stored per user in his home-directory's .config path, specifically in ~/.config/mimeapps.list. Would it be possible to change things here using a text editor?

Unfortunately xfce4-mime-settings does not allow to search or even search/replace so changing the associations is a tedious job. At least one can sort the list by the second column such that all LO entries are close to each other.

After reading through your PDF file again I now understand the problem.

Xubunbu ships with a custom mimeapps.list file [1] which has various types associated with LibreOffice programs, so installing LibreOffice6.1 will not override those. The solution for this is easy: remove the preinstalled LibreOffice.

Furthermore, entries containing "macroEnabled" probably need to be changed to lowercase-only [2].

[1] https://git.launchpad.net/xubuntu-default-settings/tree/usr/share/xubuntu/applications/defaults.list
[2] https://bugs.freedesktop.org/show_bug.cgi?id=88004

affects: xfce4-settings (Ubuntu) → xubuntu-default-settings (Ubuntu)
Changed in xubuntu-default-settings (Ubuntu):
status: Incomplete → Confirmed
Sean Davis (bluesabre) wrote :
Changed in xubuntu-default-settings (Ubuntu):
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xubuntu-default-settings - 19.04

---------------
xubuntu-default-settings (19.04) disco; urgency=medium

  * Add Terminal (F4) and Find (Primary+Shift+F) shortcuts to Thunar (LP: #1793395)
    - etc/xdg/xdg-xubuntu/Thunar/accels.scm
    - etc/xdg/xdg-xubuntu/Thunar/uca.xml.in
  * debian/xubuntu-default-settings.gsettings-override:
    - Set GNOME/GTK 3 dconf keys for fonts (LP: #1769774)
  * etc/xdg/xdg-xubuntu/autostart/xfce4-tips-autostart.desktop
    - Removed, obsolete (LP: #1805005)
  * etc/xdg/xdg-xubuntu/Thunar/uca.xml.in:
    - Enable startup-notify in Thunar's uca.xml (LP: #1794118)
  * etc/xdg/xdg-xubuntu/xfce4/xfconf/xfce-perchannel-xml/xfce4-keyboard-shortcuts.xml:
    - Add shortcut for xfce4-screenshooter region capture (Shift+Print) (LP: #1812234)
  * etc/xdg/xdg-xubuntu/xfce4/xfconf/xfce-perchannel-xml/xfce4-power-manager.xml:
    - Set default inactivity mode to Suspend on AC and battery (LP: #1768038)
  * etc/xdg/xdg-xubuntu/xfce4/xfconf/xfce-perchannel-xml/xfprint.xml
    - Removed, obsolete (LP: #1805007)
  * usr/share/xubuntu/applications/defaults.list:
    - Replace invalid macroEnabled mimetypes (LP: #1802582)
    - Remove invalid x-scheme-handler/file handler (LP: #1778069)

 -- Sean Davis <email address hidden> Mon, 28 Jan 2019 22:44:14 -0500

Changed in xubuntu-default-settings (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.