[jaunty] vesa driver stopped working (no devices found) inside KVM after X update

Bug #356133 reported by Sascha Silbe on 2009-04-06
18
This bug affects 2 people
Affects Status Importance Assigned to Milestone
X.Org X server
Won't Fix
High
xserver-xorg-video-vesa (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: xserver-xorg-video-vesa

After an update yesterday (including xorg packages, but not xserver-xorg-video-vesa), X stopped working inside KVM:

(II) VESA: driver for VESA chipsets: vesa
(WW) Falling back to old probe method for vesa
(EE) No devices detected.

KBios (kbios) wrote :

Confirmed on amd64.
The "vesa" module seems still from a prerelease of xorg (version 1.5.99).

Changed in xserver-xorg-video-vesa (Ubuntu):
status: New → Confirmed
KBios (kbios) wrote :

I tried running apt-get -b source xserver-xorg-video-vesa (to get a module compiled for the right xorg version) but the problem remains the same.

KBios (kbios) wrote :

This bug is fixed with kvm-85 and 20090420 image, but I think it's too late to include it in jaunty.

Care to elaborate why a host-side change is necessary? In my case, the host isn't running Ubuntu, so whether or not it gets into jaunty is irrelevant.

KBios (kbios) wrote :

Well, the best guess I can do is that the Ubuntu xorg upgrade made xorg itself more strict when dealing with vesa cards. Maybe te KVM emulated card wasn't completely compliant with the standards. Please note that this is a complete guess, and may be completely incorrect. Can you confirm kvm-85 solves the problem for you?

I have exactly the same problem as the initial post. I attempted to build kvm-85 and discovered it will only compile for 2.6.29 kernels (i.e. it will not compile with jaunty kernels).

Building only the kvm-85 userspace results in the same behavior (no fix).

If this is in fact fixed in kvm-85, I would suggest the fix be backported to the jaunty kvm or kvm-source packages as appropriate. Otherwise, Ubuntu users are locked out of using ubuntu guests with vesa consoles until karmic is released in six months.

Or, in the alternative, the vesa card check be relaxed in xserver-xorg-video-vesa to detect the vesa card shipped with jaunty kvm.

Geoff L (geo88) wrote :

I have exactly the same problem. Can anyone confirm that kvm-85 solves the problem ? This could be quite disruptive to install, so I'd prefer to know for sure that it would work !

Or has anyone found any other way around this ? I'm at a dead stop with jaunty under kvm-84. The cirrus driver is all but unuseable.

For what it's worth, I do not believe this bug is fixed in kvm-85, on the following basis:

1. I compiled the kvm-85 userland code from Sourceforge and ran it with the Ubuntu 9.04 kvm-source kernel module (1:84+dfsg-0ubuntu11). Same behavior, same problem.

2. I reviewed the release notes for kvm-85 (http://sourceforge.net/project/shownotes.php?group_id=180599&release_id=677328) and found no evidence this bug was addressed in kvm-85.

Geoff L (geo88) wrote :

As an experiment I tried to use the vmware driver and got a similar "no devices found" error. I've never actually tried the vmware driver before, so this may just be a coincidence (has it ever worked ?).

Probably relevant patch: http://cgit.freedesktop.org/xorg/driver/xf86-video-vesa/commit/?id=99d2cc8676a93ec21f5ca1cec3525a8dff8a6acd

This commit looks like it has a high likelihood of having broken QEMU VESA probes. One would need to trace the execution path in a debugger to confirm, though.

None of the three previous links have panned out.

I have discovered a workaround, however: KVM-85 will, in fact, work if you specify the PCI device in xorg.conf as follows:

Section "Device"
        Identifier "Configured Video Device"
        Driver "vesa"
        BusID "PCI:0:2:0"
EndSection

Make this change, download kvm-85, build the user-land code, install it somewhere (I use /usr/local/kvm), and you can use vesa mode with a Jaunty guest and a Jaunty kvm-source host kernel module.

Also, for what it's worth, the vesa video performance under kvm-85 / Jaunty guest is rather worse than it was under Jaunty kvm / Intrepid guest. It helps somewhat to copy vgabios.bin from /usr/share/kvm to your kvm-85 installation (the kvm-85 version of the vgabios is from December, vs. April for Jaunty kvm).

Recently the Xorg vesa driver stopped working in Ubuntu Jaunty [1] and Fedora Rawhide [2] when run inside kvm-84. Because it got broken in both, I'm guessing it's actually an Xorg bug.

The most interesting non-debug lines in Xorg.0.log are:

(II) VESA: driver for VESA chipsets: vesa
(WW) Falling back to old probe method for vesa
(EE) No devices detected.

The versions of the vesa driver are 2.2.0-3.fc11 for Fedora and 2.0.0-1ubuntu6 for Ubuntu Jaunty.
See the Ubuntu bug [1] for complete Xorg.0.log files before and after the breakage.

kvm-85 has been reported to work better for some users, but is not available in Debian experimental yet (so I cannot verify easily).

[1] https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-video-vesa/+bug/356133
[2] https://bugzilla.redhat.com/show_bug.cgi?id=500057

Happens for Fedora Rawhide as well now (Fedora Bug #500057 [1]), so most likely an upstream bug.

[1] https://bugzilla.redhat.com/show_bug.cgi?id=500057

Martin Olsson (mnemo) wrote :

Sascha, can you please open a good bug report at bugs.freedesktop.org that summarizes what you have found above? Once that's done, please the the "Also affects project" at the top of this page to link the upstream bug report to this bug. Thanks.

Changed in xorg-server:
status: Unknown → Confirmed
KBios (kbios) wrote :

Sorry, when I wrote "fixed with kvm-85" I was using kernel 2.6.29.1 from mainline ppa. I didn't have to change anything in xorg.conf, though.

For kvm-85, it works on Ubuntu Jaunty (2.0.0-1ubuntu6), but not on Fedora (2.2.0-3.fc11).

I can now confirm it works using KVM-85 (on a Debian lenny host).

Bryce Harrington (bryce) on 2009-09-02
tags: added: jaunty
Bryce Harrington (bryce) wrote :

[This is an automatic notification.]

Hi Sascha,

This bug was reported against an earlier version of Ubuntu, can you
test if it still occurs on Lucid?

Please note we also provide technical support for older versions of
Ubuntu, but not in the bug tracker. Instead, to raise the issue through
normal support channels, please see:

    http://www.ubuntu.com/support

If you are the original reporter and can still reproduce the issue on
Lucid, please run the following command to refresh the report:

  apport-collect 356133

If you are not the original reporter, please file a new bug report, so
we can work with you as the original reporter instead (you can reference
bug 356133 in your report if you think it may be related):

  ubuntu-bug xorg

If by chance you can no longer reproduce the issue on Lucid or if you
feel it is no longer relevant, please mark the bug report 'Fix Released'
or 'Invalid' as appropriate, at the following URL:

  https://bugs.launchpad.net/ubuntu/+bug/356133

Changed in xserver-xorg-video-vesa (Ubuntu):
status: Confirmed → Incomplete
tags: added: needs-retested-on-lucid-by-june
Bryce Harrington (bryce) on 2010-05-21
tags: added: hardy
Changed in xorg-server:
importance: Unknown → High
Vish (vish) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. We are closing this bug report because it lacks the information we need to investigate the problem, as described in the previous comments. Please reopen it if you can give us the missing information, and don't hesitate to submit bug reports in the future.
To reopen the bug report you can click on the current status, under the Status column, and change the Status back to "New".

Changed in xserver-xorg-video-vesa (Ubuntu):
status: Incomplete → Invalid
Changed in xorg-server:
importance: High → Unknown
Changed in xorg-server:
importance: Unknown → High

kvm bug for not setting the device class up properly, closing.

Changed in xorg-server:
status: Confirmed → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.