misbehaving X on quantal ppc w/ nvidia geforce fx go5200

Bug #1061790 reported by Walter Lapchynski on 2012-10-04
20
This bug affects 3 people
Affects Status Importance Assigned to Milestone
xserver-xorg-video-nouveau (Ubuntu)
Undecided
Unassigned

Bug Description

i put a lot of information here before it was suggested to make a new bug:
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1043518

but to summarize the only way i could get X to start was by turning of KMS, e.g. nomodeset or nouveau.modeset=0 boot parameters. when i did, i got such horrible graphics i wasn't able to even complete the install. a picture can be found here:
http://imgur.com/ArhrV
even using an alternate to directly do the install, the result was plagued with the same problems.

so i set to make an xorg.conf. by auto-configuring the file per instructions here:
https://wiki.ubuntu.com/PowerPCFAQ#How_do_I_configure_an_xorg.conf_file.3F
and turning off 3d acceleration which was suggested here:
http://ubuntuforums.org/showthread.php?t=2066064
and found success.

i tried several other things, like disabling other outputs and adding modelines, but this was deemed unnecessarily so i whittled the xorg.conf down to the minimum which you can find along with dmesg and Xorg.0.log here:
http://paste.ubuntu.com/1260328/

ProblemType: Bug
DistroRelease: Ubuntu 12.10
Package: xserver-xorg-video-nouveau 1:1.0.2-0ubuntu3
ProcVersionSignature: Ubuntu 3.5.0-16.25-powerpc-smp 3.5.4
Uname: Linux 3.5.0-16-powerpc-smp ppc
ApportVersion: 2.6.1-0ubuntu1
Architecture: powerpc
Date: Thu Oct 4 10:58:10 2012
InstallationMedia: Lubuntu 12.10 "Quantal Quetzal" - Beta powerpc (20121001)
ProcEnviron:
 TERM=screen
 SHELL=/bin/bash
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 LANGUAGE=en_US:en
SourcePackage: xserver-xorg-video-nouveau
UpgradeStatus: No upgrade log present (probably fresh install)

Walter Lapchynski (wxl) wrote :
Walter Lapchynski (wxl) on 2012-10-04
description: updated
ojordan (ojordan12345) wrote :

It's probably worth pointing out that you had to define an xorg.conf because you got "No devices detected" in the Xorg.0.log. A similar problem to what is currently happening to some (all?) radeon cards with PowerPC at the moment since the latest update to the radeon driver - bug 1058641 .

Walter Lapchynski (wxl) wrote :

good point. you can see dmesg/Xorg.0.log for the default boot here:
http://paste.ubuntu.com/1254953/
and indeed "No devices detected" is at the bottom

if it's relevant to anyone curious, here's the same info for nomodeset:
http://paste.ubuntu.com/1255047/

ojordan (ojordan12345) wrote :

Also, you haven't turned off just 3d acceleration, but ALL acceleration from what I understand. To turn off 3d you'd have to disable DRI or turn off AIGLX so that the software rasteriser is used. Something like that anyway. I think your problem is possibly EXA related, but FYI if you wish you could probably be a bit more selective on the acceleration you turn off.

bugbot (bugbot) on 2012-10-11
tags: added: ppc
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1061790

tags: added: iso-testing
Str8bs (str8bslinux) wrote :

Also present 20130412 PowerMac G5 (PPC64) NV34 GeForce FX5200 Ultra.
Both Lubuntu and Ubuntu splash screens display beautifully.
Ubuntu PPC desktop ISO gets to "running in low graphics mode" and then hangs when selecting either low graphics mode or reconfigure graphics.
 Something with framebuffer hand off?
 /proc/fb shows nouveaufb at 0
Logs to come.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in xserver-xorg-video-nouveau (Ubuntu):
status: New → Confirmed
Str8bs (str8bslinux) wrote :

My G5 has a known "phantom" port so I am testing with video=TV-1:d kernel parm. That was all that was needed to boot any live ISO prior to 12.10.

Lubuntu alternate ISO 20130412 GNU/Linux 3.8.0-7-powerpc64-smp ppc64

Unless otherwises stated, the forthcoming logs are booted with video=TV-1:d drm.debug=0x4 plymouth:debug .
"splash and quiet" have been removed from yaboot appends.

Machine boots Lubuntu to black screen with blinking cursor in upper left corner.

Str8bs (str8bslinux) wrote :

lspci -vvv

Str8bs (str8bslinux) wrote :

lsmod

Str8bs (str8bslinux) wrote :

Adding logs after adding video=offb:off to kernel parameters. I also tried explicitly setting resolution to connected output.
video=TV-1:d video=DVI-I-1:d video=DVI-I-2:1280x1024-24@75 drm.debug=0x4 log_buf_len=16M plymouth:debug video=offb:off

Str8bs (str8bslinux) on 2013-04-13
tags: added: raring
Str8bs (str8bslinux) wrote :

Walter et al:
I was ignorant of the "one report, per person, per hardware combination, per bug" rule of thumb. Per the guidelines, I created a separate bug report. I have removed all logs I previously attached and will move them there.
I think this may be a duplicate, but will leave to you or the maintainers to decide.
https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-video-nouveau/+bug/1170054

It may speed triage if you were to retitle this bug to include Chip. I found some great info here:
https://wiki.ubuntu.com/X/Troubleshooting/BlankScreen

My aplogies for trouncing on your bug report.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers