Clipping in libreoffice welcome screen

Bug #901959 reported by Bryce Harrington on 2011-12-09
44
This bug affects 8 people
Affects Status Importance Assigned to Milestone
xf86-video-intel
Fix Released
Medium
xserver-xorg-video-intel (Ubuntu)
Medium
Bryce Harrington
Oneiric
Undecided
Unassigned

Bug Description

[Impact]
Minor but noticeable cosmetic issue in the welcome screen for libreoffice. Caused by a regression in UXA compositing. When launching LibreOffice, a welcome panel is displayed. On Intel video drivers the left and right edges of this window are unpainted. See attached screenshot.

[Development Fix]
Fixed upstream and in precise with patch 103_fix_uxa_fill_spans.patch to the 2D X driver.

[Stable Fix]
The same patch applies without change to oneiric, and is being proposed here.

[Text Case]
1. Open LibreOffice (any component).
Broken Behavior: Welcome screen looks clipped with some portions unpainted
Fixed Behavior: Normal welcome screen displayed

[Regression Potential]
We've been carrying this patch without issue for several months now. The fix was also pretty straightforward. I'd say even though this is a cosmetic issue, the fix has proven to be quite safe. We've had a number of reports against oneiric about this so it seems to be sufficiently annoying that it's going to be worth getting fixed.

[Original Report]
When launching LibreOffice, a welcome panel is displayed. On Intel video drivers the left and right edges of this window are unpainted. See attached screenshot.

Michael Stahl (RedHat) originally found this issue (found in Fedora 16), and did some further analysis:

< mst_> we set up a clipping region with XSetRegion that has 4 rects
< mst_> then we paint about 40 polygons for the gradient, covering the entire window
< mst_> but somehow only the stuff that lands in the first of the 4 clipping rects actually shows up
< mst_> so i have a gradient along the top of the window, but other 3 borders are un-painted (very ugly)
< mst_> as i already mentioned earlier today just removing the clipping lets whole window be painted
< mst_> actually it is broken in LO 3.4, master, AOOo 3.4, havent tried anything older
< mst_> could it be it's an X problem?
< mst_> am running on F16 which is probably some bleeding edge stuff
< mst_> if i start it in Xephyr i get all gradients

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: xorg 1:7.6+7ubuntu7
ProcVersionSignature: Ubuntu 3.2.0-2.6-generic-pae 3.2.0-rc3
Uname: Linux 3.2.0-2-generic-pae i686
.tmp.unity.support.test.0:

ApportVersion: 1.90-0ubuntu1
Architecture: i386
CompizPlugins: [core,bailer,detection,composite,opengl,decor,imgpng,gnomecompat,regex,place,snap,vpswitch,mousepoll,grid,compiztoolbox,animation,move,session,resize,unitymtgrabhandles,workarounds,wall,expo,fade,ezoom,scale,unityshell]
CompositorRunning: None
Date: Thu Dec 8 17:21:31 2011
DistUpgraded: Fresh install
DistroCodename: precise
DistroVariant: ubuntu
GraphicsCard:
 Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller [8086:2a42] (rev 07) (prog-if 00 [VGA controller])
   Subsystem: Fujitsu Limited. Device [10cf:1458]
   Subsystem: Fujitsu Limited. Device [10cf:1458]
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Alpha i386 (20111121)
MachineType: FUJITSU LifeBook T4410
PccardctlIdent:
 Socket 0:
   no product info available
PccardctlStatus:
 Socket 0:
   no card
ProcEnviron:
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.2.0-2-generic-pae root=UUID=74b73169-6ac4-4698-bb5e-1f9b21250507 ro quiet splash vt.handoff=7
SourcePackage: xorg
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 09/30/2009
dmi.bios.vendor: FUJITSU // Phoenix Technologies Ltd.
dmi.bios.version: Version 1.05
dmi.board.name: FJNB206
dmi.board.vendor: FUJITSU
dmi.chassis.type: 10
dmi.chassis.vendor: A40R8CE708EA1001
dmi.modalias: dmi:bvnFUJITSU//PhoenixTechnologiesLtd.:bvrVersion1.05:bd09/30/2009:svnFUJITSU:pnLifeBookT4410:pvr:rvnFUJITSU:rnFJNB206:rvr:cvnA40R8CE708EA1001:ct10:cvr:
dmi.product.name: LifeBook T4410
dmi.sys.vendor: FUJITSU
version.compiz: compiz 1:0.9.6+bzr20110929-0ubuntu7
version.libdrm2: libdrm2 2.4.27-1ubuntu1
version.libgl1-mesa-dri: libgl1-mesa-dri 7.11-0ubuntu4
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 7.11-0ubuntu4
version.xserver-xorg-core: xserver-xorg-core 2:1.10.4-1ubuntu5
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.6.0-1ubuntu13
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.99~git20110811.g93fc084-0ubuntu1
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.15.901-1ubuntu3
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20110411+8378443-1

Bryce Harrington (bryce) wrote :
Bryce Harrington (bryce) wrote :
affects: xorg (Ubuntu) → xserver-xorg-video-intel (Ubuntu)
Changed in xserver-xorg-video-intel (Ubuntu):
assignee: nobody → Bryce Harrington (bryce)
importance: Undecided → Medium
status: New → Triaged
Download full text (3.6 KiB)

Forwarding this bug from Ubuntu (sounds like it affects Fedora too):
http://bugs.launchpad.net/ubuntu/+source/xserver-xorg-video-intel/+bug/901959

When launching LibreOffice, a welcome panel is displayed. On Intel video drivers the left and right edges of this window are unpainted. See attached screenshot.

I reproduced the bug on Ubuntu Precise (12.04) by running `libreoffice` from a terminal window.

Michael Stahl (RedHat) originally found this issue (found in Fedora 16), and did some further analysis:

< mst_> we set up a clipping region with XSetRegion that has 4 rects
< mst_> then we paint about 40 polygons for the gradient, covering the entire window
< mst_> but somehow only the stuff that lands in the first of the 4 clipping rects actually shows up
< mst_> so i have a gradient along the top of the window, but other 3 borders are un-painted (very ugly)
< mst_> as i already mentioned earlier today just removing the clipping lets whole window be painted
< mst_> actually it is broken in LO 3.4, master, AOOo 3.4, havent tried anything older
< mst_> could it be it's an X problem?
< mst_> am running on F16 which is probably some bleeding edge stuff
< mst_> if i start it in Xephyr i get all gradients

DistroRelease: Ubuntu 12.04
Package: xorg 1:7.6+7ubuntu7
ProcVersionSignature: Ubuntu 3.2.0-2.6-generic-pae 3.2.0-rc3
Uname: Linux 3.2.0-2-generic-pae i686
.tmp.unity.support.test.0:

ApportVersion: 1.90-0ubuntu1
Architecture: i386
CompizPlugins: [core,bailer,detection,composite,opengl,decor,imgpng,gnomecompat,regex,place,snap,vpswitch,mousepoll,grid,compiztoolbox,animation,move,session,resize,unitymtgrabhandles,workarounds,wall,expo,fade,ezoom,scale,unityshell]
CompositorRunning: None
Date: Thu Dec 8 17:21:31 2011
DistUpgraded: Fresh install
DistroCodename: precise
DistroVariant: ubuntu
GraphicsCard:
Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller [8086:2a42] (rev 07) (prog-if 00 [VGA controller])
Subsystem: Fujitsu Limited. Device [10cf:1458]
Subsystem: Fujitsu Limited. Device [10cf:1458]
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Alpha i386 (20111121)
MachineType: FUJITSU LifeBook T4410
PccardctlIdent:
Socket 0:
no product info available
PccardctlStatus:
Socket 0:
no card
ProcEnviron:
PATH=(custom, no user)
LANG=en_US.UTF-8ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.2.0-2-generic-pae root=UUID=74b73169-6ac4-4698-bb5e-1f9b21250507 ro quiet splash vt.handoff=7
SourcePackage: xorg
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 09/30/2009
dmi.bios.vendor: FUJITSU // Phoenix Technologies Ltd.
dmi.bios.version: Version 1.05
dmi.board.name: FJNB206
dmi.board.vendor: FUJITSU
dmi.chassis.type: 10
dmi.chassis.vendor: A40R8CE708EA1001
dmi.modalias: dmi:bvnFUJITSU//PhoenixTechnologiesLtd.:bvrVersion1.05:bd09/30/2009:svnFUJITSU:pnLifeBookT4410:pvr:rvnFUJITSU:rnFJNB206:rvr:cvnA40R8CE708EA1001:ct10:cvr:
dmi.product.name: LifeBook T4410
dmi.sys.vendor: FUJITSU
version.compiz: compiz 1:0.9.6+bzr20110929-0ubuntu7
version.libdrm2: libdrm2 2.4.27-1ubuntu1
version.libgl1-mesa-dri: libgl1-mesa-dri 7.11-0ubuntu4
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.l...

Read more...

description: updated

Created attachment 54257
Screenshot showing the clipping problem

Created attachment 54258
BootDmesg.txt

Created attachment 54259
CurrentDmesg.txt

Created attachment 54260
XorgLog.txt

Changed in xserver-xorg-video-intel:
importance: Unknown → Medium
status: Unknown → Confirmed

Yet another bug present in UXA but not SNA ;-p

commit 429a36f7481b9bfd5ed137642d2916d69a713557
Author: Chris Wilson <email address hidden>
Date: Fri Dec 9 09:54:12 2011 +0000

    uxa: Fix clip processing for uxa_fill_spans()

    Fixes regression from e0066e77e026b0dd0daa0c3765473c7d63aa6753
    (uxa: Simplify Composite solid acceleration for spans by only clipping
    once) [2.15.901]

    Bugzilla: https://bugs.freedesktop.org/show_bug.cgi?id=43649
    Signed-off-by: Chris Wilson <email address hidden>

hi Bryce,

thanks for reporting the bug, but you could have just saved me a bit of pointless work by putting me on CC: on this, or even just forwarding me a mail...

thanks Chris for fixing it so quickly :)

@mst: Sorry, I should have pinged you about it, but it came up spontaneous on IRC yesterday at 2am local and I didnt bother. Bryce was really proactive on this one ;)

Think this might be the first time I've seen someone complain when a bug got fixed *too* fast. ;-)

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xserver-xorg-video-intel - 2:2.15.901-1ubuntu4

---------------
xserver-xorg-video-intel (2:2.15.901-1ubuntu4) precise; urgency=low

  * Add 103_fix_uxa_fill_spans.patch: Fix clip processing for
    uxa_fill_spans(). Fixes regression in LibreOffice causing partially
    unpainted areas in its welcome panel.
    (LP: #901959)
 -- Bryce Harrington <email address hidden> Fri, 09 Dec 2011 11:31:16 -0800

Changed in xserver-xorg-video-intel (Ubuntu):
status: Triaged → Fix Released
Changed in xserver-xorg-video-intel:
status: Confirmed → Fix Released

*** Bug 43776 has been marked as a duplicate of this bug. ***

*** Bug 43887 has been marked as a duplicate of this bug. ***

*** Bug 43201 has been marked as a duplicate of this bug. ***

Amr Ibrahim (amribrahim1987) wrote :

This bug still affects Oneiric 11.10

*** Bug 44210 has been marked as a duplicate of this bug. ***

That is strange. Is this bug really fixed ? I cannot find the commit in master and libreoffice-3-5 branches.
My bug report bug 44210 has been done *after* this one has been closed and on my own build LO 3.5.0 beta.
Please, could you provide the link to the commit?

Thank you very much.

(In reply to comment #14)
> That is strange. Is this bug really fixed ? I cannot find the commit in master
> and libreoffice-3-5 branches.
> My bug report bug 44210 has been done *after* this one has been closed and on
> my own build LO 3.5.0 beta.
> Please, could you provide the link to the commit?
>
> Thank you very much.

Sorry I should have read more carefully the comment by Stephan Bergmann in bug 44210.
So it is a bug in X not in LibreOffice and resolution should have been NotOurBug.

No workaround possible in LO ?

Best regards. JBF

Jean-Baptiste Faure:

please note that this bugtracker is used not only for LibreOffice but also for X.org, and its drivers, where this bug has been fixed.

in Fedora 16 the driver is fixed now.

(In reply to comment #16)
> Jean-Baptiste Faure:
>
> please note that this bugtracker is used not only for LibreOffice but also for
> X.org, and its drivers, where this bug has been fixed.
>
> in Fedora 16 the driver is fixed now.

Oups, sorry. I did not see that a bug LibreOffice was marked as duplicate of a bug X.

Best regards. JBF

*** Bug 42557 has been marked as a duplicate of this bug. ***

Bryce Harrington (bryce) wrote :

See also bug #874559, which I think may be a dupe of this.

description: updated
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in xserver-xorg-video-intel (Ubuntu Oneiric):
status: New → Confirmed
Chris Halse Rogers (raof) wrote :

Currently the fix for bug #889068 is sitting in -proposed. Since that's a crasher, I'd like to get that into -updates ASAP; this SRU will move to -proposed once bug #889068 hits verification-done and is copied to updates.

Jonathan Riddell (jr) wrote :

Still waiting on approval from ubuntu-sru

*** Bug 47701 has been marked as a duplicate of this bug. ***

*** Bug 48626 has been marked as a duplicate of this bug. ***

Hello Bryce, or anyone else affected,

Accepted xserver-xorg-video-intel into oneiric-proposed. The package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in xserver-xorg-video-intel (Ubuntu Oneiric):
status: Confirmed → Fix Committed
tags: added: verification-needed

The fix for the this bug has been awaiting testing feedback in the -proposed repository for oneiric for more than 90 days. Please test this fix and update the bug appropriately with the results. In the event that the fix for this bug is still not verified 15 days from now the package will be removed from the -proposed repository.

tags: added: removal-candidate
Brian Murray (brian-murray) wrote :

The version of xserver-xorg-video-intel in oneiric-proposed has been removed as the bugs it was fixing (including this one) were not verified in a timely fashion.

Changed in xserver-xorg-video-intel (Ubuntu Oneiric):
status: Fix Committed → Triaged
tags: removed: verification-needed
tags: removed: removal-candidate
Adolfo Jayme (fitojb) on 2013-06-27
Changed in xserver-xorg-video-intel (Ubuntu Oneiric):
status: Triaged → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.