[i865G] UXA freezes system on startup (UXA bug)

Bug #328528 reported by Aram Yegenian on 2009-02-12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
xserver-xorg-video-intel (Ubuntu)

Bug Description

Binary package hint: xserver-xorg-video-intel

this bug report is related to this.

I ran the bug report tool as suggested by:

ProblemType: Bug
Architecture: i386
DistroRelease: Ubuntu 9.04
Package: xserver-xorg-video-intel 2:2.6.1-1ubuntu2
ProcVersion: Linux version 2.6.28-7-generic (buildd@palmer) (gcc version 4.3.3 (Ubuntu 4.3.3-3ubuntu2) ) #20-Ubuntu SMP Mon Feb 9 15:43:21 UTC 2009

SourcePackage: xserver-xorg-video-intel
Uname: Linux 2.6.28-7-generic i686

00:00.0 Host bridge [0600]: Intel Corporation 82865G/PE/P DRAM Controller/Host-Hub Interface [8086:2570] (rev 02)
 Subsystem: ASRock Incorporation Device [1849:2570]
00:02.0 VGA compatible controller [0300]: Intel Corporation 82865G Integrated Graphics Controller [8086:2572] (rev 02)
 Subsystem: ASRock Incorporation Device [1849:2572]

Aram Yegenian (aramyegenian) wrote :
jerrylamos (jerrylamos) wrote :

As described in wiki.ubuntu.com/X/UxaTesting I tried "AccelMethod" "uxa" on
Intel Corporation 82845G/GL[Brookdale-G]/GE Chipset Integrated Graphics Device (rev 01)
using Feb 12 2009 jaunty Xubuntu build
Linux ubuntu 2.6.28-7-generic #20-Ubuntu SMP Mon Feb 9 15:43:21 UTC 2009 i686 GNU/Linux

This is an IBM ThinkCentre A30 tower.

Booted CD Live in recovery mode, entered the xorg.conf changes.
Logon screen came up. That doesn't usually happen on CD Live unless there's a problem.
Boot proceeded to a blue screen with movable cursor. Keyboard dead to any combination of keys.
No way to get any logs or anything else since the computer is locked up altogether.

Re-Booted with "NoAccel" to write this comment. I did run ubuntu-bug xserver-xorg-video-intel however I'm not sure where the attachment is, and it was with the NoAccel boot since that's the only way it can run anyway.

Anything I can run or try to report?


Geir Ove Myhr (gomyhr) on 2009-02-15
description: updated

Aram, could you update the bug description and title to describe exactly what the problem is? The only information I currently can see is that it has to do with UXA (since that is the title) and that it is related to bug 304871.

Jerry, your bug is probably different from Aram's. Could you please file a separate bug unless you are sure that you have exactly the same problem as described by a pre-existing bug? You will need to attach at least the output of `lspci -vvnn` (it doesn not matter if it runs with NoAccel) and Xorg.0.log from when the problem occurs. To retrieve this, look in /var/log/ when you reboot. It will normally be renamed to Xorg.0.log.old when another X-server start. Please check the time when the problem occurs and compare with the timestamp on the file (`ls -l /var/log/Xorg.0.log*` will show the timestamps).

Changed in xserver-xorg-video-intel:
status: New → Incomplete
jerrylamos (jerrylamos) wrote :

The boot failure occurs on Xubuntu Jaunty from daily build 20070212.
Section "Device"
 Identifier "Configured Video Device"
 Driver "Intel"
 Option "AccelMethod" "uxa"
 Option "ModeDebug" "true"
        Option "FallbackDebug" "true"
it boots up to a blue (this was Xubuntu, Ubuntu would get a tan) screen with a movable cursor. Keyboard is dead altogether. Mouse pointer moves but mouse keys are dead. Only key that works is power off.
This is a quad boot setup so I booted on another image (Ubuntu jaunty "NoAccel") and mounted the failing image.
Attached is the Xorg.0.log. lspci will be in following attachment.

To me as an "ordinary user" the boot failure looks much like the blue screen I get if I don't use "NoAccel" and I don't use "AccelMethod" "uxa" which I assumed was bug 304871?


jerrylamos (jerrylamos) wrote :

Attached is the lspci -vvnn showing Intel 82845 VGA. I also have an IBM Thinkpad R31 with Intel 82830 which to me as a user fails in the same way. I can try to attach its Xorg.0.log as well.


jerrylamos (jerrylamos) wrote :

jaunty using "uxa" boots to tan screen dead keyboard movable cursor only on IBM Thinkpad R31. Rebooted with "NoAccel" to make this entry.

Linux version 2.6.28-7-generic (buildd@palmer) (gcc version 4.3.3 (Ubuntu 4.3.3-3ubuntu2) ) #20-Ubuntu SMP Mon Feb 9 15:43:21 UTC 2009

VGA compatible controller: Intel Corporation 82830 CGC [Chipset Graphics Controller] (rev 04)

Section "Device"
        Identifier "Configured Video Device"
        Driver "Intel"
# Option "NoAccel"
       Option "AccelMethod" "uxa"
        Option "ModeDebug" "true"
        Option "FallbackDebug" "true"

full lspci -vvnn will follow in another attachment.

I can make this a new bug - what should the title be?

Thanks, Jerry

jerrylamos (jerrylamos) wrote :

Here's the lspci -vvnn


Geir, I changed this bug report as a duplicate of 304871.

Geir Ove Myhr (gomyhr) wrote :

Jerry, you should file this as a new bug. The title can be something like "[i845] Xorg hangs with UXA enabled" (I only skimmed through your comments, but if it seems right, it could be a good title). Please upload the log files to that new bug report as well. This bug report has been marked a duplicate by the original reporter and is not likely to be followed up.

Bryce Harrington (bryce) on 2009-03-31
summary: - [i865G] UXA locks up system
+ [i865G] UXA locks up system (UXA bug)

Setting this to wishlist since we're not shipping with UXA enabled by default yet.
This bug should be fixed before we switch on UXA for this chipset.

Changed in xserver-xorg-video-intel (Ubuntu):
importance: Undecided → Wishlist
status: Incomplete → Triaged
Tomasz Czapiewski (xeros) wrote :

I've done some testing on i865G and I found that Xorg locks up with UXA (enabled manually by Option "AccelMethod" "UXA" in xorg.conf) when "drm" and "i830" kernel modules are not loaded - they are not loaded at startup time. It's strange that DRI is disabled by Xorg [(**) intel(0): DRI is disabled because it fails to run on 845G and 865G chips. (See LP 304871)] - even when passing Option "DRI" "true" to xorg.conf.
I've booted todays kubuntu jaunty i386 cd with EXA enabled by default on this chipset, then stoped KDM (checked in process list that "X" is not running - "ps aux | grep X"), then added 'Option "AccelMethod" "UXA"' in Device section in /etc/X11/xorg.conf. Next I've done 'sudo modprobe i830' in console so it loaded 'drm' and 'i830' modules - /dev/dri/card0 has appeared, then started pure Xorg by 'sudo X' - Xorg has run without problems (black screen but I suppose it's ok because on EXA and XAA have the same. Then I've installed 'xterm' and run 'DISPLAY=:0.0 xterm' as root on other console - then xterm connected but right after lost it's connection to xserver.

Then I saw that Xorg started from console showed this (just after the xterm tried to connect to X):
X: ../../src/i830_batchbuffer.h:78: intel_batch_emit_dword: Assertion `pI830->batch_ptr != ((void *)0)' failed.
(and core dumped, but I didn't found that core file by "find / -iname '*core*'" that would be core dump)

I'm attaching Xorg.0.log with that UXA start, too but I can't see errors there.

Then I've tried to modprobe and rmmod intel drm modules - insert i810 module (no error but no dri device), removing all drm modules - i830, i810 and drm - dri device in /dev/dri/card0 has disappeared and modules have unloaded (double checked by "lsmod | less" and "lsmod | grep i8", "lsmod | grep drm").
Then I've started X just the same way as before - it have not crashed or locked, connected xterm - then it has crashed with just the same error.

I've repeated the whole procedure 3 times (with rebooting cd) and always the same results - X locks up system with UXA when no drm modules loaded, but crashes X (when connecting xterm or other X apps) when drm kernel modules for this chipset are loaded - since then it crashes (not locks up) even when I unload kernel modues until I reboot and start once more from the same cd.
Kernel drm modules does not change anything with EXA or XAA - I've checked that, too. It could change somthing if DRI could be enabled at Xorg startup.

Maybe there were other modules than 'drm' and 'i830' which where loaded by 'modprobe i830' and I've should done diff from 'lsmod' before and after modprobe but I haven't thought about it then and I've didn't do it and now I don't have access to that hardware and probably wont have access to it until RC or stable release of Jaunty.

Can anyone confirm that?

Tomasz Czapiewski (xeros) wrote :
Bryce Harrington (bryce) on 2009-04-20
summary: - [i865G] UXA locks up system (UXA bug)
+ [i865G] UXA freezes system (UXA bug)
Bryce Harrington (bryce) on 2009-05-01
summary: - [i865G] UXA freezes system (UXA bug)
+ [i865G] UXA freezes system on startup (UXA bug)
Bryce Harrington (bryce) wrote :

For Karmic we're making UXA bugs like these a top priority, so I would like to forward this one upstream. First though, we need to verify the issue still exists with the latest upstream release. Would you please install and test the 2.7.0 driver and reproduce the bug, and let us know ASAP? A PPA with a Jaunty version of this driver is available at: https://edge.launchpad.net/~ubuntu-x-swat/+archive/x-updates/

Changed in xserver-xorg-video-intel (Ubuntu):
status: Triaged → Incomplete
Bryce Harrington (bryce) on 2009-05-02
Changed in xserver-xorg-video-intel (Ubuntu):
importance: Wishlist → High
Marques Johansson (marques) wrote :

I tested this yesterday. There was no improvement. (2.7.0 - newer libdrm - i865).

You can see the problems right from gdm without logging in. When typing in the username, there is corruption in the characters (some don't appear until after another is added) and the field will switch to italic and back without pressing a key.

After logging in, the system locks. sys rq+i kills X, but does't flip back to the terminal. The system locks up entirely after that because you can't login from the terminal (no backspace beeps).

sysreq+b will still reboot the system.

jerrylamos (jerrylamos) wrote :

karmic with 2.6.30-1 on IBM ThinkCentre with Intel i845 graphics running "uxa" O.K.

That's karmic by fresh install of jaunty ship level then changing sources.list and updating & upgrading daily. How do I tell which driver is being used?

jaunty with 2.6.30-rc4 on IBM Thinkpad with Intel i830 graphics fonts gradually deteriorate with characters adding pixels. It's a bit worse with 2.6.28-11. Intrepid doesn't have the problem at all.


Bryce Harrington (bryce) wrote :

Can you guys attach your /var/log/Xorg.0.log from after reproducing the issue on 2.7.0?

Also, Aram I'd like to hear from you if you've had a chance to test since you're the original reporter.

Bryce Harrington (bryce) on 2009-05-02
Changed in xserver-xorg-video-intel (Ubuntu):
status: Incomplete → New
status: New → Incomplete
Bryce Harrington (bryce) on 2009-05-05
Changed in xserver-xorg-video-intel (Ubuntu):
status: Incomplete → Triaged
Bryce Harrington (bryce) wrote :

Still waiting on info from Aram.

Also, for freeze bugs it is necessary to collect a DRI dump. For directions please see:

jerry, since you have a different chip than the original reporter, please report your issue as a separate bug. Certainly you could be seeing the same bug, but as the i830 has a distinctly different set of registers from i865, it is not certain.

Changed in xserver-xorg-video-intel (Ubuntu):
status: Triaged → Incomplete
jerrylamos (jerrylamos) wrote :

Bryce, I tried the x-freeze-test however this command:

sudo INTEL_DEBUG=batch /etc/init.d/gdm restart

results in a black screen. I can do Ctrl-Alt-F1 however I couldn't get any x display started.

I'm on rc4 with:

Module intel: vendor="X.Org Foundation"
 compiled for 1.6.0, module version = 2.6.3
 Module class: X.Org Video Driver
 ABI class: X.Org Video Driver, version 5.0

which does freeze from time to time requiring reboot. This is i830 so it would be a different bug #.

Any ideas on how to get the useful info so I can submit a bug report?
I'm dual boot so after a freeze I can bring up intrepid to look at the jaunty /var/logs.

Thanks, Jerry

On Wed, May 06, 2009 at 01:56:47AM -0000, jerrylamos wrote:
> Bryce, I tried the x-freeze-test however this command:
> sudo INTEL_DEBUG=batch /etc/init.d/gdm restart
> results in a black screen. I can do Ctrl-Alt-F1 however I couldn't get
> any x display started.

Are you able to gather the dump files from the console? Or ssh into the
box externally and do it. It shouldn't matter if X is black in this


Bryce Harrington (bryce) on 2009-05-06
tags: added: freeze
Bryce Harrington (bryce) on 2009-05-08
Changed in xserver-xorg-video-intel (Ubuntu):
status: Incomplete → New
status: New → Incomplete
Bryce Harrington (bryce) wrote :

We're closing this bug since it is has been some time with no response from the original reporter. However, if the issue still exists please feel free to reopen with the requested information. Also, if you could, please test against the latest development version of Ubuntu, since this confirms the bug is one we may be able to pass upstream for help.

Changed in xserver-xorg-video-intel (Ubuntu):
status: Incomplete → Invalid
To post a comment you must log in.