Ubuntu

[i845G] Fatal server error: Couldn't bind memory for BO front buffer (Jaunty)

Reported by Shirish Agarwal on 2008-12-03
228
This bug affects 20 people
Affects Status Importance Assigned to Milestone
xf86-video-intel
Fix Released
Critical
xserver-xorg-video-intel (Fedora)
Fix Released
Unknown
xserver-xorg-video-intel (Ubuntu)
High
Unassigned
Jaunty
High
Bryce Harrington

Bug Description

Since the change from the 2.4.1 driver to 2.5.1, Jaunty now hangs during boot, with "Fatal server error: Couldn't bind memory for BO front buffer" shown in the log.

This bug is ONLY for the issue on i845 graphics. While the same symptom can be seen with 855 and 865, the workaround and solution is different.

Also discussed at this forum: https://bugs.freedesktop.org/show_bug.cgi?id=18974

[Original Report]
Binary package hint: xserver-xorg-video-intel

Hi all,
 This is in jaunty, I get no screens.

[lspci]
00:00.0 Host bridge [0600]: Intel Corporation 82845G/GL[Brookdale-G]/GE/PE DRAM Controller/Host-Hub Interface [8086:2560] (rev 03)
00:02.0 VGA compatible controller [0300]: Intel Corporation 82845G/GL[Brookdale-G]/GE Chipset Integrated Graphics Device [8086:2562] (rev 03)
     Subsystem: Intel Corporation 82845G/GL[Brookdale-G]/GE Chipset Integrated Graphics Device [8086:2562]

Shirish Agarwal (shirishag75) wrote :
Shirish Agarwal (shirishag75) wrote :
Shirish Agarwal (shirishag75) wrote :
Shirish Agarwal (shirishag75) wrote :

I do have grub.cfg without the xforcevesa if that could be an issue?

Thank you for reporting this bug. Could you please also attche the following:
- /etc/X11/xorg.conf
- output of `lspci -vvnn`

Also, have you installed the libdrm-intel1 package? (see bug 303177)

Shirish Agarwal (shirishag75) wrote :

I have installed libdrm-intel1 package.

Attaching the output of lspci --vvnn

Shirish Agarwal (shirishag75) wrote :

Attaching the output of /etc/X11/xorg.conf

Shirish Agarwal (shirishag75) wrote :

My apt term.log

Bryce Harrington (bryce) on 2008-12-05
Changed in xserver-xorg-video-intel:
status: New → Confirmed

Created an attachment (id=20941)
Xorg.0.log

Forwarding this bug report from a Ubuntu reporter:
https://bugs.edge.launchpad.net/ubuntu/+source/xserver-xorg-video-intel/+bug/304871
Also seen on Fedora:
http://webui.sourcelabs.com/fedora/issues/461829

[Problem]
X hangs during boot with error "Couldn't bind memory for BO front buffer"

[lspci]
00:02.0 VGA compatible controller [0300]: Intel Corporation 82845G/GL[Brookdale-G]/GE Chipset Integrated Graphics Device [8086:2562] (rev 03)
 Subsystem: Intel Corporation 82845G/GL[Brookdale-G]/GE Chipset Integrated Graphics Device [8086:2562]

[Report]
Regression since 2.4.1 driver seen in 2.5.1 driver on 82845G/GL[Brookdale-G]/GE hardware. X hangs during start up and the following error message appears in the Xorg.0.log:

(EE) intel(0): Failed to pin front buffer: Cannot allocate memory

Fatal server error:
Couldn't bind memory for BO front buffer

Two other users indicated having a matching issue; one user was also on 845, the other on undeclared hardware. http://ubuntuforums.org/showthread.php?t=998754

Bryce Harrington (bryce) on 2008-12-09
Changed in xserver-xorg-video-intel:
importance: Undecided → High

Could be a 845-specific issue (in the forums link, one user saying he had the same issue also saw it on 845; the other user didn't indicate his hardware so who knows.) Anyone on hardware other than 845 able to reproduce it?

Anyway, I've forwarded it upstream here; please subscribe, etc.:
https://bugs.freedesktop.org/show_bug.cgi?id=18974

Changed in xserver-xorg-video-intel:
status: Unknown → Confirmed
Bryce Harrington (bryce) on 2008-12-09
description: updated
Jynx97 (jynx97) wrote :

Attaching the output of lspci --vvnn .

Changed in xserver-xorg-video-intel:
status: Unknown → Fix Released
DougieFresh4U (butcheeyboy) wrote :

I have the same 'Fatal error' messege, intel865G chipset. Stuck on 'vesa'
attached ispci as well

Bryce Harrington (bryce) wrote :

Thanks, so 865 is affected as well apparently. Anyone else seeing this same exact error?

description: updated

Eric says this error appears if you've got a memory allocation setup that doesn't fit in your apperture, and DRI2 will likely fix it.

I am seeing exactly this behaviour with Jaunty and 845 chipset on an IBM machine.

This is happening with the Intel 865G chipset as well

On a Dell OptiPlex GX270 (bios A07), with a current Jaunty (including libdrm-intel1 2.4.1-0ubuntu5), I have the same problems here:

(EE) intel(0): Failed to pin front buffer: Cannot allocate memory

Fatal server error:
Couldn't bind memory for BO front buffer

00:02.0 VGA compatible controller [0300]: Intel Corporation 82865G Integrated Graphics Controller [8086:2572] (rev 02) (prog-if 00 [VGA])
 Subsystem: Dell Device [1028:0151]
 Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
 Status: Cap+ 66MHz- UDF- FastB2B+ ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
 Latency: 0
 Interrupt: pin A routed to IRQ 16
 Region 0: Memory at f0000000 (32-bit, prefetchable) [size=128M]
 Region 1: Memory at feb80000 (32-bit, non-prefetchable) [size=512K]
 Region 2: I/O ports at ed98 [size=8]
 Capabilities: [d0] Power Management version 1
  Flags: PMEClk- DSI+ D1- D2- AuxCurrent=0mA PME(D0-,D1-,D2-,D3hot-,D3cold-)
  Status: D0 PME-Enable- DSel=0 DScale=0 PME-
 Kernel modules: intelfb

Anand Kumria (wildfire) wrote :

I was having this problem too.

I downgraded my kernel to 2.6.27 and things are working perfectly fine.

I suspect the problem is that libdrm is not correctly detecting that the kernel is not doing mode setting.

Twig (pfirth) wrote :

I confirm that downgrading to 2.6.27-8 also works for me. The desktop takes forever to load but I suspect that that is another issue.

Since I can't run X with the intel driver in its current state, I have been using the fbdev driver. Here are some details and (attached) log entries. I hope it can be of use:

sudo lspci -nnvv :

00:02.0 VGA compatible controller [0300]: Intel Corporation 82865G Integrated Graphics Controller [8086:2572] (rev 02) (prog-if 00 [VGA])
 Subsystem: Dell Device [1028:0151]
 Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
 Status: Cap+ 66MHz- UDF- FastB2B+ ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx+
 Latency: 0
 Interrupt: pin A routed to IRQ 16
 Region 0: Memory at f0000000 (32-bit, prefetchable) [size=128M]
 Region 1: Memory at feb80000 (32-bit, non-prefetchable) [size=512K]
 Region 2: I/O ports at ed98 [size=8]
 Capabilities: [d0] Power Management version 1
  Flags: PMEClk- DSI+ D1- D2- AuxCurrent=0mA PME(D0-,D1-,D2-,D3hot-,D3cold-)
  Status: D0 PME-Enable- DSel=0 DScale=0 PME-
 Kernel driver in use: intelfb
 Kernel modules: intelfb

Some lines from dmesg | grep -i -e intel -e drm -e agp:

[ 21.064321] Linux agpgart interface v0.103
[ 21.160181] agpgart-intel 0000:00:00.0: Intel 865 Chipset
[ 21.160644] agpgart-intel 0000:00:00.0: detected 8060K stolen memory
[ 21.162745] agpgart-intel 0000:00:00.0: AGP aperture is 128M @ 0xf0000000

[ 74.884390] intelfb: Framebuffer driver for Intel(R) 830M/845G/852GM/855GM/865G/915G/915GM/945G/945GM/945GME/965G/965GM chipsets
[ 74.884403] intelfb: Version 0.9.6
[ 74.884493] intelfb 0000:00:02.0: PCI INT A -> GSI 16 (level, low) -> IRQ 16
[ 74.884509] intelfb: 00:02.0: Intel(R) 865G, aperture size 128MB, stolen memory 8060kB
[ 74.888847] intelfb: Initial video mode is 1024x768-32@70.
[ 466.161347] [drm] Initialized drm 1.1.0 20060810
[ 466.201873] intelfb 0000:00:02.0: setting latency timer to 64
[ 466.210603] [drm] Initialized i915 1.6.0 20080730 on minor 0
[ 822.739357] [drm:i915_gem_object_bind_to_gtt] *ERROR* GTT full, but LRU list empty
[ 822.739365] [drm:i915_gem_object_pin] *ERROR* Failure to bind: -12<3>[drm:i915_gem_object_bind_to_gtt] *ERROR* GTT full, but LRU list empty
[ 827.341749] [drm:i915_gem_object_pin] *ERROR* Failure to bind: -12<3>[drm:i915_gem_object_bind_to_gtt] *ERROR* GTT full, but LRU list empty
[ 831.945566] [drm:i915_gem_object_pin] *ERROR* Failure to bind: -12<3>[drm:i915_gem_object_bind_to_gtt] *ERROR* GTT full, but LRU list empty
[ 1117.105987] [drm:i915_gem_object_pin] *ERROR* Failure to bind: -12<3>[drm:i915_gem_object_bind_to_gtt] *ERROR* GTT full, but LRU list empty
[ 1827.914660] [drm:i915_gem_object_pin] *ERROR* Failure to bind: -12

Created an attachment (id=21237)
intel driver failing to load on :1 while :0 is occupied with intelfb/fbdev driver

Bryce Harrington (bryce) on 2008-12-17
Changed in xserver-xorg-video-intel:
status: Confirmed → Triaged
DeJe (djenett) wrote :

I can confirm this bug with 855GM chipset.
For me, kernel 2.6.27 was working also. I cannot attach any logs cause I allready reformatted and removed Jaunty. I saw that this error still is in Alpha2 (https://wiki.ubuntu.com/JauntyJackalope/TechnicalOverview#Known%20Issues) so I wait testing Jaunty until at least X is working correctly. ;)

Jynx97 (jynx97) wrote :

Still seeing this issue, adding new Xorg log.

Mahesh Asolkar (asolkar) wrote :
Mahesh Asolkar (asolkar) wrote :

Same issue with 'Intel Corporation 82852/855GM Integrated Graphics Device rev 2'.

manzur (sl-solaris) wrote :

I can confirm this bug with i845 chipset

I was experiencing this problem with an old uniwell laptop (intel graphics), and have a partial resolution by changing the color depth from 24 to 16 bit, i.e. add
DefaultDepth 16
to the screen section of /etc/X11/xorg.conf

Partial resolution means I can achieve default resolution 1280x800 at 16 bit color using the intel driver

Created an attachment (id=21481)
Xorg.0.log

same problem here:
(EE) intel(0): Failed to pin back buffer: Cannot allocate memory

(Xorg.0.log ist attached)

lspci:
00:02.0 VGA compatible controller: Intel Corporation 82852/855GM Integrated Graphics Device (rev 02)

kernel: 2.6.28

using 'Option "Legacy3D" "false"' I get working 2D but no 3D:
[intel_init_bufmgr:497] Error initializing buffer manager.
X Error of failed request: BadAlloc (insufficient resources for operation)
  Major opcode of failed request: 154 (GLX)
  Minor opcode of failed request: 3 (X_GLXCreateContext)
  Serial number of failed request: 24
  Current serial number in output stream: 27

This bug is also present in xf86-video-intel-2.5.99.1

Created an attachment (id=21482)
Failure log

The same on intel 855GME here,

x11-base/xorg-server-1.5.3
x11-drivers/xf86-video-intel-2.5.1
x11-libs/libdrm-2.4.1
media-libs/mesa-7.2
sys-kernels/gentoo-sources-2.6.28
Gentoo Linux

cat ~/Xorg.0.log | grep -C3 "(EE)"
 to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
 (++) from command line, (!!) notice, (II) informational,
 (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Fri Dec 26 01:06:28 2008
(==) Using config file: "/etc/X11/xorg.conf"
(==) ServerLayout "Simple Layout"
--
(II) intel(0): xf86BindGARTMemory: bind key 4 at 0x03bfe000 (pgoffset 15358)
(II) intel(0): xf86BindGARTMemory: bind key 5 at 0x03bff000 (pgoffset 15359)
(II) intel(0): xf86BindGARTMemory: bind key 6 at 0x059ff000 (pgoffset 23039)
(EE) intel(0): Failed to pin front buffer: Cannot allocate memory

Fatal server error:
Couldn't bind memory for BO front buffer

Marques Johansson (marques) wrote :

I tried setting the DefaultDepth to 16, but that caused X to lock up (mouse worked, could not type in the log in prompt) after a few seconds (less than 15).

I tried adding NoAccel and that is allowing me to use X at 1920x1200, without compiz.

Both logs are attached.

Marques Johansson (marques) wrote :
Marques Johansson (marques) wrote :

The errors and warnings in the NoAccel log I attached are:

(WW) intel(0): libpciaccess reported 0 rom size, guessing 64kB
(WW) intel(0): Register 0x70024 (PIPEASTAT) changed from 0x80000207 to 0x00000000
(WW) intel(0): PIPEASTAT before: status: FIFO_UNDERRUN VSYNC_INT_STATUS SVBLANK_INT_STATUS VBLANK_INT_STATUS OREG_UPDATE_STATUS
(WW) intel(0): PIPEASTAT after: status:
(EE) intel(0): Failed to init memory manager

That first error message yields some google matches. I thought EE was a dead end for X, but this log is from the active session.

Marques Johansso, can you put up your xorg.conf ?
--
          Regards,
          Shirish Agarwal
  This email is licensed under http://creativecommons.org/licenses/by-nc/3.0/
http://flossexperiences.wordpress.com
065C 6D79 A68C E7EA 52B3 8D70 950D 53FB 729A 8B17

Marques Johansson (marques) wrote :

It's the vanilla xorg.conf with 'Option "NoAccel" "true"' added. I have some other junk in there, but that's all it is.

Section "Device"
 Identifier "Configured Video Device"
# when intel doesn't work, modprobe intelfb and use these instead of 'driver "intel"'
# Driver "fbdev"
# Option "UseFBDev" "true"
 Driver "intel"

 Option "NoAccel" "true" # works around LPB 304871 - probably disables the next two
 Option "XvMC" "true" # Enabled for no particular reason
 Option "TripleBuffer" "true" # Enabled for no particular reason
 Option "ModeDebug" "true" # More Verbose logging
 Option "FallbackDebug" "true" # More Verbose logging
EndSection

Section "Monitor"
 Identifier "Configured Monitor"
EndSection

Section "Screen"
# 16BPP is a possible work around for LPB 304871 that only locks me up at
# 2.6.28-3-generic, xserver-xorg-video-intel 2:2.5.1-1ubuntu7
# DefaultDepth 16
 Identifier "Default Screen"
 Monitor "Configured Monitor"
 Device "Configured Video Device"
EndSection

Marques Johansson (marques) wrote :

I've also used a daily Jaunty live CD while this bug has existed, and strangely enough, the CD which uses the latest xorg and 2.6.28 kernel doesn't give me this problem. Maybe it disables acceleration also - I didn't check.

Marques Johansson (marques) wrote :

The log shows that my XvMC is disabled, but if you are going to copy my config line per line, you may also want to make sure the file "/etc/X11/XvMCConfig" has this single line:
libIntelXvMC.so.1

Shirish Agarwal (shirishag75) wrote :

I also get few warnings

(WW) The directory "/usr/share/fonts/X11/cyrillic" does not exist.
(WW) intel(0): libpciaccess reported 0 rom size, guessing 64kB
(WW) intel(0): Register 0x70024 (PIPEASTAT) changed from 0x80000207 to 0x00000000
(WW) intel(0): PIPEASTAT before: status: FIFO_UNDERRUN VSYNC_INT_STATUS SVBLANK_INT_STATUS VBLANK_INT_STATUS OREG_UPDATE_STATUS
(WW) intel(0): PIPEASTAT after: status:
(WW) config/hal: device AT Translated Set 2 keyboard already added. Ignoring.

Bryce Harrington (bryce) on 2009-01-14
description: updated
Gavin Tweedie (gav-narx) wrote :

Pretty sure I'm hitting this too with an Intel 915GM/GMS/910GML chipset. Can supply logs if useful in addition to what is already attached.

Temp workaround for me was to switch to Vesa driver.

I have the same setup than Yu Yuwei, and I want to add that if I boot a 2.6.27 kernel, xorg starts without problems.
It is only with the 2.6.28 kernel that I can reproduce the failure.

manzur (sl-solaris) wrote :

i confirm this too, i can not use jaunty jackalope because of this bug, i am using:
Intel(r) 82845G/GL/GE/PE/GV Graphic Controller

Bryce Harrington (bryce) on 2009-01-30
Changed in xserver-xorg-video-intel:
status: Triaged → Incomplete
Bryce Harrington (bryce) on 2009-02-04
Changed in xserver-xorg-video-intel:
status: Incomplete → Triaged
Changed in xserver-xorg-video-intel:
assignee: nobody → bryceharrington
83 comments hidden view all 163 comments

(In reply to comment #21)
> Gordon, please would you mind giving us an update on the status of this bug?

I don't have more update. Eric owns this bug.

On Sat, Mar 21, 2009 at 2:04 PM, jerrylamos <email address hidden> wrote:

> Video YouTube Leona Lewis "Run" and scrolled while the video was going.
> The only problem besides the small fonts is now i cant log-in with the
> newest kernal, but the older kernal i'am able to log-in.
> No problem. Video, audio, & scroll all at the same time. Must be time
> for a new update!
>
> VGA compatible controller: Intel Corporation 82845G/GL[Brookdale-G]/GE
> Chipset Integrated Graphics Device (rev 01)
>
> Linux version 2.6.28-11-generic (buildd@rothera) (gcc version 4.3.3
> (Ubuntu 4.3.3-5ubuntu4) ) #36-Ubuntu SMP Fri Mar 20 19:40:40 UTC 2009
>
> Jerry
>
> --
> [i845G] Fatal server error: Couldn't bind memory for BO front buffer
> (Jaunty)
> https://bugs.launchpad.net/bugs/304871
> You received this bug notification because you are a direct subscriber
> of the bug.
>

(In reply to comment #22)
> I also suffered from this bug.
> But recently I found out, that it only happened, when there is a
> "Virtual"-option in my Xorg.conf:
> Section "Screen"
> Identifier "Screen0"
> Device "Device0"
> Monitor "LVDS"
> DefaultDepth 24
> SubSection "Display"
> Modes "1280x800_60"
> Virtual 2960 1056
> EndSubSection
> EndSection
>
> When I removed the Virtual-option, everything went fine.
>
> The other day i reinstalled my system (Arch Linux) and installed the newest
> packages from the testing-repository.
> Namely those packages are:
> xf86-video-intel 2.6.99.902-1
> libdrm 2.4.5-2
> mesa 7.3-2
> xorg-server 1.6.0-1
>
> After a few changes in my Xorg.conf I came to these settings:
> Section "Device"
> Identifier "Device0"
> Driver "intel"
> Option "Legacy3D" "true"
> Option "DRI" "true"
> Option "AccelMethod" "uxa"
> Option "ExaNoComposite" "true"
> EndSection
>
> I put the Virtual-section back in - I need my 22" lcd ;)
>
> And what do my eyes see?
> Everything works!
>
> I also tried the latest xf86-video-intel via GIT. Same thing there.
> I installed ioquake3 - and woohoo! 90fps.
>
> Everything's great right now.
>
> Maybe someone could try those Xorg.conf-settings and the latest git-version.
>
> Regards,
> karsten
>

This solution is not workable for me with xf86-video-intel-2.6.1 and kernel-2.6.28.8 :(

javajazz (randister) wrote :

@ubuntu:~$ lspci
00:00.0 Host bridge: Intel Corporation 82865G/PE/P DRAM Controller/Host-Hub Interface (rev 02)
00:02.0 VGA compatible controller: Intel Corporation 82865G Integrated Graphics Controller (rev 02)
00:1d.0 USB Controller: Intel Corporation 82801EB/ER (ICH5/ICH5R) USB UHCI Controller #1 (rev 02)
00:1d.1 USB Controller: Intel Corporation 82801EB/ER (ICH5/ICH5R) USB UHCI Controller #2 (rev 02)
00:1d.2 USB Controller: Intel Corporation 82801EB/ER (ICH5/ICH5R) USB UHCI Controller #3 (rev 02)
00:1d.7 USB Controller: Intel Corporation 82801EB/ER (ICH5/ICH5R) USB2 EHCI Controller (rev 02)
00:1e.0 PCI bridge: Intel Corporation 82801 PCI Bridge (rev c2)
00:1f.0 ISA bridge: Intel Corporation 82801EB/ER (ICH5/ICH5R) LPC Interface Bridge (rev 02)
00:1f.1 IDE interface: Intel Corporation 82801EB/ER (ICH5/ICH5R) IDE Controller

as others above i could only get into kde by setting DRI to false within the device section of xorg.conf.

I boot into the cli and then startx. No kdm. before the DRI fix, it would typically freeze during the splash sequence, though sometimes it would make it to the desktop with mouse moving but otherwise not functioning. No keyboard either.

it is 3/22/09 and i am updated to all the latest jaunty versions of kernel and intel and xorg and libdrm; and still not working for the 865g without a hack.

Anyway! Yes running a video will crash the desktop. Most of the time i end up at the cli (no kdm) with xorg messages there in print to read. the xorg.0.log message says "could not pin xv". so i startx into kde and open mplayer and and go to preferences to set video from xv to gl. then to real player to turn xv off. then to electricsheep screensaver to set it from xv to gl. I control alt backspace and then startx again and yes i can do the electricsheep without crashing the desktop. Oh, by the way, electricsheep uses mplayer to run the sheep.

Those interested, please note: in systemsettings within the desktop icon/desktop effects/advanced tab; I have compositing type set to "xrender". I had to change it from the default "opengl" to get transparent effects in the panel and for konsole and some plasmoids.

Those still interested please also note: I have been running jaunty for months. I have been using the xorg packages from intrepid. Everything on my system is the latest jaunty versions, except xorg. everything has worked "fine" "slow but functional" for months. if interested and AT YOUR OWN risk, just go to packages.ubuntu.com and download the xorgs you need from intrepid. then do "apt-get --purge remove xserver-xorg". now go to directory containg all those xserver-xorg packages and do a "dpkg -i xserver*". i must have gone back and forth with this a number of times. every time the repositories show a new version of xorg-intel i do a full upgrade and crash the desktop. lukily i got my little stash of intrepid xorg to get me back in.

THANKS guys for showing me the way with DRI false. Thanks.

Hello

for Device :

00:02.0 VGA compatible controller: Intel Corporation 82852/855GM Integrated Graphics Device (rev 02)

bug fixed with next xorg.conf config Video Device:

Section "Device"
        Identifier "Configured Video Device"
        Driver "intel"
        Option "XvMC" "true"
        Option "AccelMethod" "UXA"
EndSection

I have acceleration and not have problem with video ... ;-)

THANKS

Thanks for the input.

With an Intel 82865G my system locks up tight using UXA.

The following works except for some video:

Section "Device"
    VendorName "Intel Corporation"
    BoardName "Intel 82865G"
    Identifier "82865G Integrated Graphics Controller"
    Driver "intel"
    BusID "PCI:0:2:0"
    Option "DRI" "False"
# Option "NoAccel" "True"
EndSection

To run some video the 'NoAccel' line has to be:
    Option "NoAccel" "True"

We have to hope that this does get fixed at some point.

2009/3/25 segato <email address hidden>

> Hello
>
> for Device :
>
> 00:02.0 VGA compatible controller: Intel Corporation 82852/855GM
> Integrated Graphics Device (rev 02)
>
> bug fixed with next xorg.conf config Video Device:
>
> Section "Device"
> Identifier "Configured Video Device"
> Driver "intel"
> Option "XvMC" "true"
> Option "AccelMethod" "UXA"
> EndSection
>
> I have acceleration and not have problem with video ... ;-)
>
> THANKS
>
> --
> [i845G] Fatal server error: Couldn't bind memory for BO front buffer
> (Jaunty)
> https://bugs.launchpad.net/bugs/304871
> You received this bug notification because you are a direct subscriber
> of a duplicate bug.
>
> Status in X.org xf86-video-intel: Confirmed
> Status in “xserver-xorg-video-intel” source package in Ubuntu: Triaged
> Status in xserver-xorg-video-intel in Ubuntu Jaunty: Triaged
> Status in “xserver-xorg-video-intel” source package in Fedora: Fix Released
>
> Bug description:
> Since the change from the 2.4.1 driver to 2.5.1, Jaunty now hangs during
> boot, with "Fatal server error: Couldn't bind memory for BO front buffer"
> shown in the log. So far, this has been seen by two people with i845
> graphics and two with i865.
>
> Also discussed at this forum:
> https://bugs.freedesktop.org/show_bug.cgi?id=18974
>
> [Original Report]
> Binary package hint: xserver-xorg-video-intel
>
> Hi all,
> This is in jaunty, I get no screens.
>
>
>
> [lspci]
> 00:00.0 Host bridge [0600]: Intel Corporation 82845G/GL[Brookdale-G]/GE/PE
> DRAM Controller/Host-Hub Interface [8086:2560] (rev 03)
> 00:02.0 VGA compatible controller [0300]: Intel Corporation
> 82845G/GL[Brookdale-G]/GE Chipset Integrated Graphics Device [8086:2562]
> (rev 03)
> Subsystem: Intel Corporation 82845G/GL[Brookdale-G]/GE Chipset
> Integrated Graphics Device [8086:2562]
>
>

Stefan Glasenhardt (glasen) wrote :

Hi,

There are two possible solutions for this bug (at least for all 855GM-based hardware owners) :

Add the following line to your Device-Section in the "xorg.conf"-file :

Option "Legacy3d" "false"

With this option i can use EXA an 3D-acceleration an my DELL Latitude D505.

Second option :

Include the following git-commit into the driver version 2.6.3 :

"Drop Legacy3D option, only use fixed texture space with non-gem."

http://cgit.freedesktop.org/xorg/driver/xf86-video-intel/commit/?id=73db44e7ac524e84e5f0fda2d60069a9e954ad1b

This patch works perfectly with driver version 2.6.3 on my notebook and the "Legacy3D" option is no longer needed.

Hello

with this xorg.conf :

Section "Device"
        Identifier "Configured Video Device"
        Driver "intel"
        Option "XvMC" "true"
        Option "AccelMethod" "UXA"
EndSection

I have problem with de VGA output, and this VGA config found use this config :

Section "Device"
        Identifier "Configured Video Device"
        Driver "intel"
       Option "DRI" "false"
EndSection

I do change this config to use the VGA in my notebook ...

VGA output BUG NOT CLOSED

:'(

Saludos from Chile

Scott Kitterman (kitterman) wrote :

Using the 9.04 Beta Live CD it starts on my Intel 865GBF motherboard.

0000:00:02.0 VGA compatible controller: Intel Corporation 82865G Integrated Graphics Controller (rev 02) (prog-if 00 [VGA])
        Subsystem: Intel Corporation: Unknown device 4246
        Flags: bus master, fast devsel, latency 0, IRQ 11
        Memory at f0000000 (32-bit, prefetchable) [size=128M]
        Memory at ffa00000 (32-bit, non-prefetchable) [size=512K]
        I/O ports at ec00 [size=8]
        Capabilities: [d0] Power Management version 1

Bryce Harrington (bryce) wrote :

Hrmph, no word from upstream, no word from the original reporter.

Of the other commenters, some say the issue is fixed. Others (mostly 845G and 865G users) say it's still there but goes away once DRI is disabled.

It is easy enough to force DRI off for all 845G and 865G chips. I've put a patch to do this into my ppa. I would ask that 845 and 865 users please test it and verify it fixes the issue, without requiring setting anything in your xorg.conf. If it does, I can upload it.

If anyone does not think we should do this change, now's the time to speak up, but provide an explanation why.

Bryce Harrington (bryce) wrote :
Changed in xserver-xorg-video-intel (Ubuntu Jaunty):
status: Triaged → In Progress
wilbur (wilburgr) wrote :

Intel 82865G user.

Before doing the patch I would like to know what the DRI actually does and
what will be lost by patching it out. I am one of those for whom the problem
is definitely not resolved. Things like flash and video are not working
correctly or not working at all to the point where I am off looking at other
distos.

Option "XvMC" "true" does not seem to help
Option "DRI" "False" has to be false or lockup
Option "NoAccel" "True" has to be true to play videos
makes the system unpleasant to use for other things.
Option "AccelMethod" "UXA" causes lockup EXA seems OK
Option "DPMS" "false" no change noted
Option "Legacy3d" "false" no change noted

So most of the time I run with the 'NoAccel' option commented out but
activate it and restart X if I want to run a video. Some flash will not run,
for example the Dow Jones chart at
http://www.google.com/finance?q=INDEXDJX:.DJI which used to work perfectly
in 8.10 and seems to work well in a number of other distros I have tried.

At the moment 9.04 is a crippled OS with the Intel 82865G. I hope it gets
fixed and that we are not left stranded.

Many thanks for the DRI patch I will give it a try and report back.

Julian Lam (julian-lam) wrote :

Here to report that Stefan Glasenhardt's workaround works perfectly.

I added the line:
Option "Legacy3d" "false"

to xorg.conf, which enabled hardware acceleration, allowing me to get to the desktop WITH compiz. Perfect!

I've attached the requested outputs.

1 comments hidden view all 163 comments
javajazz (randister) wrote :

VGA compatible controller: Intel Corporation 82865G Integrated Graphics Controller (rev 02)

am running the latest from the jaunty repositories and still no satisfaction with electricsheep screensaver, that uses mplayer to run an avi. It will only show up in a window and not full screen as it used to do with xorg from intrepid repositories. will not work when running a 2.6.29 kernel either.

but the good news is that all flash and other videos work, I only miss my full screen electricsheep.

I do have to set DRI to false within xorg.conf because otherwise i will never make it to the kde4 desktop. AND I have to set all video apps to not use "xv" because otherwise it will crash the desktop when i run a video. i currently have mplayer set to use "x11". "gl" is too slow.

do i need to buy an nvidea card!!!!!? I will not leave ubuntu!!

wilbur (wilburgr) wrote :

March 12, 11:37pm
I installed the update with an interesting result. Now when I run a video it
is exactly the same result as pressing Ctl-Alt-Bksp. Without any warning X
is gone and after a black screen the login screen comes up and then X. So
now running a video is a software X restart. If I can figure out what is the
trigger then it will be posted. Tomorrow I will try changing some of the
Options in xorg.conf.

2009/3/27 Bryce Harrington <email address hidden>

> PPA with this fix:
>
> https://edge.launchpad.net/%7Ebryceharrington/+archive/ppa/+sourcepub/535882/+listing-archive-extra
>
> ** Changed in: xserver-xorg-video-intel (Ubuntu Jaunty)
> Status: Triaged => In Progress
>
> --
> [i845G] Fatal server error: Couldn't bind memory for BO front buffer
> (Jaunty)
> https://bugs.launchpad.net/bugs/304871
> You received this bug notification because you are a direct subscriber
> of a duplicate bug.
>
> Status in X.org xf86-video-intel: Confirmed
> Status in “xserver-xorg-video-intel” source package in Ubuntu: In Progress
> Status in xserver-xorg-video-intel in Ubuntu Jaunty: In Progress
> Status in “xserver-xorg-video-intel” source package in Fedora: Fix Released
>
> Bug description:
> Since the change from the 2.4.1 driver to 2.5.1, Jaunty now hangs during
> boot, with "Fatal server error: Couldn't bind memory for BO front buffer"
> shown in the log. So far, this has been seen by two people with i845
> graphics and two with i865.
>
> Also discussed at this forum:
> https://bugs.freedesktop.org/show_bug.cgi?id=18974
>
> [Original Report]
> Binary package hint: xserver-xorg-video-intel
>
> Hi all,
> This is in jaunty, I get no screens.
>
>
>
> [lspci]
> 00:00.0 Host bridge [0600]: Intel Corporation 82845G/GL[Brookdale-G]/GE/PE
> DRAM Controller/Host-Hub Interface [8086:2560] (rev 03)
> 00:02.0 VGA compatible controller [0300]: Intel Corporation
> 82845G/GL[Brookdale-G]/GE Chipset Integrated Graphics Device [8086:2562]
> (rev 03)
> Subsystem: Intel Corporation 82845G/GL[Brookdale-G]/GE Chipset
> Integrated Graphics Device [8086:2562]
>
>

javajazz (randister) wrote :

Intel Corporation 82865G Integrated Graphics Controller (rev 02)

the latest xorg upgrade from the jaunty repository now allows me to get into the kde4 desktop without having to set DRI to false. Yipee!

BUT, running mplayer with the "xv" driver, still, will knock me right out of kde4. and "xv" is the only way i can get electricsheep to run full screen. I have to set the driver to "x11" for videos to work. But as stated in previous posts, my electricsheep will only run in a window, not fullscreen, if set to "x11". It will run in fullscreen if I set mplayer to use "xv" driver and i revert to xorg from the intrepid repository.

anyway. congrads. you are half way there.

fix the "xv". please. I want my eye candy fullscreen.

and why is electricshhep not a default option for kde4? I had to hack it in with trial and error making a electricsheep.desktop file.

wilbur (wilburgr) wrote :

There seem to be different problems with Intel 865G video.

One is that DRI has to be disabled with
Option "DRI" "False" in /etc/xorg.conf
or with the patch from Bryce (Thanks)
http://launchpadlibrarian.net/24434513/116_846g_865g_disable_dri.patch
https://bugs.launchpad.net/bugs/304871.

Another is the acceleration. To play video (badly)
Option "NoAccel" "True" has to be set.

This setting is not practical for other use and not much good for video
other than it does not crash the system.

There are problems with all sorts of video, flash, mplayer, slide shows to
name three. Some lead to an instant restart of X, a software Ctl-Alt-Bksp,
while others simply do not play at all, cause lock up or display badly.

The system boots to lockup with UXA enabled.

Nothing additional in the logs.

If anyone has any ideas to try or tests to run please post them.

Bryce Harrington (bryce) wrote :

Alright, there are just waaaay too many different things going on with this bug.

The original problem which is targeted for jaunty is the fatal server error on 845.

The problem people are having with video, requiring NoAccel to be used is a separate bug. File a new report on that; don't comment further about it here.

From the comments, there are reporters for 845, 855, 865, and other chips, and the symptoms/fixes for each seem to be different.

845: From the last couple comments from 845 users jerrylamos and j-de-cuba it seems the issue on 845 is solved with the latest updates. Other 845 users including the original reporter have not commented further; I guess we have to assume they're not commenting because the issue is gone. So 845 is solved. Great.

855: This chip seems to be in much better shape. Many users find UXA solves the issue. Others not so much. The Legacy3D patch seems necessary for this. However I think we need to handle the 855 bugs separately from the 845 ones. So this needs to go to a different bug report.

865: From comments from randister and kitterman this may now be fixed with latest updates. Otherwise, disabling DRI solves the problem. Video is still broken but as I mentioned, that should be a separate bug.

bryce i just tested todays daily jaunty 32bits on an Dell GX270 with Intel 865 and it failed to boot the installer.
Only using Safe Graphics and having VESA on xorg.cong

FYI adding DRI false seems to work

Bryce Harrington (bryce) wrote :

I've unduped the non-845 bugs from this one. Non-845 users should unsub from this one and sub to the appropriate one:

bug 304871 - [i845] couldn't bind memory for BO backbuffer on 845

bug 322646 - [i855] couldn't bind memory for BO backbuffer on 855

bug 317457 - [i865] freeze, works only with dri false

bug 328528 - [i865] UXA locks up system (UXA bug)

If your issue doesn't fit into one of the above bugs, file a NEW one.

description: updated
Bryce Harrington (bryce) wrote :

As per the last two comments from the two most recent 845 reporters, the issue on i845G chips has been resolved with latest updates as of 2009-03-21.

Please do not reopen this bug unless you have i845 graphics and see the exact error message "Couldn't bind memory for BO front buffer".

Changed in xserver-xorg-video-intel (Ubuntu Jaunty):
status: In Progress → Fix Released
Julian Lam (julian-lam) wrote :

Thank you Bryce, et al.! Today's released fix worked perfectly. I can finally empty my xorg.conf file :)

Daniël H. (daan-is-here) wrote :

Well, after this update the scrolling and window management behavior sucks.

Daniël H. (daan-is-here) wrote :

I'm sorry, after resetting xorg.conf this problem was resolved. Strange, because I didn't ever changed it manually. Maybe because I did a upgrade from Intrepid?

Étienne BERSAC (bersace) wrote :

Hi,

I confirm the bug is fixed on MacBook White 4,1 (GMA 965)

Regards,
Étienne.
--
E Ultreïa !

Feistybird (bryanjen-tw) wrote :

Worked but get broken picture on some applications such as java applets & firefox. See images attached.

-PCI Devices-
VGA compatible controller : Intel Corporation 82845G/GL[Brookdale-G]/GE Chipset Integrated Graphics Device

jerrylamos (jerrylamos) wrote :

On Release Candidate, launchpad bug #304871 is back in spades. Integrated Intel graphics i845 boots to black screen on CD Live and install on Ubuntu and Xubuntu.

I had to boot CD Live, edit command line, remove quiet splash, add single to get recovery mode. Then in root prompt nano /etc/X11/xorg.conf to add Option "NoAccel" just after "Configured Video Device".

Same thing on install.

Update Manager lists 49 updates already, NONE of them in xorg to fix this bug again.

Performance is sluggish on scroll etc to say the least.

What happened? It was fine on Beta?

Jerry

jerrylamos (jerrylamos) wrote :

Today's updates, April 17, did fix the problem for the installed Xubuntu. Will try Ubuntu next. There weren't any xorg updates but there was a kernel update.

The release candidate (as in Daily Build 20090414) boots to black screen unless I do "NoAccel".

Thanks, someone, hope the CD Live gets fixed too.

Jerry

Edmond Thiebaud (thiebaude) wrote :

in 9.04 after login x freezes and then the OS is unusable on the Intel i815 graphics chip,so went back to 8.10 for now, until a fix is found.

HeWhoE (hewhoe) wrote :

On my 82845G/GL[Brookdale-G]/GE chipset, with the latest Jaunty updates as of April 20, I get the following error after I start X.

(EE) intel(0): Failed to init memory manager

(In reply to comment #15)

> _fence_emit_internal: drm_i915_irq_emit: -22

I just replicated this part of the bug at least, (with all the latest userspace, such as xf86-video-intel 2.7.99 from git), and a non-GEM Debian kernel (2.6.26-2-686).

Eric suggests that when the userspace opens the drm and finds that it's non-GEM it should just close it. I'll attempt that here and report back.

-Carl

(In reply to comment #25)
> (In reply to comment #15)
>
> > _fence_emit_internal: drm_i915_irq_emit: -22
>
> I just replicated this part of the bug at least, (with all the latest
> userspace, such as xf86-video-intel 2.7.99 from git), and a non-GEM Debian
> kernel (2.6.26-2-686).
>
> Eric suggests that when the userspace opens the drm and finds that it's non-GEM
> it should just close it. I'll attempt that here and report back.

Eric had some half-finished patches for this which I finished and pushed (see below).

With these patches applied, the latest driver from git now runs just fine on the non-GEM Debian kernel (2.6.26-2-686). I'd be very interested if other people that have experienced the bugs reported here could try using the latest driver and report back whether the bug is fixed.

I'll also consider cherry-picking the relevant commits here to the 2.7 branch for an upcoming 2.7.2 release.

-Carl

(In reply to comment #26)
> Eric had some half-finished patches for this which I finished and pushed (see
> below).

Here's the "see below" part I forgot to add with the last comment.

-Carl

commit 8e942b70cb9a784b3f1311affd6fc74c4bcf68bb
Author: Carl Worth <email address hidden>
Date: Thu May 21 13:12:52 2009 -0700

    Revert "Rely on BO pixmaps being present in acceleration paths."

    This reverts commit 4653a7db622ad54a3182d93c81331765d930db34.

    Eric was getting a little too ambitious about our brave, new world.
    We do still want the driver to work with old, non-GEM kernels
    after all.

commit 1a039f4371bec455cad43f0fb7b329f2ee09a974
Author: Eric Anholt <email address hidden>
Date: Mon Apr 27 17:45:02 2009 -0700

    Fold GEM detection into DRM master open.

    We don't have anything to do with the DRM unless it's GEM-enabled, unless
    we were to support GEM-but-not-DRI2, which doesn't seem useful.

    Compilation fixes by Carl Worth <email address hidden>

commit a04a51c9bb6066454e0fda3c7897f97dab436358
Author: Eric Anholt <email address hidden>
Date: Mon Apr 27 17:29:36 2009 -0700

    Open the DRM and keep the handle throughout server startup to finish.

    This will let us configure the server from start to finish with the
    most pertinent information available (KMS vs UMS, DRI2 vs non-DRI). Also,
    we now close the DRI2 fd at terminate, which we didn't before.

    This duplicates some code from DRI1 for getting a master FD like I'd done in
    DRI2, but given that we weren't loading DRI1 ourselves, this is also a
    bogosity cleanup, and avoids allocating the extra DRI1 private.

Could any of the reporters confirm this problem still exists with the latest xf86-video-intel driver and a KMS kernel? If so, I'll increase the priority and target for Q2 release (2.8).

I used to see this with a 2.5-era xf86-video-intel and now I do not with current git stuff and KMS.

In fact, I get an explicit success message:
(II) intel(0): BO memory allocation layout:
(II) intel(0): 0x00000000: start of memory manager
(II) intel(0): 0x03800000-0x03ffffff: front buffer (8192 kB) X tiled
(II) intel(0): 0x03000000-0x03004fff: HW cursors (20 kB)
(II) intel(0): 0x07fff000: end of memory manager

This is on 845.

So I assume it has been fixed.
If anyone still see this with a new driver (>=2.6.99.901) and KMS kernel, please reopen.

(In reply to comment #30)
> So I assume it has been fixed.
> If anyone still see this with a new driver (>=2.6.99.901)

typo. I meant 2.7.99.901.

Changed in xserver-xorg-video-intel:
status: Confirmed → Fix Released
Dan Astoorian (djast-ecf) wrote :

xserver-xorg-video-intel (2:2.6.3-0ubuntu9.3) for me is still reporting this in Xorg.0.log:

(**) intel(0): DRI is disabled because it fails to run without freezing on i810 and i865G chips. (See LP 304871)

i.e., the package still includes 116_8xx_disable_dri.patch.

My chipset is reported as "Intel Corporation 82865G Integrated Graphics Controller rev 2".

If the problem has been fixed, the patch should presumably be removed; if there are still problems not related to the fix associated with this bug, the message produced by the patch should be updated to refer to a more appropriate bug number.

tags: added: iso-testing
Changed in xserver-xorg-video-intel (Ubuntu):
assignee: Bryce Harrington (bryceharrington) → nobody
Changed in xserver-xorg-video-intel:
importance: Unknown → Critical
Changed in xserver-xorg-video-intel:
importance: Critical → Unknown
Changed in xserver-xorg-video-intel:
importance: Unknown → Critical
Displaying first 40 and last 40 comments. View all 163 comments or add a comment.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.