Ubuntu

[i965 mesa] reflection plugin freezes systems with Intel GM965

Reported by Jaime on 2008-11-15
106
This bug affects 19 people
Affects Status Importance Assigned to Milestone
xserver-xorg-video-intel (Ubuntu)
High
Abdul Rehman Ghori
Nominated for Karmic by herowill

Bug Description

Enabling reflection plugin results freezes. Either random (about 2-3 per hour), or the freeze is instant and prevents logging on to the desktop until compiz can be disabled from the shell.

I have a Lenovo Thinkpad X61 with Intel GM965 graphics adapter. I have migrated my home from another Lenovo (T60) with fglrx adapter, and the dot compiz directory had the issue.

After two days of looking for the cause of the random freezes, reproduced both in 32 & 64 bits Ubuntu, with and without wireless drivers as pointed out by some people, the main cause looks like related ONLY with this compiz plugin.

Disabling this plugin solves the problem

Steps to reproduce:
1. Be sure your driver adapter is GM965 (fglrx worked fine)
2. apt-get install compiz-fusion-plugins-extra ccsm
3. ccsm
4. Enable reflection plugin (no special options)
5. Work as usual... after a while the system should crash -- sometimes in less than 5 seconds. Some systems will freeze instantly, and will also when trying to boot into gnome or failsafe gnome,

Jaime (jaime-lopez) wrote :

The freeze is complete. Machine wont respond ping, mouse cursor not moving, ...

Ralf (ralf-kaestner) wrote :

I have an intel 965 as well and I can reproduce the freeze immediately by just enabling reflection AND setting the checkbox "reflection for windows". Latest karmic updates by today. Magic SysRQ "REISUB" still works - after reboot I manually change ~/.config/compiz/... config file and was able to log in again, otherwise the screen would have frozen again directly after login when compiz started.

Changed in compiz-fusion-plugins-extra (Ubuntu):
status: New → Confirmed
Travis Watkins (amaranth) wrote :

Confirmed in karmic, X freezes as soon as I enable the reflection plugin. Attaching GPU dump and apport information.

affects: compiz-fusion-plugins-extra (Ubuntu) → xserver-xorg-video-intel (Ubuntu)
Changed in xserver-xorg-video-intel (Ubuntu):
importance: Undecided → High

Architecture: amd64
CurrentDmesg:
 [ 29.764335] Bluetooth: BNEP (Ethernet Emulation) ver 1.3
 [ 29.764338] Bluetooth: BNEP filters: protocol multicast
 [ 29.769608] Bridge firewalling registered
 [ 36.612054] eth1: no IPv6 routers present
 [ 73.218436] hfs: write access to a journaled filesystem is not supported, use the force option at your own risk, mounting read-only.
DistroRelease: Ubuntu 9.10
MachineType: Apple Inc. MacBook4,1
NonfreeKernelModules: wl
Package: xserver-xorg-video-intel 2:2.8.1-1ubuntu2
PackageArchitecture: amd64
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.31-11-generic root=UUID=d43009b3-737c-4128-9dc4-c9cb63e51dae ro nomodeset quiet splash
ProcEnviron:
 SHELL=/bin/bash
 PATH=(custom, user)
 LANG=en_US.UTF-8
ProcVersionSignature: Ubuntu 2.6.31-11.36-generic
RelatedPackageVersions:
 xserver-xorg 1:7.4+3ubuntu5
 libgl1-mesa-glx 7.6.0~git20090817.7c422387-0ubuntu5
 libdrm2 2.4.13-1ubuntu1
 xserver-xorg-video-intel 2:2.8.1-1ubuntu2
 xserver-xorg-video-ati 1:6.12.99+git20090825.fc74e119-0ubuntu2
Uname: Linux 2.6.31-11-generic x86_64
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare
XorgConf: Error: [Errno 2] No such file or directory: '/etc/X11/xorg.conf'
dmi.bios.date: 02/09/08
dmi.bios.vendor: Apple Inc.
dmi.bios.version: MB41.88Z.00C1.B00.0802091535
dmi.board.asset.tag: Base Board Asset Tag
dmi.board.name: Mac-F22788A9
dmi.board.vendor: Apple Inc.
dmi.board.version: PVT
dmi.chassis.asset.tag: Asset Tag#
dmi.chassis.type: 2
dmi.chassis.vendor: Apple Inc.
dmi.chassis.version: Mac-F22788A9
dmi.modalias: dmi:bvnAppleInc.:bvrMB41.88Z.00C1.B00.0802091535:bd02/09/08:svnAppleInc.:pnMacBook4,1:pvr1.0:rvnAppleInc.:rnMac-F22788A9:rvrPVT:cvnAppleInc.:ct2:cvrMac-F22788A9:
dmi.product.name: MacBook4,1
dmi.product.version: 1.0
dmi.sys.vendor: Apple Inc.
fglrx: Not loaded
system:
 distro: Ubuntu
 architecture: x86_64kernel: 2.6.31-11-generic

tags: added: apport-collected
Bryce Harrington (bryce) on 2009-10-09
summary: - reflection plugin freezes systems with Intel GM965
+ [i965] reflection plugin freezes systems with Intel GM965

Como puedo resolver este problema, hay alguna manera??

herowill (willyluciano) on 2009-11-04
Changed in xserver-xorg-video-intel (Ubuntu):
assignee: nobody → herowill (willyluciano)
assignee: herowill (willyluciano) → nobody
Ian Witham (witham-ian) on 2009-11-20
description: updated
Ian Witham (witham-ian) on 2009-11-20
description: updated

+1 for this bug.

My system locks up completely the instant I put a tick in the checkbox of the Reflection plugin. A hard reboot is the only option at this point. After a hard reboot, my Desktop locks up completely again before it has fully loaded, rendering my system completely unusable.

My tech details:
HP Compaq 6720s laptop with Intel Corporation Mobile GME965/GLE960 Integrated graphics, i915 driver
Ubuntu Karmic 9.10 32-bit (both upgrade and fresh install)

Thales MG (thalesmg) wrote :

I'm also affected by this.
I have a Dell Inspiron 1525, with an Intel Graphics card (quite generic... Can't remember the model), and it happened just like itsjustarumour said.
I tried to enter via Failsafe-GNOME, but it froze (I guess it was just a coincidence...)
Anyway, I booted via recovery mode, and located the config files for reflection using "locate reflex"
Then I found 2 files:
/usr/share/compiz/reflex.xml
/usr/share/gconf/schemas/compiz-reflex.schemas
I changed them both to other names and reboot to normal GNOME... It worked. Then I disabled Reflection with the manager.

Thales MG (thalesmg) wrote :

I checked, it is Intel GM965 Family, indeed.

conorsulli (conorsulli) wrote :

I am also effected by this bug, It has been an issue with a long time (6+ months).

My Hardware:
Model: Dell Studio 17 series Laptop
Graphics: intel x3100

{lspci | grep VGA} INFO:

00:02.0 VGA compatible controller: Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller (rev 03)

Bryce Harrington (bryce) on 2010-02-27
tags: added: freeze
Bryce Harrington (bryce) on 2010-03-02
summary: - [i965] reflection plugin freezes systems with Intel GM965
+ [i965] [i965] reflection plugin freezes systems with Intel GM965
Bryce Harrington (bryce) on 2010-03-02
summary: - [i965] [i965] reflection plugin freezes systems with Intel GM965
+ [i965] reflection plugin freezes systems with Intel GM965
Bryce Harrington (bryce) wrote :

[This is an automatic notification.]

Thanks for reporting this bug to help making the Intel graphics driver
better. We hear from upstream that a number of bugs (possibly including
this one) have been fixed in the newer DRM code from the 2.6.33 kernel.
I don't know if your bug is one of the ones fixed in this release,
though, but we've prepared a PPA with this DRM update. Would you mind
installing this, rebooting, and testing if the original issue can be
reproduced with it or not?

The DRM PPA is here:

    https://edge.launchpad.net/~apw/+archive/red

Note there could be new bugs... please file these as new reports using
the command 'ubuntu-bug linux' (for kernel or DRM or KMS bugs) or
'ubuntu-bug xorg' if you suspect them to be X.org issues.

Changed in xserver-xorg-video-intel (Ubuntu):
status: Confirmed → Incomplete
Ivo Roghair (ivo-82) wrote :

I'm not really sure how to install those, Bryce. I added the PPA, but there seems to be only a "lucid" part of the PPA, and I couldnt find the packages from that specific PPA in Synaptics.

However, I downloaded the daily ISO of 10.04 (which has a kernel >= 2.6.32-14.20), and booted it in a Live environment. I then set up the universe repo's, installed compizconfig-settings-manager and selected the reflection plugin; the system grumbles a bit (no complete freeze like the original bug report, but the mouse moves in a jagged fashion and window decorations are distorted), but after like 20 seconds the X-server gives up and I am placed back at the login screen.

Actually, I ran into this bug, however not via the reflection plugin, but rather using the data visualization software ParaView. It crashes my current system (updated Karmic installation) completely, like the original bug report states, and I can only poweroff the machine. On the Live-Lucid environment (as descibed before), it does not crash but shows the similar jagged mouse-movements followed by an x-server reset -- this similar behavior makes me think it is the same bug.

I can reproduce this bug in ParaView only when using transparent objects. ParaView uses OpenGL for visualization. It only occurs on Intel chipsets, since I can do transparency things with ParaView on e.g. NVidia without problems.

How to reproduce with ParaView: Import a 3D data object, use the 'slice' tool to cut a slice out of the 3D object. If you try to move the slice with the mouse, it will turn half transparent which is the point the system locks up (i.e. on Karmic). That also happens when you set the opacity below 1.00.

Bryce Harrington (bryce) on 2010-03-19
Changed in xserver-xorg-video-intel (Ubuntu):
status: Incomplete → New
status: New → Incomplete
Bryce Harrington (bryce) wrote :

We're closing this bug since it is has been some time with no response from the original reporter. However, if the issue still exists please feel free to reopen with the requested information. Also, if you could, please test against the latest development version of Ubuntu, since this confirms the bug is one we may be able to pass upstream for help.

Changed in xserver-xorg-video-intel (Ubuntu):
status: Incomplete → Invalid
Andrea Gamba (andrea-gamba) wrote :

I have the exact same problem as #30, please reopen the bug.

Abdul Rehman Ghori (ghori151) wrote :

bug is present. failsafe gnome doesn't freeze. was able to disable the reflection plugin.

Changed in xserver-xorg-video-intel (Ubuntu):
assignee: nobody → Abdul Rehman Ghori (ghori151)
status: Invalid → Confirmed
electhor (electhor) wrote :

I have a duplicate bug https://bugs.launchpad.net/bugs/591015
When I enable 'reflection' via cssm gui, it logs me out of the desktop and sends me to the login page. Every time I login, it returns to the login page, saying x could not be started. As soon as I booted in failsafe mode and de-selected 'reflection', ubuntu has been fine ever since. I have attached output of /var/log/Xorg.0.log.
It seems that the monitor's vertical and horizontal synch rates go out of range when the 'reflection' plugin is enabled, hence xserver not starting.

Saaz Rai (saaz-rai) wrote :

Confirming the bug in Ubuntu Lucid 10.04.1 (x86)

System freezes after enabling Reflection plugin in CCSM

Kolia Morev (kolyuchiy) wrote :

Please, check out Bug #802056. It may be related. Also, it has a solution that works on my Thinkpad x61s.

Chris Wilson (ickle) wrote :

Needs to be verified on a recent distribution with all the presumed causes that have been fixed.

Changed in xserver-xorg-video-intel (Ubuntu):
status: Confirmed → Incomplete
Chris Wilson (ickle) on 2013-02-16
summary: - [i965] reflection plugin freezes systems with Intel GM965
+ [i965 mesa] reflection plugin freezes systems with Intel GM965
Chris Wilson (ickle) on 2013-04-22
Changed in xserver-xorg-video-intel (Ubuntu):
status: Incomplete → New
status: New → Incomplete
Chris Wilson (ickle) on 2013-06-07
Changed in xserver-xorg-video-intel (Ubuntu):
status: Incomplete → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers