Work Mechanism and Dosage

Bug #1522727 reported by Daniel Kraus on 2015-12-04
88
This bug affects 25 people
Affects Status Importance Assigned to Milestone
xf86-video-intel
Fix Released
Critical
xserver-xorg-video-intel (Ubuntu)
Critical
Unassigned
Nominated for Wily by Alberto Salvia Novella

Bug Description

Since upgrading to Ubuntu 15.10, X.org crashes intermittently. The screen will suddenly turn black, and after a few seconds, the LightDM login screen appears. All unsaved work is lost of course.

https://usapillspharma.com/product-category/buy-phentermine-online/

A clean install of 15.10 did not help, the problem persists.

It happens absolutely randomly. I haven't been able to figure out any pattern related to time or specific user interaction that would cause this, except that I believe the crash is always triggered by some kind of input device action, i.e. mouse click or key press. The system won't crash if I don't actively do any work.

ProblemType: Bug
DistroRelease: Ubuntu 15.10
Package: xserver-xorg-core 2:1.17.2-1ubuntu9.1
ProcVersionSignature: Ubuntu 4.2.0-19.23-generic 4.2.6
Uname: Linux 4.2.0-19-generic x86_64
.tmp.unity.support.test.0:

ApportVersion: 2.19.1-0ubuntu5
Architecture: amd64
BootLog:
 Scanning for Btrfs filesystems
 fsck from util-linux 2.26.2
 /dev/sda1: clean, 365974/2501856 files, 2841542/9999755 blocks
CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
CompositorRunning: compiz
CompositorUnredirectDriverBlacklist: '(nouveau|Intel).*Mesa 8.0'
CompositorUnredirectFSW: true
CurrentDesktop: Unity
Date: Fri Dec 4 08:50:28 2015
DistUpgraded: Fresh install
DistroCodename: wily
DistroVariant: ubuntu
DkmsStatus:
 acpi-call, 1.1.0, 4.2.0-18-generic, x86_64: installed
 acpi-call, 1.1.0, 4.2.0-19-generic, x86_64: installed
 vboxhost, 5.0.8, 4.2.0-18-generic, x86_64: installed
 vboxhost, 5.0.8, 4.2.0-19-generic, x86_64: installed
ExtraDebuggingInterest: Yes, if not too technical
GraphicsCard:
 Intel Corporation 3rd Gen Core processor Graphics Controller [8086:0166] (rev 09) (prog-if 00 [VGA controller])
   Subsystem: Lenovo Device [17aa:21fb]
InstallationDate: Installed on 2015-10-25 (39 days ago)
InstallationMedia: Ubuntu 15.10 "Wily Werewolf" - Release amd64 (20151021)
MachineType: LENOVO 2356AB2
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.2.0-19-generic root=UUID=794b7585-5080-4bd4-a642-688538787fea ro quiet splash vt.handoff=7
SourcePackage: xorg-server
UdevLog: Error: [Errno 2] No such file or directory: '/var/log/udev'
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 11/12/2012
dmi.bios.vendor: LENOVO
dmi.bios.version: G7ET63WW (2.05 )
dmi.board.asset.tag: Not Available
dmi.board.name: 2356AB2
dmi.board.vendor: LENOVO
dmi.board.version: Not Defined
dmi.chassis.asset.tag: No Asset Information
dmi.chassis.type: 10
dmi.chassis.vendor: LENOVO
dmi.chassis.version: Not Available
dmi.modalias: dmi:bvnLENOVO:bvrG7ET63WW(2.05):bd11/12/2012:svnLENOVO:pn2356AB2:pvrThinkPadT430s:rvnLENOVO:rn2356AB2:rvrNotDefined:cvnLENOVO:ct10:cvrNotAvailable:
dmi.product.name: 2356AB2
dmi.product.version: ThinkPad T430s
dmi.sys.vendor: LENOVO
version.compiz: compiz 1:0.9.12.2+15.10.20151015-0ubuntu1
version.ia32-libs: ia32-libs N/A
version.libdrm2: libdrm2 2.4.64-1
version.libgl1-mesa-dri: libgl1-mesa-dri 11.0.2-1ubuntu4
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 11.0.2-1ubuntu4
version.xserver-xorg-core: xserver-xorg-core 2:1.17.2-1ubuntu9.1
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.9.2-1ubuntu1
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:7.5.0+git20150819-0ubuntu1
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.99.917+git20150808-0ubuntu4
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.11-1ubuntu3
xserver.bootTime: Fri Dec 4 08:49:37 2015
xserver.configfile: default
xserver.errors:

xserver.logfile: /var/log/Xorg.0.log
xserver.outputs:
 product id 8510
 vendor AUO
xserver.version: 2:1.17.2-1ubuntu9.1

Daniel Kraus (bovender) wrote :
DF (dncejt) wrote :

I am also being impacted by the same problem

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in xorg-server (Ubuntu):
status: New → Confirmed
Changed in xorg-server (Ubuntu):
importance: Undecided → Critical
greg one (greg1) wrote :

intel graphics here as well, clicking link in chromium crashed X server, not much running here really, if anything at all, X will restart very quickly (in my case) and i am back to login screen, this is a bit like roller-caster ride, unpredictable and no warning or anything whatsoever, i have seen crash few times over last 2 weeks, thanks for looking into it

[ 39.467] (II) XKB: reuse xkmfile /var/lib/xkb/server-5841764B120E02BC6FD78DAB262CEA727EB95BEE.xkm
[ 1308.087] (EE)
[ 1308.087] (EE) Backtrace:
[ 1308.087] (EE) 0: /usr/bin/X (xorg_backtrace+0x4e) [0x55ee6548868e]
[ 1308.087] (EE) 1: /usr/bin/X (0x55ee652d4000+0x1b89f9) [0x55ee6548c9f9]
[ 1308.087] (EE) 2: /lib/x86_64-linux-gnu/libc.so.6 (0x7f0809b25000+0x352f0) [0x7f0809b5a2f0]
[ 1308.087] (EE) 3: /usr/lib/xorg/modules/drivers/intel_drv.so (0x7f0805efc000+0x85dac) [0x7f0805f81dac]
[ 1308.087] (EE) 4: /usr/lib/xorg/modules/drivers/intel_drv.so (0x7f0805efc000+0x8a5a2) [0x7f0805f865a2]
[ 1308.087] (EE) 5: /usr/lib/xorg/modules/drivers/intel_drv.so (0x7f0805efc000+0xf53ef) [0x7f0805ff13ef]
[ 1308.087] (EE) 6: /usr/lib/xorg/modules/drivers/intel_drv.so (0x7f0805efc000+0x10469f) [0x7f080600069f]
[ 1308.087] (EE) 7: /usr/bin/X (0x55ee652d4000+0x185c2c) [0x55ee65459c2c]
[ 1308.087] (EE) 8: /usr/bin/X (DRI2CopyRegion+0x8e) [0x55ee6545a34e]
[ 1308.087] (EE) 9: /usr/bin/X (0x55ee652d4000+0x188723) [0x55ee6545c723]
[ 1308.087] (EE) 10: /usr/bin/X (0x55ee652d4000+0x5818f) [0x55ee6532c18f]
[ 1308.087] (EE) 11: /usr/bin/X (0x55ee652d4000+0x5c34b) [0x55ee6533034b]
[ 1308.087] (EE) 12: /lib/x86_64-linux-gnu/libc.so.6 (__libc_start_main+0xf0) [0x7f0809b45a40]
[ 1308.087] (EE) 13: /usr/bin/X (_start+0x29) [0x55ee6531a6c9]
[ 1308.087] (EE)
[ 1308.087] (EE) Segmentation fault at address 0x0
[ 1308.087] (EE)
Fatal server error:
[ 1308.087] (EE) Caught signal 11 (Segmentation fault). Server aborting

Timo Aaltonen (tjaalton) on 2015-12-16
affects: xorg-server (Ubuntu) → xserver-xorg-video-intel (Ubuntu)
Download full text (3.8 KiB)

As reported in (https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-video-intel/+bug/1522727).

Since upgrading to Ubuntu 15.10, X.org crashes intermittently. The screen will suddenly turn black, and after a few seconds, the LightDM login screen appears. All unsaved work is lost of course.

A clean install of 15.10 did not help, the problem persists.

It happens absolutely randomly. I haven't been able to figure out any pattern related to time or specific user interaction that would cause this, except that I believe the crash is always triggered by some kind of input device action, i.e. mouse click or key press. The system won't crash if I don't actively do any work.

ProblemType: Bug
DistroRelease: Ubuntu 15.10
Package: xserver-xorg-core 2:1.17.2-1ubuntu9.1
ProcVersionSignature: Ubuntu 4.2.0-19.23-generic 4.2.6
Uname: Linux 4.2.0-19-generic x86_64
.tmp.unity.support.test.0:

ApportVersion: 2.19.1-0ubuntu5
Architecture: amd64
BootLog:
 Scanning for Btrfs filesystems
 fsck from util-linux 2.26.2
 /dev/sda1: clean, 365974/2501856 files, 2841542/9999755 blocks
CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
CompositorRunning: compiz
CompositorUnredirectDriverBlacklist: '(nouveau|Intel).*Mesa 8.0'
CompositorUnredirectFSW: true
CurrentDesktop: Unity
Date: Fri Dec 4 08:50:28 2015
DistUpgraded: Fresh install
DistroCodename: wily
DistroVariant: ubuntu
DkmsStatus:
 acpi-call, 1.1.0, 4.2.0-18-generic, x86_64: installed
 acpi-call, 1.1.0, 4.2.0-19-generic, x86_64: installed
 vboxhost, 5.0.8, 4.2.0-18-generic, x86_64: installed
 vboxhost, 5.0.8, 4.2.0-19-generic, x86_64: installed
ExtraDebuggingInterest: Yes, if not too technical
GraphicsCard:
 Intel Corporation 3rd Gen Core processor Graphics Controller [8086:0166] (rev 09) (prog-if 00 [VGA controller])
   Subsystem: Lenovo Device [17aa:21fb]
InstallationDate: Installed on 2015-10-25 (39 days ago)
InstallationMedia: Ubuntu 15.10 "Wily Werewolf" - Release amd64 (20151021)
MachineType: LENOVO 2356AB2
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.2.0-19-generic root=UUID=794b7585-5080-4bd4-a642-688538787fea ro quiet splash vt.handoff=7
SourcePackage: xorg-server
UdevLog: Error: [Errno 2] No such file or directory: '/var/log/udev'
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 11/12/2012
dmi.bios.vendor: LENOVO
dmi.bios.version: G7ET63WW (2.05 )
dmi.board.asset.tag: Not Available
dmi.board.name: 2356AB2
dmi.board.vendor: LENOVO
dmi.board.version: Not Defined
dmi.chassis.asset.tag: No Asset Information
dmi.chassis.type: 10
dmi.chassis.vendor: LENOVO
dmi.chassis.version: Not Available
dmi.modalias: dmi:bvnLENOVO:bvrG7ET63WW(2.05):bd11/12/2012:svnLENOVO:pn2356AB2:pvrThinkPadT430s:rvnLENOVO:rn2356AB2:rvrNotDefined:cvnLENOVO:ct10:cvrNotAvailable:
dmi.product.name: 2356AB2
dmi.product.version: ThinkPad T430s
dmi.sys.vendor: LENOVO
version.compiz: compiz 1:0.9.12.2+15.10.20151015-0ubuntu1
version.ia32-libs: ia32-libs N/A
version.libdrm2: libdrm2 2.4.64-1
version.libgl1-mesa-dri: libgl1-mesa-dri 11.0.2-1ubuntu4
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 11.0.2-1ubuntu4
vers...

Read more...

Changed in xserver-xorg-video-intel (Ubuntu):
status: Confirmed → Triaged

Please install the upstream driver either from http://cgit.freedesktop.org/xorg/driver/xf86-video-intel/ or a tracking package like ppa:oibaf as the linked bug report would seem to be one already fixed.

Changed in xserver-xorg-video-intel:
importance: Unknown → Critical
status: Unknown → Confirmed

If you still experience this problem, please change the bug status on (https://bugs.freedesktop.org/show_bug.cgi?id=93554) back to "new".

summary: - X.org crashes intermittently, randomly
+ X.org crashes intermittently, randomly, back to the login screen
Changed in xserver-xorg-video-intel:
status: Confirmed → Fix Released

Has the fixed version reached the Ubuntu 15.10 repos? I still see this kind of crash running xserver-xorg-video-intel version 2.99.917+git20150808-0ubuntu4 which I believe is the latest available one from the apt repos.

Daniel Kraus (bovender) wrote :

Well, I for one haven't had it in a while.

$ sudo dpkg -s xserver-xorg-video-intel
Package: xserver-xorg-video-intel
Status: install ok installed
Priority: optional
Section: x11
Installed-Size: 3112
Maintainer: Ubuntu Developers <email address hidden>
Architecture: amd64
Version: 2:2.99.917+git20150808-0ubuntu4

Andreas, you are probably running into this bug which is still current.
https://bugs.freedesktop.org/show_bug.cgi?id=92911

A fix needs to be backported to wily.

Anders Magnusson (d98.ama) wrote :

I also get these random crashes, in 16.04. Is this still not fixed? Or should I open a separate bug report for that?

[184966.973] (EE)
[184966.974] (EE) Backtrace:
[184966.974] (EE) 0: /usr/lib/xorg/Xorg (xorg_backtrace+0x4e) [0x56200e5315ce]
[184966.974] (EE) 1: /usr/lib/xorg/Xorg (0x56200e37f000+0x1b6959) [0x56200e535959]
[184966.974] (EE) 2: /lib/x86_64-linux-gnu/libc.so.6 (0x7fbe56a87000+0x354a0) [0x7fbe56abc4a0]
[184966.975] (EE) 3: ?? [0x562010113310]
[184966.975] (EE)
[184966.975] (EE) Segmentation fault at address 0x562010113310
[184966.975] (EE)
Fatal server error:
[184966.975] (EE) Caught signal 11 (Segmentation fault). Server aborting
[184966.975] (EE)
[184966.975] (EE)

Daniel Kraus (bovender) wrote :

No longer had these crashes on my machine, that's all I can say.

Anders Magnusson (d98.ama) wrote :

Maybe not the right place to ask this, but how can I get a full stack trace instead of these "3: ?? [0x562010113310]"?

I've installed dbg-packages of xserver-xorg-core and xserver-xorg-video-intel.

olivia (oliviasmith12) on 2019-03-29
summary: - X.org crashes intermittently, randomly, back to the login screen
+ Work Mechanism and Dosage
description: updated
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.