Comment 4 for bug 560306

Some background:

5xxx GPUs booted daily lives just fine still after Alpha 1. Afaik, this bug occured before Alpha 2.

I have 5770 which worked with Alpha 1 and later images. Plymouth worked and desktop loaded with resolution 800x600 without any boot parameter tweaking (nomodeset, radeon.modeset=0).

I tried to find Alpha 1 and Alpha 2 images and/or builds between them in order to address this bug more specifically. Unfortunately I haven't found any Alpha images so far.

Beta 1 & 2 (32 and 64 bit versions) just give me a black screen (signal gets lost) when Plymouth is done and desktop should be shown. Removing "quiet splash" from kernel boot parameters doesn't help. Nomodeset and/or radeon.modeset=0 have no effect on my computer. I've tried installation using USB disk and CD-RW.

My setup:

CPU: Intel i5-750 2,66 GHz
MOBO: Asus P7P55D
GPU: Asus Ati 5770 1 GB - model EAH5770/2DIS/1GD5/V2
MEM: Kingston 1333D3N9K2, 2x 2 GB
HD: Samsung F3 1 TB
PSU: Corsair 400 W
DISPLAY: NEX T4211N, 42" Full HD - connection between this and 5770 is through DVI

Just bump if you need more specific HW details.