Ubuntu

[lucid] ATI hd5xxx cards wrongly doing kms?

Reported by Dave Gilbert on 2010-04-10
196
This bug affects 39 people
Affects Status Importance Assigned to Milestone
linux-firmware (Ubuntu)
Undecided
Unassigned
Lucid
Low
Tim Gardner
xserver-xorg-video-ati (Ubuntu)
High
Unassigned
Lucid
High
Unassigned

Bug Description

Hi,
  I'm a regular on #ubuntu+1 and while I haven't got an ATI hd5xxx card myself I'm seeing multiple
people with hd5xxx cards reporting when they're trying Lucid that after installing the Betas they are getting a completely
black screen (sometimes after a splash logo); for a good few of them telling them to pass radeon.modeset=0 has
fixed this.

  This makes me think that the radeon kms code is trying to modeset for soemthing it doesn't actually know how to deal with
(or is broken for them).

  Tonights victim had an hd5750 but I think I've seen other hd5xxx; given it's multiple people and given they get a black screen I get the feeling a fix is needed, especially given the 5xxx is the newest radeon that's probably in a lot of machines.

Dave

ProblemType: Bug
DistroRelease: Ubuntu 10.04
Package: linux-image-2.6.32-19-generic 2.6.32-19.28
Regression: Yes
Reproducible: Yes
ProcVersionSignature: Ubuntu 2.6.32-19.28-generic 2.6.32.10+drm33.1
Uname: Linux 2.6.32-19-generic x86_64
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.21.
Architecture: amd64
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: Intel [HDA Intel], device 0: VT1708S Analog [VT1708S Analog]
   Subdevices: 2/2
   Subdevice #0: subdevice #0
   Subdevice #1: subdevice #1
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: dg 1862 F.... pulseaudio
CRDA: Error: [Errno 2] No such file or directory
Card0.Amixer.info:
 Card hw:0 'Intel'/'HDA Intel at 0xfbcf8000 irq 22'
   Mixer name : 'VIA VT1708S'
   Components : 'HDA:11060397,18490397,00100000'
   Controls : 36
   Simple ctrls : 20
Card1.Amixer.info:
 Card hw:1 'HDMI'/'HDA ATI HDMI at 0xfbffc000 irq 17'
   Mixer name : 'ATI R6xx HDMI'
   Components : 'HDA:1002aa01,00aa0100,00100100'
   Controls : 4
   Simple ctrls : 1
Card1.Amixer.values:
 Simple mixer control 'IEC958',0
   Capabilities: pswitch pswitch-joined penum
   Playback channels: Mono
   Mono: Playback [off]
CheckboxSubmission: f2d10bd9f943a85b486a282e7840a570
CheckboxSystem: 0531969bcfd4f03af7405c98dc94a948
Date: Sat Apr 10 22:17:48 2010
HibernationDevice: RESUME=UUID=6f692bcf-9da3-442b-854d-1d1c129a65fd
InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release amd64 (20091027)
IwConfig:
 lo no wireless extensions.

 eth0 no wireless extensions.

 virbr0 no wireless extensions.
MachineType: To Be Filled By O.E.M. To Be Filled By O.E.M.
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.32-19-generic root=UUID=d8314979-8ace-401c-88df-728ad6b89cb5 ro ignore_loglevel netconsole=4444@192.168.66.33/eth0,514@192.168.66.25/00:a0:d1:63:68:a6 quiet splash
ProcEnviron:
 PATH=(custom, user)
 LANG=en_GB.utf8
 SHELL=/bin/bash
RelatedPackageVersions: linux-firmware 1.33
RfKill:

SourcePackage: linux
dmi.bios.date: 09/10/2009
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: P1.50
dmi.board.name: P55M Pro
dmi.board.vendor: ASRock
dmi.chassis.asset.tag: To Be Filled By O.E.M.
dmi.chassis.type: 3
dmi.chassis.vendor: To Be Filled By O.E.M.
dmi.chassis.version: To Be Filled By O.E.M.
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvrP1.50:bd09/10/2009:svnToBeFilledByO.E.M.:pnToBeFilledByO.E.M.:pvrToBeFilledByO.E.M.:rvnASRock:rnP55MPro:rvr:cvnToBeFilledByO.E.M.:ct3:cvrToBeFilledByO.E.M.:
dmi.product.name: To Be Filled By O.E.M.
dmi.product.version: To Be Filled By O.E.M.
dmi.sys.vendor: To Be Filled By O.E.M.

Dave Gilbert (ubuntu-treblig) wrote :
salva84 (salva-ms) wrote :

Same problem to me, I have an ATI 5850 and when I try to install the beta 2, after the UBUNTU logo the screen goes black...

Martin Read (mar) wrote :

Same symptoms with an ATI 5870 card, signal dies to the monitor, this is with the 64 bit version.

Kazade (kazade) on 2010-04-15
Changed in linux (Ubuntu):
status: New → Confirmed
Jiri Grönroos (jiri-gronroos) wrote :

Some background:

5xxx GPUs booted daily lives just fine still after Alpha 1. Afaik, this bug occured before Alpha 2.

I have 5770 which worked with Alpha 1 and later images. Plymouth worked and desktop loaded with resolution 800x600 without any boot parameter tweaking (nomodeset, radeon.modeset=0).

I tried to find Alpha 1 and Alpha 2 images and/or builds between them in order to address this bug more specifically. Unfortunately I haven't found any Alpha images so far.

Beta 1 & 2 (32 and 64 bit versions) just give me a black screen (signal gets lost) when Plymouth is done and desktop should be shown. Removing "quiet splash" from kernel boot parameters doesn't help. Nomodeset and/or radeon.modeset=0 have no effect on my computer. I've tried installation using USB disk and CD-RW.

My setup:

CPU: Intel i5-750 2,66 GHz
MOBO: Asus P7P55D
GPU: Asus Ati 5770 1 GB - model EAH5770/2DIS/1GD5/V2
MEM: Kingston 1333D3N9K2, 2x 2 GB
HD: Samsung F3 1 TB
PSU: Corsair 400 W
DISPLAY: NEX T4211N, 42" Full HD - connection between this and 5770 is through DVI

Just bump if you need more specific HW details.

Anthony Hook (anthonyhook) wrote :

I'd like to bump this, I'm having the problem on a:
Dell Latitude XT with the ATI X1250. I had to add radeon.modeset=0

Magnus Olsson (magnus-minimum) wrote :

I'm also seeing this issue on my machine. Monitor signal is lost when login screen appears (I can see the Ubuntu logo flashing just before).

My system:
Ubuntu 10.04, 64-bit
CPU: Intel i5 760
MOBO: Asus P7P55D LE
GPU: ATI 5750-based PowerColor GoGreen-card (pci-express)
MEM: 2x2 GB Corsair at 1333 MHz
HD: 80 GB SSD X-25 G2
PSU: 750W Corsair
DISPLAY: 24" BenQ, using DVI connection between GFX.

Magnus Olsson (magnus-minimum) wrote :

Also, passing kernel argument "radeon.modeset=0" does not fix my issues.

Nigel (outerspacerace) wrote :

I have this issue too.

System:

Ubuntu 10.04 Beta 2, 64-bit
CPU: Intel i7 860
MOBO: Gigabyte GA-P55A-UD3
GPU: ATI Radeon HD 5770 (1GB)
MEM: 4GB DDR3 (PC-10600/1333MHz)
HD: 2TB SATA2 (1TB x2)

Hope some of that information is helpful.

tags: added: ati evergreen
Martin Read (mar) wrote :

Update at request of Jiri,

Hardware is

CPU: Intel i7 920
MOBO: Gigabyte GA-EX58-UD5
MEM: 6 GB DDR3 Corsair
GPU: Powercolour HD5870

Jiri Grönroos (jiri-gronroos) wrote :

Dave, are you sure the reporter even has Evergreen (5xxx) GPU? Lspci says it's 4350 and dmesg says the system is requsting RV710_pfp.bin and RV710_me.bin. Ati dropped Rxxxx naming with Evergreen series. In my example (5770) system should be requesting JUNIPER files, see http://git.kernel.org/?p=linux/kernel/git/dwmw2/linux-firmware.git;a=tree;f=radeon;h=3dc32482fcf179c43e2fcc0b30303f231774820a;hb=HEAD

Also, does this occur on AMD CPU/chipset? All reports in here and forums seem to have i5/i7 (CPU) and P55/X58 (chipset).

Jiri Grönroos (jiri-gronroos) wrote :

Filename: pool/main/l/linux-firmware/linux-firmware_1.34_all.deb

ubuntu@lucid:~$ dpkg -L linux-firmware | grep radeon
/lib/firmware/radeon
/lib/firmware/radeon/RS780_pfp.bin
/lib/firmware/radeon/R100_cp.bin
/lib/firmware/radeon/R200_cp.bin
/lib/firmware/radeon/R300_cp.bin
/lib/firmware/radeon/R420_cp.bin
/lib/firmware/radeon/R520_cp.bin
/lib/firmware/radeon/R600_me.bin
/lib/firmware/radeon/R600_pfp.bin
/lib/firmware/radeon/R600_rlc.bin
/lib/firmware/radeon/R700_rlc.bin
/lib/firmware/radeon/RS600_cp.bin
/lib/firmware/radeon/RS690_cp.bin
/lib/firmware/radeon/RS780_me.bin
/lib/firmware/radeon/RV610_pfp.bin
/lib/firmware/radeon/RV610_me.bin
/lib/firmware/radeon/RV620_pfp.bin
/lib/firmware/radeon/RV620_me.bin
/lib/firmware/radeon/RV630_pfp.bin
/lib/firmware/radeon/RV630_me.bin
/lib/firmware/radeon/RV635_pfp.bin
/lib/firmware/radeon/RV635_me.bin
/lib/firmware/radeon/RV670_pfp.bin
/lib/firmware/radeon/RV670_me.bin
/lib/firmware/radeon/RV710_pfp.bin
/lib/firmware/radeon/RV710_me.bin
/lib/firmware/radeon/RV730_pfp.bin
/lib/firmware/radeon/RV730_me.bin
/lib/firmware/radeon/RV770_pfp.bin
/lib/firmware/radeon/RV770_me.bin
/usr/share/doc/linux-firmware/licenses/LICENCE.radeon_rlc
ubuntu@lucid:~$

Evergreen support seems to be missing from linux-firmware.

affects: linux (Ubuntu) → linux-firmware (Ubuntu)
salva84 (salva-ms) wrote :

same problem with the release candidate

Tim Gardner (timg-tpi) on 2010-04-22
Changed in linux-firmware (Ubuntu Lucid):
assignee: nobody → Tim Gardner (timg-tpi)
importance: Undecided → High
milestone: none → lucid-updates
Tim Gardner (timg-tpi) wrote :

I've uploaded a test version of linux-firmware with support for the Evergreen family of Radeon GPUs. Please try linux-firmware_1.35~rtg1 from my PPA at http://launchpad.net/~timg-tpi/+archive/ppa

Robert Hooker (sarvatt) wrote :

Can anyone experiencing this problem provide a dmesg from a failed boot? There was a problem around the beta 2 timeframe where radeon.modeset=1 was forced by a modprobe conf installed with the -ati package that could have caused issues but that problem should not exist still. There is no KMS (or acceleration even) support for R5xxx+ in lucid and the earliest kernel with even basic support for KMS is 2.6.34. There should be no need to have the firmware for it unless someone is using a 2.6.34 kernel. Most likely this is an issue with the xserver-xorg-video-ati package on the affected cards and not the kernel given the lack of KMS support. Can anyone having the problem try booting with splash removed from the kernel command line as well?

Anthony Hook: Your problem is different, RS600 does not work with KMS in lucid at the moment and https://bugs.edge.launchpad.net/ubuntu/+source/linux/+bug/544590 is the bug for that issue.

Yes this is a bug in the radeon driver. I filed a bug report upstream about a month ago. But no action taken so far, seems the devs are too busy with kms these days.

https://bugs.freedesktop.org/show_bug.cgi?id=27080

Anyway for me this bug only appears if I connect my monitor to the DVI-1output port, DVI-0 works fine. It would be nice if the LiveCD had some sort of option to select the VESA driver during boot as the Evergreen code in radeon is rather new and still contains some bugs as people now find out.

Robert Hooker (sarvatt) wrote :

Does anyone have a launchpad bug on this issue that can dupe it to this bug? The logs attached to this bug are not for this particular GPU generation and are useless to try to help figure out the problem. Rafael, can you file a bug against xserver-xorg-video-ati with "ubuntu-bug xserver-xorg-video-ati" and dupe it to this one if not? The xorg log info on the fdo bug is helpful but we'd need to see your dmesg also at least.

Jiri Grönroos (jiri-gronroos) wrote :

I have no problem in RC, signal stays even after Plymouth has finished. I have resolution of 1368x768 (as opposed to 800x600 in Alphas). I did not change anything (parts, cables) on my system.

Rafael, I only have one monitor and one cable connected at once. The first thing I tried was to change the cable but the signal was lost even with another DVI cable. The cable has always been connected to the upper output in GPU (which is to say DVI-0) although I've tried DVI-1 with similiar symptoms. I also plugged two cables into both DVI outputs at once (although only one of the cables had monitor in another end connected) but the signal was still lost after Plymouth.

I did not try to include Tim's linux-firmware_1.35~rtg1 into live CD.

Robert, I've tried to boot many daily builds without "quiet splash" but it had no effect (no matter how I put the cables).

I'm able to provide all files from /var/log/ from a successful RC live session as from installed system. I'm not able to provide dmesg from failed boot attempts. Now I'm using Ati's fglrx. Could this be a race condition somewhere?

Dave Gilbert (ubuntu-treblig) wrote :

Jiri:
   I can't actually validate what hardware the people have; but there have been probably a dozen or so which say they've had hd5xxx of various types.

If this is an issue of missing firmware it really should fail in a better way! A black screen is pretty grim; falling back to not KMS would work. (I seem to remember there was a bug on mainline kernel to fall back).

Dave

I've been unable to try Lucid at all due to this bug since Beta 1. No settings help, including the nomodeset and radeon.modeset=0, and this behavior continues in the release candidate.

My hardware:

Intel Core i5-750 2.66GHz
8GB G.SKILL Ripjaws DDR3-1600 RAM
ASRock P55 Extreme Motherboard
Intel Caviar Black 500GB HDD
HIS Radeon HD 5850 1GB
LITE-ON DVD+/-DL

EDIT: I fixed the issue just now on a fifth try by moving the DVI cable back to DVI-0 and using BOTH nomodeset and radeon.modeset=0

I've been having the same issue with my desktop. I've tried livecd's, usb, and a network upgrade.

My hardware is
Motherboard: ASUS M4A78LT-M LE AM3 DDR3 ATI 3000
Processor: AMD AMD Phenom(tm) II X4 945 Processor 3012.7 Mhz
Video Card: ATI Radeon HD 5700 Series (5770)
Ram: 4 Gig DDR3 (1600 MHZ)

Same problem. I have tried:

- 'nomodeset' and 'radeon.modeset=0', and many combinations of 'noapic', 'nolapic', 'noacpi' kernel options.
- Ubuntu and Kubuntu Beta 2 live cds, and the Kubuntu Beta2 Alternate CD (all 64bit).
- Failsafe graphic mode from boot menu (fails and returns to boot menu)
- installing the ATI proprietary driver from the recovery console
- 'apt-get update/upgrading' to the latest packages from recovery console.

In any combination of the above that I've tried, it's always the same behaviour: brief splash screen followed by blank screen.

I would be happy with the most basic non-DRI 2D right now, but I can't even get that working as xorg.conf and 'dpkg-reconfigure xserver-xorg' seem to be deprecated (replaced with what I don't know?) and 'X -configure' doesn't work either.

Hardware:
- ATI Radeon HD5850
- Asus P5B Deluxe motherboard
- Intel Core2 Quad
- 4Gb RAM

Got my desktop working again, here's what did it for me:

- Fresh Kubuntu Alternate x64 CD install.
- Boot to recovery console and do the following:
>apt-get update
>apt-get upgrade
>apt-get install fglrx
>aticonfig --initial
>reboot

So just installing updated fglrx module and using aticonfig to create the intial configuration worked. Does this mean the problem is just in the 'radeon' module then?

Comment #23 Solved my problem too. since I had ubuntu already installed I just logged into a recovery prompted and dropped to a root shell and ran aticonfig --initial (i had already installed the fglrx driver yesterday when I logged in using limited graphics)
I hope this helps.

Jka (jka-pub) wrote :

This bug seems to be like the iMac 27in ATI HD5850 problem, can't boot from the RC lucid disk.
 Where as before with Beta 2 the settings worked, now end up with black screen.

https://bugs.launchpad.net/ubuntu/+source/linux/+bug/542660

Dubs (dubbystix) wrote :

I did a quick search..looks like I am the first 5830 to sign in with this problem. 64bit of 10.04 final release version. I can't really help with anything but I figured I would let you guys know my problem.

Kéri Gergely (gergelykeri) wrote :

I upgraded from 9.10 to 10.4 and same problem for me.
5850, 790XTA, B55, but the problem is with the card.

gismo (gismo-kangaroo) wrote :

try 'nomodeset' and 'radeon.modeset=0' with the recovery option in grub, a bit later select to use the low resolution for the current session and then, when you are in gnome, install the ati proprietary hardware driver. after that, everything worked fine for me.

Kido (kido-softhome) wrote :

The same here: when booting 10.4 x64 from live cd I can see Ubuntu logo for some time. Suddenly it disappears and I get the "no signal" message from my monitor. Other than having no signal the system probably loads fine as I can hear the initial sound of Ubuntu.

My specs:
AMD Phenom II x4 955
ECS A790GXM-AD3
XFX HD5770
Samsung SyncMaster T220HD

Please note that 9.10 also stopped booting after some update and I have never been able to find a solution since. 9.10 straight from live cd works fine.

I described it here:
http://tinyurl.com/244rmv6

mmm286 (mmm286) wrote :

Hi,
I have aslo this problem. I have a hd 5770 and when I try install from ubuntu live desktop and with kubunt live desktop, the monitor lost signal.

thanks and sorry for my english!

madbiologist (me-again) wrote :

Re comment 16 - there is also bug #569372, although I would be reluctant to set it as a duplicate of this bug at this late stage as it may result in a lack of attention to the (additional) information in that bug). I have mentioned this bug there.

affects: linux-firmware (Ubuntu) → xserver-xorg-video-ati (Ubuntu)
Andy Webster (webstercc) wrote :

I've got a 5850 and noticed the same problem upon booting the 10.04 AMD64 install CD. I booted with two monitors connected via DVI ports and saw the blank screen issue. I booted with a single HDMI connection and saw the same blank screen issue. I booted with a single DVI connection and was X worked fine for me. I was able to complete an install.
Hope that helps someone, if there is any more information I can provide I'd be happy to do so if it will help.

thanks,
Andy

Craig Watcham (craig-watcham) wrote :

Same problem. Switching DVI ports (to first port) solved the issue for me

Laurent Raufaste (analogue) wrote :

I fixed this by switching my display from one DVI to the other

Martin Read (mar) wrote :

Switching DVI port fixed this for me as well.

Liam Davison (liamjdavison) wrote :

Same problem - ATI HD5670 graphics card, AMD chipset with a Phenom II X4 935 processor. I can't switch DVI ports as I only have 1 DVI port and my monitor does not have HDMI or DisplayPort inputs.

Fabrice82 (fabrice82) wrote :

Affected me too :(.

simartem (simartem) wrote :

blank screen with Sapphired Radeon HD 5850. HDMI connected

Tim Gardner (timg-tpi) wrote :

Uploaded ATI Evergreen firmware in Lucid linux-firmware_1.34.1

Changed in linux-firmware (Ubuntu Lucid):
assignee: nobody → Tim Gardner (timg-tpi)
importance: Undecided → Low
milestone: none → lucid-updates
status: New → In Progress
Tim Gardner (timg-tpi) wrote :

SRU Justification

Impact: ATI Evergreen video adapters will not work without firmware.

Patch Description: Added new firmware files to the linux-firmware package. There is little chance of regression.

Patch: http://kernel.ubuntu.com/git?p=ubuntu/linux-firmware.git;a=commit;h=b2da5f655fd389b4272eafd247109a498e1a07a8

Changed in xserver-xorg-video-ati (Ubuntu):
assignee: Tim Gardner (timg-tpi) → nobody
Changed in xserver-xorg-video-ati (Ubuntu Lucid):
assignee: Tim Gardner (timg-tpi) → nobody
Thomas87 (knot-tomas) wrote :

I have same problem. Thinkpad R60 Ati Mobility Radeon X1400

Martin Pitt (pitti) wrote :

Accepted linux-firmware into lucid-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

tags: added: verification-needed
Changed in linux-firmware (Ubuntu Lucid):
status: In Progress → Fix Committed
Changed in linux-firmware (Ubuntu):
status: New → Fix Committed
Changed in linux-firmware (Ubuntu):
status: Fix Committed → Fix Released
Fabrice82 (fabrice82) wrote :

Do we have to download and burn ubuntu iso again ?

Chase Douglas (chasedouglas) wrote :

Fabrice82,

No, the release ISOs never change after release. If you can't get 10.04 LTS installed due to this bug, please try installing using the alternative ISO which has a text mode installer I think. Once 10.04 LTS is installed, perform a full upgrade to get the new firmware. Then, everything should hopefully work.

That said, this won't actually work until the firmware is released for 10.04 LTS. Hopefully this will happen soon.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux-firmware - 1.34.1

---------------
linux-firmware (1.34.1) lucid-proposed; urgency=low

  [ Chase Douglas ]

  * Add AudioScience ASI series audio device firmware
    -LP: #557037
  * Add RealTek RTL8192E firmware
    -LP: #508746
  * Update firmware from rt2870sta
    -LP: #580926

  [ Tim Gardner ]

  * radeon: add evergreen family microcode.
    -LP: #560306
 -- Chase Douglas <email address hidden> Mon, 24 May 2010 17:51:17 -0400

Changed in linux-firmware (Ubuntu Lucid):
status: Fix Committed → Fix Released
Bryce Harrington (bryce) on 2010-07-07
Changed in xserver-xorg-video-ati (Ubuntu):
status: Confirmed → Fix Released
Changed in xserver-xorg-video-ati (Ubuntu Lucid):
status: Confirmed → Fix Released
Andrew Somerville (andy16666) wrote :

I'm seeing the same behavior with an HD4200 IGP.

Hi, this bug seems to still be present. Downloaded a fresh Ubuntu Lucid 10.04.1 Desktop AMD64bit today, had the same problem of blank screens. It only worked by unplugging all but one screen connected to (apparantely) DVI #0.

Hope this helps somebody.

Sean Seago (speedkreature) wrote :

Experiencing this issue and then some.

Attempted install of Ubuntu 10.04.1 64-bit via ubuntu-minimal ISO image on CD-R.
Selected "SSH Server" and "Ubuntu Desktop"

Hardware:
AMD Phenom II 710 (x3)
8GB DDR3
GIGABYTE GA-MA770T-UD3 (AMD 770 Chipset)
2x XFX HD5770 -> 2x Monitors connected via DVI
80GB SSD (/dev/sda, /)
2TB WD HDD (/dev/sdb, /home)

When I attempt this, the system locks up as soon as it starts downloading libc6. Network interface does not respond to any attempt to ping or connect. Getting dmesg is impossible. HDD light is dead. The lights are on but no one's home.

When I attempt to use the Ubuntu Desktop image (Lucid, 64-bit), the Ubuntu logo comes up, then black screen. Can not ping computer or connect from another machine. Keyboard freezes so cannot get dmesg. HDD light flickers about every second. Sadly, rebooting is my only option and that means I lose those logs it is so vigorously writing.

The ONLY way I've been able to get my setup to work is to:
1) Install Ubuntu server 10.04 64-bit.
2) apt-get update && apt-get -y upgrade
3) apt-get install ubuntu-desktop (do NOT reboot)
4) install fglrx from repo (installing ATI drivers from AMD/ATI breaks everything at this stage)
5) Shutdown and remove 1 5770 (attempting the other installs with only 1 monitor and one 5770 has no affect)
6) Boot system (hooray we can log in!) but have that stupid "unsupported hardware" watermark there
7) remove fgrlx and install drivers from ATI
8) Shutdown, reinstall 2nd 5770, reconnect second monitor.
9) Screen is a bit screwy and the mouse randomly teleports, screen has dead areas where mouse disappears; Still use catalyst to configure monitors;
        a.) tar /etc/ati to somewhere safe (I use ~/ati_config.tar)
        b.) remove ATI drivers
        c.) install fgrlx
       d.) untar archived /etc/ati back to /etc/ati (simply extracting the contents from the ATI driver with fgrlx doens't fix any of the previous issues...i'm guessing the ATI drivers don't cleanly install and leave something useful behind that fgrlx dosn't overwrite)
A) Reboot
B) Do a complete backup, wipe the sweat off your brow, and enjoy Ubuntu.

I guess you could say I'm insanely dedicated to AMD and Ubuntu, and this is a very painful relationship.

Hossam Riyad (hossam-hossain) wrote :

any fix on Ubuntu 10.10 ATI driver v 11.2

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions

Remote bug watches

Bug watches keep track of this bug in other bug trackers.