10.4 Live CD - Blank screen with Radeon 5870

Bug #569372 reported by Mark Duncan on 2010-04-24
34
This bug affects 6 people
Affects Status Importance Assigned to Milestone
xserver-xorg-video-ati (Ubuntu)
Undecided
Unassigned

Bug Description

When booting from the 10.4 RC Live CD, only a black screen is shown after booting. CTRL-ALT-Fn to switch to a console does nothing. I have tried passing nomodeset and different vga= values with no success. Because of a complete inability to see anything on the screen, I have no log. Ubuntu 9.10 Live CD boots with no problems so this seems to be a regression.

Matteo Rossi (teo-red90) wrote :

I have the same problem on a Sony VAIO CW2C5E notebook with nVidia 310M graphics. I had this problem with beta version too and I had to install from 9.10.

madbiologist (me-again) wrote :

Modesetting support for the ATI "Evergreen" (Radeon 5xxx series) chips was only introduced upstream in kernel 2.6.34. As Lucid is using kernel 2.6.32 (with direct rendering manager (DRM) back-ported from 2.6.33), you will need to use ATI's proprietary fglrx (Catalyst) driver. Were you offered this driver during boot?

Have you tried booting using safe graphics mode?

Have you tried all of the vga= values under the heading "Linux video mode numbers" at http://en.wikipedia.org/wiki/VESA_BIOS_Extensions#Linux_video_mode_numbers

? (don't bother with the 320x200 and 640x400 modes).

If you still can't get the CD to boot to a usable desktop, hold down shift and when the grub menu appears choose recovery mode. Then choose root shell with networking (I think that's what it's called, or it could be command prompt with networking). Then enter the command apt-get install fglrx

Let us know how that goes.

madbiologist (me-again) wrote :

@Matteo - you have a different bug. Please open a new bug and attach the output of lspci -vvnn

Matteo Rossi (teo-red90) wrote :

Thanks, i opened the bug #569492

Peter M. Clausen (pclausen) wrote :

I have the same problem: Dell Lattitude D505 with Intel 855GM Graficcard

I have tried:
- normal boot
- nomodeset
- acpi=off
- nomodeset acpi=off

All resulted in blank screen, no repsonse to Alt+Ctrl+F1..F7

Its strange, because the 10.04 Alpha was running OK on my system (except for some apci problems, e.g.470926 ).

Peter M. Clausen (pclausen) wrote :

Sorry, for posting the wrong place, Bug #568779 is the one affecting me

Nick Lib (nikolauslieb) wrote :

I have the same problem on my Radeon 5850.

When booting the live CD with default options, the graphical boot splash (Plymouth) works, although it runs at a low resolution (Presumably 640x480). Once the x server should take over the screen, the screen simply blanks, although the system continues to load (CD-seeking). The system continues to respond to key strokes, but using Ctrl+Alt+Fn does *not* produce a console and the system is thus unusable.

If I had to guess, I would say that the kernel is trying to use KMS (which is actually unsupported for Evergreen/R800, as madbiologist pointed out), which would explain the lack of a console (unless console hot keys are disabled like Ctrl+Alt+Backspace is on the live CD). I had the same issue, when I first installed my 5850 and I had to install fglrx to fix the issue on my Karmic + xorg edgers PPA + Lucid kernel. However, from vague memory, the Lucid Alpha 3 CD booted fine on the same system.

I was not offered to use fglrx during boot. I tried using "nomodeset", which had no effect.

Setting a "vga=" option caused Plymouth to boot at the selected resolution. However, it had no effect on the screen blanking.

I was unable to find a "safe graphics mode" or any menu option for booting to a command line with and without holding shift.

I also tried turning off ACPI via the boot option, which caused The graphical Plymouth splash to be replaced by what appeared to be a text version. However at the end of the boot sequence, instead of X starting up, a red "[Ok]" from the boot log appeared on top of the Text-Plymouth screen and the system appeared to hang.

Brian Murray (brian-murray) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. This bug did not have a package associated with it, which is important for ensuring that it gets looked at by the proper developers. You can learn more about finding the right package at https://wiki.ubuntu.com/Bugs/FindRightPackage. I have classified this bug as a bug in xorg.

When reporting bugs in the future please use apport, either via the appropriate application's "Help -> Report a Problem" menu or using 'ubuntu-bug' and the name of the package affected. You can learn more about this functionality at https://wiki.ubuntu.com/ReportingBugs.

affects: ubuntu → xorg (Ubuntu)
Bryce Harrington (bryce) on 2010-04-30
affects: xorg (Ubuntu) → xserver-xorg-video-ati (Ubuntu)

Hi Mark,

Please run the command 'apport-collect BUGNUMBER', which will attach several files we need for debugging.

[This is an automated message. Apologies if it has reached you inappropriately; please just reply to this message indicating so.]

tags: added: needs-xorglog
tags: added: needs-lspci-vvnn
Changed in xserver-xorg-video-ati (Ubuntu):
status: New → Incomplete
Bryce Harrington (bryce) on 2010-05-02
tags: added: black-screen
Nick Lib (nikolauslieb) wrote :

Hi Bryce,

I tried to run "apport-collect 569372", but as there does not appear to be an update to this bug, I assume the attempt failed. As this is a blank screen issue, I had no visual feedback to see why it failed.

Here's what I tried to do:
-booted the final release (not RC) normally
-waited for all disk activity to end (and then some -- I assume X had started and everything was loaded)
-pressed Alt+F2 to bring up the "Run Application" dialog
-entered "apport-collect 569372"
Result: no activity on CD or Internet router

As this appeared to fail, I tried switching to console 5 (Ctrl+Alt+F5) and entering the command again (twice). This time I had both CD and Internet activity (on the second attempt), although from what I can now see on this page that apparently still failed. Perhaps the console requires a login, before I could enter the command? Or maybe apport-collect requires user interaction? Just in case, I tried pressing Enter several times, hoping that default answers would do the trick.

In the meantime, I have worked around the issue and installed Lucid, by temporarily disabling my Radeon HD5850 and using the integrated HD4200 of my 785G chip-set and then installing fglrx. After that I re-enabled my HD5850, disabled my HD4200 and ran "aticonfig --initial". I will attach the result of lspci -vvnn on this system, in the hope that it makes no difference that it is now running fglrx on a proper installation. Unfortunately, I can't find an xorg log which doesn't mention fglrx on the system, so I assume the relevant logs were overwritten, as I had to reboot a couple of times since fixing the driver (sorry, this is my main system and I needed it to be usable).

In order to help fix this issue, I would be happy to help out with the xorg log, if someone has a clever idea for retrieving it off the live system, while effectively being blind. Or if necessary, I should be able to try installing another copy in a new partition on the same machine (then do the graphics switch; boot the system which won't work and retrieve the log with the system which will work).

cfwrsfan (cfwrsfan) wrote :

Hi, new here, not sure if this has been fixed or not but it seems that I have this same problem. Whenever I try to boot from the live cd, it loads (at least), and shows all the menus and stuff but there is no text and it looks like an old nintendo game that backfires (you know, colors off, random artifacts etc. etc.). I tried booting noapic and acpi=off and a whole slew of other options (everything as mentioned in the posts above)...to no avail. Anyway, I know it has to do with graphics (obviously) and I have an nvidia gtx 280. I've had problems with nvidia in the past, but I've always had a safe graphics mode. Why doesn't this release have one? That's confusing to me as I always had to rely on that in order to install linux anyway. I digress, I'd love it if there were some way to fix the problem I'm having. You guys are great, keep up the good work!

Bryce Harrington (bryce) wrote :

[Resetting to incomplete since we need a response from the original reporter on this].

Changed in xserver-xorg-video-ati (Ubuntu):
status: Incomplete → New
status: New → Incomplete
Nick Lib (nikolauslieb) wrote :

Hey Bryce

The original reporter may have worked around the issue and then forgotten about it. I was just hoping to help fix this.

Is my input of no use...? I'll save myself any further effort on this if it isn't.

Thanks

Nick

Bryce Harrington (bryce) wrote :

[This is an automatic notification.]

Hi Mark,

This bug was reported against an earlier version of Ubuntu, can you
test if it still occurs on Lucid?

Please note we also provide technical support for older versions of
Ubuntu, but not in the bug tracker. Instead, to raise the issue through
normal support channels, please see:

    http://www.ubuntu.com/support

If you are the original reporter and can still reproduce the issue on
Lucid, please run the following command to refresh the report:

  apport-collect 569372

If you are not the original reporter, please file a new bug report, so
we can work with you as the original reporter instead (you can reference
bug 569372 in your report if you think it may be related):

  ubuntu-bug xorg

If by chance you can no longer reproduce the issue on Lucid or if you
feel it is no longer relevant, please mark the bug report 'Fix Released'
or 'Invalid' as appropriate, at the following URL:

  https://bugs.launchpad.net/ubuntu/+bug/569372

Changed in xserver-xorg-video-ati (Ubuntu):
status: Incomplete → New
status: New → Incomplete
tags: added: needs-retested-on-lucid-by-june
madbiologist (me-again) wrote :

@Nick Lib - Thanks for the tip about running "aticonfig --initial" after installing fglrx. I forgot to mention that in comment 2.

@cfwrsfan - I you have an NVIDIA GTX280 you have a different bug. Please open a new bug and attach the output of lspci -vvnn
Also, I don't think you want to be messing with noapic. APIC is the Advanced Programmable Interrupt Controller (see http://en.wikipedia.org/wiki/Advanced_Programmable_Interrupt_Controller ) and is completely different to acpi, which is the the Advanced Configuration and Power Interface (see http://en.wikipedia.org/wiki/ACPI ). ACPI is older (but is still being actively developed).

Mark Duncan (eattheapple) wrote :

I have tested this on the final Ubuntu and Kubuntu releases. Neither boot properly and just end up at a blank and unresponsive screen exactly as in the RC. I have not found a vga= setting that works.

I tried running "apport-collect 569372", but like Nick above, could not because of the blank and unresponsive screen.

madbiologist (me-again) on 2010-05-06
Changed in xserver-xorg-video-ati (Ubuntu):
status: Incomplete → Confirmed
status: Confirmed → New
status: New → Confirmed
madbiologist (me-again) wrote :

It is interesting that UMS (nomodeset) is not working for either of you, given that UMS for these cards was committed upstream on the 1st February 2010, well before xserver-xorg-video-ati 6.13.0 was released on 5th April 2010 (and before KMS was added to a 2.6.34 kernel RC).

I also found a patch titled "radeon/kms: fix possible crtc mask for evergreen" at http://cgit.freedesktop.org/xorg/driver/xf86-video-ati/commit/?id=2f680b631357661511456f07b7b4ba1aa2cbf30c but I'm not sure what it is supposed to do.

madbiologist (me-again) wrote :

This seems to be the same bug as bug #560306, although I would be reluctant to set this bug as a duplicate of that one at this late stage as it may result in a lack of attention to the (additional) information in this bug. I have mentioned this bug there.

summary: - 10.4 RC Live CD - Blank screen with Radeon 5870
+ 10.4 Live CD - Blank screen with Radeon 5870
Nick Lib (nikolauslieb) wrote :

Thank you for the updates, madbiologist!

Do you know if I could run apport-collect, although I'm not the original reporter? If so, I'll be happy to sit down with a different working system and try to figure out, how to run apport blindly. Hopefully any prompts involved should be predictable enough.

Are you saying that our issue seems not to be KMS related, as nomodeset should be forcing UMS? I suppose it is highly unlikely that nomodeset is not working as expected?

madbiologist (me-again) wrote :

Yes, anyone can run apport-collect <bugnumber>, assuming there is not a build error in the package that the bug is assigned to (xserver-xorg-video-ati in this case) like there was in the Intel graphics driver for a while during Lucid development.

And yes, nomodeset should be forcing UMS. However I found some reports in the forums that nomodeset is not working for some people, both on ATI and Intel graphics. An alternative option which seems to work is radeon.modeset=0

However I emailed ATI's Alex Deucher about the patch I mentioned in the second paragraph of comment 17. This is his reply:

> I'm unsure as to what it is supposed to do/fix.  Would you be able to
> explain briefly for me, with references if necessary?

It just expands the possible crtc mask for the output when mapping the
the kms stuff to xrandr. evergreen cards have 6 crtcs. The old mask
would have limited it to 4 IIRC. It only affects cards capable of
more than 4 independent heads.

>
> In particular, does it have any relevance to the Launchpad bugs at
> https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-video-ati/+bug/569372
> and
> https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-video-ati/+bug/560306
> ?

No relevance. Your best bet for evergreen is kms. The ums
modesetting code doesn't work well for digital outputs and I haven't
had time to sort out why.

Laurent Raufaste (analogue) wrote :

I fixed this by switching my display from one DVI to the other

madbiologist (me-again) wrote :

@Laurent - Thanks for the info. Are you using the standard Lucid kernel or the 2.6.34 kernel PPA? Are you using any of the boot options mentioned above? Can you please provide the output of lspci -vvnn and the output of xrandr --verbose from the working system?

Laurent Raufaste (analogue) wrote :

I'm using the stock lucid amd64 CD with the stock kernel and no boot option specified. I just put the CD in and wait for the desktop to appear.

I attached a text file containing the output of the lspci -vvnn and xrandr --verbose commands.

If you need anything else, just ask !

Baboune (seyvet) wrote :

Got exact same problem. Will try to start by installing 9.10 and then move to 10.04.

Mark Duncan (eattheapple) wrote :

Baboune,

It may be easier to download the alternate install CD then choosing to boot to a recovery console after installing. Once at the console, you can install the Radeon drivers and then 10.04 will boot properly. This is what I had to do to get it installed. Unfortunately, vsync is completely broken even if you force it so the experience isn't the greatest (movies are almost unbearable with all the tearing).

Jiri Grönroos (jiri-gronroos) wrote :

Most likely a duplicate of #560306.

tags: added: evergreen
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions