Comment 6 for bug 413892

Mark Falcey (mfalcey) wrote :

I just tried the 2.6.31-8.10 rt kernel with fglrx and the kernel module build fails. This is from the terminal when installing the kernel headers. This is a clean stock karmic beta install fully updated to today with fglrx already installed on the generic kernel. The rt kernel gave me a short "unable to install module" message when it was installing. When I installed the kernel headers a little while later I got this

[code]
Selecting previously deselcted package linux-rt-headers-2.6.31-8,
unpacking linux-rt-headers-2.6.31-8 (from .../linux-rt-headers-2.6.31-8.10_all.deb
Selecting previously deselcted package linux-headers-2.6.31-8-rt,
Unpacking linux-headers-2.6.21-8-rt (from.../linux-headers-2.6.31-8-rt_2.6.31-8.10_amd64.deb

Setting up linux-rt headers-2.6.31-8 (2.6.31-8.10)
Setting up linux-headers-2.6.31-8-rt (2.6.31-8.10)
run-parts: executing /etc/kerenl/header_postinst.d/dkms

* Running DKMS auto installation service for kernel 2.6.31.8-rt

* fglrx (8.660)...
fglrx (8.660): Installing module.
.....(bad exit status: 6)
  Build failed. Installation skipped.
   ....fail!

run-parts: executing /etc/kernel/headers_postinst.d/nvidia-common
[/code]

I also tried building from /usr/src/fglrx-8.660 and have attached the make.sh.log
I can also give you excepts from the Xorg.0.log which has a few interesting messages besides the usual no DKMS messages

drmDynamicMajor: failed to open /proc/ati/major
drmDynamicMajor: failed to open /proc/ati/major

(WW) fglrx(1): Unable to register ADL handler for 0x00110000
(WW) fglrx(1): Unable to register ADL handler for 0x00120000
(WW) fglrx(1): Unable to register ADL handler for 0x00130000

(EE) fglrx(2): Multiview is only supported with acceleration; this screen will now shutdown.
(EE) fglrx(2): PreInit failed
(II) fglrx(2): === [atiddxPreInit] === end
(EE) fglrx(2): Failed to disable interrupts. Errorcode -9
(EE) fglrx(2): Failed shutdown interrupts. Error -9
(II) UnloadModule: "fglrx"
(II) UnloadModule: "xaa"
(II) UnloadModule: "fb"
(II) UnloadModule: "dri"
(II) UnloadModule: "fglrxdrm"
(II) UnloadModule: "fglrxdrm"

(WW) fglrx(0): could not detect X server version (query_status=-1)
(EE) fglrx(0): atiddxDriScreenInit failed, GPS not been initialized.
(WW) fglrx(0): ***********************************************
(WW) fglrx(0): * DRI initialization failed! *
(WW) fglrx(0): * (maybe driver kernel module missing or bad) *
(WW) fglrx(0): * 2D acceleraton available (MMIO) *
(WW) fglrx(0): * no 3D acceleration available *
(WW) fglrx(0): ********************************************* *

II) Module amdxmm: vendor="X.Org Foundation"
 compiled for 1.4.99.906, module version = 1.0.0
(EE) fglrx(0): XMM failed to open CMMQS connection.
(II) fglrx(0): XMM failed to initialize!

I have a HD3650 and a HD3450 running in xinerama with 3 monitors on the generic kernel with no problems