[ubuntu studio karmic-alpha 4] 100% cpu usage

Bug #413892 reported by Scott Lavender on 2009-08-15
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
xserver-xorg-video-ati (Ubuntu)
Undecided
Unassigned
Nominated for Karmic by 914ian914
Nominated for Lucid by 914ian914

Bug Description

Binary package hint: xorg

Screen text resolution appears too large and individual lines of text wrap around screen onto a second line before usplash is displayed also. Usplash only makes it to filling in the second 'u' before monitor loses signal which then comes back only when the system gets to the GDM.

Anything that scrolls (e.g. Firefox) or updates continuous (system monitor) causes cpu to hit 100%.

If the system is left alone, even in Firefox without scrolling, the cpu drops to normal amounts.

Additionally, sometimes typed keys are repeated numerous times.

Using Ubuntu Studio 9.10 Karmic Alpha-4.

ProblemType: Bug
Architecture: i386
CurrentDmesg:
 [ 24.604039] eth0: no IPv6 routers present
 [ 45.559130] gdu-notificatio[2948]: segfault at c ip b801cb5e sp bfacf4c0 error 4 in libgdu.so.0.0.0[b8013000+23000]
Date: Fri Aug 14 22:16:14 2009
DistroRelease: Ubuntu 9.10
Lsusb:
 Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
 Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
 Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
 Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
 Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
MachineType: Dell Computer Corporation Dimension 4600
Package: xorg 1:7.4+3ubuntu5
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.31-1-rt root=UUID=c779e57e-29d8-4e0b-907a-4ba823904c23 ro quiet splash
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/bash
RelatedPackageVersions:
 xserver-xorg 1:7.4+3ubuntu5
 libgl1-mesa-glx 7.5-1ubuntu1
 libdrm2 2.4.12-1ubuntu1
 xserver-xorg-video-intel 2:2.8.0-0ubuntu2
 xserver-xorg-video-ati 1:6.12.99+git20090629.f39cafc5-0ubuntu5
SourcePackage: xorg
Uname: Linux 2.6.31-1-rt i686
XorgConf: Error: [Errno 2] No such file or directory: '/etc/X11/xorg.conf'
dmi.bios.date: 08/26/2004
dmi.bios.vendor: Dell Computer Corporation
dmi.bios.version: A12
dmi.board.name: 02Y832
dmi.board.vendor: Dell Computer Corp.
dmi.chassis.type: 6
dmi.chassis.vendor: Dell Computer Corporation
dmi.modalias: dmi:bvnDellComputerCorporation:bvrA12:bd08/26/2004:svnDellComputerCorporation:pnDimension4600:pvr:rvnDellComputerCorp.:rn02Y832:rvr:cvnDellComputerCorporation:ct6:cvr:
dmi.product.name: Dimension 4600
dmi.sys.vendor: Dell Computer Corporation
fglrx: Not loaded
system:
 distro: Ubuntu
 architecture: i686kernel: 2.6.31-1-rt

Scott Lavender (slavender) wrote :
Scott Lavender (slavender) wrote :

Also, any time screen changes, e.g. switching between windows or change pages in Firefox, the cpu shoots up to 100%

summary: - [karmic-alpha 4] 100% cpu usage
+ [ubuntu studio karmic-alpha 4] 100% cpu usage
description: updated
Bryce Harrington (bryce) wrote :

Likely a client issue - see https://wiki.ubuntu.com/X/Troubleshooting/HighCPU and try to identify what application is causing it.

affects: xorg (Ubuntu) → ubuntu
affects: ubuntu → xorg (Ubuntu)
Bryce Harrington (bryce) on 2009-08-21
Changed in xorg (Ubuntu):
status: New → Confirmed
Bryce Harrington (bryce) wrote :

See previous comment. Also, the key repeating is probably a different issue that should be reported separately.

affects: xorg (Ubuntu) → ubuntu
Victor Vargas (kamus) wrote :

Can you try to reproduce this issue in latest Ubuntu Karmic version or up to date?

affects: ubuntu → xserver-xorg-video-ati (Ubuntu)
Bryce Harrington (bryce) on 2009-10-09
tags: added: karmic
Mark Falcey (mfalcey) wrote :

I just tried the 2.6.31-8.10 rt kernel with fglrx and the kernel module build fails. This is from the terminal when installing the kernel headers. This is a clean stock karmic beta install fully updated to today with fglrx already installed on the generic kernel. The rt kernel gave me a short "unable to install module" message when it was installing. When I installed the kernel headers a little while later I got this

[code]
Selecting previously deselcted package linux-rt-headers-2.6.31-8,
unpacking linux-rt-headers-2.6.31-8 (from .../linux-rt-headers-2.6.31-8.10_all.deb
Selecting previously deselcted package linux-headers-2.6.31-8-rt,
Unpacking linux-headers-2.6.21-8-rt (from.../linux-headers-2.6.31-8-rt_2.6.31-8.10_amd64.deb

Setting up linux-rt headers-2.6.31-8 (2.6.31-8.10)
Setting up linux-headers-2.6.31-8-rt (2.6.31-8.10)
run-parts: executing /etc/kerenl/header_postinst.d/dkms

* Running DKMS auto installation service for kernel 2.6.31.8-rt

* fglrx (8.660)...
fglrx (8.660): Installing module.
.....(bad exit status: 6)
  Build failed. Installation skipped.
   ....fail!

run-parts: executing /etc/kernel/headers_postinst.d/nvidia-common
[/code]

I also tried building from /usr/src/fglrx-8.660 and have attached the make.sh.log
I can also give you excepts from the Xorg.0.log which has a few interesting messages besides the usual no DKMS messages

drmDynamicMajor: failed to open /proc/ati/major
drmDynamicMajor: failed to open /proc/ati/major

(WW) fglrx(1): Unable to register ADL handler for 0x00110000
(WW) fglrx(1): Unable to register ADL handler for 0x00120000
(WW) fglrx(1): Unable to register ADL handler for 0x00130000

(EE) fglrx(2): Multiview is only supported with acceleration; this screen will now shutdown.
(EE) fglrx(2): PreInit failed
(II) fglrx(2): === [atiddxPreInit] === end
(EE) fglrx(2): Failed to disable interrupts. Errorcode -9
(EE) fglrx(2): Failed shutdown interrupts. Error -9
(II) UnloadModule: "fglrx"
(II) UnloadModule: "xaa"
(II) UnloadModule: "fb"
(II) UnloadModule: "dri"
(II) UnloadModule: "fglrxdrm"
(II) UnloadModule: "fglrxdrm"

(WW) fglrx(0): could not detect X server version (query_status=-1)
(EE) fglrx(0): atiddxDriScreenInit failed, GPS not been initialized.
(WW) fglrx(0): ***********************************************
(WW) fglrx(0): * DRI initialization failed! *
(WW) fglrx(0): * (maybe driver kernel module missing or bad) *
(WW) fglrx(0): * 2D acceleraton available (MMIO) *
(WW) fglrx(0): * no 3D acceleration available *
(WW) fglrx(0): ********************************************* *

II) Module amdxmm: vendor="X.Org Foundation"
 compiled for 1.4.99.906, module version = 1.0.0
(EE) fglrx(0): XMM failed to open CMMQS connection.
(II) fglrx(0): XMM failed to initialize!

I have a HD3650 and a HD3450 running in xinerama with 3 monitors on the generic kernel with no problems

tags: added: iso-testing
Mark Falcey (mfalcey) wrote :

FYI, this seems to be fixed in the 2.6.31-9rt kernel. fglrx builds properly now. I am using a stock clean Karmic amd64 release install fully updated with the following metapackages installed on top.

linux-rt
ubuntustudio-audio
ubuntustudio-audio-plugins
ubuntustudio-desktop

I have not tried xinerama yet on this install so.....but fglrx does seem to be working properly otherwise.

Bryce Harrington (bryce) on 2010-04-06
Changed in xserver-xorg-video-ati (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers