Ubuntu

vmmouse seems to register incorrect x,y values for mouseclick

Reported by Stefan Hamminga on 2008-07-14
90
This bug affects 3 people
Affects Status Importance Assigned to Milestone
xserver-xorg-input-vmmouse (Ubuntu)
High
Unassigned
Intrepid
High
Unassigned

Bug Description

Binary package hint: xserver-xorg-input-vmmouse

Running the Kubuntu Intrepid Alpha 2 CD, no updates installed. Problems also occurred in previous Ubuntu Intrepid packages. Switching vmmouse in xorg.conf to mouse cures the problem. The host is Windows XP x64 SP2 with VMWare Server 1.04. The guest OS is 32 bit.

WORKAROUND:

Edit /etc/X11/xorg.conf and replace

Driver "vmmouse"

with the standard mouse driver:

Driver "mouse"

Chris Coulson (chrisccoulson) wrote :

I can confirm this.

I'm running Intrepid Alpha 2 (fully up-to-date) in VMWare Workstation on Hardy host machine. Using the 'vmmouse' driver causes mouse clicks to occur at the wrong x,y values on the screen. Using the 'mouse' driver fixes it

Changed in xserver-xorg-input-vmmouse:
status: New → Confirmed
Chris Coulson (chrisccoulson) wrote :
Chris Coulson (chrisccoulson) wrote :

From the comments I saw in the package release history a fix is included in the latest builds

Changed in xserver-xorg-input-vmmouse:
status: Confirmed → Fix Committed
Chris Coulson (chrisccoulson) wrote :

Which build are you referring to? The most recent build I could find was 1:12.5.1-1ubuntu3, which I'm already running. It's definately broken in this version.

There was a comment in the changelog for an older version, which suggests it might be fixed:

xserver-xorg-input-vmmouse (1:12.5.1-1ubuntu2) intrepid; urgency=low

  * debian/patches/100_fix_scale.patch, debian/patches/series: drop our patch,
    as if was fixed in the new upstream release (in a different way). Fixing
    the scale twice broke it again. :-)
    .
    The package can be synced again.

 -- Daniel Holbach < <email address hidden>> Wed, 25 Jun 2008 07:53:22 +0200

Changed in xserver-xorg-input-vmmouse:
status: Fix Committed → Confirmed
Tux (peter-hoogkamer) wrote :

I can confirm this problem on a VMware Workstation 5.5.0 running Intrepid Alpha 2 with kernel 2.6.26-4-generic and xserver-xorg-input-vmmouse 1:12.5.1-1. My mouse is stuck in the right bottom corner.

Replacing vmmouse in xorg.conf with mouse cures the problem. It's not yet clear to me what the root cause is. :(

Iain Lane (laney) wrote :

Confirmed with 8.10 Alpha 3 too. This appears to be unrelated to the previous vmmouse upload by dholbach: I was experiencing that bug too and that upload fixed it. Now it is back (but the mouse is stuck in the bottom right instead of the top left as it was before).

Iain Lane (laney) wrote :

Interestingly, I only see this when I boot the live CD in KVM, not vbox.

kgoeser (kevin-kevin-online) wrote :

I think bug #248816 and bug #248098 are the

kgoeser (kevin-kevin-online) wrote :

... same like this one (short cuts can be a pain).

Changed in xserver-xorg-input-vmmouse:
importance: Undecided → High
cros13 (cros13) wrote :

The immediate workaround is to edit /etc/X11/xorg.conf and replace

Driver "vmmouse"

with the standard mouse driver:

Driver "mouse"

description: updated

I'm also seeing this behavior with VMWare Server 1.0.4

Switching the driver from vmmouse to mouse worked for me also.

ROnaldve (ronald-oponzezolder) wrote :

I asume this change of xorg.conf is on the host? not on the guest? For others seeing this also.

Xeletron (xeletron) wrote :

Confirmed in vmware 2 Rc1

The change needs to be made in the guest OS (quite logical since it also occurs with XP as host OS).

Christopher Hoover (choover) wrote :

I see this on 64-bit Vista running 32-bit Intrepid under VM Workstation 6.0.5-build-109488.

Timo Aaltonen (tjaalton) wrote :

so you are seeing this issue with current intrepid? The input drivers in xorg.conf are ignored since input-hotplug is used, so changing the driver to mouse should not do anything. Please attach your /var/log/Xorg.0.log.

Changed in xserver-xorg-input-vmmouse:
status: Confirmed → Incomplete

I installed Intrepid Ibex alpha 6 under VMware Workstation 6.0.5 and this
problem is no longer present.

Thank you!

--------------------------------------------------
From: "Timo Aaltonen" <email address hidden>
Sent: Friday, September 19, 2008 10:54 AM
To: <email address hidden>
Subject: [Bug 248521] Re: vmmouse seems to register incorrect x,y values for
mouseclick

> so you are seeing this issue with current intrepid? The input drivers in
> xorg.conf are ignored since input-hotplug is used, so changing the
> driver to mouse should not do anything. Please attach your
> /var/log/Xorg.0.log.
>
> ** Changed in: xserver-xorg-input-vmmouse (Ubuntu)
> Status: Confirmed => Incomplete
>
> --
> vmmouse seems to register incorrect x,y values for mouseclick
> https://bugs.launchpad.net/bugs/248521
> You received this bug notification because you are a direct subscriber
> of a duplicate bug.
>

Per your request...here is my log.
----------------------------------------
> From: <email address hidden>
> To: <email address hidden>
> Date: Fri, 19 Sep 2008 17:54:22 +0000
> Subject: [Bug 248521] Re: vmmouse seems to register incorrect x, y values for mouseclick
>
> so you are seeing this issue with current intrepid? The input drivers in
> xorg.conf are ignored since input-hotplug is used, so changing the
> driver to mouse should not do anything. Please attach your
> /var/log/Xorg.0.log.
>
> ** Changed in: xserver-xorg-input-vmmouse (Ubuntu)
> Status: Confirmed => Incomplete
>
> --
> vmmouse seems to register incorrect x,y values for mouseclick
> https://bugs.launchpad.net/bugs/248521
> You received this bug notification because you are a direct subscriber
> of a duplicate bug.

John Dong (jdong) wrote :

still happens for me; xorg.0.log attached.

Chris Coulson (chrisccoulson) wrote :

Still happens for me too. I've attached my xorg log as well.

Paul - you don't see it because your xorg is not loading the vmmouse module.

Changed in xserver-xorg-input-vmmouse:
status: Incomplete → Confirmed

Hrmmmm....

Maybe it is because I can't install vmware tools?

--------------------------------------------------
From: "Chris Coulson" <email address hidden>
Sent: Friday, September 19, 2008 12:11 PM
To: <email address hidden>
Subject: [Bug 248521] Re: vmmouse seems to register incorrect x,y values for
mouseclick

> Still happens for me too. I've attached my xorg log as well.
>
> Paul - you don't see it because your xorg is not loading the vmmouse
> module.
>
> ** Attachment added: "Xorg.0.log"
> http://launchpadlibrarian.net/17767337/Xorg.0.log
>
> ** Changed in: xserver-xorg-input-vmmouse (Ubuntu)
> Status: Incomplete => Confirmed
>
> --
> vmmouse seems to register incorrect x,y values for mouseclick
> https://bugs.launchpad.net/bugs/248521
> You received this bug notification because you are a direct subscriber
> of a duplicate bug.
>

Matthew Woerly (nattgew) wrote :

I only had this issue after I did install vmware tools.

Paul Choi (pyckorea) wrote :

So it sounds like on a fresh Vmware Workstation install of ibex alpha 6,
there's no issue until vmware tools is installed.

I can't get my tools to install therefore I am not having this mouse
problem. Not being able to install vmware tools however is a whole another
problem unfortunately. :(

--------------------------------------------------
From: "Nattgew" <email address hidden>
Sent: Friday, September 19, 2008 1:37 PM
To: <email address hidden>
Subject: [Bug 248521] Re: vmmouse seems to register incorrect x,y values for
mouseclick

> I only had this issue after I did install vmware tools.
>
> --
> vmmouse seems to register incorrect x,y values for mouseclick
> https://bugs.launchpad.net/bugs/248521
> You received this bug notification because you are a direct subscriber
> of a duplicate bug.
>

Timo Aaltonen (tjaalton) wrote :

jdong: interesting that you don't have AutoAddDevices set to false, or evdev loaded. Is hald running? Please attach the output of 'lshal'.

Chris Coulson (chrisccoulson) wrote :

Just for completeness - I had to set AutoAddDevices to false in order to get the vmmouse module to load.

Philip Langdale (langdalepl) wrote :

I have pushed a new upstream release that fixes the broken mouseclicks:

http://xorg.freedesktop.org/releases/individual/driver/xf86-input-vmmouse-12.5.2.tar.bz2

and I have filed bug 285305 to track adding proper input hotplug detection.

Philip Langdale (langdalepl) wrote :

I'd like to nominate updating the driver as an SRU. Intrepid isn't officially out yet, but it will be before any update can take place. As the current driver is completely broken and unusable, there is no way to regress the situation and having a broken driver sitting around is highly undesirable.

Bryce Harrington (bryce) on 2008-10-18
Changed in xserver-xorg-input-vmmouse:
milestone: none → ubuntu-8.10
status: Confirmed → Triaged
Bryce Harrington (bryce) wrote :

I've reviewed the upstream changes, and cherry picked out the code changes for this bugfix, in hopes we can possibly squeeze this in for the release. If not, I agree we'll want an SRU to get this in.

Bryce Harrington (bryce) wrote :

I've uploaded this package for intrepid as well, for release team review.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xserver-xorg-input-vmmouse - 1:12.5.1-1ubuntu4

---------------
xserver-xorg-input-vmmouse (1:12.5.1-1ubuntu4) intrepid; urgency=low

  * vmmouse_abs_valuator_axis.diff
    + Cherrypick change from upstream 12.5.2 release which conditionalizes
      xf86InitValuatorAxisStruct() calls based on the ABS_VALUATOR_AXES
      setting. This fixes a problem where incorrect x,y values are
      registered from mouse clicks. (LP: #248521)

 -- Bryce Harrington <email address hidden> Sat, 18 Oct 2008 00:04:05 -0700

Changed in xserver-xorg-input-vmmouse:
status: Triaged → Fix Released
Christopher Hoover (choover) wrote :

ii xserver-xorg-input-vmmouse 1:12.5.1-1ubuntu4 X.Org X server -- VMMouse input driver to us

1:12.5.1-1ubunt4 does *not* fix this problem for me.

This version of the input driver here, http://launchpadlibrarian.net/11183204/vmmouse_drv.so, does fix the problem. I ma using the same xorg.conf in both cases. I have evdev and auto add disabled.

Philip Langdale (langdalepl) wrote :

That other build is incorrect in the way it attempts to address the problem.

What is your output of 'xinput list' with the original and new 12.5.1?

Christopher Hoover (choover) wrote :

With the 11183204 driver:

ch@gato:~$ xinput list
"Virtual core keyboard" id=0 [XKeyboard]
 Num_keys is 248
 Min_keycode is 8
 Max_keycode is 255
"Virtual core pointer" id=1 [XPointer]
 Num_buttons is 32
 Num_axes is 2
 Mode is Relative
 Motion_buffer is 256
 Axis 0 :
  Min_value is 0
  Max_value is -1
  Resolution is 0
 Axis 1 :
  Min_value is 0
  Max_value is -1
  Resolution is 0
"VMWare Mouse" id=2 [XExtensionPointer]
 Num_buttons is 3
 Num_axes is 2
 Mode is Relative
 Motion_buffer is 256
 Axis 0 :
  Min_value is 0
  Max_value is -1
  Resolution is 1
 Axis 1 :
  Min_value is 0
  Max_value is -1
  Resolution is 1
"Generic Keyboard" id=3 [XExtensionKeyboard]
 Num_keys is 248
 Min_keycode is 8
 Max_keycode is 255
"Generic Keyboard" id=4 [XExtensionKeyboard]
 Num_keys is 248
 Min_keycode is 8
 Max_keycode is 255
ch@gato:~$

With 12.5.1:

"Virtual core keyboard" id=0 [XKeyboard]
 Num_keys is 248
 Min_keycode is 8
 Max_keycode is 255
"Virtual core pointer" id=1 [XPointer]
 Num_buttons is 32
 Num_axes is 2
 Mode is Relative
 Motion_buffer is 256
 Axis 0 :
  Min_value is 0
  Max_value is -1
  Resolution is 0
 Axis 1 :
  Min_value is 0
  Max_value is -1
  Resolution is 0
"VMWare Mouse" id=2 [XExtensionPointer]
 Num_buttons is 5
 Num_axes is 2
 Mode is Relative
 Motion_buffer is 256
 Axis 0 :
  Min_value is 0
  Max_value is -1
  Resolution is 1
 Axis 1 :
  Min_value is 0
  Max_value is -1
  Resolution is 1
"Generic Keyboard" id=3 [XExtensionKeyboard]
 Num_keys is 248
 Min_keycode is 8
 Max_keycode is 255
"Generic Keyboard" id=4 [XExtensionKeyboard]
 Num_keys is 248
 Min_keycode is 8
 Max_keycode is 255

"original" is which specific version?

Philip Langdale (langdalepl) wrote :

Bryce. Your patch unfortunately left out the configure.ac change. Without it, it won't set the #ifdef correctly. So, the net result is that nothing has changed. That's why Christopher didn't observe any change.

Christopher - if you build 12.5.2 from source, it should work.

mosaic (cxjzhu) wrote :

I am running intrepid inside vmware workstation 6.5

I used the work around /dev/mouse (instead of /dev/vmmouse), the mouse start to function, however, I cannot freely move inside and outside of VM Guest without using the Control-Alt key combo, when I was using /dev/vmmouse driver, it didn't have the same problem

I also tried the http://launchpadlibrarian.net/11183204/vmmouse_drv.so, same problem as above.

When I used the original /dev/vmmouse, the mouse points to the wrong coordinate, however, it can move in and outside VM guest without the Control-Alt key combo, some further fix needs to be done.

mosaic (cxjzhu) wrote :

BTW, I am using kernel 2.6.27-7-generic, 64-bit, gcc 4.3.2, I compiled the vmware tools on this machine.

History:

I was using Hardy, I noticed, when I was compiling vmware tools, vsock.o cannot be loaded into kernel as a module, aside from this, everything else is working fine. After I tried unseccussfully for a solution to vsock.o, I decided to upgrade the kernel to the newest version, to see whether that will help. Obviously, it's still a no go. However, after I updated the xorg-server... packages, I start to have this mouse problem as observed above. So definitely it was something in xorg-server... broke it. Just an observation from a layman, hope you guys can find a fix soon.

Thanks for your hard work.

Bryce Harrington (bryce) wrote :

What is the configure.ac change?

Changed in xserver-xorg-input-vmmouse:
status: Fix Released → In Progress
Philip Langdale (langdalepl) wrote :

Diff attached.

Bryce Harrington (bryce) wrote :

debdiff for including this

Bryce Harrington (bryce) on 2008-10-21
Changed in xserver-xorg-input-vmmouse:
status: In Progress → Fix Committed
Steve Langasek (vorlon) wrote :

Accepted into intrepid.

xserver-xorg-input-vmmouse (1:12.5.1-1ubuntu5) intrepid; urgency=low

  * vmmouse_abs_valuator_axis.diff:
    + Also include a required change to configure[.ac]

 -- Bryce Harrington <email address hidden> Mon, 20 Oct 2008 18:27:17 -0700

Changed in xserver-xorg-input-vmmouse:
status: Fix Committed → Fix Released
Christopher Hoover (choover) wrote :

I still have no love with 1:12.5.1-1ubuntu5.

"Virtual core keyboard" id=0 [XKeyboard]
 Num_keys is 248
 Min_keycode is 8
 Max_keycode is 255
"Virtual core pointer" id=1 [XPointer]
 Num_buttons is 32
 Num_axes is 2
 Mode is Relative
 Motion_buffer is 256
 Axis 0 :
  Min_value is 0
  Max_value is -1
  Resolution is 0
 Axis 1 :
  Min_value is 0
  Max_value is -1
  Resolution is 0
"VMWare Mouse" id=2 [XExtensionPointer]
 Num_buttons is 5
 Num_axes is 2
 Mode is Relative
 Motion_buffer is 256
 Axis 0 :
  Min_value is 0
  Max_value is -1
  Resolution is 1
 Axis 1 :
  Min_value is 0
  Max_value is -1
  Resolution is 1
"Generic Keyboard" id=3 [XExtensionKeyboard]
 Num_keys is 248
 Min_keycode is 8
 Max_keycode is 255
"Generic Keyboard" id=4 [XExtensionKeyboard]
 Num_keys is 248
 Min_keycode is 8
 Max_keycode is 255

mosaic (cxjzhu) wrote :

Confirm with Chris's finding. I still have to use mouse driver instead of vmmouse, then of course, I cannot move in and out of guest without hitting the control+alt.

Helge Titlestad (helgedt) wrote :

Changing status from fixed to confirmed after the last two comments + my observations that it's still not fixed in xserver-xorg-input-vmmouse 1:12.5.1-1ubuntu5.

Changed in xserver-xorg-input-vmmouse:
status: Fix Released → Confirmed
Helge Titlestad (helgedt) wrote :

Here's my Xorg.0.log when using the vmmouse driver

Tux (peter-hoogkamer) wrote :

I am testing the vmmouse on ubuntu 8.10 release. This is working pretty good. I added the following to my xorg.conf :

Section "InputDevice"
Identifier "Configured Mouse"
Driver "vmmouse"
Option "CorePointer"
Option "Device" "/dev/input/mice"
Option "Protocol" "ImPS/2"
Option "Buttons" "5"
Option "ZAxisMapping" "4 5"
EndSection

When grabbing the mouse focus in the VM sometimes it loses focus. Getting out of the VM sometimes needs a second attempt (mouse get stuck on VM edge). It looks like X or the vmmouse module sometimes cannot determine whether the mouse is in the VM or outside the VM.

Tux (peter-hoogkamer) wrote :
Tux (peter-hoogkamer) wrote :
Tux (peter-hoogkamer) wrote :

Hi,

I can confirm that the 1ubuntu5 version improved things. Previously all clicks where registered at the lower right corner of the screen, now it seems movement of the mouse is registered by the system.
However the coordinates are still off, so I still have to use the normal mouse driver.

When I move the mouse INTO the VMWare window, the shown mouse pointer and the coordinates registered by the guest system are quite close at first. The more I move the pointer into the window, the more the coordinates drift.

Example: I can click the Applications menu, when I move the pointer in from the upper left corner, however when I move the pointer down the menu, the lowest menu entry will highlight while the pointer is actually just about at the middle of the menu.

This is with Kernel 2.6.27-7-generic and VMWare Workstation 6.5 with latest VMWare Tools (from VMWare) installed. The problem occurs with and without /usr/bin/vmware-user started.

Martin Pitt (pitti) wrote :

Accepted into intrepid-proposed, please test and give feedback here. Please see https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in xserver-xorg-input-vmmouse:
milestone: ubuntu-8.10 → none
status: Confirmed → Fix Committed
Helge Titlestad (helgedt) wrote :

Martin: I should only update the xserver-xorg-input-vmmouse package from intrepid-proposed, right?

With the package from intrepid-proposed, I got this error:

(II) XINPUT: Adding extended input device "Configured Mouse" (type: MOUSE)
(II) VMWARE(0): VMMOUSE DEVICE_INIT
(II) VMWARE(0): VMMOUSE DEVICE_ON
(II) VMWARE(0): vmmouse enabled

Backtrace:
0: /usr/X11R6/bin/X(xf86SigHandler+0x79) [0x80c3009]
1: [0xb80d6400]
2: /usr/X11R6/bin/X(xf86PostButtonEvent+0xdf) [0x80da69f]
3: /usr/lib/xorg/modules/input//vmmouse_drv.so [0xb7b7220b]
4: /usr/X11R6/bin/X(EnableDevice+0x9d) [0x808564d]
5: /usr/X11R6/bin/X(InitAndStartDevices+0x7b) [0x80857bb]
6: /usr/X11R6/bin/X(main+0x350) [0x8071bf0]
7: /lib/tls/i686/cmov/libc.so.6(__libc_start_main+0xe5) [0xb7cd6685]
8: /usr/X11R6/bin/X [0x8071101]
Saw signal 11. Server aborting.
(II) VMWARE(0): VMMOUSE DEVICE_OFF/CLOSE
(II) VMWARE(0): VMMouseUnInit

MD4 (bruno-mueller) wrote :

this morning the new xserver-xorg-input-vmmouse package from proposed was installed on my system
(Host: Windows XP, Vmware Workstation 6.5, Guest Ubuntu 8.10 Intrepid)

I can now move the mouse in and out of the vmware guest with no problem.

there is one problem now:
A singleClick is taken as an doubleClick
I checked this out using "Mouse Preferences", so whenever I click on the light bulb it is on

any ideas

Hi,

I got the same error as Helge with the new package. This is VMWare Workstation 6.5 on Ubuntu 8.04, Intrepid guest.
Error occurs with and without paravirtualization enabled. VMWare Tools are installed on the guest.

Greetings, Hanno.

Bryce Harrington (bryce) wrote :

Please report new errors you encounter as new bugs. One bug per issue please.

Changed in xserver-xorg-input-vmmouse:
status: Confirmed → Fix Released

With the new package I have the right behaviour (mouse moves out of vm
without Ctrl-Alt), but when moving into the vm and klicking the cursor
jumps to another location in the vm. So I think the registration of
incorrect x,y coordinates is not solved. Although it is better than
before.

2008/11/7 Bryce Harrington <email address hidden>:
> Please report new errors you encounter as new bugs. One bug per issue
> please.
>
> ** Changed in: xserver-xorg-input-vmmouse (Ubuntu)
> Status: Confirmed => Fix Released
>
> --
> vmmouse seems to register incorrect x,y values for mouseclick
> https://bugs.launchpad.net/bugs/248521
> You received this bug notification because you are a direct subscriber
> of the bug.
>

MD4 (bruno-mueller) wrote :

Changed my xorg.conf

now everything works as expected

Attachment contains both xorg.conf

Philip Langdale (langdalepl) wrote :

Those of you with problems with the new (working) driver should remove all input device references from xorg.conf. vmmouse now works with input hotplug.

Philip Langdale schrieb:
> Those of you with problems with the new (working) driver should remove
> all input device references from xorg.conf. vmmouse now works with input
> hotplug.
>

Thanks! That worked. I just changed my configuration to "default", when
asked in the "low resolution" dialog.
After a reboot everything worked as expected.

Nice work!

Hanno.

Christopher Hoover (choover) wrote :

Works for me.

Thanks Martin, Philip, et al.

-ch

Martin Pitt (pitti) wrote :

Copied to intrepid-updates.

Changed in xserver-xorg-input-vmmouse:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers