upgrade 8.04LTS to 10.4LTS RC results in no keyboard available

Bug #569803 reported by jmhdassen on 2010-04-25
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
xserver-xorg-input-evdev (Ubuntu)
Undecided
Unassigned

Bug Description

I have upgraded Ubuntu 9.10 64 bit to Ubuntu 10.4 RC without any problem.

But when I upgrade Ubuntu 8.04LTS there are problems:

2. When I remove flashplugin, then the upgrade process seems to run fine and results in a booting system. But the system does not accept keyboard input anywhere. Mouse input is OK and input from onboard keyboard is ok also.

both above systems are running on VMware.

regards, JD

jmhdassen (jmhdassen) wrote :

dist upgrade logs attached

Neal Gompa (ngompa13) wrote :

A fresh installation of Ubuntu 10.04 Beta 2 or RC will result in this too. It worked in Beta 1.

David Tombs (dgtombs) wrote :

Does the keyboard work in a virtual terminal? (Ctrl+Alt+F1, etc.) If so, the issue is with X.

Changed in ubuntu:
status: New → Incomplete
jmhdassen (jmhdassen) wrote :

The problem ALSO exists in the virtual terminal.

Moreover the problem exists for all upgrades and fresh installs of 10.4 LTS RC for the login dialog (i.e. it is impossible to enter a password from the keyboard). This does not bother me too much since I am behind firewall and can use automatic login. But the issue is possibly related.

(By all upgrades I mean, upgrades from 8.04 and from 9.10, both i386 and amd64).

Cheers, JD

jmhdassen (jmhdassen) wrote :

Sorry, CORRECTION.

The problem does NOT exist in the virtual terminal.

The rest of the comments are correct.

So if it is an X problem, what is the solution. I am very reluctant to upgrade my actual servers (which are not on VMware) until this issue has been resolved.

JD

David Tombs (dgtombs) wrote :

OK, I'll assign this to xserver-xorg-input-evdev. Having an associated packaged is important for ensuring that the bug gets looked at by the proper developers. You can learn more about finding the right package at https://wiki.ubuntu.com/Bugs/FindRightPackage. (FYI, just a package of "xorg" would have been fine for this bug; xserver-xorg-input-evdev is just more specific.)

Thanks!

affects: ubuntu → xserver-xorg-input-evdev (Ubuntu)
Changed in xserver-xorg-input-evdev (Ubuntu):
status: Incomplete → New
David Tombs (dgtombs) wrote :

I'm also going to edit your bug description to target the keyboard issue, I hope you don't mind. Please file a separate report for the flash issue. Thanks!

description: updated
Chris Halse Rogers (raof) wrote :

It seems likely that this is a duplicate of bug #548891. What does the file /etc/default/console-setup contain?

Changed in xserver-xorg-input-evdev (Ubuntu):
status: New → Incomplete
jmhdassen (jmhdassen) wrote :

This is the content of /etc/default/console-setup:

-------------------------------------------------------------------------------------------------------------------------------------
# A configuration file for setupcon

# Change to "yes" and setupcon will explain what is being doing
VERBOSE_OUTPUT=yes

# Setup these consoles. Most people do not need to change this.
ACTIVE_CONSOLES="/dev/tty[1-6]"

# Put here your encoding. Valid charmaps are: UTF-8 ARMSCII-8 CP1251
# CP1255 CP1256 GEORGIAN-ACADEMY GEORGIAN-PS IBM1133 ISIRI-3342
# ISO-8859-1 ISO-8859-2 ISO-8859-3 ISO-8859-4 ISO-8859-5 ISO-8859-6
# ISO-8859-7 ISO-8859-8 ISO-8859-9 ISO-8859-10 ISO-8859-11 ISO-8859-13
# ISO-8859-14 ISO-8859-15 ISO-8859-16 KOI8-R KOI8-U TIS-620 VISCII
CHARMAP="UTF-8"

# The codeset determines which symbols are supported by the font.
# Valid codesets are: Arabic Armenian CyrAsia CyrKoi CyrSlav Ethiopian
# Georgian Greek Hebrew Lao Lat15 Lat2 Lat38 Lat7 Thai Uni1 Uni2 Uni3
# Vietnamese. Read README.fonts for explanation.
CODESET="Uni1"

# Valid font faces are: VGA (sizes 8, 14 and 16), Terminus (sizes
# 12x6, 14, 16, 20x10, 24x12, 28x14 and 32x16), TerminusBold (sizes
# 14, 16, 20x10, 24x12, 28x14 and 32x16), TerminusBoldVGA (sizes 14
# and 16), Fixed (sizes 13, 14, 15, 16 and 18), Goha (sizes 12, 14 and
# 16), GohaClassic (sizes 12, 14 and 16).
FONTFACE="Fixed"
FONTSIZE="16"

# You can also directly specify nonstandard font and ACM to load:
# FONT=/usr/local/share/funnyfonts/sarge16.psf
# ACM=/usr/local/share/consoletrans/my_special_encoding.acm

# The following variables describe your keyboard and can have the same
# values as the XkbModel, XkbLayout, XkbVariant and XkbOptions options
# in /etc/X11/xorg.conf.
XKBMODEL="thinkpad60"
XKBLAYOUT="us"
XKBVARIANT=""
XKBOPTIONS=""

# Do not update the following md5 sum if you change
# /etc/console-setup/boottime.kmap.gz and Debconf will not overwrite
# your custom keymap. Do not update it even if you want to make
# Debconf overwrite it. Instead simply specify the empty string as
# a md5 sum.

BOOTTIME_KMAP_MD5="aaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaa"
-----------------------------------------------------------------------------------------------------------------------------------

Chris Halse Rogers (raof) wrote :

Hm. That all looks right, although that MD5 sum is either amazingly lucky, or incorrect ;).

Does running “sudo dpkg-reconfigure console-setup” and rebooting fix this?

jmhdassen (jmhdassen) wrote :

I have done the “sudo dpkg-reconfigure console-setup” and the problem has gone away after reboot.

The console-setup file is the same, except for the MD5 which is now an empty string......... So I guess whatever is done during the upgrade process is not entirely correct............

Now the behaviour is completely normal, including being able to login using the keyboard.

Thanks,

Jos Dassen

Bryce Harrington (bryce) wrote :

[This is an automatic notification.]

Hi jmhdassen,

This bug was reported against an earlier version of Ubuntu, can you
test if it still occurs on Lucid?

Please note we also provide technical support for older versions of
Ubuntu, but not in the bug tracker. Instead, to raise the issue through
normal support channels, please see:

    http://www.ubuntu.com/support

If you are the original reporter and can still reproduce the issue on
Lucid, please run the following command to refresh the report:

  apport-collect 569803

If you are not the original reporter, please file a new bug report, so
we can work with you as the original reporter instead (you can reference
bug 569803 in your report if you think it may be related):

  ubuntu-bug xorg

If by chance you can no longer reproduce the issue on Lucid or if you
feel it is no longer relevant, please mark the bug report 'Fix Released'
or 'Invalid' as appropriate, at the following URL:

  https://bugs.launchpad.net/ubuntu/+bug/569803

Changed in xserver-xorg-input-evdev (Ubuntu):
status: Incomplete → New
status: New → Incomplete
tags: added: needs-retested-on-lucid-by-june
jmhdassen (jmhdassen) wrote :

I have finally managed to do another upgrade to a copy of the 8.0.4 LTS Virtual Machine (upgrade servers seem heavily overloaded at present).

The symptoms are still the same: no keyboard after migration. dpkg-reconfigure console-setup did not help.

But I did find out what was really the problem. The problem disappears after reinstalling VMware Tools and reboot. Now I do know that VMware Tools is needed for 'smooth' operation, but now it turns out you will not get any keyboard input at all without it being reinstalled. This I find a bit surprising since it does have an effect even on the login screen, when vmware tools have not started up yet. And I have not seen this with any previous versions.
Obviously it is not that straightforward either to reinstall VMware Tools, since it must all be done with the on screen keyboard.

I am not sure whether this is now an Ubuntu problem or a VMware problem or a combination of both.
(My VMware is Workstation 7.0.1)

But since there is a workaround, I can live with it.

Bryce Harrington (bryce) on 2010-05-21
tags: added: hardy
Launchpad Janitor (janitor) wrote :

[Expired for xserver-xorg-input-evdev (Ubuntu) because there has been no activity for 60 days.]

Changed in xserver-xorg-input-evdev (Ubuntu):
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers