If -synaptics is installed, GNOME Mouse & Touchpad Settings doesn't work

Bug #1686081 reported by Jeremy Bicha on 2017-04-25
90
This bug affects 24 people
Affects Status Importance Assigned to Milestone
Release Notes for Ubuntu
Undecided
Unassigned
gnome-control-center (Ubuntu)
Medium
Daniel van Vugt
Artful
Undecided
Unassigned
gtk+3.0 (Ubuntu)
Medium
Daniel van Vugt
mutter (Ubuntu)
Medium
Daniel van Vugt
Artful
Undecided
Unassigned
xorg (Ubuntu)
High
Jean-Baptiste Lallement
Artful
High
Jean-Baptiste Lallement
xubuntu-meta (Ubuntu)
Undecided
Unassigned
Artful
Undecided
Unassigned

Bug Description

I'm splitting this issue off from LP: #1685542 (which made xserver-xorg-input-all no longer recommend xserver-xorg-input-synaptics) for tracking the remaining issues.

gnome-control-center only supports libinput. If xserver-xorg-input-synaptics is installed (because it's used by some desktops which haven't been ported to libinput yet), synaptics overrides libinput. That makes gnome-control-center's Mouse & Touchpad settings panel only show basic settings and important configurations don't work.

Questions
---------
1. Which desktops/apps still need -synaptics?
- Unity
- Xfce?
- LXDE? LXQt?
All the other major desktops have already been ported (LP: #1417980)

2. Can these apps be ported or removed before 18.04 LTS is released?

3. Can the desktops be ported and how bad is it if they are not ported and -synaptics is no longer available?

4. If -synaptics can't be removed completely from 18.04 LTS, does it make sense to have gnome-control-center Conflicts: xserver-xorg-input-synaptics?

5. Is there any other way we can fix this conflict?

Jeremy Bicha (jbicha) on 2017-04-25
description: updated
Timo Aaltonen (tjaalton) wrote :

the only one that needs -synaptics is unity

Paul White (paulw2u) wrote :

When testing both Xubuntu 17.10 daily ISOs (20170428) I found that tap and double tap on the touchpad to not be working. Scrolling was fine.

Installing -synaptics re-enabled the tap/double tap functionality after logging out and back in again.

Timo Aaltonen (tjaalton) wrote :

tap-to-click isn't enabled by default in -libinput

Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1686081

tags: added: iso-testing
tags: added: desktop-trello-import
tags: removed: desktop-trello-import
Jeremy Bicha (jbicha) wrote :

Here's a request asking for gnome-control-center to warn somehow when the Synaptics driver is in use:

https://bugzilla.gnome.org/show_bug.cgi?id=784266

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xubuntu-meta - 2.216

---------------
xubuntu-meta (2.216) artful; urgency=medium

  * Refreshed dependencies
  * Added xserver-xorg-input-synaptics to core-recommends, desktop-
    recommends (LP: #1686081)
  * Update Standards-Version to 4.0.0
    - debian/control

 -- Sean Davis <email address hidden> Mon, 18 Sep 2017 20:44:45 -0400

Changed in xubuntu-meta (Ubuntu):
status: New → Fix Released
Didier Roche (didrocks) on 2017-09-20
tags: added: rls-aa-incoming
Will Cooke (willcooke) on 2017-09-27
tags: removed: rls-aa-incoming
Changed in xorg (Ubuntu Artful):
assignee: nobody → Jean-Baptiste Lallement (jibel)
Changed in ubuntu-release-notes:
status: New → Fix Released
Consumology (hgms72-4oneway) wrote :

After upgrading my laptop to 17.10 I had right click functionality on my touchpad. Then it was gone, some other people also reported this on askubuntu but I could not find a related bug. After finding this bug I installed xserver-xorg-input-synaptics and right click on my touchpad is back. So the disappearing right click functionality is a problem in libinput?

Daniel Frost (k-one) wrote :

Hi, I just upgraded from 17.04 to 17.10.
I m running my ubuntu in Xorg mode.
After the upgrade (Dell Laptop with an Alps touchpad) there are no touchpad settings available at all (see attached screenshot).
The touchpad would work though, but I could not disable it at all. Pressing the Function-key+F3 would show the on-screen symbol of the disabled touchpad, but it wouldn't disable the touchpad.
At the moment I am using a bash script that is utilizing "xinput --disable $device" to enable/disable the touchpad.

Chris Rainey (ckrzen) wrote :

@k-one, do the following:

$ sudo apt-get update && sudo apt-get --auto-remove purge xserver-xorg-input-synaptics && sudo apt-get install xserver-xorg-input-libinput

$ reboot

Fixed?

Daniel Frost (k-one) wrote :

Hi Chris,

thanks for taking time to look into this.
I tried your code, but no, the system touchpad hotkey (FN+F3) is still not working.
There are still no touchpad settings available.
And my workaround-script doesn't work anymore either. ;-)

Chris Rainey (ckrzen) wrote :

Hrmmmm ... curious.

You can revert my code by reversing the action and reinstalling the -synaptics driver.

Might be time for a clean-install?

Daniel Frost (k-one) wrote :

Hm, some things you should not do in the middle of the night. :-(

I have tried your code again today. It does work!
Touchpad works fine, settings are available.

Yesterday, doing a simple copy&paste, I did miss the linebrake after the end of the first line here in the launchpad code (same in the email).

So I have to apologize for making you go "Hrmmmm ... curious." :-)
And thanks a lot for the working touchpad.

Awesome. Welcome to GNOME proper!

On Tue, Jan 30, 2018 at 3:35 PM Daniel Frost <email address hidden> wrote:

> Hm, some things you should not do in the middle of the night. :-(
>
> I have tried your code again today. It does work!
> Touchpad works fine, settings are available.
>
> Yesterday, doing a simple copy&paste, I did miss the linebrake after the
> end of the first line here in the launchpad code (same in the email).
>
> So I have to apologize for making you go "Hrmmmm ... curious." :-)
> And thanks a lot for the working touchpad.
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1686081
>
> Title:
> If -synaptics is installed, GNOME Mouse & Touchpad Settings doesn't
> work
>
> Status in Release Notes for Ubuntu:
> Fix Released
> Status in xorg package in Ubuntu:
> Confirmed
> Status in xubuntu-meta package in Ubuntu:
> Fix Released
> Status in xorg source package in Artful:
> Confirmed
> Status in xubuntu-meta source package in Artful:
> Fix Released
>
> Bug description:
> I'm splitting this issue off from LP: #1685542 (which made xserver-
> xorg-input-all no longer recommend xserver-xorg-input-synaptics) for
> tracking the remaining issues.
>
> gnome-control-center only supports libinput. If xserver-xorg-input-
> synaptics is installed (because it's used by some desktops which
> haven't been ported to libinput yet), synaptics overrides libinput.
> That makes gnome-control-center's Mouse & Touchpad settings panel only
> show basic settings and important configurations don't work.
>
> Questions
> ---------
> 1. Which desktops/apps still need -synaptics?
> - Unity
> - Xfce?
> - LXDE? LXQt?
> All the other major desktops have already been ported (LP: #1417980)
>
> 2. Can these apps be ported or removed before 18.04 LTS is released?
>
> 3. Can the desktops be ported and how bad is it if they are not ported
> and -synaptics is no longer available?
>
> 4. If -synaptics can't be removed completely from 18.04 LTS, does it
> make sense to have gnome-control-center Conflicts: xserver-xorg-input-
> synaptics?
>
> 5. Is there any other way we can fix this conflict?
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/ubuntu-release-notes/+bug/1686081/+subscriptions
>

Chris Rainey (ckrzen) wrote :

@me ... remember to use the <code> tags !!

On Tue, Jan 30, 2018 at 4:10 PM Chris Rainey <email address hidden> wrote:

> Awesome. Welcome to GNOME proper!
>
>
> On Tue, Jan 30, 2018 at 3:35 PM Daniel Frost <email address hidden> wrote:
>
>> Hm, some things you should not do in the middle of the night. :-(
>>
>> I have tried your code again today. It does work!
>> Touchpad works fine, settings are available.
>>
>> Yesterday, doing a simple copy&paste, I did miss the linebrake after the
>> end of the first line here in the launchpad code (same in the email).
>>
>> So I have to apologize for making you go "Hrmmmm ... curious." :-)
>> And thanks a lot for the working touchpad.
>>
>> --
>> You received this bug notification because you are subscribed to the bug
>> report.
>> https://bugs.launchpad.net/bugs/1686081
>>
>> Title:
>> If -synaptics is installed, GNOME Mouse & Touchpad Settings doesn't
>> work
>>
>> Status in Release Notes for Ubuntu:
>> Fix Released
>> Status in xorg package in Ubuntu:
>> Confirmed
>> Status in xubuntu-meta package in Ubuntu:
>> Fix Released
>> Status in xorg source package in Artful:
>> Confirmed
>> Status in xubuntu-meta source package in Artful:
>> Fix Released
>>
>> Bug description:
>> I'm splitting this issue off from LP: #1685542 (which made xserver-
>> xorg-input-all no longer recommend xserver-xorg-input-synaptics) for
>> tracking the remaining issues.
>>
>> gnome-control-center only supports libinput. If xserver-xorg-input-
>> synaptics is installed (because it's used by some desktops which
>> haven't been ported to libinput yet), synaptics overrides libinput.
>> That makes gnome-control-center's Mouse & Touchpad settings panel only
>> show basic settings and important configurations don't work.
>>
>> Questions
>> ---------
>> 1. Which desktops/apps still need -synaptics?
>> - Unity
>> - Xfce?
>> - LXDE? LXQt?
>> All the other major desktops have already been ported (LP: #1417980)
>>
>> 2. Can these apps be ported or removed before 18.04 LTS is released?
>>
>> 3. Can the desktops be ported and how bad is it if they are not ported
>> and -synaptics is no longer available?
>>
>> 4. If -synaptics can't be removed completely from 18.04 LTS, does it
>> make sense to have gnome-control-center Conflicts: xserver-xorg-input-
>> synaptics?
>>
>> 5. Is there any other way we can fix this conflict?
>>
>> To manage notifications about this bug go to:
>>
>> https://bugs.launchpad.net/ubuntu-release-notes/+bug/1686081/+subscriptions
>>
>

William Maddox (wmaddox) wrote :

I experienced this problem when doing a *clean installation* of Ubuntu GNOME 16.04.3. I confirmed that the synaptics driver was in use. apt-get update; apt-get upgrade did not resolve the problem.

I was able to get the touchpad settings working by uninstalling the synaptics driver and installing libinput. I had to upgrade a held-back dependency in order to do this, and I'm not sure if the result was entirely kosher.

It seems like a clean installation should not have this problem, nor is it clear to me how the synaptics support got dropped in Ubuntu GNOME 16.04.3 when the upstream version affected was 3.20, and 16.04.3 is still documented as including GNOME 3.18. I can understand how these kinds of issues can occur in an upgrade to a new major version such as 17.10, but it's really a big boo-boo to have this sort of breakage in the routine updates to an LTS release. It would at least be helpful to mention this issue in the release notes for UG 16.04.3.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubuntu:
status: New → Confirmed
affects: gtk+3.0 (Ubuntu) → ubuntu
Changed in ubuntu:
assignee: nobody → Daniel van Vugt (vanvugt)
status: New → In Progress
Changed in mutter (Ubuntu):
assignee: nobody → Daniel van Vugt (vanvugt)
importance: Undecided → Medium
status: New → In Progress
Changed in xorg (Ubuntu):
status: Confirmed → Invalid
Changed in xorg (Ubuntu Artful):
status: Confirmed → Invalid
Changed in gnome-control-center (Ubuntu):
assignee: nobody → Daniel van Vugt (vanvugt)
importance: Undecided → Medium
status: New → In Progress
Changed in gnome-control-center (Ubuntu Artful):
status: New → Confirmed
Changed in mutter (Ubuntu Artful):
status: New → Confirmed
Daniel van Vugt (vanvugt) wrote :

I'm merging bug 1733032 (which contains fixes) into this one.

no longer affects: ubuntu
no longer affects: Ubuntu Artful
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubuntu:
status: New → Confirmed
affects: gtk+3.0 (Ubuntu) → ubuntu
Changed in ubuntu:
assignee: nobody → Daniel van Vugt (vanvugt)
importance: Undecided → Medium
status: New → In Progress
no longer affects: ubuntu
Changed in ubuntu:
status: New → Confirmed
affects: gtk+3.0 (Ubuntu) → ubuntu
Changed in ubuntu:
assignee: nobody → Daniel van Vugt (vanvugt)
importance: Undecided → Medium
status: New → In Progress
affects: ubuntu → gtk+3.0 (Ubuntu)

The attachment "mutter_3.28.0-1ubuntu1.debdiff" seems to be a debdiff. The ubuntu-sponsors team has been subscribed to the bug report so that they can review and hopefully sponsor the debdiff. If the attachment isn't a patch, please remove the "patch" flag from the attachment, remove the "patch" tag, and if you are member of the ~ubuntu-sponsors, unsubscribe the team.

[This is an automated message performed by a Launchpad user owned by ~brian-murray, for any issue please contact him.]

tags: added: patch
Jeremy Bicha (jbicha) wrote :

Daniel, I built & installed mutter & gnome-control-center with your patches but I still don't see the Touchpad Settings in my Ubuntu (on Xorg) session after installing xserver-xorg-input-synaptics.

Daniel van Vugt (vanvugt) wrote :

Jeremy,

That may be due to the gdk bug mentioned in the gnome-control-center patch. I tried working around it there but probably need to propose a better fix to gdk (which I had started but became too busy to finish). Although I do have an alternative gnome-control-center fix in mind (less elegant) that would avoid the gdk bug better.

Also make sure you're running it on a machine with a touchpad :)

Daniel van Vugt (vanvugt) wrote :

Upstream bug for GDK's touchpad detection:
https://gitlab.gnome.org/GNOME/gtk/issues/97

Daniel van Vugt (vanvugt) wrote :

Fix (v2) for gnome-control-center.

This includes a workaround for gdk so we're not waiting for that fix. This does however depend on the mutter fix being present.

Daniel van Vugt (vanvugt) wrote :

Fix (with the new bug ID) for mutter.

Jeremy Bicha (jbicha) on 2018-03-19
Changed in mutter (Ubuntu):
status: In Progress → Fix Committed
tags: added: block-proposed
Jeremy Bicha (jbicha) on 2018-03-19
Changed in gnome-control-center (Ubuntu):
status: In Progress → Fix Committed
tags: removed: block-proposed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package mutter - 3.28.0-2

---------------
mutter (3.28.0-2) unstable; urgency=medium

  [ Simon McVittie ]
  * Update Vcs-* for migration from Alioth svn to salsa.debian.org git
  * debian/gbp.conf: Add
  * Refresh patch series with gbp pq

  [ Daniel van Vugt ]
  * Add synaptics-support.patch
    - Allow touchpad settings to work with xserver-xorg-input-synaptics.
      Note that this is unneeded on GNOME on Wayland where libinput is
      always used. (LP: #1686081)

  [ Jeremy Bicha ]
  * Bump debhelper compat to 11

 -- Jeremy Bicha <email address hidden> Sun, 18 Mar 2018 20:11:29 -0400

Changed in mutter (Ubuntu):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-control-center - 1:3.28.0-0ubuntu1

---------------
gnome-control-center (1:3.28.0-0ubuntu1) bionic; urgency=medium

  [ Jeremy Bicha ]
  * New upstream release

  [ Gunnar Hjalmarsson ]
  * debian/rules:
    - Add X-Ubuntu-Gettext-Domain to .desktop files and strip inline
      translations (LP: #1755473).
    - Build gnome-control-center-2.0.pot.
  * Modify 71_ubuntu_dock_settings.patch:
    - Drop non-existing gnome-ubuntu-panel.desktop.in from POTFILES.in.

  [ Daniel van Vugt ]
  * Add 0004-Expose-touchpad-settings-if-synaptics-is-in-use.patch
    - Allow touchpad settings to work with xserver-xorg-input-synaptics
      Note that this is unneeded on GNOME on Wayland where libinput is
      always used. (LP: #1686081)

  [ Andrea Azzarone ]
  * Add auto_quit_after_goa_add.patch:
    - Hide window after adding an online account from another app.
      (LP: #1754651)

 -- Jeremy Bicha <email address hidden> Mon, 19 Mar 2018 08:37:32 -0400

Changed in gnome-control-center (Ubuntu):
status: Fix Committed → Fix Released
Alex (a-cat) wrote :

Hello!

After these patches gnome no longer respects settings in /etc/X11/xorg.conf.d/*-synaptics.conf file, like Option "TapButton1" "1", Option "TapButton2" "2", Option "TapButton3" "3" etc.

Daniel van Vugt (vanvugt) wrote :

Alex,

The mutter fix does set its own settings for TapButtons. And gnome-control-center (for reasons unexplained) has no GUI to configure it. But you can affect those settings by installing and running 'gnome-tweak-tool' and then set:

  gnome-tweak-tool > Keyboard & Mouse > Touchpad > Mouse Click Emulation = Fingers

which is the same as TapButton1=1 TapButton2=3 TapButton3=2.

If that's not enough then you can also force your own settings by running command 'synclient'. Once you know the synclient syntax you want you can apply it automatically at login by running 'gnome-session-properties'.

And if that's still not enough then you can also log a bug if you like:
https://bugs.launchpad.net/ubuntu/+source/mutter/+filebug

Daniel van Vugt (vanvugt) wrote :

Also make sure you have Settings > Mouse & Touchpad > Touchpad > Tap to Click = ON
:)

Alex (a-cat) wrote :

Daniel,

There is a small inconvenience with 'synclient' command - I have to run it not just at startup, but also every time I restart gnome-shell (after installing an extension, for example). But anyway, it looks like libinput 1.10.2 resolved the problem with hysteresis on my touchpad, so I can just use it and set options like "TappingButtonMap" "lmr" and "HorizontalScrolling" "off" with libinput driver in /etc/X11/xorg.conf.d/.

And thank you for your work on improving Ubuntu! :)

Daniel van Vugt (vanvugt) wrote :

Alex,

You shouldn't ever have to run synclient manually again. See comment #36:

"Once you know the synclient syntax you want you can apply it automatically at login by running 'gnome-session-properties'."

Alex (a-cat) wrote :

Daniel,

I have added 'synclient' command with options I want to gnome-session-properties, and at login everything works as expected:

a-cat@laptop:~$ synclient | grep -E 'TapButton|HorizTwoFingerScroll'
    HorizTwoFingerScroll = 0
    TapButton1 = 1
    TapButton2 = 2
    TapButton3 = 3

But if for whatever reason I restart gnome-shell (with Alt+F2 r or gnome-shell --replace) I end up with mutter's settings:

a-cat@laptop:~$ synclient | grep -E 'TapButton|HorizTwoFingerScroll'
    HorizTwoFingerScroll = 1
    TapButton1 = 1
    TapButton2 = 3
    TapButton3 = 2

It's not a big deal, I don't restart gnome-shell every day, but I am lazy, so I bind 'synclient' command with my preferred option to a custom shortcut, so I can get my settings back quickly after restarting gnome-shell.

Daniel van Vugt (vanvugt) wrote :

We're overloading this bug with tangential discussion. So if you have any ongoing issues, please open a new bug.

Jeremy Bicha (jbicha) wrote :

I am unsubscribing ubuntu-sponsors now since the patches here for bionic for gnome-control-center and mutter have been uploaded.

Please feel free to resubscribe ubuntu-sponsors if you have something else that needs sponsoring.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.