Ubuntu

Drop and sub menus don't always show up

Reported by Serrano Pereira on 2010-10-23
288
This bug affects 52 people
Affects Status Importance Assigned to Milestone
xorg-server (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: xorg-server

I recently upgraded from Ubuntu 10.04 to 10.10, and now application menus sometimes don't show up. As far as I can tell, this happens randomly for all drop and sub menus, including menus for applets/indicators in the gnome-panel, gnome-terminal, thunderbird, gedit, nautilus, and all other applications I've tested.

It seems to happen randomly, some menus display fine, but some don't display. Interestingly, when the menu doesn't appear, and you move your pointer to the place where the menu should appear, the menu suddenly appears. Also, this seems to happen once per menu, so if a specific menu didn't display, the second time you click that menu item, the menu does display, and will display properly the next times you click it. But, if you restart that application, it will start over again.

The problem doesn't happen after disabling compiz. When compiz is started again, the problem is back.

Maybe this issue came to Maverick with the new X.Org Server 1.9 release.
(The X.Org, Mesa Plans For Ubuntu 10.10) http://www.phoronix.com/scan.php?page=news_item&px=ODI0Nw

Comment #20 contains a video illustrating the problem.

ProblemType: Bug
DistroRelease: Ubuntu 10.10
Package: compiz 1:0.8.6-0ubuntu9.1f
ProcVersionSignature: Ubuntu 2.6.35-22.35-generic-pae 2.6.35.4
Uname: Linux 2.6.35-22-generic-pae i686
NonfreeKernelModules: nvidia
Architecture: i386
CompizPlugins: [core,ccp,move,resize,place,decoration,text,mousepoll,imgjpeg,workarounds,shift,regex,resizeinfo,png,animation,svg,animationaddon,blur,wall,loginout,obs,wobbly,video,fade,scale,expo,addhelper,ezoom]
Date: Sat Oct 23 14:44:36 2010
InstallationMedia: Ubuntu 10.04 LTS "Lucid Lynx" - Release i386 (20100429)
MachineType: CLEVO CO. M740TU(N)/M760TU(N)/W7X0TUN
PackageArchitecture: all
PciDisplay: 01:00.0 VGA compatible controller [0300]: nVidia Corporation G98M [GeForce G 105M] [10de:06ec] (rev a1) (prog-if 00 [VGA controller])
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.35-22-generic-pae root=UUID=96a0f5fc-e386-445c-b36c-3072ee33c387 ro vga=792 splash quiet quiet splash nomodeset video=uvesafb:mode_option=1366x768-24,mtrr=3,scroll=ywrap
ProcEnviron:
 PATH=(custom, user)
 LANG=en_US.utf8
 SHELL=/bin/bash
RelatedPackageVersions:
 xserver-xorg 1:7.5+6ubuntu3
 libgl1-mesa-glx 7.9~git20100924-0ubuntu2
 libdrm2 2.4.21-1ubuntu2.1
 xserver-xorg-video-intel 2:2.12.0-1ubuntu5
 xserver-xorg-video-ati 1:6.13.1-1ubuntu5
SourcePackage: compiz
dmi.bios.date: 04/02/2009
dmi.bios.vendor: Phoenix Technologies LTD
dmi.bios.version: 1.02.22
dmi.board.asset.tag: Tag 12345
dmi.board.name: M740TU(N)/M760TU(N)/W7X0TUN
dmi.board.vendor: CLEVO Co.
dmi.board.version: Not Applicable
dmi.chassis.asset.tag: No Asset Tag
dmi.chassis.type: 1
dmi.chassis.vendor: No Enclosure
dmi.chassis.version: N/A
dmi.modalias: dmi:bvnPhoenixTechnologiesLTD:bvr1.02.22:bd04/02/2009:svnCLEVOCO.:pnM740TU(N)/M760TU(N)/W7X0TUN:pvrNotApplicable:rvnCLEVOCo.:rnM740TU(N)/M760TU(N)/W7X0TUN:rvrNotApplicable:cvnNoEnclosure:ct1:cvrN/A:
dmi.product.name: M740TU(N)/M760TU(N)/W7X0TUN
dmi.product.version: Not Applicable
dmi.sys.vendor: CLEVO CO.
system: distro = Ubuntu, architecture = i686, kernel = 2.6.35-22-generic-pae

carbonariy (carbonariy) wrote :

Confirm.
Fix: install compizconfig-settings-manager, go to Effects -> Animations panel and remove second line in "Open Animation" tab (that affects to menu/drop-down/etc)

Samic (i-samic) wrote :

carbonariy, I did as you said even I turned off the Animations but it doesn't changed anything!

Also I just wanted to add that there are some pictures here :
http://ubuntuforums.org/showthread.php?p=10015027

What carbonariy said didn't work for me either.

Nadav (nadav74) wrote :

carbonairy's comment is indeed useless. What's more interesting - does everybody affected have a NVidia display adapter?

Samic (i-samic) wrote :

I have Nvidia! but these things happened after upgrading to maverick

Nadav (nadav74) wrote :

Samic, same here. It doesn't happen with Lucid.

solan (solan85) wrote :

I can also confirm this bug. Exactly as described above. Ubuntu 10.10, compiz 0.8.6, nvidia proprietary driver. Upgraded from 10.04, where this bug wasn't present at the time.

pfrenssen (pieter-frenssen) wrote :

I can confirm this. Started happening after upgrade to 10.10. I have compiz 0.8.6, NVIDIA proprietary driver 260.19.06

Nadav (nadav74) wrote :

If I may add, I'm using the native driver as well. I have the same native proprietary versions on two installations on the same box (I have one root partition for Lucid and one for Maverick, both mount the same /home). I've had this issue with all native driver versions I tried on Maverick (260.19.06, 256.53) but not on Lucid. So this "feature" is distinct to Maverick and is probably an issue with Compiz and not with the drivers.

Another small thing I can add: my Maverick installation is a clean one, not an upgrade from Lucid. This issue happens with both the account previously created by Lucid and with one created with Maverick (meaning, it's absolutely clean, so it's definitely not an upgrade issue).

Marco Giancotti (ma.giancotti) wrote :

I have this problem too on a clean install, but I have an ATI card with the manufacturer's drivers, so this may not be related to nvidia.

Got the same problem here. Some additional information:
Also occurs with Metacity when Compositing (gconf: apps/metacity) is enabled, so I filed a bug against the nvidia drivers that got marked duplicate. Can anyone confirm that this is not just a compiz problem? If so, we should figure out where exactly the problem lies...

Seeing that people with different drivers (and different WMs) got this problem, my best guess would be the X.org Compositing Extension. Anyone with a way to prove that?

Alex Boudrin (a-boudrin) wrote :

I have the same problem. Maverick/Gnome with Compiz at Aspire 5740G with an ATI proprietary drivers.

flm (flmommens) wrote :

Same issue here with nvidia driver 1.9.0. Updated from 10.4 which didn't have the problem.

Thorsten Roth (thorsten-roth) wrote :

Same problem here with nvidia driver 260.19.06...

Could anyone else please try using Metacity with Compositing (Activate Metacity, open gconf-editor, navigate to /apps/metacity/general/ and check compositing manager) enabled so we can pinpoint the culprit?

Thorsten Roth (thorsten-roth) wrote :

Also happens on my laptop with Intel graphics, by the way, so it's definitely not an NVidia issue.

I selected "Metacity" as the Window Manager using fusion-icon (Metacity
was already selected). Then checked "compositing_manager" in
gconf-editor, but I didn't notice any difference (I don't really
understand why that option is useful).

On 11/08/2010 10:51 PM, Philipp Specht wrote:
> Could anyone else please try using Metacity with Compositing (Activate
> Metacity, open gconf-editor, navigate to /apps/metacity/general/ and
> check compositing manager) enabled so we can pinpoint the culprit

pfrenssen (pieter-frenssen) wrote :

Philipp Specht, how can I activate Metacity?

Davis Bynum (lerris) wrote :

I'm having this same issue since upgrading to 10.10. I'm using a Radeon 4850 with the proprietary fglrx drivers so I do believe it's definitely not a video card issue. I've attached a quick video illustrating the problem with dropdown menus. Submenus act the same way. I also find with submenus, however, that if I click three times (which would be the equivalent of show, hide, show) on one that isn't showing properly, it fixes it for that menu as well.

I also notice this problem with Eclipse, but it only affected submenus in that. It seemed to affect ~100% of the submenus in Eclipse, however, but in other apps it's maybe 30%.

I tried using metacity with compositing, but had the same issue. I also tried, before that, disabling compiz plugins one at a time to see if I could pinpoint any specific one causing it. Again, no luck.

Anyway, hopefully the video illustrates the problem a bit more clearly.

Alexandre Anoutchine (xirius) wrote :

Same problem here. Clean install (Maverick). NVidia 260.19.06. It only happens with compiz. It doesn't happen with Lucid.
Probably this issue came to Maverick with the new X.Org Server 1.9 release.
(The X.Org, Mesa Plans For Ubuntu 10.10) http://www.phoronix.com/scan.php?page=news_item&px=ODI0Nw

pfrenssen: Disabling visual effects in the Appearence Options will enable Metacity.
Serrano Pereira: Compositing uses textures for each window, making it possible to have effects like real transparency.

Anyway, I'm with Alexandre Anoutchine on this being an X.org bug, we should mark this bug accordingly.

Nadav (nadav74) wrote :

Alexandre, let me try to put it right: because Maverick is not a LTS release, Canonical released beta quality versions of X and Mesa?...

Alexandre Anoutchine (xirius) wrote :

@Nadav: I wouldn't say beta quality just the latest releases of the pakages. LTS releases usually use "community proven stable versions" of the packages. The have to ensure 3 years support for them.

affects: compiz (Ubuntu) → xorg-server (Ubuntu)
description: updated
missyou11 (missyou11) wrote :

Same here when I was using 10.04 with compiz on. Later I switched to Awesome and the nouveau driver, this happens again, but only with Awesome's own menu.

Wait.. so for you this happend with 10.04 Lucid Lynx? Could you explain
when it started happening? Can you reproduce it somehow?

On 11/13/2010 06:16 AM, missyou11 wrote:
> Same here when I was using 10.04 with compiz on. Later I switched to
> Awesome and the nouveau driver, this happens again, but only with
> Awesome's own menu.

missyou11 (missyou11) wrote :

@Serrano Pereira: Yes, that's why I switched to Awesome. I don't remember when it started. I can only tell that's before July 17th, on which day I had recorded this weird behavior. And there might be some days before I recorded it.

I can't reproduce it now, because I've switched to the nouveau driver, which don't support compiz. But now the main menu of Awesome behaves the same way. It was normal before I upgraded to 10/10 and installed nouveau.

Nadav (nadav74) wrote :

For what it matters, it can also be reproduced with VirtualBox when desktop effects are enabled.

Thorsten Roth (thorsten-roth) wrote :

Some more information on this:
When I have alpha blurring enabled in Compiz (without even using it for the window decorations!), the window menu button really often does not show the menu when clicked. After disabling the blur effect, the problem still exists, but not as often as before. WTF? ;)

And btw, for me it also happens with Metacity and Compositing enabled, though it's not as as bad. Don't know for sure if it also happens without compositing, not yet tested...

Manuel Bua (manuel-bua) wrote :

I'm also affected by this: you can also make the menus appear by just moving the mouse around the area where the menu is supposed to appear: it seems that doing that will trigger the redrawing of the menu.

Manuel Bua (manuel-bua) wrote :

I may add that (using compiz 0.8.6) tooltips are also affected by this problem: one need to stand firm with the mouse on a UI element for the default timeout for tooltips to show up, then move one pixel or two and the tooltip will appear.

missyou11 (missyou11) wrote :

Some more information about the same problem on my Awesome: I am using xcompmgr when this appears. When I kill xcompmgr, the menu behaves normal.

Devin Davis (rd-kryten) wrote :

I've also been seeing this bug since upgrading to Maverick from Lucid. Compiz on HD4800 with fglrx 8.723.1. Both menus and mouseovers are affected and seem to appear when you mouseover where they should be.

Architecture: amd64
DistroRelease: Ubuntu 10.10
DkmsStatus:
 virtualbox-ose, 3.2.8, 2.6.35-23-generic, x86_64: installed
 fglrx, 8.780, 2.6.35-23-generic, x86_64: installed
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Release amd64 (20101007)
MachineType: Shuttle Inc SA76
NonfreeKernelModules: fglrx
Package: xorg-server (not installed)
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.35-23-generic root=UUID=922f6b48-7e70-4657-a370-4f260693a655 ro quiet splash
ProcEnviron:
 LANG=en_US.utf8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.35-23.41-generic 2.6.35.7
Tags: maverick maverick
Uname: Linux 2.6.35-23-generic x86_64
UserGroups: adm admin cdrom dialout libvirtd lpadmin plugdev sambashare
dmi.bios.date: 12/15/2009
dmi.bios.vendor: Phoenix Technologies, LTD
dmi.bios.version: 6.00 PG
dmi.board.name: FA76
dmi.board.vendor: Shuttle Inc
dmi.board.version: V10
dmi.chassis.type: 3
dmi.chassis.vendor: Shuttle Inc
dmi.chassis.version: G2
dmi.modalias: dmi:bvnPhoenixTechnologies,LTD:bvr6.00PG:bd12/15/2009:svnShuttleInc:pnSA76:pvrV10:rvnShuttleInc:rnFA76:rvrV10:cvnShuttleInc:ct3:cvrG2:
dmi.product.name: SA76
dmi.product.version: V10
dmi.sys.vendor: Shuttle Inc
glxinfo: Error: [Errno 2] No such file or directory
system:
 distro: Ubuntu
 codename: maverick
 architecture: x86_64
 kernel: 2.6.35-23-generic

tags: added: apport-collected

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

I attached apport info above. I too am experiencing this problem. Often a menu will highlight when I click on it, but the contents will not appear. I can click several times with no effect. Sometimes adjacent menus also will not show up, but it seems inconsistent. To get the menu to appear, I usually click elsewhere on the screen (e.g. the desktop background) and then go back to the menu and try opening it again.

Note that I am NOT running an nVidia driver. The hardware driver listed under the "Additional Drivers" system admin menu is "ATI/AMD proprietary FGLRX graphics driver." I'm sure the apport info has more specific details.

Aaron Baugher (aaron-baugher) wrote :

Experiencing it here:

Xubuntu 10.10, amd64
X.org 1.9.0 on two monitors with TwinView
NVidia GeForce 8500GT with driver v. 260.19.06
compiz 1:0.8.6-0ubuntu9.1

Id2ndR (id2ndr) wrote :

As Jake Shorelan said, I also make the menu appears by clinking on an other window and the go back to the original window. The trouble also appears with my firefox's adress bar where the completion does not appear.

RadaR (radarlog) wrote :

I think I fixed this by enabling "indirect rendering" in Compiz.

Enabling "Indirect Rendering" did not work for me.

Martín V. (martinvukovic) wrote :

Same problem here.
Using Maverick 64bits,
VGA compatible controller: ATI Technologies Inc RS690 [Radeon X1200 Series]
Compiz 1:0.8.6-0ubuntu9.1
2.6.35-22-generic #35-Ubuntu SMP Sat Oct 16 20:45:36 UTC 2010 x86_64 GNU/Linux

Changed in xorg-server (Ubuntu):
status: New → Confirmed
Jingyue Wang (jingyue) wrote :

I'm having the same problem. My system is Ubuntu Maverick amd64. I'm not using compiz but using metacity with composite enabled. The problem is the same as those described by other people. I also tried running metacity with compiz, the problem is still there. My current graphics driver is a proprietary driver downloaded from ati. But under a clean installation(right after I installed maverick amd64 without using any proprietary driver), the problem is still the same. Acutally I downloaded the ati driver in the hope of solving this problem, but it doesn't help.

nece228 (obuolis) wrote :

Hi,
Im currently using arch linux and the same problem is in here too since upgrading to xorg-server. But in AUR theres a package which fixes this issue:
http://aur.archlinux.org/packages.php?ID=41438
Someone could just backport patches and give us PPA with this fixed xorg-server

Roger Bradley (olegprawn) wrote :

I experienced the same sub menu slow/non appearance. I'm using Ubuntu 10.10 x64 with the ATI proprietary driver. As soon as I set Visual Effects to 'None' via System/Preferences/Appearance all sub menus were available instantly.

Alex Maguran (amaguran) wrote :

Same here: Ubuntu 10.10, compiz, fglrx 11.1.

Disabling animations in Compiz does not fix this. I think we are getting false solutions because it is easy to be fooled into thinking that the problem is fixed because of the behavior of the problem. I'm pretty sure that the problem is masked due to some sort of caching of the popup menus (disk access, graphic, who knows?). It may appear random simply because of flushing of whatever is being cached.

I've got wine installed which has lots and lots of sub menus under the applications menu. Clicking on Applications and then hovering the mouse into the deep wine sub menus I was able to determine that the first time I hovered over a popup it never appeared. If I moved away from that menu and then came back it always appeared on the second try. Exiting out of the applications menu and starting over shows that previously visited popup menus showed on the first visit but any previously unvisited popup does not appear until the second visit.

However that being said I rarely logout and I'm fairly certain that this problem reappears from time to time on some menus (making it appear random -- I thought it was until today). So that is why I'm pretty sure that something is being cached and flushed.

I'm running 10.10 with the ATI proprietary driver.

Adding to my previous comment. What I described above was after a new login. Also in every case when hovering over the menu selection and sliding right the popup does eventually display when the mouse goes off the right of the menu.

Having run through all the menus and repeatedly verifying that they all popped up on the first visit I did the following: Right click Applications, select edit menus and then select close without doing anything. That seems to have flushed some but not all popup menus and the ones that don't come up on the first try are not always the same.

This makes me think that we are definitely dealing with something related to the creation of the menu display taking too long for the menu to be generated. It could be from the lookup of the menu definition on disk, finding the icon files, doing the drawing of the menus etc. My best guess is that it is either a timeout on the lookup/display or something related to mouse hover timing that creates a sort of race condition that cause the menu to not display. I don't know enough about how the displays are generated to know whether this lies on the Gnome side or Compiz or X11, but given that just bringing up the edit applications dialog regenerates the problem I'd track down the problem by looking in Gnome first -- what does opening that dialog do -- and trace it from there into X11, GTK, Compiz, or wherever.

I'm using a fairly high end system -- AMD quad core, 8GB ram, SSD, I wonder if this problem is more pronounced on a system with far fewer resources. That could be another clue.

Sorry for the string of comments but I've got one more piece of information. As Roger posted above setting visual effects to none appears to solve the problem. However that is not the end of it. Using the Edit menus approach in my previous post I visited some but not all of the menus while visual effects were disabled. They all popped up immediately. Then I changed visual effects back to 'extra' and immediately went through the Applications menu. All of the menus I 'touched' while effects were off came up on the first visit while none of the ones I did not 'touch' did.

So this tells me that the root cause of the odd behavior exists irregardless of which visual effect mode is being used. It is just that without effects it does not manifest itself. I feel this reinforces my theory that we are violating timing somewhere due to a stack up of delays with cache hits/misses likely causing the timing variation. Using visual effects uses up enough of the timing margin to push cache misses into causing problems.

Sadly I'm not familiar with how the mouse movement drives menu display through all of the library layers so I have no idea where to look in source code to continue further. I'll have to leave that to the devs and hope that these observations prove fruitful.

Colin Keenan (colinkeenan) wrote :

I have this problem too - even on web pages with dropdown menus. I've had this problem for a long time, definitely in Ubuntu 10.04 as well as 10.10 but then I get the latest unstable updates so may have gotten whatever was causing the problem early while still using 10.04.

I don't use compiz. I had the problem with compositing turned on for metacity, and also with mutter that I use now. I've had this problem on 3 different computers, all using the proprietary Nvidea driver.

I also have a problem with office applications not always displaying the window when opened. Specifically Open Office (now using Libra Office and still have the same problem) and also GnuCash. Usually works fine the first time I start one of these apps after logging in, but if close the app and try to open it again a while later, nothing shows up. I have to kill the process from System Monitor and then try to open it again. That usually works, but sometimes I have to log out and back in.

Joe Thomlinson (jthomlin) wrote :

Add me to the list as well. Amd64 10.10, Compiz and Nvidia drivers. Menus and drop downs randomly don't display on first activation unless you move the pointer over the screen area where the menu should be and then it appears, subsequent activations work as expected.

I have seen the problem as far back as 9.04 (Amd64, Compiz & Nvidia), although mainly with the Firefox 'awsome bar' occasionally not showing matching previous entries as I type a URL. If I clicked outside firefox and then back to it the problem goes away for a while, I still get this occasionally today on 10.10.

Trex (279trex) wrote :

The problem seems to completely disappear when I installed the Orta 1.4.1 theme on XFCE from xfce-look.org. Very strange.

Id2ndR (id2ndr) wrote :

I don't encountered the problem in natty.

Serrano Pereira, this bug was reported a while ago and there hasn't been any activity in it recently. We were wondering if this is still an issue? If so, could you please test for this with the latest development release of Ubuntu? ISO images are available from http://cdimage.ubuntu.com/daily-live/current/ .

If it remains an issue, could you please run the following command in the development release from a Terminal (Applications->Accessories->Terminal), as it will automatically gather and attach updated debug information to this report:

apport-collect -p xorg-server REPLACE-WITH-BUG-NUMBER

Please note, given you already have done this in a prior release, performing this on a release prior to Trusty would not be helpful.

Thank you for your understanding.

Helpful bug reporting tips:
https://wiki.ubuntu.com/ReportingBugs

Changed in xorg-server (Ubuntu):
importance: Undecided → Low
status: Confirmed → Incomplete

I had this problem for years, even on LMDE / Debian installs. I had forgotten about this bug report but now realize that since I switched from Gnome to xfce the problem has gone away. I now use xubuntu and add compiz/emerald to it. This makes sense since as I said back in 2011 I'm fairly certain this is an issue related to timing and menu caching which would be specific to gnome.

Christopher Penalver, I think the problem disappeared with one of the later Ubuntu releases, though I can't remember which one. I can't remember having this problem since the release of Unity. I've been using Gnome Classic a lot since Unity came out, and I don't think I've had this problem since then.

Serrano Pereira, this bug report is being closed due to your last comment https://bugs.launchpad.net/ubuntu/+source/xorg-server/+bug/665546/comments/74 regarding this being fixed with an update. For future reference you can manage the status of your own bugs by clicking on the current status in the yellow line and then choosing a new status in the revealed drop down box. You can learn more about bug statuses at https://wiki.ubuntu.com/Bugs/Status. Thank you again for taking the time to report this bug and helping to make Ubuntu better. Please submit any future bugs you may find.

Changed in xorg-server (Ubuntu):
status: Incomplete → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers