Recent libgl-mesa graphics update prevents drop down list menu appearing in apps like firefox three line/bar menu icon

Bug #1780664 reported by Curtis Gedak on 2018-07-08
118
This bug affects 21 people
Affects Status Importance Assigned to Milestone
xorg-server (Ubuntu)
Undecided
Unassigned
Xenial
Undecided
Timo Aaltonen

Bug Description

[Impact]

Recent libgl-mesa 18.0.5-0ubuntu0~16.04.1 graphics update prevents
drop down list menu appearing in apps like firefox three line/bar menu
icon.

After recently applying updates, left clicking on some application
menus and icons no longer displays a drop-down menu list.

For example in Firefox when I left-click on the **three line/bar**
icon in the upper right-hand corner, the normal drop down list menu
does not display. Also the menu drop down doesn't display in
keypassx. Further xchat-gnome doesn't even display a window.

Another anomaly is that my KDE bottom menu bar changed to a dark
theme.

[Test case]

Install the update, log in and check that things work normally again

[Regression potential]

none, this just prevents a premature feature to kick in

[Other info]

I'm using Kubuntu 16.04 on an Intel i7-7700k computer with Intel HD
Graphics. I have KDE **System Settings -> Compositor** enabled with:

   Scale method : Accurate
   Rendering backend: OpenGL 3.1
   OpenGL interface: GLX
   Tearing prevention ("vsync"): Full screen repaints
   Keep window thumbnails: Only for Shown Windows

INVESTIGATION

After several hours of searching the Internet I found one other case
of a similar problem.

   Firefox's Menu Bar won't open
   https://support.mozilla.org/en-US/questions/1194760

The reported solution was to rollback the graphics drivers.

Because the issues cropped up after applying updates on July 6, 2018,
I tracked down the list of recent updates with:

   grep -A 2 'Start-Date: 2018-07-06' /var/log/apt/history.log | tail -1 >packages.txt

After some editing to place packages on separate lines, and
identifying the grahics libraries, I arrived at the following list:

------------------------------

libgles2-mesa:amd64 (17.2.8-0ubuntu0~16.04.1 18.0.5-0ubuntu0~16.04.1)
libglapi-mesa:amd64 (17.2.8-0ubuntu0~16.04.1 18.0.5-0ubuntu0~16.04.1)
libglapi-mesa:i386 (17.2.8-0ubuntu0~16.04.1 18.0.5-0ubuntu0~16.04.1)
libxatracker2:amd64 (17.2.8-0ubuntu0~16.04.1 18.0.5-0ubuntu0~16.04.1)
libegl1-mesa:amd64 (17.2.8-0ubuntu0~16.04.1 18.0.5-0ubuntu0~16.04.1)
libgbm1:amd64 (17.2.8-0ubuntu0~16.04.1 18.0.5-0ubuntu0~16.04.1)
libwayland-egl1-mesa:amd64 (17.2.8-0ubuntu0~16.04.1 18.0.5-0ubuntu0~16.04.1)
libgl1-mesa-dri:amd64 (17.2.8-0ubuntu0~16.04.1 18.0.5-0ubuntu0~16.04.1)
libgl1-mesa-dri:i386 (17.2.8-0ubuntu0~16.04.1 18.0.5-0ubuntu0~16.04.1)
libosmesa6:amd64 (17.2.8-0ubuntu0~16.04.1 18.0.5-0ubuntu0~16.04.1)
libosmesa6:i386 (17.2.8-0ubuntu0~16.04.1 18.0.5-0ubuntu0~16.04.1)
libgl1-mesa-glx:amd64 (17.2.8-0ubuntu0~16.04.1 18.0.5-0ubuntu0~16.04.1)
libgl1-mesa-glx:i386 (17.2.8-0ubuntu0~16.04.1 18.0.5-0ubuntu0~16.04.1)
mesa-vdpau-drivers:amd64 (17.2.8-0ubuntu0~16.04.1 18.0.5-0ubuntu0~16.04.1)

------------------------------

To revert to the prior graphic drivers I tracked down the '.deb'
packages for each of the above packages and downloaded the
'17.2.8-0ubuntu0~16.04.1' version.

For example:

https://launchpad.net/ubuntu/xenial/amd64/libxatracker2/17.2.8-0ubuntu0~16.04.1

I also discovered that some of these depended on
libllvm5.0_5.0-3~16.04.1 so I also downloaded the following files:

  libllvm5.0_5.0-3~16.04.1_amd64.deb
  libllvm5.0_5.0-3~16.04.1_i386.deb

WORKAROUND (ROLLBACK TO PRIOR VERSION)

Install older versions with:

sudo dpkg -i \
  libllvm5.0_5.0-3~16.04.1_amd64.deb \
  libllvm5.0_5.0-3~16.04.1_i386.deb \
  libegl1-mesa_17.2.8-0ubuntu0~16.04.1_amd64.deb \
  libgbm1_17.2.8-0ubuntu0~16.04.1_amd64.deb \
  libgl1-mesa-dri_17.2.8-0ubuntu0~16.04.1_amd64.deb \
  libgl1-mesa-dri_17.2.8-0ubuntu0~16.04.1_i386.deb \
  libgl1-mesa-glx_17.2.8-0ubuntu0~16.04.1_amd64.deb \
  libgl1-mesa-glx_17.2.8-0ubuntu0~16.04.1_i386.deb \
  libglapi-mesa_17.2.8-0ubuntu0~16.04.1_amd64.deb \
  libglapi-mesa_17.2.8-0ubuntu0~16.04.1_i386.deb \
  libgles2-mesa_17.2.8-0ubuntu0~16.04.1_amd64.deb \
  libosmesa6_17.2.8-0ubuntu0~16.04.1_amd64.deb \
  libosmesa6_17.2.8-0ubuntu0~16.04.1_i386.deb \
  libwayland-egl1-mesa_17.2.8-0ubuntu0~16.04.1_amd64.deb \
  libxatracker2_17.2.8-0ubuntu0~16.04.1_amd64.deb \
  mesa-vdpau-drivers_17.2.8-0ubuntu0~16.04.1_amd64.deb

After rebooting, all the issues disappeared.

For example I was once again able to left-click on the Firefox **three
line/bar** menu and view the drop down list menu. Also the KDE bottom
menu bar retured to the normal "breeze" light grey colour.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in mesa (Ubuntu):
status: New → Confirmed
Christian Kaenzig (ckaenzig) wrote :

Hello,

I confirm this bug also affects me on several Kubuntu 16.04 machines since this morning, apparently following the unattended upgrades that happened on Friday.

The symptoms are as described int the bugerport. I see them in okular and a custom Python application that uses PyQt4. The bug makes these applications unusable.

Pascal Peter (pascal-peter) wrote :

Hello,

I also confirm this bug on 2 computers with Kubuntu 16.04.

By selecting XRender as the rendering engine everything works.

Curtis Gedak (gedakc) wrote :

Thanks @Pascal for indicating that the drop down menu lists do appear by selecting XRender as the rendering engine.

Unfortunately XRender has other issues. The reason I originally changed away from using the default settings is because then I had issues with screen tearing [1] and an inability to login due to SDDM login screen hangs [2].

[1] https://askubuntu.com/questions/764302/screen-tearing-on-kubuntu-16-04-with-intel-drivers

[2] https://askubuntu.com/questions/765364/kubuntu-16-04-sddm-login-screen-hangs/

Curtis Gedak (gedakc) wrote :

To help others with reverting to a prior version of libgl1-mesa
graphics drivers, I have provided the following download links.

libgl1-mesa .deb packages (14 files) - Search for "Downloadable files"
----------------------------------------------------------------------

https://launchpad.net/ubuntu/xenial/amd64/libegl1-mesa/17.2.8-0ubuntu0~16.04.1

https://launchpad.net/ubuntu/xenial/amd64/libgbm1/17.2.8-0ubuntu0~16.04.1

https://launchpad.net/ubuntu/xenial/amd64/libgl1-mesa-dri/17.2.8-0ubuntu0~16.04.1
https://launchpad.net/ubuntu/xenial/i386/libgl1-mesa-dri/17.2.8-0ubuntu0~16.04.1

https://launchpad.net/ubuntu/xenial/amd64/libgl1-mesa-glx/17.2.8-0ubuntu0~16.04.1
https://launchpad.net/ubuntu/xenial/i386/libgl1-mesa-glx//17.2.8-0ubuntu0~16.04.1

https://launchpad.net/ubuntu/xenial/amd64/libglapi-mesa/17.2.8-0ubuntu0~16.04.1
https://launchpad.net/ubuntu/xenial/i386/libglapi-mesa/17.2.8-0ubuntu0~16.04.1

https://launchpad.net/ubuntu/xenial/amd64/libgles2-mesa/17.2.8-0ubuntu0~16.04.1

https://launchpad.net/ubuntu/xenial/amd64/libosmesa6/17.2.8-0ubuntu0~16.04.1
https://launchpad.net/ubuntu/xenial/i386/libosmesa6/17.2.8-0ubuntu0~16.04.1

https://launchpad.net/ubuntu/xenial/amd64/libwayland-egl1-mesa/17.2.8-0ubuntu0~16.04.1

https://launchpad.net/ubuntu/xenial/amd64/libxatracker2/17.2.8-0ubuntu0~16.04.1

https://launchpad.net/ubuntu/xenial/amd64/mesa-vdpau-drivers/17.2.8-0ubuntu0~16.04.1

libllvm5 .deb packages (2 files) - Search for "Binary Package"
--------------------------------------------------------------

https://ubuntu.pkgs.org/16.04/ubuntu-updates-main-i386/libllvm5.0_5.0-3~16.04.1_i386.deb.html
https://ubuntu.pkgs.org/16.04/ubuntu-updates-main-amd64/libllvm5.0_5.0-3~16.04.1_amd64.deb.html

Curtis Gedak (gedakc) wrote :

While waiting for a fix to this issue, I decided to put a *hold* on
these packages so that they won't be upgraded.

To place a hold on these packages using apt:

  sudo apt-mark hold \
    libegl1-mesa \
    libgbm1 \
    libgl1-mesa-dri \
    libgl1-mesa-glx \
    libglapi-mesa \
    libgles2-mesa \
    libosmesa6 \
    libosmesa6 \
    libwayland-egl1-mesa \
    libxatracker2 \
    mesa-vdpau-drivers

To list the packages on hold:

  apt-mark showhold

Later if/when a fix is available the hold can be removed with:

  sudo apt-mark unhold \
    libegl1-mesa \
    libgbm1 \
    libgl1-mesa-dri \
    libgl1-mesa-glx \
    libglapi-mesa \
    libgles2-mesa \
    libosmesa6 \
    libosmesa6 \
    libwayland-egl1-mesa \
    libxatracker2 \
    mesa-vdpau-drivers

Download full text (3.8 KiB)

This appears to be the same bug I am experiencing.

Graphical regression

Kubuntu xenial/16.04.4
Intel HD Graphics 530

Symptoms:
* Under KDE Plasma 5, the blur effect for most widgets with a transparent background is not rendered. Instead, an opaque background is rendered.

* The on-screen display provided by KMix when adjusting the volume using keyboard hotkeys is not rendered. Instead, only its background blur effect is rendered.

* In some applications, some pop-up menu widgets do not render (they are invisible). For example, in Clementine, the drop down menu on the Stop button does not appear visibly when summoned, the main menus do not appear visibly when summoned, and the right-click menu does not appear visibly when summoned. In Firefox, the all-in-one "hamburger" menu, as well as other pop-ups from the main toolbar, do not appear visibly when summoned. However, the main menus (accessed by pressing Alt, if hidden) do appear. In the print dialogs in Okular, the drop-downs for "Page set" and for printer-specific settings do not drop down. (Selection has to be made by blindly scrolling through options using the arrow keys.)

As remarked by others, menu and volume OSD visibility is restored by using XRender instead of OpenGL 3.1, but there is no background blur effect and the background of Plasma widgets remains opaque.

For completeness, here are the results of my investigation into which packages were causing the problem. This seems very similar to what has already been said.

The symptoms appeared after upgrading some packages using the package manager (aptitude).

The following subset of the package upgrades that took place appear to have caused the symptoms, since downgrading only these packages eliminates the symptoms:
package / old version / new version
libwayland-egl1-mesa:amd64 17.2.8-0ubuntu0~16.04.1 18.0.5-0ubuntu0~16.04.1
libdrm-common:all 2.4.83-1~16.04.1 2.4.91-2~16.04.1
libdrm-dev:amd64 2.4.83-1~16.04.1 2.4.91-2~16.04.1
libdrm2:amd64 2.4.83-1~16.04.1 2.4.91-2~16.04.1
libdrm2:i386 2.4.83-1~16.04.1 2.4.91-2~16.04.1
libdrm-intel1:amd64 2.4.83-1~16.04.1 2.4.91-2~16.04.1
libdrm-intel1:i386 2.4.83-1~16.04.1 2.4.91-2~16.04.1
libdrm-radeon1:amd64 2.4.83-1~16.04.1 2.4.91-2~16.04.1
libdrm-radeon1:i386 2.4.83-1~16.04.1 2.4.91-2~16.04.1
libdrm-nouveau2:amd64 2.4.83-1~16.04.1 2.4.91-2~16.04.1
libdrm-nouveau2:i386 2.4.83-1~16.04.1 2.4.91-2~16.04.1
libdrm-amdgpu1:amd64 2.4.83-1~16.04.1 2.4.91-2~16.04.1
libdrm-amdgpu1:i386 2.4.83-1~16.04.1 2.4.91-2~16.04.1
libegl1-mesa:amd64 17.2.8-0ubuntu0~16.04.1 18.0.5-0ubuntu0~16.04.1
libgl1-mesa-dri:i386 17.2.8-0ubuntu0~16.04.1 18.0.5-0ubuntu0~16.04.1
libgl1-mesa-dri:amd64 17.2.8-0ubuntu0~16.04.1 18.0.5-0ubuntu0~16.04.1
mesa-vdpau-drivers:amd64 17.2.8-0ubuntu0~16.04.1 18.0.5-0ubuntu0~16.04.1
libsensors4:i386 [not previously installed] 1:3.4.0-2

There were other package upgrades at the same time, but downgrading only these packages eliminated the symptoms. There are no symptoms with the following versions:
package / version downgraded to
libwayland-egl1-mesa:amd64 11.2.0-1ubuntu
libdrm-common:all 2.4.83-1
libdrm-dev:amd64 2.4.83-1
libdrm2:amd64 2.4.83-1
libdrm2:i386 2.4.83-1
libdrm-intel1:amd64 2.4.83...

Read more...

Possible related or duplicate bug #1780846

Thank you @gedakc for pointing out that old package versions are available to download from Launchpad. I did not know that.

The intersection of the set of packages which @gedakc downgraded and the set of packages I downgraded is:
libegl1-mesa:amd64
libwayland-egl1-mesa:amd64
libgl1-mesa-dri:amd64
libgl1-mesa-dri:i386
mesa-vdpau-drivers:amd64

However, it is not possible to downgrade just the packages in this intersection, due to unsatisfied dependencies.

I'm sorry, my previous comment seems to be untrue.

I have just found that aptitude will happily upgrade everything else the latest version, if I hold just these five packages at the versions listed:
libwayland-egl1-mesa:amd64 11.2.0-1ubuntu2
libegl1-mesa:amd64 11.2.0-1ubuntu2
libgl1-mesa-dri:i386 11.2.0-1ubuntu2
libgl1-mesa-dri:amd64 11.2.0-1ubuntu2
mesa-vdpau-drivers:amd64 11.2.0-1ubuntu2

So it is in fact possible to have just these five packages downgraded while waiting for a fix.

Timo Aaltonen (tjaalton) wrote :

Do you see the same corruption with 18.04 stock (mesa 18.0.0~rc5) and upgraded (mesa 18.0.5)?

Changed in mesa (Ubuntu):
status: Confirmed → Incomplete
Timo Aaltonen (tjaalton) wrote :

but first, are you using the stock X stack.. what does 'apt-cache policy xserver-xorg-core' show?

Timo Aaltonen (tjaalton) wrote :

I believe this is a dupe of https://bugs.freedesktop.org/show_bug.cgi?id=103699

so enable the testing PPA (add-apt-repository ppa:canonical-x/testing) and upgrade, should bring a new xserver-xorg-core among others..

Curtis Gedak (gedakc) wrote :

Thanks Timo for looking at this issue.

Following is the output requested:

$ apt-cache policy xserver-xorg-core
xserver-xorg-core:
  Installed: 2:1.18.4-0ubuntu0.7
  Candidate: 2:1.18.4-0ubuntu0.7
  Version table:
 *** 2:1.18.4-0ubuntu0.7 500
        500 http://ca.archive.ubuntu.com/ubuntu xenial-updates/main amd64 Packages
        500 http://security.ubuntu.com/ubuntu xenial-security/main amd64 Packages
        100 /var/lib/dpkg/status
     2:1.18.3-1ubuntu2 500
        500 http://ca.archive.ubuntu.com/ubuntu xenial/main amd64 Packages
$

I'm not running 18.04 so I am unable to comment on whether the issue exists there.

QUESTION: If I enable the testing PPA, will the changes be limited to this isue, or will it also affect other apps?

This is my main development computer and I depend on a stable system for my purposes.

Thanks,
Curtis

Bram Metsch (metsch) wrote :

I also experienced this problem, and upgrading xserver-xorg-core and xserver-common fixed it.
So, it is rather a mesa/xorg-server incompatibilty?

Timo Aaltonen (tjaalton) on 2018-07-14
affects: mesa (Ubuntu) → xorg-server (Ubuntu)
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in xorg-server (Ubuntu Xenial):
status: New → Confirmed
Timo Aaltonen (tjaalton) wrote :

yes it is

thanks for testing!

Changed in xorg-server (Ubuntu):
status: Incomplete → Invalid
Changed in xorg-server (Ubuntu Xenial):
assignee: nobody → Timo Aaltonen (tjaalton)
status: Confirmed → Triaged
Robie Basak (racb) on 2018-07-18
tags: added: regression-update
Andreas Ntaflos (daff) wrote :

Using Kubuntu 16.04 on a Thinkpad X240 with Intel graphics this problem also causes Yakuake ("Quake-style terminal emulator based on KDE Konsole technology") to remain invisible when activated. It still accepts input and the window is in focus, it just is not visible.

Switching the compositor rendering backend from OpenGL to XRender works around the problem but the XRender backend seems to cause massive screen tearing when scrolling or watching videos so this workaround is suboptimal.

Installing xserver-common and xserver-xorg-core from ppa:canonical-x/testing fixes the issue!

Reg Dodds (reg-dodds) wrote :

OpenGL interface GLX must be deselected in Compositor and EGL chosen.
GLX does causes "okular menu buttons not clickable and Firefox open menu button dead" problem.

Select OpenGL interface EGL.
OR select XRender.

The problem lies hidden somwherw in GLX.

Peter Barker (pegranka) wrote :

Selecting OpenGL interface EGL fixed the menu drop-down problem, so all the programs I use operate OK, but with menu buttons grey instead of usual colour. Ths bug the same as reported in https://bugs.launchpad.net/ubuntu/+source/okular/+bug/1782132

Curtis Gedak (gedakc) wrote :

I tried using OpenGL and EGL for the compositor, but unfortunately EGL has issues. More specifically with EGL I experienced an inability to login due to SDDM login screen hangs. This is similar to the issue I experienced with XRender [1] which I noted earlier in this report.

[1] https://askubuntu.com/questions/765364/kubuntu-16-04-sddm-login-screen-hangs/

Timo Aaltonen (tjaalton) on 2018-08-10
description: updated

Hello Curtis, or anyone else affected,

Accepted xorg-server into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/xorg-server/2:1.18.4-0ubuntu0.8 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-xenial to verification-done-xenial. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-xenial. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in xorg-server (Ubuntu Xenial):
status: Triaged → Fix Committed
tags: added: verification-needed verification-needed-xenial

The bug is fixed for me by installing xserver-common and xserver-xorg-core version 2:1.18.4-0ubuntu0.8 from xenial-proposed. I will continue to run this version and watch for problems, but it seems good so far.

In aptitude, I see that xserver-xorg-core suggests xfonts-100dpi | xfonts-75dpi (UNSATISFIED) so maybe a packaging issue there.

Curtis Gedak (gedakc) wrote :

Hi Timo,

Thank you for your perseverance to resolve this issue.

I am at a writers conference for the next three days. My earliest opportunity to test will be on Monday, August 13th, 2018. I will plan to test xorg-server from xenial-proposed and let you know after I've completed testing.

In the meantime Patrick has mentioned that the fix worked so I am hopeful it will work for me too.

Curtis

Bram Metsch (metsch) wrote :

Fixes it for me, too.

tags: added: verification-done-xenial
removed: verification-needed-xenial
Peter Barker (pegranka) wrote :

Thanks Timo,
Using xenial-proposed and running
sudo apt-get install xserver-xorg-core/xenial-proposed
fixed it for me also (the above command also updated xserver-common)

Curtis Gedak (gedakc) wrote :

Hi Timo,

To test I removed the package holds, updated and upgraded to current released packages, and then rebooted. At this point I confirmed the issue in the original report.

Next I enabled the xenial-proposed repository, updated and then installed the following two packages:

  sudo apt install xserver-common/xenial-proposed xserver-xorg-core/xenial-proposed

Then I rebooted. After reboot I confirmed that these proposed xenial packages did indeed fix the issue. I was once again able to click on the three line/bar icon in Firefox and see the drop down menu list display. I also confirmed that there were no regressions in my testing (no SDDM hang on login, and no screen tearing).

Following is the output you requested earlier.

$ apt-cache policy xserver-xorg-core
xserver-xorg-core:
  Installed: 2:1.18.4-0ubuntu0.8
  Candidate: 2:1.18.4-0ubuntu0.8
  Version table:
 *** 2:1.18.4-0ubuntu0.8 400
        400 http://archive.ubuntu.com/ubuntu xenial-proposed/main amd64 Packages
        100 /var/lib/dpkg/status
     2:1.18.4-0ubuntu0.7 500
        500 http://ca.archive.ubuntu.com/ubuntu xenial-updates/main amd64 Packages
        500 http://security.ubuntu.com/ubuntu xenial-security/main amd64 Packages
     2:1.18.3-1ubuntu2 500
        500 http://ca.archive.ubuntu.com/ubuntu xenial/main amd64 Packages
$

Thank you very much for fixing this problem and seeing it through to xenial-proposed. If there is any more steps you need me to take to get this into an official release package then please let me know.

Sincerely,
Curtis Gedak

tags: removed: verification-needed
Anssi Saari (9-as) wrote :

I also had this issue and it was fixed by installing xserver-xorg-core version 2:1.18.4-0ubuntu0.8 from xenial-proposed.

Timo Aaltonen (tjaalton) wrote :

thanks for testing everyone, it'll take a few days until the update finds its way to xenial-updates

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xorg-server - 2:1.18.4-0ubuntu0.8

---------------
xorg-server (2:1.18.4-0ubuntu0.8) xenial; urgency=medium

  * glx-do-not-pick-srgb-config-for-32bit-rgba-visual.diff: Fix a
    regression with newer mesa. (LP: #1780664)

 -- Timo Aaltonen <email address hidden> Sat, 14 Jul 2018 01:28:30 +0300

Changed in xorg-server (Ubuntu Xenial):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for xorg-server has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Unfortunately, this fix did not work for Bug #1780846 (which was "related" and marked as duplicate), so I removed the "duplicate" status. The workaround (downgrading mesa packages), fortunately, works. Seems it is something related, but not the same.

updated successfully and issue solved for apps. issue was in apps like Telegram Desktop, Back in Time, Mixxx, Firefox and some others..

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.