Xorg crashed with SIGABRT in OsAbort()

Bug #1338492 reported by LAHLOU Benoit on 2014-07-07
This bug affects 63 people
Affects Status Importance Assigned to Milestone
X.Org X server
xorg-server (Ubuntu)

Bug Description

At startup, my screen flashes in light green, and can't log to lightdm. Adding the ATI driver, it will install with a missing link... Erasing cyrillic path and 75 and 100 dpi path folders.
At this time, can't find again the missing link, and just install missings fonts don't fix the bug..

ProblemType: Crash
DistroRelease: Ubuntu 14.10
Package: xserver-xorg-core 2:1.15.1-0ubuntu8
ProcVersionSignature: Ubuntu 3.13.0-24.47-generic 3.13.9
Uname: Linux 3.15.0-6-generic x86_64

ApportVersion: 2.14.4-0ubuntu1
Architecture: amd64
 * Setting up X socket directories... 
[ OK ]
  * Starting automatic crash report generation: apport 
[ OK ]
CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
CompositorRunning: compiz
CompositorUnredirectDriverBlacklist: '(nouveau|Intel).*Mesa 8.0'
CompositorUnredirectFSW: true
CrashCounter: 1
Date: Mon Jul 7 10:44:49 2014
DistUpgraded: Fresh install
DistroCodename: utopic
DistroVariant: ubuntu
ExecutablePath: /usr/bin/Xorg
ExtraDebuggingInterest: Yes
 Advanced Micro Devices, Inc. [AMD/ATI] Trinity [Radeon HD 7660D] [1002:9901] (prog-if 00 [VGA controller])
   Subsystem: ASUSTeK Computer Inc. Device [1043:8526]
 Advanced Micro Devices, Inc. [AMD/ATI] Caicos [Radeon HD 6450/7450/8450 / R5 230 OEM] [1002:6779] (prog-if 00 [VGA controller])
   Subsystem: PC Partner Limited / Sapphire Technology Radeon HD 6450 1 GB DDR3 [174b:e164]
InstallationDate: Installed on 2014-07-03 (3 days ago)
InstallationMedia: Ubuntu 14.10 "Utopic Unicorn" - Alpha amd64 (20140520)
MachineType: System manufacturer System Product Name
ProcCmdline: /usr/bin/X -core :0 -seat seat0 -auth /var/run/lightdm/root/:0 -nolisten tcp vt7 -novtswitch

ProcKernelCmdLine: BOOT_IMAGE=/vmlinuz-3.13.0-24-generic root=UUID=68f3fab7-5c4e-4d3a-9d6d-a493c47946db ro quiet splash
Signal: 6
SourcePackage: xorg-server
 OsAbort ()
 ?? ()
 FatalError ()
 ?? ()
 __libc_start_main (main=0x7ffb7ec04db0, argc=11, argv=0x7fff4f6b2e88, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7fff4f6b2e78) at libc-start.c:287
Title: Xorg crashed with SIGABRT in OsAbort()
UpgradeStatus: No upgrade log present (probably fresh install)

dmi.bios.date: 11/07/2012
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: 5401
dmi.board.asset.tag: To be filled by O.E.M.
dmi.board.name: F2A55
dmi.board.vendor: ASUSTeK COMPUTER INC.
dmi.board.version: Rev X.0x
dmi.chassis.asset.tag: Asset-1234567890
dmi.chassis.type: 3
dmi.chassis.vendor: Chassis Manufacture
dmi.chassis.version: Chassis Version
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvr5401:bd11/07/2012:svnSystemmanufacturer:pnSystemProductName:pvrSystemVersion:rvnASUSTeKCOMPUTERINC.:rnF2A55:rvrRevX.0x:cvnChassisManufacture:ct3:cvrChassisVersion:
dmi.product.name: System Product Name
dmi.product.version: System Version
dmi.sys.vendor: System manufacturer
version.compiz: compiz 1:0.9.11+14.10.20140606-0ubuntu2
version.ia32-libs: ia32-libs N/A
version.libdrm2: libdrm2 2.4.54-1
version.libgl1-mesa-dri: libgl1-mesa-dri 10.2.2-1ubuntu1
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 10.2.2-1ubuntu1
version.xserver-xorg-core: xserver-xorg-core 2:1.15.1-0ubuntu8
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.8.2-1ubuntu2
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:7.3.0-1ubuntu4
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.99.910-0ubuntu1
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.10-1ubuntu2
xserver.bootTime: Mon Jul 7 10:48:37 2014
xserver.configfile: default
 input Power Button KEYBOARD, id 6
 input Power Button KEYBOARD, id 7
 input Eee PC WMI hotkeys KEYBOARD, id 8
 input AT Translated Set 2 keyboard KEYBOARD, id 9
 input ImPS/2 Logitech Wheel Mouse MOUSE, id 10
xserver.errors: RADEON(G0): [XvMC] Failed to initialize extension.
xserver.logfile: /var/log/Xorg.0.log
xserver.version: 2:1.15.1-0ubuntu8
xserver.video_driver: radeon

LAHLOU Benoit (benoit-lahlou-u) wrote :

 OsAbort () at ../../os/utils.c:1351
 AbortServer () at ../../os/log.c:773
 FatalError (f=f@entry=0x7ffb7ed79856 "no screens found") at ../../os/log.c:911
 dix_main (argc=11, argv=0x7fff4f6b2e88, envp=<optimized out>) at ../../dix/main.c:203
 __libc_start_main (main=0x7ffb7ec04db0 <main>, argc=11, argv=0x7fff4f6b2e88, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7fff4f6b2e78) at libc-start.c:287

Changed in xorg-server (Ubuntu):
importance: Undecided → Medium
tags: removed: need-amd64-retrace
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in xorg-server (Ubuntu):
status: New → Confirmed
tags: added: trusty
information type: Private → Public
Martijn (kleptog-l) wrote :

What can I do to help resolve this bug? It's annoyingly repeatable, I get it at least ten times a day.

Basically lightdm starts normally. Then after a suspend/resume cycle it says the session is locked. lightdm is now in a state where it doesn't/can't talk to the X server into vt7. So it starts a new greeter on vt8 and tries to switch to it (which fails). Switching manually and typing in the correct password seems to work but then the X server crashes with signal 6 (this bug) and then it spawns the greeter again on vt8. After about three times it finally succeeds in unlocking the session on vt7 and I can continue working.

Sometimes it gets unlocked but the mouse no longer works, but that's probably a completely different problem.

Attaching the lightdm.log, in case it sheds light on the problem.

Flashrom (m-schult) wrote :

i dont see the taskbar in the on the left side and on the top

tags: added: bugpattern-needed
tags: added: vivid
Jeffrey Tees (jeff-tees) wrote :

Got this error after installing kubuntu-desktop from cli and selecting sddm (which failed to install as screen was black next reboot) recofigured to return to lightdm and purged sddm, next reboot, error on unity login reporting sddm was not installed correctly, screen resolution has changed. Not seen this error before this.

Jim Leinweber (jiml-mail) wrote :

got looping lock screen crashes after trying to log in a second user

junior0 (igor-travov-gmail) wrote :

The seance before this I installed with my micro sd (64Mb) card and set a need string in /etc/fstab file for
automounting this new partiotion (FS4) and at start it was OK

/dev/sdc5 /media/extra-msd1 ext4 rw,noatime,discard,nosuid,nodev,uhelper=udisks

Then I tryed to copy my old archive files to that new partition (sdc5) to make more free space my hard disk (sda1 - FS4).

It was very- very slowly (to copy 1 Gb need up to 3 houres) and I did "sudo reboot".
After that I could-not at first load my first partition linux (ubuntu15.04 - sda1 - 45 Gb) and worked on my second partiton
(ubuntu14.04.02 - 48 GB) and after editing /etc/fstab on first part. I may reboted and coming to this variant ubuntu15.04.

Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:

tags: added: iso-testing
Enrico (enricobe) wrote :

On my Xubuntu install, this error appeared at the first boot after removing FGLRX driver (apt-get purge fglrx*)

Mark Faine (mark-faine) wrote :

Apport sent me here saying my bug was already known and was at this page, however, this doesn't appear to be the same bug to me. Is there anyway I can confirm they are the same?

BRUN (christian-brun2244) wrote :

Ubuntu 15.04.
Internet very difficult to reach since 3 or 4 last updates.
I've tried to replace display driver with generic...Always the same problem.
I've reinstalled the proprietary driver (ATI ). No change.
I can not have Internet any more. (Waiting time too long).
Note : All is OK with my portable computer ( Nvidia card ).

Open bug in launchpad.net :

#0 0x00007ffb7c6cf117 in __GI_raise (sig=sig@entry=6) at ../nptl/sysdeps/unix/sysv/linux/raise.c:56
        resultvar = 0
        pid = 3738
        selftid = 3738
#1 0x00007ffb7c6d0808 in __GI_abort () at abort.c:89
        save_stage = 2
        act = {__sigaction_handler = {sa_handler = 0x7ffb7f0075c0 <displayfd>, sa_sigaction = 0x7ffb7f0075c0 <displayfd>}, sa_mask = {__val = {140718144253320, 140734525811800, 140718137570727, 1, 0, 0, 140718100835624, 140718141577302, 140734525811800, 140718140050869, 140718137599365, 0, 18446744073709551615, 140718144224960, 140734525811600, 0}}, sa_flags = 2126203328, sa_restorer = 0x7ffb7ebb49c0}
        sigs = {__val = {32, 0 <repeats 15 times>}}
#2 0x00007ffb7ed6ee0e in OsAbort () at ../../os/utils.c:1351
No locals.
#3 0x00007ffb7ed74423 in AbortServer () at ../../os/log.c:773
No locals.
#4 0x00007ffb7ed750f8 in FatalError (f=f@entry=0x7ffb7ed79856 "no screens found") at ../../os/log.c:911
        args = {{gp_offset = 8, fp_offset = 48, overflow_arg_area = 0x7fff4f6b2d40, reg_save_area = 0x7fff4f6b2c70}}
        args2 = {{gp_offset = 8, fp_offset = 48, overflow_arg_area = 0x7fff4f6b2d40, reg_save_area = 0x7fff4f6b2c70}}
        beenhere = 1
#5 0x00007ffb7ec19bb2 in dix_main (argc=11, argv=0x7fff4f6b2e88, envp=<optimized out>) at ../../dix/main.c:203
        i = <optimized out>
        alwaysCheckForInput = {0, 1}
#6 0x00007ffb7c6b9ec5 in __libc_start_main (main=0x7ffb7ec04db0 <main>, argc=11, argv=0x7fff4f6b2e88, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7fff4f6b2e78) at libc-start.c:287
        result = <optimized out>
        unwind_buf = {cancel_jmp_buf = {{jmp_buf = {0, 4741840274197947594, 140718140050869, 140734525812352, 0, 0, -4742017395905420086, -4739864558119705398}, mask_was_saved = 0}}, priv = {pad = {0x0, 0x0, 0x7ffb7ed78a50 <__libc_csu_init>, 0x7fff4f6b2e88}, data = {prev = 0x0, cleanup = 0x0, canceltype = 2128054864}}}
        not_first_call = <optimized out>
#7 0x00007ffb7ec04dde in _start ()
No symbol table info available.

It's not clear to me what this bug report is about, neither from what's written here nor in the referenced launchpad report.

If the problem is that Xorg aborts with "no screens found" as indicated by the backtrace in this report, please attach the corresponding Xorg.0.log file.

Luca Ciavatta (cialu) wrote :

On my Ubuntu 15.04 over a MacBook Pro 8.2, this error appears trying to make Radeon GPU working. This machine, actually, works only with Intel graphics and with the Radeon disable by this trick in the grub:
 outb 0x728 1
 outb 0x710 2
 outb 0x740 2
 outb 0x750 0 #this disable discrete Radeon gpu graphics

Unable to work with Radeon only or with Hybrid graphics. Also with nomodeset the system boot into a black screen.

tags: added: wily
Changed in xorg-server:
importance: Undecided → Unknown
status: New → Unknown

Created attachment 120886

original xorg reported on launchpad

(In reply to Tr4sK from comment #2)
> original xorg reported on launchpad

That doesn't correspond to the backtrace in the original bug description here.

Still confused about what the problem is.

Changed in xorg-server:
importance: Unknown → Critical
status: Unknown → Confirmed

Does ANYONE have an ETA on when this is going to be fixed? THIS IS AFFECTING MY MAIN COMP!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.