xorg crashes when clicking in inkscape work area

Bug #1023004 reported by rasda on 2012-07-10
48
This bug affects 11 people
Affects Status Importance Assigned to Milestone
Inkscape
High
Unassigned
xorg-server (Ubuntu)
Undecided
Unassigned

Bug Description

clicking on the workarea in any inkscape document crashes xorg and brings me to the login screen.
this happens in all window managers (gnome and unity 2D&3D).
i am using the internal intel graphic card on a lenovo T520 with a i7-2670QM.
this behaviour is always reproducable.

syslog:
gnome-session[2311]: Gdk-WARNING: gnome-session: Fatal IO error 11 (Die Ressource ist zur Zeit nicht verfügbar) on X server :0.#012

Xorg.log:
Backtrace:
[ 5122.869] 0: /usr/bin/X (xorg_backtrace+0x26) [0x7fb427f61996]
[ 5122.869] 1: /usr/bin/X (0x7fb427dd9000+0x18c83a) [0x7fb427f6583a]
[ 5122.869] 2: /lib/x86_64-linux-gnu/libpthread.so.0 (0x7fb4270ff000+0xfcb0) [0x7fb42710ecb0]
[ 5122.869] 3: /usr/bin/X (0x7fb427dd9000+0x5e71a) [0x7fb427e3771a]
[ 5122.869] 4: /usr/bin/X (0x7fb427dd9000+0x58070) [0x7fb427e31070]
[ 5122.869] 5: /usr/bin/X (0x7fb427dd9000+0x1230ef) [0x7fb427efc0ef]
[ 5122.869] 6: /usr/bin/X (0x7fb427dd9000+0x4e8b1) [0x7fb427e278b1]
[ 5122.869] 7: /usr/bin/X (0x7fb427dd9000+0x3d6da) [0x7fb427e166da]
[ 5122.869] 8: /lib/x86_64-linux-gnu/libc.so.6 (__libc_start_main+0xed) [0x7fb425f9476d]
[ 5122.869] 9: /usr/bin/X (0x7fb427dd9000+0x3d9d1) [0x7fb427e169d1]
[ 5122.869] Segmentation fault at address 0x28
[ 5122.869]
Caught signal 11 (Segmentation fault). Server aborting
[ 5122.869]

lsb_release -rd
Description: Ubuntu 12.04 LTS
Release: 12.04

apt-cache policy xserver-xorg-core
xserver-xorg-core:
  Installiert: 2:1.11.4-0ubuntu10.3
  Kandidat: 2:1.11.4-0ubuntu10.3
  Versionstabelle:
 *** 2:1.11.4-0ubuntu10.3 0
        500 http://de.archive.ubuntu.com/ubuntu/ precise-updates/main amd64 Packages
        100 /var/lib/dpkg/status
     2:1.11.4-0ubuntu10 0
        500 http://de.archive.ubuntu.com/ubuntu/ precise/main amd64 Packages

apt-cache policy xserver-xorg-video-intel
xserver-xorg-video-intel:
  Installiert: 2:2.17.0-1ubuntu4
  Kandidat: 2:2.17.0-1ubuntu4
  Versionstabelle:
 *** 2:2.17.0-1ubuntu4 0
        500 http://de.archive.ubuntu.com/ubuntu/ precise/main amd64 Packages
        100 /var/lib/dpkg/status

CVE References

bugbot (bugbot) on 2012-07-12
tags: added: precise
su_v (suv-lp) wrote :

Possibly triggered by a recent upgrade of xserver-related packages as described in this forum topic: <http://forums.linuxmint.com/viewtopic.php?f=59&t=106911>? Seems to affect not only Inkscape, but GIMP as well.

<off-topic>
It also reminds me of a similar crash which occurred with a recent prerelease candidate of X11/XQuartz (XQuartz 2.7.2_beta4 (xorg-server 1.12.0.901)) on OS X:
Bug #972914 “[OS X] Crash when clicking inside drawing area with XQuartz 2.7.2 beta4”
<https://bugs.launchpad.net/inkscape/+bug/972914>
which turned out to be a bug in the X server (XQuartz) and not related to Inkscape's code base.
<off-topic>

tags: added: crash
Changed in inkscape:
importance: Undecided → High
rasda (racinraz) wrote :

it seems that the last xserver update fixed the problem.

from the changelog of xserver-common:

xorg-server (2:1.11.4-0ubuntu10.5) precise-security; urgency=low

  * SECURITY UPDATE: do not use input device names in logging format
    strings (LP: #996250):
    - debian/patches/509_log-format-fix.patch: backported upstream changes.
    - CVE-2012-2118

 -- Steve Beattie <email address hidden> Mon, 09 Jul 2012 15:24:55 -0700

Changed in xorg-server (Ubuntu):
status: New → Fix Released
Changed in inkscape:
status: New → Fix Released
su_v (suv-lp) wrote :

Thanks for the update - closing as 'Invalid' for project 'Inkscape'.

Changed in inkscape:
status: Fix Released → Invalid
marianitn (marianitn) wrote :

Hey, I'm still experiencing the same behaviour with Inkscape and Xorg. My package versions are:

   - xserver-xorg-core: Installed: 2:1.11.4-0ubuntu10.6
   - xserver-xorg-video-intel: Installed: 2:2.17.0-1ubuntu4
   - inkscape: Installed: 0.48.3.1-1ubuntu1

Please tell me on any info I can provide to fix this.

Nils Ole Tippenhauer (noleti) wrote :

I experience the same bug. I run a brand new laptop here (Lenovo X1 carbon), with fresh & updated Ubuntu. Only happens with inkscape, gimp runs fine (there were similar issues in gimp earlier I read).

Inkscape version: Inkscape 0.48.3.1 r9886

- xserver-xorg-core: Installed: 2:1.13.0-0ubuntu6

This completely breaks inkscape, of course.

Roland Arsenault (rolker) wrote :

I am also experiencing the same behavior of X crashing as soon as I click on the Inkscape canvas with Ubuntu 12.10.

- inkscape 0.48.3.1-1ubunt amd64
- xserver-xorg-core 2:1.13.0-0ubunt amd64
- nvidia-current 304.51.really.3 amd64

su_v (suv-lp) wrote :

> X crashing as soon as I click on the Inkscape canvas with Ubuntu 12.10.

The same issue had been reported for Arch Linux a month ago, but apparently it went away after another system update (probably of xorg-*):
- Bug #1072389 “Inkscape Segfaults X”?
  <https://bugs.launchpad.net/inkscape/+bug/1072389>

Tuomas (tuma+sec) wrote :

Moreover, it seems not to be nvidia driver specific, but appears with nouveau drivers as well.
xserver-xorg-video-nouveau version 1.0.2-0ubuntu3, Ubuntu 12.10.

Tuomas (tuma+sec) wrote :

Last week (28th November) I was using inkscape without problems. I tried to downgrade all ubuntu packages that were upgraded last week, but without success. Now it does not work at all. My workaround is to use inkscape through VNC.

Massimo (maxx5) wrote :

Same here, ubuntu precise with all updates applied.
Inkscape crashes just clicking inside work area.

su_v (suv-lp) wrote :

For recent X crashes on Ubuntu 12.10, please refer to this newer report:
Bug #1081108 “Xorg crash after clicking on workspace in inkscape”
<https://bugs.launchpad.net/ubuntu/+source/xorg-server/+bug/1081108>

no longer affects: xorg-server
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.