Quicklauncher settings display French text in English environment

Bug #179917 reported by meist3r
24
This bug affects 4 people
Affects Status Importance Assigned to Milestone
xfce4-quicklauncher-plugin (Ubuntu)
Low
Lionel Le Folgoc

Bug Description

Binary package hint: xfce4-quicklauncher-plugin

I use the quicklauncher to fill my dock with icons. When I do a right-click on the Quicklauncher and select "Properties" I see a window "Configure Quicklauncher". The scrollable area of the settings have French titles "icone", "commande", "nom" instead of the English "Icon" and "Command" "Name". The spacing, tooltips and labels settings are also named in French: "Espace entre les lanceurs", "afficher les tooltips", "afficher les labels". I tested this with the German language pack and my standard English working environment, all the texts change except for those mentioned above. Maybe additional language support/translation is needed.

Revision history for this message
In , Jeromeg (jeromeg) wrote :

User-Agent: Mozilla/5.0 (X11; U; Linux i686; en; rv:1.8.1.11) Gecko/20071204 Epiphany/2.20 Firefox/2.0.0.11
Build Identifier:

This was reported on Launchpad: https://bugs.launchpad.net/ubuntu/+source/xfce4-quicklauncher-plugin/+bug/179917
by: https://bugs.launchpad.net/~markus-napp

Reproducible: Always

Steps to Reproduce:
Do a right-click on the Quicklauncher and select "Properties" I see a window "Configure Quicklauncher".

Actual Results:
The scrollable area of the settings have French titles "icone", "commande", "nom" instead of the English "Icon" and "Command" "Name". The spacing, tooltips and labels settings are also named in French: "Espace entre les lanceurs", "afficher les tooltips", "afficher les labels". I tested this with the German language pack and my standard English working environment, all the texts change except for those mentioned above. Maybe additional language support/translation is needed.

Expected Results:
Text should match the locale of the system.

Revision history for this message
Jérôme Guelfucci (jerome-guelfucci-deactivatedaccount) wrote :

Thank you for your bug report. I can confirm this.

Changed in xfce4-quicklauncher-plugin:
importance: Undecided → Low
status: New → Triaged
Revision history for this message
In , Masse-nicolas (masse-nicolas) wrote :

Some translations were missing in the en_GB file. Hopefully fixed in trunk

Revision history for this message
In , Jeromeg (jeromeg) wrote :

Ok, thank you very much.

Revision history for this message
Jérôme Guelfucci (jerome-guelfucci-deactivatedaccount) wrote :

This was already fixed in upstream's svn.

Changed in xfce4-quicklauncher-plugin:
status: Triaged → Fix Committed
Changed in xfce:
status: Unknown → Fix Released
Revision history for this message
Lionel Le Folgoc (mrpouit) wrote :

I'll test and upload the upstream patch.

Changed in xfce4-quicklauncher-plugin:
assignee: nobody → mrpouit
Revision history for this message
Lionel Le Folgoc (mrpouit) wrote :

I'll upload as soon as the alpha freeze is over.

Changed in xfce4-quicklauncher-plugin:
status: Fix Committed → In Progress
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xfce4-quicklauncher-plugin - 1.9.4-1ubuntu2

---------------
xfce4-quicklauncher-plugin (1.9.4-1ubuntu2) hardy; urgency=low

  * debian/rules: drop xfce.mk and use {autotools,debhelper,simple-patchsys}.mk
    instead.
  * debian/control:
    - set Maintainer to MOTU
    - re-add autotools-dev to b-d
    - bump Standards-Version to 3.7.3, no change
    - move the homepage to the new field.
  * debian/patches: upstream svn patches which fix several issues:
    - 01_save-settings.patch: correctly save plugin settings (LP: #179916)
    - 02_fix-missing-english-translation.patch: add missing English translation
      strings (LP: #179917).

 -- Lionel Le Folgoc <email address hidden> Tue, 04 Mar 2008 22:02:47 +0100

Changed in xfce4-quicklauncher-plugin:
status: In Progress → Fix Released
Revision history for this message
meist3r (meist3r) wrote :

Wow this is just great. Way faster than I ever imagined and you guys did a great job addressing the problems. I don't use the new version just yet, I'll wait for the next update of the files (I like to run the repo versions).

Thanks a lot for solving both of the bugs I submitted and keep up the fantastic work. People like you are the reason for the success of Linux and it will be people like you that will make lots of money and fans with their work in the future. I draw my hat, all my respect.

Merci beaucoup - Thanks a lot

Revision history for this message
Jim Campbell (jwcampbell) wrote :

I still show this problem in version 1.9.4-1ubuntu2
||/ Name Version Description
+++-==============-==============-=======
ii xfce4-quicklau 1.9.4-1ubuntu2 rapid launcher plugin for the Xfce4 panel

steps to reproduce
- add quicklauncher plugin to the panel
- right-click on quicklauncher icon, and select quicklauncher properties
- properties text appears in french

all english language packs installed.

Changed in xfce4-quicklauncher-plugin:
status: Fix Released → Confirmed
Revision history for this message
Lionel Le Folgoc (mrpouit) wrote :

What's the output of "locale"?

Upstream only added the en_GB locale, so I guess it won't show with en_US.

Revision history for this message
Lionel Le Folgoc (mrpouit) wrote :

This should probably be moved to en.po to be available to all English locales.

Changed in xfce4-quicklauncher-plugin:
status: Confirmed → In Progress
Revision history for this message
Jim Campbell (jwcampbell) wrote : Re: [Bug 179917] Re: Quicklauncher settings display French text in English environment

Out put of locale:

jim@mousepad:~$ locale
LANG=en_US.UTF-8
LC_CTYPE="en_US.UTF-8"
LC_NUMERIC="en_US.UTF-8"
LC_TIME="en_US.UTF-8"
LC_COLLATE="en_US.UTF-8"
LC_MONETARY="en_US.UTF-8"
LC_MESSAGES="en_US.UTF-8"
LC_PAPER="en_US.UTF-8"
LC_NAME="en_US.UTF-8"
LC_ADDRESS="en_US.UTF-8"
LC_TELEPHONE="en_US.UTF-8"
LC_MEASUREMENT="en_US.UTF-8"
LC_IDENTIFICATION="en_US.UTF-8"
LC_ALL=

On Sat, Mar 29, 2008 at 11:17 AM, Lionel Le Folgoc <email address hidden>
wrote:

> This should probably be moved to en.po to be available to all English
> locales.
>
> ** Changed in: xfce4-quicklauncher-plugin (Ubuntu)
> Status: Confirmed => In Progress
>
> --
> Quicklauncher settings display French text in English environment
> https://bugs.launchpad.net/bugs/179917
> You received this bug notification because you are a direct subscriber
> of the bug.
>

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xfce4-quicklauncher-plugin - 1.9.4-1ubuntu3

---------------
xfce4-quicklauncher-plugin (1.9.4-1ubuntu3) hardy; urgency=low

  * debian/patches/02_fix-missing-english-translation: add en.po instead of
    en_GB.po (LP: #179917, really this time).

 -- Lionel Le Folgoc <email address hidden> Sat, 29 Mar 2008 18:52:08 +0100

Changed in xfce4-quicklauncher-plugin:
status: In Progress → Fix Released
Revision history for this message
Jim Campbell (jwcampbell) wrote :

Thanks, Lionel. This update did fix the problem on my machine. :)

Revision history for this message
Urbán Dániel (urban.dani) wrote :

For me, it's still French.

The output of "locale":

LANG=C
LC_CTYPE="C"
LC_NUMERIC="C"
LC_TIME="C"
LC_COLLATE="C"
LC_MONETARY="C"
LC_MESSAGES="C"
LC_PAPER="C"
LC_NAME="C"
LC_ADDRESS="C"
LC_TELEPHONE="C"
LC_MEASUREMENT="C"
LC_IDENTIFICATION="C"
LC_ALL=

(I've chosen "No localization" during the installation.)

Revision history for this message
Urbán Dániel (urban.dani) wrote :

In the RC, it's still in French, if the locale is "C" ("No localization" option in the installer).
I've attached a screenshot.

Revision history for this message
Urbán Dániel (urban.dani) wrote :

So I think it's not fixed...

Changed in xfce4-quicklauncher-plugin:
status: Fix Released → Confirmed
Revision history for this message
Lionel Le Folgoc (mrpouit) wrote :

Urbán Dániel a écrit :
> So I think it's not fixed...
>
> ** Changed in: xfce4-quicklauncher-plugin (Ubuntu)
> Status: Fix Released => Confirmed
>

This particular bug is fixed ("C" is different from "an English
environment").
The remaining issue which should be reported upstream is that the source
code is in french, so French strings appear when using LANG="C".

  status fixreleased

--
Lionel Le Folgoc - https://launchpad.net/~mrpouit
EEBA 555E 0CDE 92BB 3AF4 4AB3 45A0 357B 5179 5910

Changed in xfce4-quicklauncher-plugin:
status: Confirmed → Fix Released
Revision history for this message
Urbán Dániel (urban.dani) wrote :

Ok, sorry.

Revision history for this message
In , Bugzilla-xfce (bugzilla-xfce) wrote :

This bug has resurfaced on my recent install of Xubuntu (Ubuntu 14.04.2, 64bit; xfce4-panel 4.11.0-0ubuntu1; xfce4-quicklauncher-plugin 1.9.4-10ubuntu1).

The output of `locale` in terminal:

LANG=nl_NL.UTF-8
LANGUAGE=nl_NL
LC_CTYPE="nl_NL.UTF-8"
LC_NUMERIC="nl_NL.UTF-8"
LC_TIME="nl_NL.UTF-8"
LC_COLLATE="nl_NL.UTF-8"
LC_MONETARY="nl_NL.UTF-8"
LC_MESSAGES="nl_NL.UTF-8"
LC_PAPER="nl_NL.UTF-8"
LC_NAME="nl_NL.UTF-8"
LC_ADDRESS="nl_NL.UTF-8"
LC_TELEPHONE="nl_NL.UTF-8"
LC_MEASUREMENT="nl_NL.UTF-8"
LC_IDENTIFICATION="nl_NL.UTF-8"
LC_ALL=

The output of both `check-language-support -l nl` and `check-language-support -l en` in terminal come up empty, i.e. every necessary package for those language appear to be installed.

This bug was NOT present on an earlier, 32bit, PC I had, with Xubuntu 14.04.0 installed. I can't reproduce the exact xfce4-panel and xfce4-quicklauncher-plugin versions, for that PC, anymore.

Changed in xfce:
importance: Unknown → Medium
Revision history for this message
Nils Ole Tippenhauer (noleti) wrote :

This feature is still present in Xubuntu 16.04. Of course, it is not critical, but it would be great if it could eventually be fixed by changing the source code localization to the more common English. My locale output is as reported in #21 (only with "en_SG.UTF-8").

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.