Checkboxes for hidden/visible indicators not working properly

Bug #1311685 reported by Jens Herrmann on 2014-04-23
46
This bug affects 12 people
Affects Status Importance Assigned to Milestone
xfce4-indicator-plugin (Ubuntu)
Undecided
Unassigned

Bug Description

When I open the properties dialog for the indicator plugin I am not able to check or uncheck on of the (in this case 4) checkboxes in the list of 'Known Indicators' anymore (checkboxes for 'Appearance' above do work). To see a change in the status of the checkboxes in 'Known Indicators' I have to close the dialog and reopen it. Also note that a click on the checkboxes does change the indicators present in the panel (after a restart of the panel) .
This has worked before, until yesterdays update to Xubuntu 14.04.

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: xfce4-indicator-plugin 2.3.2-0ubuntu2
ProcVersionSignature: Ubuntu 3.11.0-15.25-generic 3.11.10
Uname: Linux 3.11.0-15-generic x86_64
ApportVersion: 2.14.1-0ubuntu3
Architecture: amd64
Date: Wed Apr 23 15:41:11 2014
EcryptfsInUse: Yes
InstallationDate: Installed on 2013-11-26 (148 days ago)
InstallationMedia: Xubuntu 13.10 "Saucy Salamander" - Release amd64 (20131016)
SourcePackage: xfce4-indicator-plugin
UpgradeStatus: Upgraded to trusty on 2014-04-22 (1 days ago)

Jens Herrmann (bugs-u) wrote :
Alistair Buxton (a-j-buxton) wrote :

Confirming. This is a strange one.

Changed in xfce4-indicator-plugin (Ubuntu):
status: New → Confirmed
Jens Herrmann (bugs-u) wrote :

Somehow this has solved itself here. Now here all the checkboxes do work in the way one would expect.

Confirming as well. Checks within the checkboxes are not visibile, though if I log back out and log back in, sometimes the icon I clicked the "hide" checkbox next to, is actually hidden. The checkboxes do not ever appear to indicate this though.

LAZA (laza74) wrote :
Toshio Ito (debug-ito) wrote :

Confirmed this bug in Xubuntu 16.04 beta, xfce4-indicator-plugin 2.3.3-0ubuntu4

Troy Heron (troy-heron) wrote :

Confirmed in Xubuntu 15.04 final, xfce4-indicator-plugin 2.3.3-0ubuntu4

spike speigel (frail-knight) wrote :

This is happening in 17.04

xfce4-indicator-plugin 2.3.3-0ubuntu6

tags: added: xenial zesty
Paul White (paulw2u) wrote :

I'm not sure I'm seeing the problem as described but testing Xubuntu 17.10 32-bit and 64-bit live ISOs I can certainly confirm that I am not *always* able to change the status of the checkboxes. A logout and login or a restart of the panel seems to restore correct operation.

tags: added: artful
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1311685

tags: added: iso-testing
David Pearson (akxwi-dave) wrote :

as with paulw2u, while test the AA ISO's I am not always able to recreate this..

I did notice however that when you are able to select them, The tick does seem to take its time to draw..

Paul White (paulw2u) wrote :

What I am seeing today on both 32-bit and 64-bit ISOs for AA (20170511) is that the checkboxes can be freely selected or deselected until the options dialog is closed. On reopening, the checkboxes are "locked". They cannot be selected or deselected until the panel is restarted, normal operation resumes until the dialog is closed again.

I think you should be able to change your mind without having to restart the panel before you can make further changes.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers