Scrivania contents differ from the Desktop ones

Bug #941399 reported by Sandra Farnedi
46
This bug affects 5 people
Affects Status Importance Assigned to Milestone
Xdg User Dirs
New
Undecided
Unassigned
xdg-user-dirs (Ubuntu)
Undecided
Unassigned

Bug Description

The GUI interface doesn't reflect the terminal window contents. I suppose it's a language problem in the edubuntu user. Other users are OK.
See the attached screen-shot.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: xorg 1:7.6+10ubuntu1
ProcVersionSignature: Ubuntu 3.2.0-17.27-generic-pae 3.2.6
Uname: Linux 3.2.0-17-generic-pae i686
.tmp.unity.support.test.0:

ApportVersion: 1.93-0ubuntu2
Architecture: i386
CasperVersion: 1.304
CompizPlugins: [core,composite,opengl,compiztoolbox,decor,vpswitch,snap,mousepoll,resize,place,move,wall,grid,regex,imgpng,session,gnomecompat,animation,fade,unitymtgrabhandles,workarounds,scale,expo,ezoom,unityshell]
CompositorRunning: compiz
Date: Sun Feb 26 12:57:12 2012
DistUpgraded: Fresh install
DistroCodename: precise
DistroVariant: ubuntu
GraphicsCard:
 Advanced Micro Devices [AMD] nee ATI Radeon Mobility X1400 [1002:7145] (prog-if 00 [VGA controller])
   Subsystem: Fujitsu Technology Solutions Device [1734:10b0]
LiveMediaBuild: Edubuntu 12.04 "Precise Pangolin" - Alpha i386 (20120225)
MachineType: FUJITSU SIEMENS AMILO Pi 1556
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 LANG=it_IT.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: noprompt cdrom-detect/try-usb=true persistent file=/cdrom/preseed/hostname.seed boot=casper initrd=/casper/initrd.lz quiet splash -- debian-installer/language=it keyboard-configuration/layoutcode?=it
SourcePackage: xorg
Symptom: display
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 07/19/2007
dmi.bios.vendor: FUJITSU SIEMENS
dmi.bios.version: 1.25
dmi.board.name: AMILO Pi 1556
dmi.board.vendor: FUJITSU SIEMENS
dmi.board.version: Not Applicable
dmi.chassis.asset.tag: Not Applicable
dmi.chassis.type: 10
dmi.chassis.vendor: FUJITSU SIEMENS
dmi.chassis.version: AMILO Pi 1556
dmi.modalias: dmi:bvnFUJITSUSIEMENS:bvr1.25:bd07/19/2007:svnFUJITSUSIEMENS:pnAMILOPi1556:pvrNotApplicable:rvnFUJITSUSIEMENS:rnAMILOPi1556:rvrNotApplicable:cvnFUJITSUSIEMENS:ct10:cvrAMILOPi1556:
dmi.product.name: AMILO Pi 1556
dmi.product.version: Not Applicable
dmi.sys.vendor: FUJITSU SIEMENS
version.compiz: compiz 1:0.9.7.0~bzr2995-0ubuntu5
version.libdrm2: libdrm2 2.4.30-1ubuntu1
version.libgl1-mesa-dri: libgl1-mesa-dri 8.0.1-0ubuntu2
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 8.0.1-0ubuntu2
version.xserver-xorg-core: xserver-xorg-core 2:1.11.4-0ubuntu4
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.6.99.901+git20120126-0ubuntu2
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.99~git20111219.aacbd629-0ubuntu2
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.17.0-1ubuntu4
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20111201+b5534a1-1build2

Revision history for this message
Sandra Farnedi (sandra-farnedi-d) wrote :
Revision history for this message
Sandra Farnedi (sandra-farnedi-d) wrote :
Revision history for this message
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/941399

tags: added: iso-testing
Revision history for this message
Fabio Marconi (fabiomarconi) wrote :

Hello Sandra
Yes probably is something related to localization, but I cannot understand how many Desktop dir Edubuntu has.
If Desktop is translated to Scrivania why Desktop is listable ?

affects: xorg (Ubuntu) → edubuntu-live (Ubuntu)
Revision history for this message
Sandra Farnedi (sandra-farnedi-d) wrote : Re: [Bug 941399] Re: Scrivania contents differ from the Desktop ones
Download full text (4.2 KiB)

edubuntu user has just one Desktop directory correctly displayed by
the ls shell command, but the GUI interface names it Scrivania as I
chose the italian language; the Scrivania directory in not present if
I look at the home directory using ls shell command. If I log out and
log in again the Desktop/Scrivania contents are correctly displayed.
I suppose some link is not correctly managed. If I create a new user
its home directory has no Desktop directory but just Scrivania
directory, so no problem exists. The problem just concerns the built
in edubuntu user.

2012/2/26 Fabio Marconi <email address hidden>:
> Hello Sandra
> Yes probably is something related to localization, but I cannot understand how many Desktop dir Edubuntu has.
> If Desktop is translated to Scrivania why Desktop is listable ?
>
> ** Package changed: xorg (Ubuntu) => edubuntu-live (Ubuntu)
>
> ** Also affects: edubuntu
>   Importance: Undecided
>       Status: New
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/941399
>
> Title:
>  Scrivania contents differ from the Desktop ones
>
> Status in Edubuntu Project:
>  New
> Status in “edubuntu-live” package in Ubuntu:
>  New
>
> Bug description:
>  The GUI interface doesn't reflect the terminal window contents. I suppose it's a language problem in the edubuntu user. Other users are OK.
>  See the attached screen-shot.
>
>  ProblemType: Bug
>  DistroRelease: Ubuntu 12.04
>  Package: xorg 1:7.6+10ubuntu1
>  ProcVersionSignature: Ubuntu 3.2.0-17.27-generic-pae 3.2.6
>  Uname: Linux 3.2.0-17-generic-pae i686
>  .tmp.unity.support.test.0:
>
>  ApportVersion: 1.93-0ubuntu2
>  Architecture: i386
>  CasperVersion: 1.304
>  CompizPlugins: [core,composite,opengl,compiztoolbox,decor,vpswitch,snap,mousepoll,resize,place,move,wall,grid,regex,imgpng,session,gnomecompat,animation,fade,unitymtgrabhandles,workarounds,scale,expo,ezoom,unityshell]
>  CompositorRunning: compiz
>  Date: Sun Feb 26 12:57:12 2012
>  DistUpgraded: Fresh install
>  DistroCodename: precise
>  DistroVariant: ubuntu
>  GraphicsCard:
>   Advanced Micro Devices [AMD] nee ATI Radeon Mobility X1400 [1002:7145] (prog-if 00 [VGA controller])
>     Subsystem: Fujitsu Technology Solutions Device [1734:10b0]
>  LiveMediaBuild: Edubuntu 12.04 "Precise Pangolin" - Alpha i386 (20120225)
>  MachineType: FUJITSU SIEMENS AMILO Pi 1556
>  ProcEnviron:
>   TERM=xterm
>   PATH=(custom, no user)
>   LANG=it_IT.UTF-8
>   SHELL=/bin/bash
>  ProcKernelCmdLine: noprompt cdrom-detect/try-usb=true persistent file=/cdrom/preseed/hostname.seed boot=casper initrd=/casper/initrd.lz quiet splash -- debian-installer/language=it keyboard-configuration/layoutcode?=it
>  SourcePackage: xorg
>  Symptom: display
>  UpgradeStatus: No upgrade log present (probably fresh install)
>  dmi.bios.date: 07/19/2007
>  dmi.bios.vendor: FUJITSU SIEMENS
>  dmi.bios.version: 1.25
>  dmi.board.name: AMILO Pi 1556
>  dmi.board.vendor: FUJITSU SIEMENS
>  dmi.board.version: Not Applicable
>  dmi.chassis.asset.tag: Not Applicable
>  dmi.chassis.type: 10
>  dmi.chassis.vendor: FUJITSU SIEMENS
>  dmi.chassis.version: AMILO Pi 1556
>  dmi.modalias:...

Read more...

Changed in edubuntu-live (Ubuntu):
status: New → Fix Released
Changed in edubuntu:
status: New → Fix Released
Revision history for this message
Sandra Farnedi (sandra-farnedi-d) wrote :

The problem is still present in the today (2012-02-28) build, so I change it from fixed to confirmed

Changed in edubuntu-live (Ubuntu):
status: Fix Released → Confirmed
no longer affects: edubuntu
Revision history for this message
Sandra Farnedi (sandra-farnedi-d) wrote :

Do you mean that the problem affects only the live version?

Revision history for this message
Sandra Farnedi (sandra-farnedi-d) wrote :

Confirmed in the today (2012-03-01) build

Revision history for this message
Sandra Farnedi (sandra-farnedi-d) wrote :

edubuntu - version 2012-03-05. Confirmed.

Revision history for this message
Sandra Farnedi (sandra-farnedi-d) wrote :

In the today (2012-03-08) build the problem is present also for users different from edubuntu

Revision history for this message
Sandra Farnedi (sandra-farnedi-d) wrote :

The problem seems to be fixed in the today (2012-03-12) build

Changed in edubuntu-live (Ubuntu):
status: Confirmed → Fix Released
Revision history for this message
Sandra Farnedi (sandra-farnedi-d) wrote :

Confirmed in the today (2012-13-03) edubuntu build! It'really strange it seems to be fixed, but then it appears again.

Changed in edubuntu-live (Ubuntu):
status: Fix Released → Confirmed
Revision history for this message
Sandra Farnedi (sandra-farnedi-d) wrote :

I think it's a localisation problem: see also 951397 and 952749. Something is wrong when translating directory names.

Revision history for this message
Sandra Farnedi (sandra-farnedi-d) wrote :

Note: I am using an edubuntu live version (usb persistent)

Revision history for this message
Stéphane Graber (stgraber) wrote :

Moving to xdg-user-dirs, it looks to me like Unity starts before xdg-user-dirs did the required changes...

affects: edubuntu-live (Ubuntu) → xdg-user-dirs (Ubuntu)
Revision history for this message
Fabio Marconi (fabiomarconi) wrote :

confirmed in today's build

---
Ubuntu Bug Squad volunteer triager
http://wiki.ubuntu.com/BugSquad

Revision history for this message
Sergio Zanchetta (primes2h) wrote :

Confirmed.
I also noticed that it's "Desktop" showing the home directory, but it's "Scrivania" on the side pane. (See screenshot)

Revision history for this message
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu localized ISO testing tracker.

A list of all reports related to this bug can be found here:
@results

tags: added: localized-iso
Revision history for this message
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu localized ISO testing tracker.

A list of all reports related to this bug can be found here:
http://localized-iso.qa.ubuntu.com/qatracker/reports/bugs//941399

Revision history for this message
Sandra Farnedi (sandra-farnedi-d) wrote :

the problem seems to be solved in the today (2012-03-19) build

Changed in xdg-user-dirs (Ubuntu):
status: Confirmed → Fix Released
Revision history for this message
Giovanni Tornatore (gianni-tornatore-71-deactivatedaccount) wrote :

Hello, I have tested precise-dvd-amd64.iso (20120324) (md5sum:- 91637aa5907d621a0a6f0b41a98b79d2), on live usb persistent.

This bug is confirmed.

Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubuntu:
status: New → Confirmed
affects: xdg-user-dirs → ubuntu
affects: ubuntu → xdg-user-dirs
Revision history for this message
Sergio Zanchetta (primes2h) wrote :

This bug appeared again in build 20120325. :-(

Changed in xdg-user-dirs (Ubuntu):
status: Fix Released → Confirmed
Revision history for this message
Sandra Farnedi (sandra-farnedi-d) wrote :

Confirmed in 20120327.1 beta2 version.

Revision history for this message
Sandra Farnedi (sandra-farnedi-d) wrote :

confirmed in edubuntu - 20120410 build - italian language chosen

Revision history for this message
Sandra Farnedi (sandra-farnedi-d) wrote :

see also bug #959152

Revision history for this message
Giovanni Tornatore (gianni-tornatore-71-deactivatedaccount) wrote :

Hello, I have tested Edubuntu amd64 20121211 (md5sum:- 55c0d1196032c280c018f75c22dc5c5d *raring-dvd-amd64.iso), on live usb persistent.

This bug is confirmed!

To post a comment you must log in.