msiexec no longer works

Bug #1383214 reported by Rob van den Berg on 2014-10-20
166
This bug affects 36 people
Affects Status Importance Assigned to Milestone
Wine
Fix Released
Medium
wine (Debian)
Fix Released
Unknown
wine1.6 (Ubuntu)
High
Unassigned
Vivid
High
Unassigned
Wily
High
Louis Issembe

Bug Description

[Impact]
 * prevents msiexec from working
 * msiexec is pretty important for installing most software
 * this upload contains the patch that got pulled into the debian wine package

[Test Case]
 * [can someone affected please attach a good test case?]
 * run "wine msiexec -i ActivePython-2.7.8.10-win32-x86.msi" and verify that it does not work with the original version and that it does work with the update

[Regression Potential]
 * low, patch is upstream and in debian

It seems to me this has to do with wine being compiled with gcc 4.9
https://bugs.winehq.org/show_bug.cgi?id=36453

output msiexec /i superwave_p8.msi
err:msidb:get_tablecolumns column 1 out of range
err:msidb:get_tablecolumns column 2 out of range
fixme:storage:create_storagefile Storage share mode not implemented.
err:msidb:get_tablecolumns column 1 out of range
err:msidb:get_tablecolumns column 2 out of range
err:msidb:get_tablecolumns column 1 out of range
err:msidb:get_tablecolumns column 2 out of range
err:msidb:get_tablecolumns column 1 out of range
err:msidb:get_tablecolumns column 2 out of range
err:msidb:get_tablecolumns column 3 out of range
err:msidb:get_tablecolumns column 1 out of range
err:msidb:get_tablecolumns column 2 out of range
err:msidb:get_tablecolumns column 3 out of range
err:msidb:get_tablecolumns column 1 out of range
err:msidb:get_tablecolumns column 2 out of range
err:msidb:get_tablecolumns column 3 out of range
err:msidb:get_tablecolumns column 1 out of range
err:msidb:get_tablecolumns column 2 out of range
err:msidb:get_tablecolumns column 3 out of range

ProblemType: Bug
DistroRelease: Ubuntu 14.10
Package: wine 1:1.6.2-0ubuntu6
ProcVersionSignature: Ubuntu 3.16.0-23.30-lowlatency 3.16.4
Uname: Linux 3.16.0-23-lowlatency x86_64
NonfreeKernelModules: nvidia
ApportVersion: 2.14.7-0ubuntu7
Architecture: amd64
CurrentDesktop: XFCE
Date: Mon Oct 20 10:28:32 2014
InstallationDate: Installed on 2014-07-04 (107 days ago)
InstallationMedia: Xubuntu 14.04 LTS "Trusty Tahr" - Release amd64 (20140416.2)
SourcePackage: wine1.6
UpgradeStatus: No upgrade log present (probably fresh install)

Created attachment 48299
terminal output/backtrace

db.c:773: Test marked todo: query failed: 1615
db.c:1498: Test failed: MsiDatabaseOpenView failed
db.c:1501: Test failed: MsiViewExecute failed
db.c:1504: Test failed: MsiViewFetch failed
db.c:1510: Test failed: MsiViewFetch failed
db.c:1511: Test failed: string length wrong
db.c:1761: Test marked todo: Expected 'test2.txt\n', got test1.txt
db.c:1831: Test failed: SELECT query failed: 1615
db.c:1835: Test failed: Failed to get string: 6
db.c:1836: Test failed: Expected 'filename1', got Binary.filename1.1
db.c:1841: Test failed: Failed to get stream: 6
db.c:1842: Test failed: Expected 'test.txt\n', got
Unhandled exception: page fault on read access to 0x00000018 in 32-bit code (0x7ebdab61).

Backtrace:
=>0 0x7ebdab61 msi_update_table_columns+0x21(db=0x127920, name="MOO") [/home/austin/wine-git/dlls/msi/table.c:955] in msi (0x0032f768)
  1 0x7ebdce8c msi_table_load_transform+0x106b(db=0x127920, stg=0x1317b8, st=0x139e20, transform=0x13a1c8, bytes_per_strref=0x2) [/home/austin/wine-git/dlls/msi/table.c:2686] in msi (0x0032f888)
  2 0x7ebddac8 msi_table_apply_transform+0x377(db=0x127920, stg=0x1317b8) [/home/austin/wine-git/dlls/msi/table.c:2789] in msi (0x0032f9b8)
  3 0x7ebba3f7 MSI_DatabaseApplyTransformW+0x136(db=0x127920, szTransformFile="winetst-db.mst", iErrorCond=0) [/home/austin/wine-git/dlls/msi/msiquery.c:744] in msi (0x0032fa28)
  4 0x7ebba479 MsiDatabaseApplyTransformW+0x48() in msi (0x0032fa68)
  5 0x7ebba594 MsiDatabaseApplyTransformA+0xa3(hdb=<couldn't compute location>, szTransformFile=<couldn't compute location>, iErrorCond=<couldn't compute location>) [/home/austin/wine-git/dlls/msi/msiquery.c:790] in msi (0x0032fab8)
  6 0x7ecccbc7 test_try_transform+0x5f6() [/home/austin/wine-git/dlls/msi/tests/db.c:3136] in msi_test (0x0032fc68)
  7 0x7ecd0f0e func_db+0x11fd() [/home/austin/wine-git/dlls/msi/tests/db.c:9663] in msi_test (0x0032fd58)
  8 0x7ec8b9f8 main+0x327(argc=<is not available>, argv=<is not available>) [/home/austin/wine-git/dlls/msi/tests/../../../include/wine/test.h:584] in msi_test (0x0032fe08)

I'll attach the full backtrace.

I tried to bisect gcc, but quickly hit a roadblock:
austin@aw25 ~/gcc-git $ git bisect bad
The merge base daf81a9011692e3ed26192fe397ea5673686a1f0 is bad.
This means the bug has been fixed between daf81a9011692e3ed26192fe397ea5673686a1f0 and [e9c762ec4671d77e301492e4f9e92e1d3d667188].

I can confirm that GCC-4.9.0 likewise fails on my system. Although I didn't perform the test cited by Austin English, the error at runtime when launching firefox with pipelight/wine shows these errors

err:msidb:get_tablecolumns column 1 out of range
err:msidb:get_tablecolumns column 2 out of range
[...]

I rolled back through to wine-1.17.14 (including omitting the xattr patch from the pipelight project [http://fds-team.de/cms/projects.html]). In all cases, using GCC-4.9.0 led to the "get_tablecolumns column X out of range". Since I always keep one previous compiler version available, building with GCC-4.8.2 solved the problem both with the patched wine sources and the plain vanilla code.

By the way, I tried again compiling again with GCC-4.9.0 with CFLAGS set to "-O0 -march=i686" to no avail. My normal CFLAGS are "-O2 -march=native".

The system is the latest SVN Linux from Scratch (LFS and BLFS) on this platform with 32 GB of RAM:

ASUSTeK COMPUTER INC. P8Z77-V LX (Quad-Core Hyper-Threaded Intel(R) Core(TM) i7-3770K @ 3.50GHz)

http://www.linuxquestions.org/questions/linux-from-scratch-13/pipelight-wine-4175503999/

Looks like something in dlls/msi/table.c causes corruption in the test installer database when compiled with gcc-4.9 and -O2. If I compile with -O0 the crash goes away.

*** Bug 36464 has been marked as a duplicate of this bug. ***

*** Bug 36453 has been marked as a duplicate of this bug. ***

Just thought it would be worth mentioning that this problem is still present in version 1.7.19 (as I have tested just now on Arch x86_64).

Created attachment 48545
Fix for msi get_tablecolumns

Attached a patch that fixes this error for me on gcc-4.9.

(In reply to Daniel Beitler from comment #7)
> Created attachment 48545 [details]
> Fix for msi get_tablecolumns
>
> Attached a patch that fixes this error for me on gcc-4.9.

Works for me as well, thanks.

Over at Arch, the wine package maintainer incorporated the patch from this bug report into a new package to test (https://bugs.archlinux.org/task/40310), but as mentioned over there I still get the same problem as before.

Specifically, I'm trying to install the MS Visual C++ 2010 runtime using winetricks - console output & backtrace attached.

Created attachment 48556
Console output & Backtrace when running winetricks vcrun2010

(In reply to Adam Hirst from comment #9)
> Over at Arch, the wine package maintainer incorporated the patch from this
> bug report into a new package to test
> (https://bugs.archlinux.org/task/40310), but as mentioned over there I still
> get the same problem as before.
>
> Specifically, I'm trying to install the MS Visual C++ 2010 runtime using
> winetricks - console output & backtrace attached.

I just tried "winetricks vcrun2010" using the arch package wine-1.7.19-2-x86_64 and it worked fine for me.
Can you please try again in a clean prefix?

Created attachment 48563
Console output & Backtrace for vcrun2010 using 1.7.19-3

I had run it using a clean wineprefix beforehand, but to be sure I reinstalled the package (which had another update relating to some other bug), rebooted my machine, and made another clean wineprefix. Same problem (attached).

Ah(!), false alarm.

It seems that a part of the solution was adding an optional dependency to wine on x86_64, namely lib32-libxslt. After installing that (which pulled lib32-libxml2 as another dep), vcrun2010 installs just fine.

Sorry about that. This particular issue now seems to be fixed for me.

(In reply to Daniel Beitler from comment #7)
> Created attachment 48545 [details]
> Fix for msi get_tablecolumns
>
> Attached a patch that fixes this error for me on gcc-4.9.

I can also confirm the efficacy of the patch. And the correction properly deals with the change made in GCC-4.9.0, ``Null pointer checks may be optimized away more aggressively'' shown here:

https://gcc.gnu.org/gcc-4.9/porting_to.html

Fixed by deb274226783ab886bdb44876944e156757efe2b.

Closing bugs fixed in 1.7.20.

Rob van den Berg (rghvdberg) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in wine1.6 (Ubuntu):
status: New → Confirmed
Changed in wine1.6 (Ubuntu):
importance: Undecided → High
CaCO3 (caco3) wrote :

Same happens when I try to install Adobe Reader trhough wine.

wine AdbeRdr11008_de_DE.exe
err:menubuilder:init_xdg error looking up the desktop directory
err:service:service_send_start_message service L"WebCake Desktop Updater" failed to start
fixme:service:scmdatabase_autostart_services Auto-start service L"WebCake Desktop Updater" failed to start: 1053
err:msidb:get_tablecolumns column 1 out of range
err:msidb:get_tablecolumns column 2 out of range
err:msidb:get_tablecolumns column 1 out of range
err:msidb:get_tablecolumns column 2 out of range
err:msidb:get_tablecolumns column 1 out of range
err:msidb:get_tablecolumns column 2 out of range
err:msidb:get_tablecolumns column 1 out of range
err:msidb:get_tablecolumns column 2 out of range
err:msidb:get_tablecolumns column 1 out of range
err:msidb:get_tablecolumns column 2 out of range
err:msidb:get_tablecolumns column 1 out of range
err:msidb:get_tablecolumns column 2 out of range

I applied the suggested winetricks as shown in https://appdb.winehq.org/objectManager.php?sClass=version&iId=27093&iTestingId=86883

In , Focht (focht) wrote :

Hello folks,

this is issue is still present with Wine 1.6.x versions provided by some distros which use gcc 4.9 by default.

I see this specific problem reported every few months in #winehq.
The recommendation is to tell the user upgrade to Wine 1.7.x which fixes a lot of other things (the choice is not that bad in the end).

Anyway, since there won't be Wine 1.6.3 it might to useful to inform Wine package maintainers of this issue (who didn't get the message/are aware of this) and force them to provide an updated "stable" Wine 1.6.2 package with the patch backported.

Today's "winner":

http://pastebin.com/pZXB7KAv

Lubuntu 14.10 (Utopic Unicorn)
Wine 1.6.2

Regards

jre (jre-phoenix) wrote :

The above mentioned bug is a dupe of https://bugs.winehq.org/show_bug.cgi?id=36139.

This bug causes quite many windows programs to fail to install with wine. Upstream suggests in the bugreport to reach out for the packagers, what seems not to have happened yet, so here we are. (ARCH and Debian already fixed it in their 1.6 packages.)

It affects wine in utopic (and probably vivid) , but afaik not trusty (I assume there an older gcc is used).

Fixed upstream in wine 1.7.20 by
commit deb274226783ab886bdb44876944e156757efe2b
Author: Daniel Beitler <email address hidden>
Date: Sun May 18 13:27:42 2014 -0400

Greets
jre

(In reply to Anastasius Focht from comment #17)
> Anyway, since there won't be Wine 1.6.3 it might to useful to inform Wine
> package maintainers of this issue (who didn't get the message/are aware of
> this) and force them to provide an updated "stable" Wine 1.6.2 package with
> the patch backported.

Debian (bugs.debian.org/765645 in 1.6.2-12) and ARCH (bugs.archlinux.org/task/40310 in 1.6.2 rel -2) already fixed it.

Ubuntu has https://bugs.launchpad.net/ubuntu/+source/wine1.6/+bug/1383214
I just updated that report.

The attachment "Upstream commit fixing the problem" seems to be a patch. If it isn't, please remove the "patch" flag from the attachment, remove the "patch" tag, and if you are a member of the ~ubuntu-reviewers, unsubscribe the team.

[This is an automated message performed by a Launchpad user owned by ~brian-murray, for any issues please contact him.]

tags: added: patch
Barry Drake (b-drake) wrote :

I have just posted a bug at: https://bugs.launchpad.net/bugs/1414995 which I think may be a duplicat of this bug. I've got a lot more facts about it that I've put on #1414995, especially the fact that the problem does not occur with wine 1.6 under Linux Mint even though Mint takes the identical packages from the Ubuntu repos. This must be an upstream bug - I havent a clue where to begin looking.

Changed in wine (Debian):
status: Unknown → Fix Released
Clark Wierda (cbwierda) wrote :

I get this error on first run of winecfg after installing from repository.

I'm using Kubuntu 14.10 and have verified that the same version of the package is loaded.

I got it working.

$ wine --version
wine-1.7.38

I recommend you use a newer version of wine :) go to the website and check
how to install the latest version rather than that i the repo perhaps?

On 25 May 2015 at 13:46, Clark Wierda <email address hidden> wrote:

> I get this error on first run of winecfg after installing from
> repository.
>
> I'm using Kubuntu 14.10 and have verified that the same version of the
> package is loaded.
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (1414995).
> https://bugs.launchpad.net/bugs/1383214
>
> Title:
> msiexec no longer works
>
> Status in Wine:
> Unknown
> Status in wine1.6 package in Ubuntu:
> Confirmed
> Status in wine package in Debian:
> Fix Released
>
> Bug description:
> It seems to me this has to do with wine being compiled with gcc 4.9
> https://bugs.winehq.org/show_bug.cgi?id=36453
>
> output msiexec /i superwave_p8.msi
> err:msidb:get_tablecolumns column 1 out of range
> err:msidb:get_tablecolumns column 2 out of range
> fixme:storage:create_storagefile Storage share mode not implemented.
> err:msidb:get_tablecolumns column 1 out of range
> err:msidb:get_tablecolumns column 2 out of range
> err:msidb:get_tablecolumns column 1 out of range
> err:msidb:get_tablecolumns column 2 out of range
> err:msidb:get_tablecolumns column 1 out of range
> err:msidb:get_tablecolumns column 2 out of range
> err:msidb:get_tablecolumns column 3 out of range
> err:msidb:get_tablecolumns column 1 out of range
> err:msidb:get_tablecolumns column 2 out of range
> err:msidb:get_tablecolumns column 3 out of range
> err:msidb:get_tablecolumns column 1 out of range
> err:msidb:get_tablecolumns column 2 out of range
> err:msidb:get_tablecolumns column 3 out of range
> err:msidb:get_tablecolumns column 1 out of range
> err:msidb:get_tablecolumns column 2 out of range
> err:msidb:get_tablecolumns column 3 out of range
>
> ProblemType: Bug
> DistroRelease: Ubuntu 14.10
> Package: wine 1:1.6.2-0ubuntu6
> ProcVersionSignature: Ubuntu 3.16.0-23.30-lowlatency 3.16.4
> Uname: Linux 3.16.0-23-lowlatency x86_64
> NonfreeKernelModules: nvidia
> ApportVersion: 2.14.7-0ubuntu7
> Architecture: amd64
> CurrentDesktop: XFCE
> Date: Mon Oct 20 10:28:32 2014
> InstallationDate: Installed on 2014-07-04 (107 days ago)
> InstallationMedia: Xubuntu 14.04 LTS "Trusty Tahr" - Release amd64
> (20140416.2)
> SourcePackage: wine1.6
> UpgradeStatus: No upgrade log present (probably fresh install)
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/wine/+bug/1383214/+subscriptions
>

--
Mike Clark
<email address hidden>
<email address hidden>

Benjamin Geese (ben-8409) wrote :

Wine in Ubuntu 15.04 is still affected and almost useless this way.

Changed in wine:
importance: Unknown → Medium
status: Unknown → Fix Released
Jeppe Bundsgaard (jeppe) wrote :

Problem can be solved in Ubuntu 15.04 by installing wine 1.7 (beta). See how here: https://www.winehq.org/download/ubuntu

Thank you, works with new wine

Per Gjerløv

2015-06-20 16:43 GMT+02:00 Jeppe Bundsgaard <email address hidden>:

> Problem can be solved in Ubuntu 15.04 by installing wine 1.7 (beta). See
> how here: https://www.winehq.org/download/ubuntu
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (1414995).
> https://bugs.launchpad.net/bugs/1383214
>
> Title:
> msiexec no longer works
>
> Status in Wine:
> Fix Released
> Status in wine1.6 package in Ubuntu:
> Confirmed
> Status in wine package in Debian:
> Fix Released
>
> Bug description:
> It seems to me this has to do with wine being compiled with gcc 4.9
> https://bugs.winehq.org/show_bug.cgi?id=36453
>
> output msiexec /i superwave_p8.msi
> err:msidb:get_tablecolumns column 1 out of range
> err:msidb:get_tablecolumns column 2 out of range
> fixme:storage:create_storagefile Storage share mode not implemented.
> err:msidb:get_tablecolumns column 1 out of range
> err:msidb:get_tablecolumns column 2 out of range
> err:msidb:get_tablecolumns column 1 out of range
> err:msidb:get_tablecolumns column 2 out of range
> err:msidb:get_tablecolumns column 1 out of range
> err:msidb:get_tablecolumns column 2 out of range
> err:msidb:get_tablecolumns column 3 out of range
> err:msidb:get_tablecolumns column 1 out of range
> err:msidb:get_tablecolumns column 2 out of range
> err:msidb:get_tablecolumns column 3 out of range
> err:msidb:get_tablecolumns column 1 out of range
> err:msidb:get_tablecolumns column 2 out of range
> err:msidb:get_tablecolumns column 3 out of range
> err:msidb:get_tablecolumns column 1 out of range
> err:msidb:get_tablecolumns column 2 out of range
> err:msidb:get_tablecolumns column 3 out of range
>
> ProblemType: Bug
> DistroRelease: Ubuntu 14.10
> Package: wine 1:1.6.2-0ubuntu6
> ProcVersionSignature: Ubuntu 3.16.0-23.30-lowlatency 3.16.4
> Uname: Linux 3.16.0-23-lowlatency x86_64
> NonfreeKernelModules: nvidia
> ApportVersion: 2.14.7-0ubuntu7
> Architecture: amd64
> CurrentDesktop: XFCE
> Date: Mon Oct 20 10:28:32 2014
> InstallationDate: Installed on 2014-07-04 (107 days ago)
> InstallationMedia: Xubuntu 14.04 LTS "Trusty Tahr" - Release amd64
> (20140416.2)
> SourcePackage: wine1.6
> UpgradeStatus: No upgrade log present (probably fresh install)
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/wine/+bug/1383214/+subscriptions
>

Barry Drake (b-drake) wrote :

Note that in 15.10, at the moment, wine can't be installed at all - either 1.6x or 1.7x. I'll have to wait a bit longer. Not sure, but I think with the number of changes, a new version of wine is going to have to be built and packaged before there is any chance. Maybe this time, 15.10 will actually be released with a fully working wine next October. Here's hoping!

Michael Vogt (mvo) on 2015-07-15
Changed in wine1.6 (Ubuntu Vivid):
status: New → Confirmed
importance: Undecided → High
Michael Vogt (mvo) on 2015-07-16
Changed in wine1.6 (Ubuntu Vivid):
status: Confirmed → In Progress
description: updated
description: updated
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package wine1.6 - 1:1.6.2-0ubuntu10

---------------
wine1.6 (1:1.6.2-0ubuntu10) wily; urgency=medium

  * cherry pick deb274226783ab886bdb44876944e156757efe2b to
    make msiexec work again (LP: #1383214)

 -- Michael Vogt <email address hidden> Wed, 15 Jul 2015 21:14:40 +0200

Changed in wine1.6 (Ubuntu Wily):
status: Confirmed → Fix Released
jre (jre-phoenix) wrote :

Hello Michael,

it's great to see that you took care of this, thanks!

Any chance that you can also fix this for 14.04 LTS (Trusty)?

Greets
jre

Michael Clark (mickster04) wrote :
Download full text (3.1 KiB)

It's fixed in the newer version of wine, the issue isn't with Ubuntu

On Fri, 17 Jul 2015 8:25 am jre-phoenix <email address hidden>
wrote:

> Hello Michael,
>
> it's great to see that you took care of this, thanks!
>
> Any chance that you can also fix this for 14.04 LTS (Trusty)?
>
> Greets
> jre
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (1414995).
> https://bugs.launchpad.net/bugs/1383214
>
> Title:
> msiexec no longer works
>
> Status in Wine:
> Fix Released
> Status in wine1.6 package in Ubuntu:
> Fix Released
> Status in wine1.6 source package in Vivid:
> In Progress
> Status in wine1.6 source package in Wily:
> Fix Released
> Status in wine package in Debian:
> Fix Released
>
> Bug description:
> [Impact]
> * prevents msiexec from working
> * msiexec is pretty important for installing most software
> * this upload contains the patch that got pulled into the debian wine
> package
>
> [Test Case]
> * [can someone affected please attach a good test case?]
> * run "wine msiexec -i ActivePython-2.7.8.10-win32-x86.msi" and verify
> that it does not work with the original version and that it does work with
> the update
>
> [Regression Potential]
> * low, patch is upstream and in debian
>
> It seems to me this has to do with wine being compiled with gcc 4.9
> https://bugs.winehq.org/show_bug.cgi?id=36453
>
> output msiexec /i superwave_p8.msi
> err:msidb:get_tablecolumns column 1 out of range
> err:msidb:get_tablecolumns column 2 out of range
> fixme:storage:create_storagefile Storage share mode not implemented.
> err:msidb:get_tablecolumns column 1 out of range
> err:msidb:get_tablecolumns column 2 out of range
> err:msidb:get_tablecolumns column 1 out of range
> err:msidb:get_tablecolumns column 2 out of range
> err:msidb:get_tablecolumns column 1 out of range
> err:msidb:get_tablecolumns column 2 out of range
> err:msidb:get_tablecolumns column 3 out of range
> err:msidb:get_tablecolumns column 1 out of range
> err:msidb:get_tablecolumns column 2 out of range
> err:msidb:get_tablecolumns column 3 out of range
> err:msidb:get_tablecolumns column 1 out of range
> err:msidb:get_tablecolumns column 2 out of range
> err:msidb:get_tablecolumns column 3 out of range
> err:msidb:get_tablecolumns column 1 out of range
> err:msidb:get_tablecolumns column 2 out of range
> err:msidb:get_tablecolumns column 3 out of range
>
> ProblemType: Bug
> DistroRelease: Ubuntu 14.10
> Package: wine 1:1.6.2-0ubuntu6
> ProcVersionSignature: Ubuntu 3.16.0-23.30-lowlatency 3.16.4
> Uname: Linux 3.16.0-23-lowlatency x86_64
> NonfreeKernelModules: nvidia
> ApportVersion: 2.14.7-0ubuntu7
> Architecture: amd64
> CurrentDesktop: XFCE
> Date: Mon Oct 20 10:28:32 2014
> InstallationDate: Installed on 2014-07-04 (107 days ago)
> InstallationMedia: Xubuntu 14.04 LTS "Trusty Tahr" - Release amd64
> (20140416.2)
> SourcePackage: wine1.6
> UpgradeStatus: No upgrade log present (probably fresh install)
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/wine/+bug/1383214/+subscrip...

Read more...

jre (jre-phoenix) wrote :

Hello Michael Clark (the previous message was directed at Michael Vogt)

This problem just appears if Wine is compiled with GCC 4.9. When Wine 1.6 was released this wasn't the case. So Ubuntu (and other dists) introduced this bug when they compiled with the "wrong" GCC. Just have a look at the upstream bug report, especially https://bugs.winehq.org/show_bug.cgi?id=36139#c17 where upstream said that this should be fixed by the distros because there won't be a 1.6.3.

Anyway, this is a bug which makes Wine1.6 in Trusty unusable in many cases, while it is easy to solve with low regression potential as Michael Vogt correctly indicated.

I'm well aware of the fact that this was fixed in 1.7.20, and that you can install a recent version from the PPA.
Still I think a LTS shouldn't go with a broken Wine, even if it is just in Universe. Therefore my pledge to Michael Vogt.

Hello Rob, or anyone else affected,

Accepted wine1.6 into vivid-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/wine1.6/1:1.6.2-0ubuntu8.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in wine1.6 (Ubuntu Vivid):
status: In Progress → Fix Committed
tags: added: verification-needed
terrjie (terrjie) wrote :
terrjie (terrjie) wrote :

The Fix doesn't work for me. msiexec crashed on starting msi-file. The backtrace is in the previous post.

apport hater (g112) wrote :

Confirming,
the -proposed package allowed me to install a MSI package on a clean wine prefix.

Brian Murray (brian-murray) wrote :

@terrjie - Could you elaborate as to which specific version of wine (e.g. apt-cache policy wine) you are using?

Ryan Mottley (ligerzero459) wrote :

-proposed package fixed the issue for me. Successfully able to install MSI package

As a part of the Stable Release Updates quality process a search for Launchpad bug reports using the version of wine1.6 from vivid-proposed was performed and bug 1490095 was found. Please investigate this bug report to ensure that a regression will not be created by this SRU. In the event that this is not a regression remove the "verification-failed" tag from this bug report and tag 1490095 "bot-stop-nagging". Thanks!

tags: added: verification-failed
Marius Kruger (amanica) wrote :

upgrading to the -proposed version worked for met too.

$ apt-cache policy wine
wine:
  Installed: 1:1.6.2-0ubuntu8.1
  Candidate: 1:1.6.2-0ubuntu8.1
  Version table:
 *** 1:1.6.2-0ubuntu8.1 0
        400 http://za.archive.ubuntu.com/ubuntu/ vivid-proposed/universe amd64 Packages
        100 /var/lib/dpkg/status
     1:1.6.2-0ubuntu8 0
        500 http://za.archive.ubuntu.com/ubuntu/ vivid/universe amd64 Packages

$ aptitude -t vivid-proposed
(Reading database ... 286193 files and directories currently installed.)
Preparing to unpack .../wine1.6-amd64_1%3a1.6.2-0ubuntu8.1_amd64.deb ...
Unpacking wine1.6-amd64 (1:1.6.2-0ubuntu8.1) over (1:1.6.2-0ubuntu8) ...
Preparing to unpack .../wine1.6_1%3a1.6.2-0ubuntu8.1_amd64.deb ...
Unpacking wine1.6 (1:1.6.2-0ubuntu8.1) over (1:1.6.2-0ubuntu8) ...
Preparing to unpack .../wine1.6-i386_1%3a1.6.2-0ubuntu8.1_i386.deb ...
Unpacking wine1.6-i386 (1:1.6.2-0ubuntu8.1) over (1:1.6.2-0ubuntu8) ...
Preparing to unpack .../wine_1%3a1.6.2-0ubuntu8.1_amd64.deb ...
Unpacking wine (1:1.6.2-0ubuntu8.1) over (1:1.6.2-0ubuntu8) ...
Processing triggers for mime-support (3.58ubuntu1) ...
Processing triggers for gnome-menus (3.10.1-0ubuntu5) ...
Processing triggers for desktop-file-utils (0.22-1ubuntu3) ...
Processing triggers for bamfdaemon (0.5.1+15.04.20150202-0ubuntu1) ...
Rebuilding /usr/share/applications/bamf-2.index...
Processing triggers for man-db (2.7.0.2-5) ...
Processing triggers for hicolor-icon-theme (0.14-0ubuntu1) ...
Setting up wine1.6 (1:1.6.2-0ubuntu8.1) ...
Setting up wine1.6-i386 (1:1.6.2-0ubuntu8.1) ...
Setting up wine (1:1.6.2-0ubuntu8.1) ...
Setting up wine1.6-amd64 (1:1.6.2-0ubuntu8.1) ...
Processing triggers for libc-bin (2.21-0ubuntu4) ...

tags: added: verification-done
removed: verification-failed verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package wine1.6 - 1:1.6.2-0ubuntu8.1

---------------
wine1.6 (1:1.6.2-0ubuntu8.1) vivid-proposed; urgency=medium

  * cherry pick deb274226783ab886bdb44876944e156757efe2b to
    make msiexec work again (LP: #1383214)

 -- Michael Vogt <email address hidden> Wed, 15 Jul 2015 21:14:40 +0200

Changed in wine1.6 (Ubuntu Vivid):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for wine1.6 has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

In , Focht (focht) wrote :

*** Bug 39664 has been marked as a duplicate of this bug. ***

In , Focht (focht) wrote :

Hello folks,

refining summary to collect more dupes here.
I removed the wine-test part to avoid overly long summary since it's rarely run by the end user.

What matters is the error message from running real world app/game installers to be found in Wine Bugzilla (live)search.

Regards

In , Focht (focht) wrote :

*** Bug 37787 has been marked as a duplicate of this bug. ***

In , Focht (focht) wrote :

*** Bug 37554 has been marked as a duplicate of this bug. ***

Louis Issembe (virpub) on 2016-01-25
Changed in wine1.6 (Ubuntu Wily):
assignee: nobody → Louis Issembe (virpub)
Barry Drake (b-drake) wrote :

It was fixed a long time ago. I suggest closing this bug please.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Related questions

Remote bug watches

Bug watches keep track of this bug in other bug trackers.