rosetta stone won't install via WINE

Bug #103537 reported by ddumanis on 2007-04-05
2
Affects Status Importance Assigned to Milestone
Wine
Confirmed
Medium
wine (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: wine

I get a Java-related error and crash when I try to install Rosetta Stone for Windows via WINE.

Instances of successful Rosetta Stone/WINE installs are common on the Web. Not sure if this is a WINE issue, a Feisty issue, or both.

Problem is described in more detail here (by someone else who reproduced it exactly):
http://groups.google.com/group/comp....7088833dcade07

In , Dan Kegel (dank) wrote :

$ wine SRIWS.exe
Invocation of this Java Application has caused an InvocationTargetException.
This application will now exit. (LAX)

Stack Trace:
java.lang.NoClassDefFoundError
        at java.lang.Class.forName0(Native Method)
        at java.lang.Class.forName(Unknown Source)
        at java.awt.Toolkit$2.run(Unknown Source)
        at java.security.AccessController.doPrivileged(Native Method)
        at java.awt.Toolkit.getDefaultToolkit(Unknown Source)
        at sun.awt.GlobalCursorManager$CursorEvent.<init>(Unknown Source)
        at sun.awt.GlobalCursorManager.<clinit>(Unknown Source)
        at java.awt.Cursor.initIDs(Native Method)
        at java.awt.Cursor.<clinit>(Unknown Source)
        at java.awt.Window.<init>(Unknown Source)
        at java.awt.Frame.<init>(Unknown Source)
        at java.awt.Frame.<init>(Unknown Source)
        at com.zerog.ia.installer.Main.c(Unknown Source)
        at com.zerog.ia.installer.Main.main(Unknown Source)
        at java.lang.reflect.Method.invoke(Native Method)
        at com.zerog.lax.LAX.launch(Unknown Source)
        at com.zerog.lax.LAX.main(Unknown Source)

Sadly, WINEDEBUG=+relay causes the installer to abort early,
so I didn't learn anything with that.

Looking at +file, I see the last file opened before the crash was
C:\\windows\\temp\\i1174067555\\windows\\resource\\jre\\bin\\awt.dll
That JRE seems to be Sun's J2RE Version 1.3.1.

You can use a different JRE, but you have to tell the installer to do it.
I haven't tried this yet, but there is some doc on how to do it here:
http://www.zerog.com/iamanual/usermanual_ia45/user_guides/contents.htm

Stephan Ruegamer (sadig) on 2007-05-28
Changed in wine:
assignee: nobody → ubuntu-wine
In , Dan Kegel (dank) wrote :

There is a free demo, but you have to send away for the CD-ROM.
The installer aborts with a java error,
also described here:
http://www.spinics.net/lists/wine/msg24150.html
The installer has an embedded copy of Java, namely
Java(TM) 2 Runtime Environment, Standard Edition (build 1.3.1_11-b02)
The error message helpfully prints out the exact command
used to invoke java, and this actually reproduces
the error if you run it by hand, which makes for a much
shorter log.

This may be a dup of bug 7767, but at least Rosetta Stone
has a free demo, which can't be said of the app in 7767.

In , Dan Kegel (dank) wrote :

Created an attachment (id=6569)
Script showing how to invoke the failing java command, taken from log file.

could you please post the error log?
And it seems to be a problem with wine.
I hope there should be a antery for this one in wine projects bugzilla

Dan Kegel (dank) wrote :

Bug filed, http://bugs.winehq.org/show_bug.cgi?id=8571
winehq is the place to work on this.

Changed in wine:
status: Unknown → Confirmed
In , Dan Kegel (dank) wrote :

The appdb entry shows how to run the installer with your own JVM,
which gets you to the next problem...

In , Dan Kegel (dank) wrote :

Bug 8571 may be a dup of this one.
http://bugs.winehq.org/attachment.cgi?id=6569 shows how to
reproduce the error with a naked jre.
http://appdb.winehq.org/objectManager.php?sClass=version&iId=7390
seems to have a recipe for getting past this for at least one app.

Dan:

You are correct in the duplicate, but bug 8571 has a link to a very good description of why this error occurs and what to do to fix it. Leaving this for you to mark as a duplicate.

BTW, Java 1.3 is VERY old and I think it is not maintained by Sun anymore. However, if we need to support this, development effort should be expended but not in favor of other higher priority problems/bugs.

James

In , Dan Kegel (dank) wrote :

Still not working today. Often seems to hang.
Sometimes aborts with a font-y sort of stack dump
which 'winetricks corefonts' might help. But tracking
this down is frustrating as it usually seems to hang
(right after loading awt?)

Changed in wine:
status: New → Confirmed

Does this still fail in 1.0? It seems like later versions of Rosetta install according to AppDB.

Changed in wine:
assignee: ubuntu-wine → nobody
importance: Undecided → Low
status: Confirmed → Triaged
In , Jthorn (jthorn) wrote :

Created an attachment (id=15823)
This is the output from the terminal window

I'm running Ubuntu Hardy Heron and have been updating Wine regularly. The Rosetta Stone version is 2.1.5.3A. Alas, I still cannot run Rosetta Stone and was hoping that if I contributed my error messages as well it would provide a more knowledgeable person with the information they needed to solve the problem. Attached is the terminal window output after running "wine autorun.exe" off of the installation CD. Until I figure out how to put two attachments on a single comment, I will post another comment with the log file mentioned in the terminal output.

Many thanks,
- Jon

In , Jthorn (jthorn) wrote :

Created an attachment (id=15824)
Error log from trying to install Rosetta Stone

And this is the log file I mentioned in the previous Comment.

Many thanks,
- Jon

*** Bug 7767 has been marked as a duplicate of this bug. ***

Dupe

*** This bug has been marked as a duplicate of bug 8571 ***

Closing.

Is this still an issue in current (1.2-rc2 or newer) Wine?

In , Focht (focht) wrote :

*** Bug 21126 has been marked as a duplicate of this bug. ***

Could you please confirm whether this is still an issue in a recent Ubuntu release and with a recent version of wine (preferably 1.2) from https://launchpad.net/~ubuntu-wine/+archive/ppa ?
Thanks

We are closing this bug report because it lacks the information we need to investigate the problem, as described in the previous comments. Please reopen it if you can give us the missing information, and don't hesitate to submit bug reports in the future. To reopen the bug report you can click on the current status, under the Status column, and change the Status back to "New". Thanks again!

Changed in wine (Ubuntu):
status: Triaged → Invalid
Changed in wine:
importance: Unknown → Medium

Created an attachment (id=33267)
log of install attempt - Rosetta Stone v2.1.5.3Asms under Wine 1.2.2

(In reply to comment #8)
> Is this still an issue in current (1.2-rc2 or newer) Wine?

Yes, although the symptoms are different. I tried installing Rosetta Stone v2.1.5.3Asms under Wine 1.2.2. Log attached.

Jack Leigh (leighman) on 2011-02-14
Changed in wine (Ubuntu):
status: Invalid → Triaged

This ticket has not been updated for over 850 days.

Is this still an issue in wine version 1.6-rc4 or higher or is this to be closed as abandoned ?

In , Focht (focht) wrote :

Hello folks,

--- quote ---
You are correct in the duplicate, but bug 8571 has a link to a very good description of why this error occurs and what to do to fix it. Leaving this for you to mark as a duplicate.
--- quote ---

Sorry, but I fail to see any technical explanation in bug 8571 why this error occurs.
Where is this link you are talking about?

Anyway, resolving this bug as dupe of 8571 is plain wrong.

This bug is older and targets a list of affected apps/installers (all 'Zero-G' technology installers = LAX based).
Bug 8571 doesn't add anything useful. It talks about a single application.
Reversing the dupe.

If found another LAX-based installer showing the same symptoms: Parashara's Light Professional 7.0.1

$ wine --version
wine-1.7.14-142-gbd69346

Regards

In , Focht (focht) wrote :

Hello folks,

this is dupe of bug 7767 which targets all Zero-G (LAX) based installers, not the other way around...

Regards

*** This bug has been marked as a duplicate of bug 7767 ***

In , Focht (focht) wrote :

*** Bug 8571 has been marked as a duplicate of this bug. ***

In , Focht (focht) wrote :

Hello folks,

filling some fields, refining summary.

Regards

Changed in wine:
status: Confirmed → Invalid

Closing duplicate bugs.

Rolf Leggewie (r0lf) on 2018-05-20
Changed in wine:
importance: Medium → Unknown
status: Invalid → Unknown
summary: - rosetta stone won't install via WINE in Feisty
+ rosetta stone won't install via WINE
Changed in wine:
importance: Unknown → Medium
status: Unknown → Confirmed

Is still a bug in current wine(3.20)?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.