wesnoth-all meta-package request (for gnome-app-install)

Bug #82436 reported by Dave Morley on 2007-01-31
34
This bug affects 1 person
Affects Status Importance Assigned to Milestone
gnome-app-install
Undecided
Unassigned
wesnoth (Debian)
Fix Released
Unknown
wesnoth (Ubuntu)
Wishlist
Emilio Pozuelo Monfort

Bug Description

New users of Linux/Ubuntu will see gnome-app-install and simply assume that is how you get a program installed.
Currently when you install "wesnoth" you get no music and no campaigns this makes the package almost useless.

My spec as such is for a meta-package called wesnoth-all which would install wesnoth along with all of it's extra packages for inclusion into gnome-app-install.
This means then that new users need only use this package and have a game ready to rock straight away.

Binary package hint: gnome-app-install

New users of Linux/Ubuntu will see g-a-i and simply assume that is how you get a program installed.
Currently when you install "westnoth" you get no music and no campaigns this makes the package almost useless.

My spec as such is for a meta-package called westnoth-all which would install westnoth along with all of it's extra packages for inclusion into gnome-app-install.
This means then that new user need only use this package and have a game ready to rock straight away.

Dave Morley (davmor2) wrote :

I was recommended adding this here rather than as a blueprint.

Áron Sisak (asisak) wrote :

This is not a problem in gnome-app-install but in Wesnoth (source package).

Changed in gnome-app-install:
importance: Undecided → Wishlist
status: Unconfirmed → Confirmed
Áron Sisak (asisak) wrote :

Thanks for all suggestions. Now I marked all former discussion about this as a duplicate of this bug, because the solution is detailed here (whereas the problem is described better in duplicates).

Áron Sisak (asisak) on 2007-02-01
description: updated
Changed in wesnoth:
assignee: nobody → asisak
status: Confirmed → In Progress
Changed in wesnoth:
status: Unknown → Unconfirmed
description: updated
Dave Morley (davmor2) wrote :

Nice one Aron. :)

Emilio Pozuelo Monfort (pochu) wrote :

Format: 1.0
Source: wesnoth
Version: 1.2.2-0ubuntu1
Binary: wesnoth-httt, wesnoth-music, wesnoth-ttb, wesnoth-editor, wesnoth-utbs, wesnoth-data, wesnoth-ei, wesnoth, wesnoth-all, wesnoth-trow, wesnoth-tsg, wesnoth-server
Maintainer: Ubuntu MOTU Developers <email address hidden>
Architecture: any
Standards-Version: 3.7.2
Build-Depends: cdbs (>= 0.4.23-1.1), debhelper (>= 4.2.21), libsdl-image1.2-dev, libfreetype6-dev, libsdl-mixer1.2-dev, libsdl-net1.2-dev, libfribidi-dev, python-dev (>= 2.3), libsdl1.2-dev
Original-Maintainer: Isaac Clerencia <email address hidden>
Uploaders: Cyril Bouthors <email address hidden>
Files:
 08b15bedd4985ebf9d5b5f407a832996 75660907 wesnoth_1.2.2.orig.tar.gz
 07eaef76a8b29f009cc8ed70e1dbb6db 13844 wesnoth_1.2.2-0ubuntu1.diff.gz

Changed in wesnoth:
assignee: asisak → pochu
status: In Progress → Fix Released
VF (vfiend) wrote :

I just tried installing wesnoth from gnome-app-install on latest Feisty and it just installed wesnoth and wesnoth-data, not wesnoth-all, should I file a new bug?

Emilio Pozuelo Monfort (pochu) wrote :

Please, file one against gnome-app-install.

VF (vfiend) wrote :

Done, see bug 96301

On Wednesday 20 July 2005 14:09, Frank S. Thomas wrote:
> It would be nice to have a wesnoth-campaigns metapackage which depends
> on all official Wesnoth campaigns. With this package istalled one
> doesn't need to manually install campaigns that become available with
> newer versions of Wesnoth.

Since wesnoth-data Recommends all Wesnoth campaigns and most APT package
manager install recommended packages by default, I think that a
wesnoth-campaigns metapackage is not warranted any more. Therefore I'm
closing this bug report.

Grüße,
Frank

Changed in wesnoth:
status: Unconfirmed → Fix Released

# Changing my submitter address for archived bug reports.
# I'm sorry for the noise!
unarchive 376857
unarchive 319185
unarchive 279062
unarchive 441272
unarchive 437431
unarchive 367195
unarchive 344826
unarchive 299090
unarchive 340590
owner 376857 "Frank S. Thomas" <email address hidden>
submitter 376857 "Frank S. Thomas" <email address hidden>
submitter 319185 "Frank S. Thomas" <email address hidden>
submitter 279062 "Frank S. Thomas" <email address hidden>
submitter 441272 "Frank S. Thomas" <email address hidden>
submitter 437431 "Frank S. Thomas" <email address hidden>
submitter 367195 "Frank S. Thomas" <email address hidden>
submitter 344826 "Frank S. Thomas" <email address hidden>
submitter 299090 "Frank S. Thomas" <email address hidden>
submitter 340590 "Frank S. Thomas" <email address hidden>
archive 376857
archive 319185
archive 279062
archive 441272
archive 437431
archive 367195
archive 344826
archive 299090
archive 340590
stop

As of Jaunty, this is still a problem.

From the description of gnome-app-install:

"Please note that this package recommends only three of the official campaigns, those that are considered to be an introduction to the game. They are just recommended but not depended on - quite some people enjoy the multiplayer mode for which they aren't needed. If you want to have all the official campaigns installed you are encouraged to install wesnoth."

Firstly, this description is easy to miss. I and another person have missed this description. Secondly, the packages set to install do not include critical components such as music. Users should not be expected to hunt around to get the game they want to work working. This should be a two click process to get the necessary packages included. Currently, it fails fantastically at providing a working program upon install via add/remove.

Changed in gnome-app-install:
status: New → Confirmed

 Hi!

* Chauncellor <email address hidden> [2009-09-19 18:38:30 CEST]:
> As of Jaunty, this is still a problem.

 Erm, is not?

> >From the description of gnome-app-install:
>
> "Please note that this package recommends only three of the official
> campaigns, those that are considered to be an introduction to the game.
> They are just recommended but not depended on - quite some people enjoy
> the multiplayer mode for which they aren't needed. If you want to have
> all the official campaigns installed you are encouraged to install
> wesnoth."

 You are looking at the package description of wesnoth-core, *not* of
wesnoth in jaunty:

<http://packages.ubuntu.com/jaunty/wesnoth>
vs.
<http://packages.ubuntu.com/jaunty/wesnoth-core>

> Firstly, this description is easy to miss. I and another person have
> missed this description. Secondly, the packages set to install do not
> include critical components such as music.

 I am not really sure why you call the music a "critical" component, it
isn't needed at all? It is nice to have of course, but "critical" is
something completely different.

> Users should not be expected to hunt around to get the game they want
> to work working.

 ... and they aren't anymore since the jaunty release because jaunty
comes with the complete suite (minus the server) when installing the
wesnoth package.

 Or does gnome-app-install only offer wesnoth-core for installation but
not wesnoth itself? I'm not on an ubuntu system myself so I can't check
that part.

 Thanks anyway!
Rhonda

Hi,

That description came straight out of the add/remove description.

From gnome-app-install, the complete suite is not installed. I had a friend new to Ubuntu that wanted to play the game after playing on my machine. She called me when she didn't have any music.

The only packages that are installed through add/remove are:

wesnoth-core
wesnoth-data
wesnoth-httt
wesnoth-tsg
wesnoth-ttb

Emmet Hikory (persia) wrote :

Indeed. I can confirm this result with Jaunty. It is a bug only in gnome-app-install, in that gnome-app-install installs wesnoth-core rather than either wesnoth or wesnoth-all.

Emmet Hikory (persia) wrote :

This was fixed previously as bug #96301, and the rename clause still appears to exist in gnome-app-install/util/rename.cfg to point at "wesnoth-all" when installing "wesnoth" (checked karmic source). I'm not sufficiently familiar with gnome-app-install, but does perhaps the hint need to be adjusted to rename "wesnoth-core" to "wesnoth"? Might this be related to the package rename that happened in 1:1.5.5-1, so that the .desktop file previously provided by "wesnoth" is now provided by "wesnoth-core", and the filter misses?

Rhonda D'Vine (rhonda) wrote :

Then this is a completely different bug in gnome-app-install and not affecting wesnoth - shouldn't a new bug be opened about it then instead of reusing an old one? This feels strange, and LP still doesn't permit one to unsubscribe from specific bugs when subscribed to a package. :(

My apologies, I just thought it would be cleaner to just use this one as the report was specifically trying to address this same issue that is occurring.

In Karmic, Software Store is installing all packages but the following:

wesnoth-server
wesnoth-tools
wesnoth-dbg
wesnoth-editor

Is this intended behavior? the only one I'd care to have included still is the wesnoth-server package, but I'd be happy to mark this as fixed as it addresses the core problems such as campaigns and music.

Rhonda D'Vine (rhonda) wrote :

* Chauncellor <email address hidden> [2009-10-26 06:49:52 CET]:
> In Karmic, Software Store is installing all packages but the following:
>
> wesnoth-server
> wesnoth-tools
> wesnoth-dbg
> wesnoth-editor
>
> Is this intended behavior? the only one I'd care to have included
> still is the wesnoth-server package, but I'd be happy to mark this as
> fixed as it addresses the core problems such as campaigns and music.

 Yes, this is expected. The -tools package is for developers of
campaigns, the -dbg package is for debugging, and the -editor package is
just an empty transitional package, wesnoth has the editor included now.

 About the -server package, it is only needed if you really want to
become a server for multiplayer games yourself. People usually use the
official servers, and for lan games it's not needed neither, if I am not
mistaken--can be wrong on that.

 Though, like said, people usually use the official servers instead of
playing around with IP addresses and stuff, and given that all campaigns
are pulled in people also play campaigns for which they obviously don't
need the server neither. ;)

 Thanks!
Rhonda

Anil Pal (itsmeanilpal) on 2013-10-11
Changed in gnome-app-install:
status: Confirmed → Incomplete
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.