Wesnoth installs with no campaigns

Bug #72744 reported by Adam Petaccia on 2006-11-21
2
Affects Status Importance Assigned to Milestone
wesnoth (Debian)
Fix Released
Unknown
wesnoth (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: wesnoth

I know that its possible to technically have wesnoth installed with no campaigns, but this is a very bad idea. Wesnoth (not wesnoth-data) should _recommend_ (not suggest) that at least one campaign be installed. This is likely to confuse new users, and experienced onces as well - and already has, because I've gotten a few "help me's!" with it already.

Installing wesnoth without any campaigns is offering a game with severly reduced functionality (and the tutorial doesn't count).

Morgan Collett (morgan) wrote :

I installed wesnoth and it took me ages to figure out why clicking "Campaign" had no effect -- because there were no campaigns installed. I had installed Wesnoth with Add/Remove... (on Edgy) and there are no campaign packages visible there. If I had used synaptic I would probably have noticed them.

So I think this bug would be solved by listing the campaigns in Add/Remove... and by updating the description of the Wesnoth package to indicate that campaigns should also be installed.

Changed in wesnoth:
status: Unconfirmed → Confirmed
Alec Wright (alecjw) wrote :

I had a simmilar idea: http://ubuntuforums.org/showthread.php?p=1902111#post1902111

The 3 possible ideas in the post are:
1. Make wesnoth depend on wesnoth-music, wesnoth-editor and the campaigns. However, some people might not want music, campaigns and editors.
2. Make a "wesnoth-all" metapackage which depends on wesnoth and the music, editor and campaigns. However, you would instinctively install the wesnoth package rather than wesnoth-all, unless you knew whay you were doing, so few people would use it.
3. Rename wesnoth to wesnoth-base, and make a metapackage called wesnoth which depends on wesnoth-base and the music, editor and campaigns.

No. 3 seems to be the best option.
I think that these changes should be implemented in feisty.

Changed in wesnoth:
status: Unknown → Unconfirmed
Changed in wesnoth:
status: Unconfirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.