Pen no longer works after resuming from suspend

Bug #108961 reported by Cay Horstmann
24
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Fix Released
Undecided
Unassigned
linux-source-2.6.20 (Ubuntu)
Won't Fix
Medium
Unassigned
wacom-tools (Ubuntu)
Invalid
Undecided
Unassigned

Bug Description

Binary package hint: wacom-tools

I have a Thinkpad X60 tablet running Feisty 2.6.20-15-generic.

The Wacom pen works fine after the system boots.

When I suspend and then resume the laptop, the pen fails to work.

Tags: cft-2.6.27
Revision history for this message
Manfred Haelters (manfred-haelters) wrote :

I confirm this bug... Also X60 tablet on feisty 2.6.20-16

Revision history for this message
anco (ancovanbergeijk) wrote :

Saw several people complaining about this bug including myself, so changed to confirmed

Changed in wacom-tools:
status: New → Confirmed
Revision history for this message
anco (ancovanbergeijk) wrote :

By the way I have this bug on Toshiba tabletpc R15-S829 somewhat annoying to be forced to fully reboot before using the wacom tablet again...

Revision history for this message
Leon van der Ree (lvanderree) wrote :

I can confirm this on my freshly installed Gutsy on a Toshiba M200 tabletpc

Revision history for this message
Leon van der Ree (lvanderree) wrote :

But I wonder if anyone checks the wacom problems. My bug-report is still untouched (besides the one from you anco)

Revision history for this message
Giuseppe Benigno (giuseppe-benigno) wrote :

I can confirm too this on my new installed Gutsy on a Toshiba M200 tabletpc.

Revision history for this message
Rick @ rickandpatty.com (rick-rickandpatty) wrote :

I have a Toshiba M200 tablet with the same problem. Is this is a kernel problem rather than a Wacom driver problem. The digitizer in the M200 is a serial device (I think that's true on the Thinkpad X41/X60 tablets, too).

When initially booting the system, the digitizer's serial port is detected: (dmesg output below)

[ 22.207011] Serial: 8250/16550 driver $Revision: 1.90 $ 4 ports, IRQ sharing enabled
[ 22.207940] 00:09: ttyS0 at I/O 0x338 (irq = 4) is a 16550A

The pen works fine, until I suspend. After resuming, the pen fails, and dmesg starts spitting out these errors:

[ 1024.204000] ttyS0: LSR safety check engaged!
[ 1024.204000] ttyS0: LSR safety check engaged!
[ 1024.204000] ttyS0: LSR safety check engaged!

Googling that message seems to indicate that the reason the pen no longer works is that the serial port is no longer being detected after the resume. The same thing happens with hibernate -a dead serial port / pen on resume.

Revision history for this message
Benson Joeris (bjoeris) wrote :

I'm having the same problem on a Toshiba Portege M200, but I'm not sure this is only related to suspending. The pen also dies if I switch users (via the user switcher tool) or restart X (via logging out).

Revision history for this message
Gerator (gerator) wrote :

Same problem on a Toshiba Portege M400 running Gutsy i386 (generic kernel)

Revision history for this message
Tom Jaeger (thjaeger) wrote :

If you're running a Toshiba laptop, you're probably seeing a different bug than the one originally reported:

https://bugs.launchpad.net/ubuntu/+source/linux-source-2.6.22/+bug/152187

The Thinkpad bug already occurred in feisty, the Toshiba bug was introduced in gutsy. See the link for a possible workaround for the latter bug.

Revision history for this message
Rick @ rickandpatty.com (rick-rickandpatty) wrote :

I've just installed Ubuntu Gutsy on a Thinkpad X41 tablet and the pen works fine after a suspend/resume or a hibernate/resume cycle. Has the IBM problem (whatever it was) been fixed in Gutsy?

(The Toshiba M200 still, as of 12/3/07, exhibits the symptoms I posted above...)

Changed in linux-source-2.6.20:
assignee: nobody → ubuntu-kernel-acpi
importance: Undecided → Medium
status: New → Confirmed
Revision history for this message
Leann Ogasawara (leannogasawara) wrote :

The Hardy Heron Alpha2 release will be coming out soon (around Dec 20). It will have an updated version of the kernel. It would be great if you could test with this new release if this issue still exists. I'll be sure to update this report when Alpha2 is available. Thanks!

Changed in linux:
status: New → Incomplete
Revision history for this message
Leann Ogasawara (leannogasawara) wrote :

I'm opened a new task ('linux') against the actively developed kernel. However, this report will be closed against linux-source-2.6.20 as it does not meet the criteria for a stable release update. You can learn more about the stable release update process at https://wiki.ubuntu.com/StableReleaseUpdates . Thanks!

Changed in linux-source-2.6.20:
status: Confirmed → Won't Fix
Revision history for this message
Leon van der Ree (lvanderree) wrote :

I installed Hardy Alpha on my Toshiba M200 to test the pen-features

After installation gdm/X booted with a minimal Xorg.conf without problems, but without pen support.
I installed wacom-tools and used wacdump to test the output of /dev/ttyS0 this worked correct.
I noticed a missing symlink /dev/input/wacom, I re-created this and tested wacdump on this symlink which worked out OK as well.

I copied the wacom-pen lines from gutsy's xorg.conf to hardy's but pen did not work in X after restarting X (but I now think I have forgotten to include them in the "ServerLayout". I will try it again tomorrow).

After stand-by (which did not brought back my X/gnome display) I tried to run wacom-tools again in the console, but it could not find /dev/ttyS0 anymore...

Revision history for this message
Leann Ogasawara (leannogasawara) wrote :

Thanks for testing Leon. However, it appears you have a different set of hardware than the original bug reporter. Can you please open a new bug report? The development teams prefer bug reports to target a specific bug against a specific set of hardware. We can easily mark bugs as duplicates later if necessary.

For those who do have the appropriate hardware, Hardy Heron Alpha2 was recently released. It contains an updated version of the kernel. You can download and try the new Hardy Heron Alpha2 release from http://cdimage.ubuntu.com/releases/hardy/alpha-2/ . You should be able to then test the new kernel via the LiveCD. If you can, please verify if this bug still exists or not and report back your results. General information regarding the release can also be found here: http://www.ubuntu.com/testing/hardy/alpha2 . Thanks!

Revision history for this message
Leon van der Ree (lvanderree) wrote :

I added my findings for hardy and my M200 under bug 151902

Revision history for this message
Connor Imes (ckimes) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. You reported this bug a while ago and there hasn't been any activity in it recently. We were wondering is this still an issue for you? Can you try with latest Ubuntu release? Thanks in advance.

Revision history for this message
Leon van der Ree (lvanderree) wrote :

I've added the following repository:

deb http://ppa.launchpad.net/stefan-bader-canonical/ubuntu hardy main
deb-src http://ppa.launchpad.net/stefan-bader-canonical/ubuntu hardy main

which since a while have fixed this issue. (or at least I think this repository contains the fix for this problem)

It is mentioned in another thread regarding this same bug.

the kernel I am running is: 2.6.24-21-generic #1 SMP

for more information please ask

Revision history for this message
Connor Imes (ckimes) wrote :

<email address hidden>, if you are still having this problem, please provide the information requested at https://wiki.ubuntu.com/DebuggingACPI - otherwise please let us know if it works, then we can close this bug.

leon van der Ree, your problem is with different hardware, so your report should probably be elsewhere. After following the bugs you have posted and/or linked to, it seems your problem was fixed. However, you may also want to see bug 66646 for your M200. You said using those LP repositories works, so either stick with those or try a default installation of Ubuntu. If your system does not work with a default Hardy install, or with some simple config change, you may want to open a new bug since your others have been closed. If you open a new bug, it should preferably be with a fresh install since you are using unofficial repositories, and include the information requested in the above link, then make a comment here about the new bug, and I will be happy to work on the triage for you.

Revision history for this message
Justin Dugger (jldugger) wrote :

The Toshiba m200 and the x60t should have the same tablet hardware and use the same driver.

Stefan Bader is a kernel team member; the kernel in his PPA may be "unofficial," but he should know whether he's done anything to fix this or not!

Most importantly, it would be fantastic if people tested this on Intrepid.

Revision history for this message
Leann Ogasawara (leannogasawara) wrote :

The Ubuntu Kernel Team is planning to move to the 2.6.27 kernel for the upcoming Intrepid Ibex 8.10 release. As a result, the kernel team would appreciate it if you could please test this newer 2.6.27 Ubuntu kernel. There are one of two ways you should be able to test:

1) If you are comfortable installing packages on your own, the linux-image-2.6.27-* package is currently available for you to install and test.

--or--

2) The upcoming Alpha5 for Intrepid Ibex 8.10 will contain this newer 2.6.27 Ubuntu kernel. Alpha5 is set to be released Thursday Sept 4. Please watch http://www.ubuntu.com/testing for Alpha5 to be announced. You should then be able to test via a LiveCD.

Please let us know immediately if this newer 2.6.27 kernel resolves the bug reported here or if the issue remains. More importantly, please open a new bug report for each new bug/regression introduced by the 2.6.27 kernel and tag the bug report with 'linux-2.6.27'. Also, please specifically note if the issue does or does not appear in the 2.6.26 kernel. Thanks again, we really appreicate your help and feedback.

Revision history for this message
Matt May (mattmay) wrote :

I installed Intrepid beta 1, set up my Toshiba M200 tablet according to instructions, and it functions correctly before and after suspend.

Revision history for this message
Leann Ogasawara (leannogasawara) wrote :

Thanks for testing and the feedback Matt. cay, since you are the original bug reporter, care to confirm if this is resolved for you with Intrepid? Thanks.

Revision history for this message
Cay Horstmann (cay) wrote :

Yes, this works with Intrepid. Thanks for checking.

Changed in linux:
status: Incomplete → Fix Released
Connor Imes (ckimes)
Changed in wacom-tools:
status: Confirmed → Invalid
Revision history for this message
Kazupon (kazupon-up) wrote :

My intuos3 doesn't work after suspend.

Revision history for this message
Kazupon (kazupon-up) wrote :

I forgot to comment my OS.
My OS is intrepid.

Revision history for this message
Connor Imes (ckimes) wrote :

Kazupon, please open a new bug report for your problem. Thank you.

Curtis Hovey (sinzui)
Changed in linux-source-2.6.20 (Ubuntu):
assignee: Registry Administrators (registry) → nobody
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers