Serial Wacom tablet fails to return from ACPI suspend to RAM

Bug #152187 reported by Michael Heath on 2007-10-13
48
Affects Status Importance Assigned to Milestone
Linux
Fix Released
Medium
linux (Ubuntu)
Medium
Stefan Bader
Hardy
Medium
Stefan Bader
linux-source-2.6.22 (Ubuntu)
Medium
Unassigned
Hardy
Medium
Unassigned

Bug Description

Binary package hint: linux-source-2.6.22

On a Toshiba M200 Tablet PC, the integrated serial-line Wacom tablet interface locks up under the 2.6.22 kernel on Gutsy when returning from a suspend or hibernate.

I have verified that the serial settings the device file (ttyS0) are exactly as they were before reboot; the interface is mapped to the same location, same IRQ, and uart. The /sys filesystem reports in it's pnp information that the device is at the same location as it was before suspend. However, attempting to access the /dev/ttyS0 device causes the kernel to return a LSR Safety Check Engaged message.

Gerator (gerator) wrote :

Exactly the same problem here on a Toshiba Portege M400 tablet, running Gutsy i386 (generic kernel).

Benson Joeris (bjoeris) wrote :

I am also experiencing this bug on a Portege M200. I just upgraded from Feisty to Gutsy, and this bug was NOT present on Feisty.

Same bug, same symtoms on another Toshiba M200 tablet PC running Gutsy with the i386-generic kernel and all updates as of 11/28/07). This sounds similar to bug #108961 (reported on another tablet PC that uses an integrated serial Wacom tablet).

I also see this bug when using suspend to disk. Same symptoms (non-functioning stylus and "ttyS0: LSR safety check engaged!" messages in dmesg log).

This is a highly annoying bug in Gutsy, since it makes the suspend to ram or disk functions useless on a Tablet PC. I didn't have this problem in Dapper, and it may be worth reinstalling Dapper (for all its faults) just to get around the
problem.

Are there any workarounds?

Changed in linux-source-2.6.22:
status: New → Confirmed
Tom Jaeger (thjaeger) wrote :

I had the same problem on a Toshiba R25. I poked around a little bit and it turns out the problem was introduced in kernel 2.6.21-rc4 and filed a kernel bug report:
http://bugzilla.kernel.org/show_bug.cgi?id=9487

Until it's fixed, the workaround I hinted at in the report (commenting that single line) works at least for my system. I'm pretty sure that it's NOT doing the right thing, though - to be honest I don't even understand what the code does.

I've made the workaround available as a kernel package that you might want to try - we'll find out if launchpad supports 20M attachments. But be sure you have a working kernel in case something goes horribly wrong - the package will replace the existing gutsy kernel image.

Tom Jaeger (thjaeger) wrote :

Your kernel image work for me!

Thank a lot

Best regards

Vincenzo Ciancia (vincenzo-ml) wrote :

It works for me, too, thanks a lot. Marking an older bug as a dupe of this, since this contains more information.

Changed in linux-source-2.6.22:
assignee: nobody → ubuntu-kernel-team
importance: Undecided → Medium
status: Confirmed → Triaged

I can confirm that Tom Jaeger;s patched kernel fixes this issue on a Toshiba M200 for both suspend-to-ram and suspend-to-disk. (I see no LSR safety check messages in my logs and the stylus works).

I have another laptop with an integrated serial Wacom tablet - a Thinkpad X41. For what it;s worth, suspend to ram and disk has always worked fine under Gutsy on the X41. Only the Toshiba loses the stylus.

Changed in linux:
status: Unknown → Confirmed

Hi All,

The Hardy Heron kernel was recently uploaded for testing. We'd really appreciate it if you could try testing with this newer kernel and verify if this issue still exists. Unfortunately, the Hardy Heron Alpha1 LiveCD was released with the older 2.6.22 kernel. You'll have to manually install the newer Hardy Heron kernel in order to test. This should not be the case for Alpha2 which is set to come out around Dec 20. However, here are the instructions to install if you choose to do so, otherwise just wait for Alpha2 to come out:

1) edit the file /etc/apt/sources.list and add the following line:

deb http://archive.ubuntu.com/ubuntu hardy main restricted

2) sudo apt-get update
3) sudo apt-get install linux-image-2.6.24-1-generic
4) reboot and select the new kernel from the grub menu

After you've tested, please feel free to revert back - ie boot into the old kernel, sudo apt-get remove linux-image-2.6.24-1-generic, and remove the line from /etc/apt/sources.list . Please update this report with your results. Thanks in advance!

Changed in linux:
status: New → Incomplete
Tom Jaeger (thjaeger) wrote :

Unfortunately, the tablet pen refuses to work altogether under that particular kernel for no obvious reason: there are no error messages in dmesg and HAL claims the tablet is connected to /dev/ttyS0, yet there is no data sent to /dev/ttyS0 if the pen is moved (except for some garbage that's spewed out at regular intervals), which never happened to me with any stock kernel. I'll probably be able to investigate the issue further later this week. By the way, is there a canonical way to generate a .config that includes only those modules that are in use right now?

Tom Jaeger (thjaeger) wrote :

The issue still exists.

Turns out the new kernel doesn't create /dev/input/wacom anymore. If I create a link to /dev/ttyS0 the behavior is identical to 2.6.22-14: The pen works initially but the serial connection dies after Standby/Hibernate.

Tom, thanks for testing and the update. Can you please attach the following information:

* uname -a > uname-a.log
* cat /proc/version_signature > version.log
* dmesg > dmesg.log
* sudo lspci -vvnn > lspci-vvnn.log

Please be sure to attach each file as a separate attachment. Also, please capture the dmesg output after you come back from Suspend. For more information regarding the kernel team bug policy, please refer to https://wiki.ubuntu.com/KernelTeamBugPolicies . Thanks again and we appreciate your help and feedback.

Tom Jaeger (thjaeger) wrote :
Tom Jaeger (thjaeger) wrote :
Tom Jaeger (thjaeger) wrote :
Tom Jaeger (thjaeger) wrote :
Tom Jaeger (thjaeger) wrote :

From what I've gathered so far, the bug happens during pnp initialization, which is done at boot time and not before or after standby.

Vincenzo Ciancia (vincenzo-ml) wrote :

I can confirm that the pen does not work with new hardy kernel. Is there some other package missing? I suspect I should try to install hardy, will see if I can do that during christmas vacations.

Changed in linux:
assignee: nobody → ubuntu-kernel-team
importance: Undecided → Medium
status: Incomplete → Triaged
Tom Jaeger (thjaeger) wrote :

Vincenzo, that is just a matter of creating the appropriate symlink:

sudo ln -s /dev/ttyS0 /dev/input/wacom

Then restart the X server and now the pen should work - well, until you put the computer in standby.

Tom Jaeger (thjaeger) wrote :

I think I've gotten to a point where a kernel developer could really help. The problem is, I don't think anybody is reading my kernel bug report and this being the first time I'm doing something like this, I'm not sure what the proper etiquette to make myself heard would be. Do you think it's appropriate to just assign the bug to someone (Shaohua Li would be the obvious choice, I think)? Or should I CC a mailing list (acpi-bugzilla?)? Thanks, Tom.

Tom,

I don't want to get sidetracked from the bug at hand, but...
In reference to the need to create the /dev/input/wacom symlink...Does your hardy system have a /etc/init.d/xserver-xorg-input-wacom ? This is the init script that automatically sets up this symlink on Gutsy. If you're missing it, do yuo have the package xserver-xorg-input-wacom installed?

In reference to your kernel bug reporting protocol....you can't assign the bug or change its status unless your a moderator on the kernel bug system. I'm not sure what the best thing to do would be. I'll add a comment, see if we can generate some more attention. Maybe send an e-mail to the kernel mailing list?

Tom Jaeger (thjaeger) wrote :

Michael,

Thanks, the init script was the right pointer. I turns out that the sysfs interface changed slightly in 2.6.24, which broke the script. I filed a new bug report against wacom-tools: https://bugs.launchpad.net/ubuntu/+source/wacom-tools/+bug/177878. It's a trivial fix, but it's kind of a moot point until this issue is taken care of: https://bugs.launchpad.net/ubuntu/+source/wacom-tools/+bug/175050.

As for the kernel bug, I think I'll just wait a few days, and if there's no response, I'll post to LKML.

schmolch (saschaheid) wrote :

Sorry to interrupt but does this mean that linuxwacom is supposed to work with xorg-7.3?

From watching the linuxwacom mailing list traffic and trying myself on my x60t i was under the impression its not ready yet.

Tom Jaeger (thjaeger) wrote :

Good news, I've identified the problem (for details, see http://article.gmane.org/gmane.linux.acpi.devel/26955 ) and submitted a patch to the linux acpi developers that appears to have a good chance of getting accepted. Updated ubuntu kernel packages are provided in this thread (thanks to Matthew Thomas for uploading them, this was more than my paltry internet connection could handle).

I encourage everyone to test them: the 2.6.22 package is for gutsy, the 2.6.24 package for hardy (caveat: wacom support is currently broken in hardy if you update to xorg-7.3).

Tom Jaeger (thjaeger) wrote :

[off topic]
Schmolch, updated wacom-tools packages were uploaded today. All I had to do was enable XAA in xorg.conf to work around performance problems while scrolling (GMA 950) and now everything works perfectly.

Changed in linux:
status: Confirmed → Fix Released
Changed in linux:
assignee: ubuntu-kernel-team → stefan-bader-canonical
status: Triaged → In Progress
Vincenzo Ciancia (vincenzo-ml) wrote :

I have now the problem, on 2.6.24-4 in hardy, that the tablet does not work after suspend to disk (hibernate). Is anyone here experiencing this problem? I see in this report we where only talking about suspend-to-ram but maybe it is the same bug.

Stefan Bader (smb) wrote :

The fix mentioned in https://launchpad.net/ubuntu/+source/linux/+bug/152187/comments/26 unfortunately hasn't made it upstream in its current form. There still seem to be some objections from upstream. Currently there is no way but to wait for the outcome of that bugzilla report.

Changed in linux:
assignee: stefan-bader-canonical → canonical-qa
status: In Progress → Triaged
Vincenzo Ciancia (vincenzo-ml) wrote :

Stefan: I am not sure to be understanding. At the url

http://bugzilla.kernel.org/show_bug.cgi?id=9487

the bug is marked as "RESOLVED" so why shouldn't the patch be included in ubuntu's kernel? Where are the objections you are referring to?

Vincenzo:

That is not the way the Kernel's bugzilla is maintained/moderated. It being marked as resolved there does not mean the patch has hit upstream, and indeed it has not. As such, this patch is not included in the Ubuntu kernel builds.

Stefan Bader (smb) wrote :

Just a small update. The kernel bug that is referenced was reopened today. For the time being rather the ACPI side is addressed, but there is still movement.

Changed in linux:
status: Fix Released → In Progress
Tom Jaeger (thjaeger) wrote :

Stefan: Are you still planning on backporting the solution to a gusty kernel? Because if you are, you might as well apply the current patch. It's probably the least intrusive patch we are ever going to get. It is in acpi-test and has both the approval of both the linux acpi maintainer and the acpi goto-guy. So what if the acpica maintainer thinks it uses variable names that may be confusing at some point in the future? That's none of our concern if we're just backporting.

A backport to Gutsy will probably not be done. According to the SRU policy, the fix should already be deployed and tested in the current development version before an update to the stable releases will be considered. For more information regarding stable release updates, please see: https://wiki.ubuntu.com/StableReleaseUpdates . Also please note this bug report is not being closed against the actively developed kernel and work will continue on trying to fix it for the next release. If the state of this bug should change such that it qualifies for the SRU process it will be re-evaluated. Thanks.

Changed in linux-source-2.6.22:
status: Triaged → Won't Fix
Changed in linux:
assignee: canonical-qa → leannogasawara
Tom Jaeger (thjaeger) wrote :

Let me explain why this is taking upstream so long to fix, as far as I understand it. It's not because they're not happy with the available patches or because they are "half-baked", it's because the bug occurs in code that is shared between different operating systems. In order for a fix to be applied upstream, there are a few things that need to happen. First of all, this needs to be fixed in ACPICA, the generic ACPI implementation that linux shares with most other OSes. Here we're almost there, ACPICA version 20080213 basically includes the necessary changes, but there is a typo in there that will definitely break things. Robert Moore is aware of this and I'm sure it will be corrected in their next version. The other thing that needs to happen is for the ACPICA changes to be integrated into linux. This involves source-to-source translation using a utility called acpisrc and making the necessary adjustments in the affected parts of the linux kernel and is generally only done at the beginning of a linux release cycle, hence already after ubuntu's kernel freeze (Yes, what I'm saying is that this issue won't be fixed upstream until 2.6.26). Waiting for this patch is not a good idea anyway, because it will be one big patch including all the acpica changes since the last merge 2007-10-10 (presumably, that's acpica 20070919).

But at least everybody agrees on what needs to be done and how this should be accomplished, so the final fix will probably be very similar to the patches we have now.

Tom Jaeger (thjaeger) wrote :

ACPICA version 20080321 is out with the remaining issues fixed. Please let me know if you want me to create a kernel patch based the changes in the resource code between 20080123 and 20080321.

Tom Jaeger (thjaeger) wrote :

Linuxified acpcia changes. This was created via acpisrc and lindent from the ACPICA unix source distributions version 20080123 and 20080321. Applies in drivers/acpi/resources.

Tom Jaeger (thjaeger) wrote :

Required linux-side changes. Basically just a few field declarations that are necessary to get linux to build after the previous patch is applied. The 4 additional lines in rsparser.c ensure that the additional information that _CRS gathers is passed to _SRS. This patch is created by me, but everything's completely straightforward

Tom Jaeger (thjaeger) wrote :

dmesg output from an ubuntu kernel build using the two patches above.

Tom Jaeger (thjaeger) wrote :

An updated linux-image-2.6.24 deb.

Changed in linux:
status: In Progress → Fix Released

Hi Tom,

Thank you for all of you efforts both here and working with upstream. It's definitely appreciated. We're almost at the kernel freeze for Hardy and typically only critical bug fixes or extremely simple patches are being pulled in. I'll reassign to the kernel team to evaluate but this may have to wait for the next Intrepid Ibex release. Thanks.

Changed in linux:
assignee: leannogasawara → ubuntu-kernel-team
Vincenzo Ciancia (vincenzo-ml) wrote :

Leann: could this be a stable release update some time after LTS release, instead of just next release? It's a regression after all and hardy should be "long term support".

Changed in linux:
milestone: none → ubuntu-8.04.1
Vince (v-brz) wrote :

And, by the way:

$ sudo dmidecode -s system-manufacturer
TOSHIBA
$ sudo dmidecode -s system-product-name
PORTEGE M200
$ sudo dmidecode -s system-version
PPM21E-0260Z-GR

Hi Vincenzo,

I just spoke with the kernel team. While it is too late in the development cycle to get this into Hardy 8.04 we'll target this for the Hardy 8.04.1 point release as well as for Intrepid 8.10. Hope that helps. Thanks.

Vincenzo Ciancia (vincenzo-ml) wrote :

That's very good news. Thanks to you, and to Tom who is practically fixing my whole ubuntu tablet.

Stefan Bader (smb) on 2008-04-25
Changed in linux:
assignee: ubuntu-kernel-team → stefan-bader-canonical
status: Triaged → In Progress
Stefan Bader (smb) on 2008-04-28
Changed in linux:
status: In Progress → Fix Committed
Tim Gardner (timg-tpi) wrote :

Back to 'In Progress' pending regression testing. http://kernel.ubuntu.com/git?p=ubuntu/ubuntu-hardy.git;a=commit;h=f051c70c1aec562bb48cee4784da7c81816aab18 reverts these ACPI changes until then.

Changed in linux:
status: Fix Committed → In Progress
marian99us (marian99us) wrote :

@tom jäger & everyone else

hi,
could you please help me out with my toshiba R25, day before yesterday i installed ubuntu from the ubuntu website (i mean it is the latest version), i have no idea what kernel and stuff like that means, i have no previous knowledge of Linux what so ever! all i need is to be able to use my tablet once again, because my touch pad really sucks! i can hardly use it. it just tooooo slow, it sporadically take input when i just want to scroll, or just won't take the single click when i really mean it.

just for the record: my stylus just won't trigger nothing! it just no matter how hard i hit the screen with it! :( the pointer just doesn't bother to move!

Leon van der Ree (lvanderree) wrote :

@marian99us

You probably want to take a look at the wiki or forums to find an answer for your question, and not in launchpad.

Good forum-post: http://ubuntuforums.org/showthread.php?t=25151

and a wiki-entry: https://help.ubuntu.com/community/WacomTabletIssue

Goodluck

Vincenzo Ciancia (vincenzo-ml) wrote :

I can be more precise - sorry for commenting on wrong bug report but this will be visible to everybody who will find the question trough web search - Marian99us: bug you are facing is probably

https://bugs.edge.launchpad.net/ubuntu/+source/wacom-tools/+bug/188787

If you have a file named

/dev/input/wacom

then you probably just need to configure Xorg for the tablet. I prepared a "fixed" package that does this automatically for tablet pcs (if /dev/input/wacom exists, that is, if the driver is working: if that file does not exist, then the problem is elsewhere and NOT fixed by my package!)

Add the sources.list entries of the ubuntu-quickfix archive (if you trust the repository, which currently is very young but should not harm) or just click on the xorg debs in that page (but that's more complicated if you don't know linux at all.

https://edge.launchpad.net/~ubuntu-quickfix/+archive

You can use synaptic for everything, learning how to add apt-sources is easy but out-of-scope for this bug report - you will find tons of guides on the web.

marian99us (marian99us) wrote :

@Vincenzo Ciancia
thank you so much for your help,
i do have the file /dev/input/wacom
but i still don't know where to begin?
i feel so dumb asking for step by step instructions, but i am sure i can learn fast!

Stefan Bader (smb) wrote :

I put up a some kernel packages (with a linux-image that contains the ACPI fixes) to my PPA at
https://launchpad.net/~stefan-bader-canonical/+archive.

Please try this kernel and report any success/regressions. Thanks.

Leon van der Ree (lvanderree) wrote :

Great,

I just installed it,
manually installed my nvidia driver
and the pen is working again (also after suspending) but you already had some idea of that of course ;-)

Any things I have to look out for (with regards to regression)

Stefan Bader (smb) wrote :

Since this changes ACPI code, there might (but do not have to) be devices that show errors or do have problems with suspend/resume. Anything odd that suddenly arises with the new kernel.

Tom Jaeger (thjaeger) wrote :

The biggest chunk of the fix has been committed upstream, but as I see it there is one important piece missing, so that the pen still won't wake up. Unfortunately my tablet is broken, so I've been unable to do the testing necessary to convince upstream that the patch is in fact needed.

If someone could confirm that
(a) the issue is still present on the latest git tree and
(b) the following patch fixes it: http://bugzilla.kernel.org/attachment.cgi?id=15978
that would be greatly appreciated.

(if you don't know what any of this means, please ignore this message)

Thanks,
Tom

Steve Langasek (vorlon) on 2008-06-05
Changed in linux:
milestone: ubuntu-8.04.1 → none
Leon van der Ree (lvanderree) wrote :

I used the patched kernel from https://launchpad.net/~stefan-bader-canonical/+archive ever since and it worked perfectly. Never noticed any problems, use my tablet almost everyday and I never turn it off (always in standby)

I was wondering why the 8.04.1 target is removed.

Vince (v-brz) wrote :

Does that mean the bug will not be fixed for ubuntu 8.04.1 ?

Tom Jaeger (thjaeger) wrote :

Small update on the mainline front: Bjorn Helgaas rediscovered the issue and came to the same conclusions as I did. The patch I commented on in comment #54 is indeed needed, and a slightly modified version has been accepted to -mm [1], let's hope it'll get into 2.6.26.

Having spent a considerable amount of time trying to get this issue fixed, I'd also appreciate an explanation as to why this has been rejected for 8.04.1.

[1] http://userweb.kernel.org/~akpm/mmotm/broken-out/pnpacpi-use-_crs-irq-descriptor-length-for-_srs-v2.patch

Tormod Volden (tormodvolden) wrote :

If you look closer at the bug status, the "linux (Ubuntu) -> Hardy" task is still milestoned for 8.04.1.

Stefan Bader (smb) wrote :

Still struggling to get this through. Could someone verify whether the issue exists with the latest (-19) Ubuntu kernel (compared to the PPA one)?

Still not working with 2.6.24-17 kernel on amd64 (porterge m400).

If you can tell me where to find the -19 kernel I will give it a try (sorry for this newbie q)

Stefan Bader (smb) wrote :

You have to enable hardy-proposed in the software sources (System->Administration). BTW, I updated my PPA with the patch version that hit upstream (plus the missing part). If this one still works and the one currently in -proposed doesn't I hope to finally get the argument through.

Ok, have been testing it (I actually had proposed enabled, but had hardwired the kernel in menu.lst, so was using 17 anyway)

Using proposed -19, still same behavior: after resume from hibernate or suspend there is no wacom stylus.

Same message about the ttyS0 (this is after suspend):
[ 4.231263] ttyS0: LSR safety check engaged!

Toshiba Portege M400, PPM40E-1SM010SP
Ubuntu 8.04 up to date, with proposed enabled, amd64
kernel: 2.6.24-19-generic #1 SMP

Best,

Stefan Bader (smb) wrote :

@Juan,

thanks a lot. If I might stress you more, could you also try the new PPA?

Where do I get the PPA version?

Stefan Bader (smb) wrote :

See https://bugs.launchpad.net/ubuntu/+source/linux-source-2.6.22/+bug/152187/comments/51

The page also describes how to add this as installation source.

Ken Arnold (kenneth-arnold) wrote :

I can confirm that Stefan's build fixes the problem on a Toshiba M200 tablet.

(A bit difficult to test since I normally use it in X, with the nvidia driver, which isn't built for this; I switched back to the nv driver, but had to stop the X server before suspend because it doesn't resume properly. Is that a known bug?)
-Ken

Leon van der Ree (lvanderree) wrote :

I compiled the nvidia driver myself to fix that issue.

Confirmed Stefan's build -20 works properly on Toshiba M400 (amd64), both suspend/hibernate.

Thanks!

Stefan Bader (smb) wrote :

Return of the patch as commit 9501391cf0c7b8dd6eb9a75876a900d9052f8f39 in ubuntu-hardy. This time consisting of the cherry-pick 1d5b285da1893b90507b081664ac27f1a8a3dc5b from upstream plus the missing patch from -mm.

Changed in linux:
milestone: ubuntu-8.04.1 → ubuntu-8.04.2
status: In Progress → Fix Committed
Stefan Bader (smb) wrote :

As for Intrepid, the ACPICA patch is already merged (between 2.6.25 and 2.6.25-rc1 upstream). Currently the rsparser update is missing but will be there as soon as that goes upstream.

Steve Langasek (vorlon) wrote :

rolling back to 'in progress' for hardy due to the (regrettably) special meaning assigned to the 'fix committed' state for SRUs.

Stefan, is this bug fixed in the 2.6.26 kernel that was just uploaded to intrepid?

Changed in linux:
status: Fix Committed → In Progress
Tim Gardner (timg-tpi) wrote :

Steve - Its not in Intrepid yet. It will be when Ben rebases against -rc5 (real soon now).

Tim Gardner (timg-tpi) on 2008-06-19
Changed in linux:
status: In Progress → Fix Committed
Stefan Bader (smb) on 2008-07-14
Changed in linux:
status: In Progress → Fix Committed
Steve Langasek (vorlon) on 2008-07-17
Changed in linux-source-2.6.22:
status: Won't Fix → Invalid
Steve Langasek (vorlon) wrote :

my understanding is that this is fixed now in intrepid.

Changed in linux:
status: Fix Committed → Fix Released
Steve Langasek (vorlon) wrote :

Accepted into -proposed, please test and give feedback here. Please see https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

nkri (nkri) wrote :

I can also confirm that the kernel patches on Stefan Bader's PPA (https://launchpad.net/~stefan-bader-canonical/+archive) work beautifully. I am running Hardy on a Toshiba Portege M400, and with this patch, all my hardware is still detected, etc. The stylus now works when resuming from suspend (haven't tried it with hibernate, since I've disabled that on my machine) and everything functions just as it should. Thanks Stefan!

Vincenzo Ciancia (vincenzo-ml) wrote :

My toshiba tablet pc is finally back from assistance (it took more than 2 months). I am now running intrepid alpha 6 and the tablet works after suspend to ram. Thanks to everybody who worked on this.

nkri (nkri) wrote :

Vincenzo-

Would you mind posting the xorg.conf you're using for Intrepid? I'm trying out the beta LiveCD right now and can get the tablet working with my Hardy configuration (attached), but then scrolling and middle-click on the touchpad don't work.

Thanks!
-nkri

Vincenzo Ciancia (vincenzo-ml) wrote :

Yes, old configuration files don't work with intrepid. The attached one works, but I am unsure if it will work for intrepid (see recent messages on the ubuntu-devel-discuss mailing list)

nkri (nkri) wrote :

Thanks, it worked wonders! Ok, so I can now also confirm that this bug is fixed in Intrepid:)

Martin Pitt (pitti) wrote :

linux 2.6.24-21 copied to hardy-updates.

Changed in linux:
status: Fix Committed → Fix Released

Per a decision made by the Ubuntu Kernel Team, bugs will longer be assigned to the ubuntu-kernel-team in Launchpad as part of the bug triage process. The ubuntu-kernel-team is being unassigned from this bug report. Refer to https://wiki.ubuntu.com/KernelTeamBugPolicies for more information. Thanks.

mcDavid (david-ursem) wrote :

I've got exactly the same problem, running Ubuntu 9.04B, kernel 2.6.28-11, using a Bamboo fun medium tablet.

Changed in linux:
importance: Unknown → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.