Does not exit correctly, have to "kill -9 <PID>

Bug #1819543 reported by elhoir
236
This bug affects 41 people
Affects Status Importance Assigned to Milestone
VLC media player
Fix Committed
Undecided
Rémi Denis-Courmont
vlc (Debian)
Fix Released
Unknown
vlc (Ubuntu)
Fix Released
Undecided
Unassigned

Bug Description

Does not exit correctly, have to "kill -9 <PID>

ProblemType: Bug
DistroRelease: Ubuntu 19.04
Package: vlc 3.0.6-1
ProcVersionSignature: Ubuntu 4.19.0-13.14-lowlatency 4.19.20
Uname: Linux 4.19.0-13-lowlatency x86_64
ApportVersion: 2.20.10-0ubuntu23
Architecture: amd64
CurrentDesktop: XFCE
Date: Mon Mar 11 22:10:39 2019
InstallationDate: Installed on 2014-03-28 (1809 days ago)
InstallationMedia: Ubuntu 14.04 LTS "Trusty Tahr" - Alpha amd64 (20140323)
SourcePackage: vlc
UpgradeStatus: Upgraded to disco on 2019-02-12 (27 days ago)

Revision history for this message
elhoir (jfarroyo82) wrote :
summary: - Does not exit correctluy, have to "kill -9 <PID>
+ Does not exit correctly, have to "kill -9 <PID>
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in vlc (Ubuntu):
status: New → Confirmed
Revision history for this message
Philipp (philippun) wrote :

This also happens on Ubuntu 19.10 with vlc 3.0.8-2.
Strangely it does close properly if you press Ctrl + Q or do it via "Media -> Quit".

Revision history for this message
Nikola M (nikolam) wrote :

Same thing still happens in VLC 3.0.8-0-gf350b6b5a7 on Xubuntu 19.10 as of 20200302 .
After playing, for example "Cloud Atlas", (Mp4 video) VLC does not exit normally.
(4ea7d873a5a5494ffcf09ccb939a8943e0c5bdcc magnet hash)

Revision history for this message
Jani Uusitalo (uusijani) wrote :

Still present in 20.04 (Focal) with vlc 3.0.9.2-1, though here at least it seems to only affect some URLs, not all. When I view a stream from my local webcam, vlc -vvv in the terminal shows

    main playlist debug: incoming request - stopping current input

as the final message, and does not exit (after closing the window; Ctrl-Q still works). But when streaming from Wowza's RTSP test stream [1], vlc exits just fine after closing the window.

Debian bug 916595 [2] and related VLC ticket [3] mention disabling hardware acceleration as a workaround, but even so I was unable to make it work (i.e. exit properly).

Possibly related: Ubuntu bug #1847162. There's also been discussion about the issue over on Manjaro forums [4].

* [1] rtsp://wowzaec2demo.streamlock.net/vod/mp4:BigBuckBunny_115k.mov
* [2] https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=916595
* [3] https://trac.videolan.org/vlc/ticket/20627
* [4] https://forum.manjaro.org/t/vlc-not-closing/69965/2

Changed in vlc (Debian):
status: Unknown → New
Revision history for this message
Mattia (io-mattia98) wrote :

Happens to me with all media files. After closing VLC I can't double click another file until I kill VLC. The applet also does nothing.
This does seem to depend on which type of video output I use. Automatic often seems to cause this. VDPAU sometimes seem to cause, and OpenGL also sometimes. It seems to vary with the codec. X11 video output seems to never cause this, but consumes a lot of CPU. XVideo seems to be fine too, less CPU consumption.
Ubuntu MATE 20.04.1

Revision history for this message
Loic Dachary (dachary) wrote :

I'm able to reproduce this bug on Ubuntu 20.04 with an AMD processor.

Revision history for this message
antonioni (antonioni-rocha) wrote :

I thought it was a KDE bug (I use KDE Neon), and this bug is present in VLC in KDE, too.

A important link:
https://trac.videolan.org/vlc/ticket/21875

Revision history for this message
Freedom Bacon (freedombacon) wrote :

I didn't have this problem until upgrading 20.04, though I also upgraded the video card from HD5000 to R7 when I did. Try setting "Hardware-accelerated decoding" to something other than Automatic or VDPAU.

https://bugs.launchpad.net/ubuntu/+source/vlc/+bug/1871949/comments/8

Revision history for this message
MAR (mattmax42) wrote :

My machine is also suffering with the same issue.

VLC 3.0.9.2-1
Linux Mint 20

VLC will not exit, have to kill it manually before I can launch another instance.

Revision history for this message
TJ (tj) wrote :

So far when this affects me (20.04) it is when I've opened the media from a file manager or started VLC via the menu.In both cases it uses "vlc --start-from-file ..." - if I start vlc on the command-line without that option it seems to quit/terminate correctly and not hang about.

Revision history for this message
Ricardo Gabriel da Silva Brunne Valle (gabrielbrunne) wrote :

Affects me on Kubuntu 20.04 in multiple machines. If I close the app via the "X" button AND it is playing some media file it gets stuck and I need to give a "killall -9 vlc" command. It closes just fine if I stop the media before closing with the "X" button. If I quit the app with CTRL+Q or with the close command in the "media" menu it exits just fine even if media is playing. Starting the app via command line, panel or by clicking on a file seems to have no effect on this behavior.

Revision history for this message
ElTouco72 (eltouco72) wrote :

It affects me since I migrated to Ubuntu 20.04 LTS
VLC 3.0.11

Revision history for this message
Jerry Quinn (jlquinn) wrote :

It affects me in 20.04 LTS. I didn't have it in 18.04 LTS.

Revision history for this message
Rémi Denis-Courmont (rdenis) wrote :

VLC Trac #21875 is fixed.

Changed in vlc:
importance: Unknown → Undecided
status: Unknown → New
assignee: nobody → Rémi Denis-Courmont (rdenis)
status: New → Fix Committed
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package vlc - 3.0.12-3

---------------
vlc (3.0.12-3) unstable; urgency=medium

  * debian/patches: Apply upstream patches to prevent process freeze on exit
    (Closes: #916595) (LP: #1819543)

 -- Sebastian Ramacher <email address hidden> Tue, 09 Mar 2021 17:42:00 +0100

Changed in vlc (Ubuntu):
status: Confirmed → Fix Released
Revision history for this message
Jeffrey Walton (noloader) wrote :

Thank you very much everyone.

I have several senior citizens on Linux Mint and they really needed VLC to exit correctly. They don't do the command line so they can't fix it themselves.

Changed in vlc (Debian):
status: New → Fix Released
Revision history for this message
Rael Gugelmin Cunha (rael-gc) wrote :

I can see this fix was released for `unstable`. Any chance we get it on 20.04?

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.