Virtualbox 4.1 (vboxdrv) Blocks Machine Suspend

Bug #814323 reported by Daniel Lombraña González on 2011-07-21
94
This bug affects 15 people
Affects Status Importance Assigned to Milestone
virtualbox (Ubuntu)
Medium
Unassigned

Bug Description

With the kernel version 2.6.32-32 the laptop suspends and resumes without problems. With the last update to 2.6.32-33 the laptop does not suspend. It is even worst, because the laptop screen goes black and then a few seconds later the fan starts blowing and does not stop until you power off the computer by pressing the power button several seconds.

The previous version works perfectly well, so the update introduced a bug.

ProblemType: Bug
DistroRelease: Ubuntu 10.04
Package: linux-image-2.6.32-33-generic 2.6.32-33.70
Regression: Yes
Reproducible: Yes
ProcVersionSignature: Ubuntu 2.6.32-33.70-generic 2.6.32.41+drm33.18
Uname: Linux 2.6.32-33-generic i686
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.21.
Architecture: i386
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: Intel [HDA Intel], device 0: ALC262 Analog [ALC262 Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: teleyinex 2001 F.... pulseaudio
 /dev/snd/pcmC0D0p: teleyinex 2001 F...m pulseaudio
CRDA: Error: [Errno 2] No existe el fichero o el directorio
Card0.Amixer.info:
 Card hw:0 'Intel'/'HDA Intel at 0xdaa20000 irq 21'
   Mixer name : 'Realtek ALC262'
   Components : 'HDA:10ec0262,104d2f00,00100302 HDA:14f12c06,104d1700,00100000'
   Controls : 17
   Simple ctrls : 9
Date: Fri Jul 22 00:09:28 2011
HibernationDevice: RESUME=UUID=13c1b7bc-0c13-42ef-9acc-7cfb3b2707bb
InstallationMedia: Ubuntu 10.04 LTS "Lucid Lynx" - Release i386 (20100429)
MachineType: Sony Corporation VGN-Z11MN_B
PccardctlIdent:
 Socket 0:
   no product info available
PccardctlStatus:
 Socket 0:
   no card
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.32-33-generic root=UUID=6318bb8c-fcb5-4f5a-8d39-0ccb1ed4e9fd ro acpi_osi="!Windows 2006" quiet splash
ProcEnviron:
 LANGUAGE=es_ES:en
 PATH=(custom, user)
 LANG=es_ES.UTF-8
 SHELL=/bin/bash
RelatedPackageVersions: linux-firmware 1.34.7
SourcePackage: linux
dmi.bios.date: 07/17/2009
dmi.bios.vendor: INSYDE
dmi.bios.version: R2169M3
dmi.board.asset.tag: N/A
dmi.board.name: VAIO
dmi.board.vendor: Sony Corporation
dmi.board.version: N/A
dmi.chassis.asset.tag: N/A
dmi.chassis.type: 10
dmi.chassis.vendor: Sony Corporation
dmi.chassis.version: N/A
dmi.modalias: dmi:bvnINSYDE:bvrR2169M3:bd07/17/2009:svnSonyCorporation:pnVGN-Z11MN_B:pvrJ003CY1V:rvnSonyCorporation:rnVAIO:rvrN/A:cvnSonyCorporation:ct10:cvrN/A:
dmi.product.name: VGN-Z11MN_B
dmi.product.version: J003CY1V
dmi.sys.vendor: Sony Corporation

Related branches

Brad Figg (brad-figg) on 2011-07-21
Changed in linux (Ubuntu):
status: New → Confirmed
description: updated
Umang Varma (umang) wrote :

I can confirm that I am affect by exactly the same issue.

The hard disk seems to switch off properly, because I can hear the click sound and when I force the laptop to power off, I don't hear the scratching sound that I do when (on the rare occasions) I have to force my computer to shutdown while its running.

The screen first turns black then goes off. However, the fan keeps blowing and there seems to be no way to get the laptop to resume. Using the previous kernel (2.6.32-32-generic) fixes this issue for me. Clearly this is some sort of regression.

icyfeet (icyfeet) wrote :

I confirm it too.
Same behaviour on my machine.

Umang Varma (umang) wrote :

I am now affected by this problem on 2.6.32-32-generic also. I think I have some idea as to what might be causing this:

I had installed VirtualBox when I was using 32-33. I imagine that it did something to the kernel to be able to do the functions of a Host OS on my laptop. Now, after I switched back to the 32-32, VirtualBox told me today that there were errors and I should fixed them by running:

     sudo /etc/init.d/vboxdrv setup

Now, I have the same issue I did with 32-33 with the 32-32 kernel also. So I believe that this might be the problem.

$ apt-cache policy virtualbox-4.1
virtualbox-4.1:
  Installed: 4.1.0-73009~Ubuntu~lucid
  Candidate: 4.1.0-73009~Ubuntu~lucid
  Version table:
 *** 4.1.0-73009~Ubuntu~lucid 0
        500 http://download.virtualbox.org/virtualbox/debian/ lucid/contrib Packages

icyfeet (icyfeet) wrote :

I can confirm it is connected with virtualbox.

Here is a bugreport with a workaround that worked for me:

http://www.virtualbox.org/ticket/9260

icyfeet (icyfeet) wrote :

Addition:

I do not know what will happen to the virtual machine when unloading the modules while the machine is running!!

Joe Burgess (joemburgess) wrote :

Daniel and Umang,

Do you two also have virtualbox installed? I'm trying to figure out if icyfeet's issue is the same issue as yours.

thanks

Dear Joe,

Yes I also have VirtualBox 4.1 and it seems like this software is the problem. I will unload the modules and test if the problem is related to VirtualBox too.

Regards,

Daniel

Andreas Hasenack (ahasenack) wrote :

I also had this problem, but with vmware-player installed (VMware-Player-3.1.4-385536.i386.bundle). I removed it and now suspend works again.

Andreas Hasenack (ahasenack) wrote :

Something that might be related or not, but that I found out also because of vmware, is that "modprobe -r parport_pc" or "rmmod parport_pc" hang here in D state. The vmware initscript did that, that's how I found out.

FWIW I'm on a thinkpad T61.

Andreas Hasenack (ahasenack) wrote :

Oh, and I'm on lucid 2.6.32-33-generic-pae #70 i686.

Andreas Hasenack (ahasenack) wrote :

After removing vmware player, rmmod parport_pc started working again for me, so for now I'm blaming vmware.

Hi again,

I have removed the following modules: vboxpci, vboxnetadp, vboxnetflt and vboxdrv and then click Suspend. This time suspend and resume worked perfectly well, so I guess that the problem is related to this modules.

Should we contact Oracle and warn them about this issue?

Regards,

Daniel

Joe Burgess (joemburgess) wrote :

Daniel,

Please be sure to confirm this issue exists with the latest development release of Ubuntu. ISO CD images are available from http://cdimage.ubuntu.com/daily/current/ . However, note you can only test Suspend, not Hibernate, when using a LiveCD. If the issue remains, run the following command from a Terminal (Applications->Accessories->Terminal) it will automatically gather and attach updated debug information to this report.

apport-collect -p linux 814323

Also, please be sure to take a look at https://wiki.ubuntu.com/DebuggingKernelSuspendHibernateResume . If you can provide any additional information outlined there it would be much appreciated.

Additionally, if you could try to reproduce this with the upstream mainline kernel that would be great. It will allow additional upstream developers to examine the issue. Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Once you've tested the upstream kernel, please remove the 'needs-upstream-testing' tag. This can be done by clicking on the yellow pencil icon next to the tag located at the bottom of the bug description and deleting the 'needs-upstream-testing' text. Thanks in advance.

Joe Burgess (joemburgess) wrote :

Andreas,

you are using vmware player correct? Daniel and icyfeet are using virtualbox, so while your problem seems related, I don't think it's the same problem. Could you open a separate bug for the vmware player related issue?

Sadly, I can't find any open bug tracker for vmware player so I couldn't report anything there but I told the virtualbox bug report about this bug report.

Thanks.

summary: - The laptop does not suspend anymore
+ Virtualbox 4.1 (vboxdrv) Blocks Machine Suspend

Same problem here on my Thinkpad Edge 13. The workaround in the Virtualbox' bug ticket[1] worked for me.

[1]: http://www.virtualbox.org/ticket/9260

Andreas Hasenack (ahasenack) wrote :

Joe, I opened bug #816963 for the same issue but with vmware-player.

Joe Burgess (joemburgess) wrote :

Thanks Andreas.

Everony else that has this bug though. This has been forwarded to upstream you can track it and make comments at: http://www.virtualbox.org/ticket/9260

Andy Whitcroft (apw) on 2011-07-27
Changed in linux (Ubuntu):
importance: Undecided → Medium
status: Confirmed → Triaged
akhalfan (akhalfan) wrote :

workaround: before suspending, unload the vboxdrv module and suspend will work

Yes, the easiest way to solve the problem for now is to run:

sudo /etc/init.d/vboxdrv stop

Before you suspend. Another option is what people have described in the messages about black-listing VBox modules when suspending the machine.

Eugene San (eugenesan) on 2011-07-30
affects: linux (Ubuntu) → virtualbox (Ubuntu)
Changed in virtualbox (Ubuntu):
status: Triaged → Fix Committed
Eugene San (eugenesan) wrote :

Solution provided in upstream.

Attaching fixing patch:

sudo -i
service vboxdrv stop
wget -O /tmp/vboxhost-fix-panic.patch http:/launchpad.net/..../vboxhost-fix-panic.patch
cd /usr/share/virtualbox/src/vboxhost
patch -p1 < /tmp/vboxhost-fix-panic.patch
dkms remove -m vboxhost -v 4.1.0 --all
dkms add -m vboxhost -v 4.1.0
dkms build -m vboxhost -v 4.1.0
dkms install -m vboxhost -v 4.1.0
service vboxdrv start

tags: added: patch

Hi everyone,

I have successfully tested the patch!! Thanks a lot Eugene!!! It works like a charm!! If you need something else to check, let me know.

Regards,

Daniel

lotharmat (matdcooke) wrote :

That patch works a treat! - Many thanks!

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package virtualbox - 4.1.0-dfsg-2ubuntu1

---------------
virtualbox (4.1.0-dfsg-2ubuntu1) oneiric; urgency=low

  * Merge from Debian unstable, remaining changes:
    - Add Apport hook.
      - debian/virtualbox.files/source_virtualbox.py
      - debian/virtualbox.install
    - Drop *-source packages.
    - Add vboxguest modalias the to the package control field.

virtualbox (4.1.0-dfsg-2) unstable; urgency=low

  * Install vboxpci module in virtualbox-modules packages, thanks to
    YOSHINO Yoshihito. (Closes: #637177)
  * Add 36-fix-kernel-panic-suspend.patch from upstream SVN to fix a kernel
    panic on suspend caused by the vboxdrv module.
    (Closes: #637226; LP: #814323)

virtualbox (4.1.0-dfsg-1) unstable; urgency=low

  * New upstream release.
  * Use VBOX_BUILD_PUBLISHER instead of VBOX_VERSION_STRING to set the
    version suffix.
  * Refresh patches.
  * Drop 22-no-static-libstdcpp.patch and 31-multiarch-dri-path.patch,
    applied upstream.
  * Add 34-fix-vboxpci-build.patch to fix a VBoxPCI build failure.
  * Add vboxpci kernel module to virtualbox-dkms and virtualbox-source.
  * Update package names in 04-vboxdrv-references.patch.
  * Add 35-libvdeplug-soname.patch to fix VDE networking. (Closes: #636335)
  * Drop broken "alloc" symlink in virtualbox-dkms and virtualbox-source.
 -- Felix Geyer <email address hidden> Wed, 10 Aug 2011 17:34:57 +0200

Changed in virtualbox (Ubuntu):
status: Fix Committed → Fix Released
Jullian Gafar (jullian-gafar) wrote :

My VirtualBox is already on 4.1.2 and this issue is still a problem.

I reinstalled my system a couple of days ago with Natty 1104-64bit. My kernel is 2.6.38-11-generic amd64.

When I first installed it, suspend works fine, but after I reinstalled all of the softwares that I am using, suspend does not work anymore and I end up with issues same as above.

So, if it is still vboxdrv causing the issue, then the above should not be closed.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.